Remove expired ports:

2012-05-30 audio/libtunepimp-old MusicBrainz RDF webservice no longer functions
2012-06-01 audio/libtunepimp MusicBrainz RDF webservice no longer functions

Approved by:	Jason E. Hale <bsdkaffee@gmail.com> (maintainer), eadler (mentor)
This commit is contained in:
Alex Kozlov 2012-06-20 03:16:21 +00:00
parent a723205840
commit f14d52587a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=299670
40 changed files with 2 additions and 870 deletions

2
MOVED
View File

@ -3528,3 +3528,5 @@ x11-themes/gtk-qt-engine||2012-06-16|Has expired: BROKEN for more than 6 month
devel/bazaar|devel/baz|2012-06-17|Project renamed
devel/bazaar-ng|devel/bzr|2012-06-17|Project renamed
ftp/IglooFTP||2012-06-18|Has expired: No longer supported
audio/libtunepimp||2012-06-20|MusicBrainz RDF webservice no longer functions
audio/libtunepimp-old||2012-06-20|MusicBrainz RDF webservice no longer functions

View File

@ -391,8 +391,6 @@
SUBDIR += libsmf
SUBDIR += libsndfile
SUBDIR += libtremor
SUBDIR += libtunepimp
SUBDIR += libtunepimp-old
SUBDIR += libumidi
SUBDIR += libvorbis
SUBDIR += libworkman

View File

@ -1,56 +0,0 @@
# New ports collection makefile for: tunepimp
# Date Created: 11 Aug 2004
# Whom: Lauri Watts <lauri@kde.org>
#
# $FreeBSD$
#
PORTNAME= libtunepimp-old
PORTVERSION= 0.4.4
PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= audio
MASTER_SITES= http://ftp.osuosl.org/pub/musicbrainz/ \
http://ns.ael.ru/~fluffy.khv/
DISTNAME= libtunepimp-${PORTVERSION}
MAINTAINER= fluffy@FreeBSD.org
COMMENT= Client library for musicbrainz
LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac \
expat:${PORTSDIR}/textproc/expat2 \
mad:${PORTSDIR}/audio/libmad \
mp4v2.10:${PORTSDIR}/multimedia/mp4v2 \
musicbrainz:${PORTSDIR}/audio/libmusicbrainz \
ogg:${PORTSDIR}/audio/libogg \
tag:${PORTSDIR}/audio/taglib \
vorbis:${PORTSDIR}/audio/libvorbis
DEPRECATED= MusicBrainz RDF webservice no longer functions
EXPIRATION_DATE= 2012-05-30
CONFLICTS= trm-0*
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --libdir=${PREFIX}/lib/tunepimp-0.4 --includedir=${PREFIX}/include/tunepimp-0.4
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -liconv
USE_LDCONFIG= ${PREFIX}/lib/tunepimp-0.4
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g ; \
s|^CPPFLAGS=|#CPPFLAGS=|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-lthr|${PTHREAD_LIBS}|g' \
${WRKSRC}/lib/threads/posix/Makefile.in
@${REINPLACE_CMD} -e 's|<mp4\.h>|<mp4v2/mp4v2.h>|g' \
${WRKSRC}/plugins/mp4/mp4.cpp
post-configure:
@${REINPLACE_CMD} -e 's|\(^LDFLAGS =.*\)|\1 ${PTHREAD_LIBS} -liconv|g' \
${WRKSRC}/examples/Makefile
@${REINPLACE_CMD} -e \
's|PREFIX"/lib/tunepimp/plugins"|PREFIX"/lib/tunepimp-0.4/tunepimp/plugins"|g' \
${WRKSRC}/lib/tunepimp.cpp
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (libtunepimp-0.4.4.tar.gz) = e2628d48e7299104241d48260fe101fd003fd9910635cfc6bdede49d22664b79
SIZE (libtunepimp-0.4.4.tar.gz) = 1031379

View File

@ -1,27 +0,0 @@
--- examples/Makefile.in.orig Tue Sep 12 19:17:31 2006
+++ examples/Makefile.in Tue Sep 12 19:17:56 2006
@@ -53,10 +53,10 @@
PROGRAMS = $(bin_PROGRAMS)
am_tp_tagger_OBJECTS = tagger.$(OBJEXT)
tp_tagger_OBJECTS = $(am_tp_tagger_OBJECTS)
-tp_tagger_DEPENDENCIES = $(top_builddir)/lib/libtunepimp.la
+tp_tagger_DEPENDENCIES = $(top_builddir)/lib/libtunepimp-0.4.la
am_trm_OBJECTS = trm.$(OBJEXT)
trm_OBJECTS = $(am_trm_OBJECTS)
-trm_DEPENDENCIES = $(top_builddir)/lib/libtunepimp.la
+trm_DEPENDENCIES = $(top_builddir)/lib/libtunepimp-0.4.la
DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
@@ -207,9 +207,9 @@
#
INCLUDES = -I$(top_srcdir)/include -I$(top_srcdir)/lib -I$(top_srcdir)/lib/threads/posix
tp_tagger_SOURCES = tagger.c
-tp_tagger_LDADD = $(top_builddir)/lib/libtunepimp.la @READLINE_LIBS@
+tp_tagger_LDADD = $(top_builddir)/lib/libtunepimp-0.4.la @READLINE_LIBS@
trm_SOURCES = trm.c
-trm_LDADD = $(top_builddir)/lib/libtunepimp.la
+trm_LDADD = $(top_builddir)/lib/libtunepimp-0.4.la
all: all-am
.SUFFIXES:

View File

@ -1,20 +0,0 @@
--- lib/Makefile.in.bak Sat Jan 28 21:54:05 2006
+++ lib/Makefile.in Tue Sep 12 19:11:17 2006
@@ -240,7 +240,7 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = utf8 threads
INCLUDES = -I$(top_srcdir)/include/tunepimp -Ithreads/posix
-lib_LTLIBRARIES = libtunepimp.la
+lib_LTLIBRARIES = libtunepimp-0.4.la
libtunepimp_la_SOURCES = tunepimp.cpp filecache.cpp filelookup.cpp analyzer.cpp dirsearch.cpp metadata.cpp submit.cpp astrcmp.c track.cpp lookup.cpp lookuptools.cpp write.cpp c_wrapper.cpp watchdog.cpp plugins.cpp readmeta.cpp fileio.cpp
# Here are a set of rules to help you update your library version information:
@@ -338,7 +338,7 @@
done
libpluginsupport.la: $(libpluginsupport_la_OBJECTS) $(libpluginsupport_la_DEPENDENCIES)
$(CXXLINK) $(libpluginsupport_la_LDFLAGS) $(libpluginsupport_la_OBJECTS) $(libpluginsupport_la_LIBADD) $(LIBS)
-libtunepimp.la: $(libtunepimp_la_OBJECTS) $(libtunepimp_la_DEPENDENCIES)
+libtunepimp-0.4.la: $(libtunepimp_la_OBJECTS) $(libtunepimp_la_DEPENDENCIES)
$(CXXLINK) -rpath $(libdir) $(libtunepimp_la_LDFLAGS) $(libtunepimp_la_OBJECTS) $(libtunepimp_la_LIBADD) $(LIBS)
mostlyclean-compile:

View File

@ -1,17 +0,0 @@
--- lib/metadata.cpp.orig Wed Nov 10 17:37:26 2004
+++ lib/metadata.cpp Wed Sep 14 17:25:59 2005
@@ -34,6 +34,14 @@
#include "astrcmp.h"
}
+#ifndef min
+#define min(a,b) ((a) < (b) ? (a) : (b))
+#endif
+
+#ifndef max
+#define max(a,b) ((a) > (b) ? (a) : (b))
+#endif
+
const int numAlbumTypeStrings = 11;
const char *albumTypeStrings[] =
{

View File

@ -1,20 +0,0 @@
--- lib/utf8/utf8util.cpp.orig Mon Jul 11 05:01:23 2005
+++ lib/utf8/utf8util.cpp Wed Sep 14 17:19:42 2005
@@ -38,7 +38,7 @@
char *dest;
string to;
- to.clear();
+ to = "";
ret = utf8_encode(from.c_str(), &dest);
if (ret >= 0)
{
@@ -54,7 +54,7 @@
char *dest;
string to;
- to.clear();
+ to = "";
ret = utf8_decode(from.c_str(), &dest);
if (ret >= 0)
{

View File

@ -1,13 +0,0 @@
--- plugins/flac/flac.cpp.orig Tue Jun 28 13:03:06 2005
+++ plugins/flac/flac.cpp Wed Sep 14 17:35:23 2005
@@ -33,7 +33,10 @@
#ifdef WIN32
#include <winsock.h>
#else
+#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
+#include <arpa/inet.h>
#include <sys/param.h>
#endif

View File

@ -1,57 +0,0 @@
--- plugins/flac/flacdecode.cpp.orig 2008-03-28 21:05:11.000000000 +0100
+++ plugins/flac/flacdecode.cpp 2008-03-28 21:08:21.000000000 +0100
@@ -28,6 +28,14 @@
#include <string.h>
#include "flacdecode.h"
+#include <FLAC/export.h>
+/* FLAC 1.1.3 has FLAC_API_VERSION_CURRENT == 8 */
+#if !defined(FLAC_API_VERSION_CURRENT) || FLAC_API_VERSION_CURRENT < 8
+#define LEGACY_FLAC
+#else
+#undef LEGACY_FLAC
+#endif
+
void FLAC_errorcb(const FLAC__StreamDecoder * decoder,
FLAC__StreamDecoderErrorStatus status, void *client_data)
{
@@ -99,7 +107,11 @@ FLAC__StreamDecoderWriteStatus FLAC_writ
FLAC__StreamDecoderReadStatus FLAC_readcb(const FLAC__StreamDecoder *decoder,
FLAC__byte buffer[],
+#ifdef LEGACY_FLAC
unsigned *bytes,
+#else
+ size_t *bytes,
+#endif
void *client_data)
{
clientdata_t *cd = reinterpret_cast < clientdata_t * >(client_data);
@@ -131,6 +143,7 @@ FlacDecode::FlacDecode(const string & fi
if (!cd.in)
return;
+#ifdef LEGACY_FLAC
if (!FLAC__stream_decoder_set_read_callback(decoder, &FLAC_readcb))
return;
@@ -149,6 +162,10 @@ FlacDecode::FlacDecode(const string & fi
state = FLAC__stream_decoder_init(decoder);
if (state != FLAC__STREAM_DECODER_SEARCH_FOR_METADATA)
return;
+#else
+ if (FLAC__stream_decoder_init_stream(decoder, &FLAC_readcb, NULL, NULL, NULL, NULL, &FLAC_writecb, &FLAC_metadatacb, &FLAC_errorcb, &cd) != FLAC__STREAM_DECODER_INIT_STATUS_OK)
+ return;
+#endif
FLAC__stream_decoder_process_until_end_of_metadata(decoder);
state = FLAC__stream_decoder_get_state(decoder);
@@ -221,6 +238,8 @@ int FlacDecode::read(char *data, int max
break;
state = FLAC__stream_decoder_get_state(decoder);
+ if (state == FLAC__STREAM_DECODER_END_OF_STREAM)
+ break;
if (state != FLAC__STREAM_DECODER_SEARCH_FOR_FRAME_SYNC ||
state != FLAC__STREAM_DECODER_READ_FRAME)
{

View File

@ -1,11 +0,0 @@
--- plugins/flac/flacdecode.h.orig 2008-03-28 21:08:34.000000000 +0100
+++ plugins/flac/flacdecode.h 2008-03-28 21:08:49.000000000 +0100
@@ -27,7 +27,7 @@
#ifndef __VORBIS_DECODE_H
#define __VORBIS_DECODE_H
-#include <FLAC/file_decoder.h>
+#include <FLAC/stream_decoder.h>
#include <string>
#include "decode_plugin.h"
#include "fileio.h"

View File

@ -1,13 +0,0 @@
--- plugins/mp3/mp3.cpp.orig Tue Jul 12 06:44:06 2005
+++ plugins/mp3/mp3.cpp Wed Sep 14 17:32:42 2005
@@ -33,7 +33,10 @@
#ifdef WIN32
#include <winsock.h>
#else
+#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
+#include <arpa/inet.h>
#include <sys/param.h>
#endif

View File

@ -1,23 +0,0 @@
--- plugins/mp4/mp4.cpp.orig Sun Jan 22 13:13:15 2006
+++ plugins/mp4/mp4.cpp Sun Oct 21 07:45:19 2007
@@ -224,9 +224,7 @@
strcpy(mdata->fileFormat, fileName + strlen(fileName) - 3);
- if (!MP4Close(mp4file))
- return 0;
-
+ MP4Close(mp4file);
return 1;
}
@@ -306,8 +304,7 @@
sprintf(temp, "%d", mdata->nonAlbum);
MP4SetMetadataFreeForm(mp4file, "MusicBrainz Non-Album", (u_int8_t *)temp, strlen(temp) + 1);
- if (!MP4Close(mp4file))
- return 0;
+ MP4Close(mp4file);
return 1;
}

View File

@ -1,13 +0,0 @@
--- plugins/vorbis/vorbis.cpp.orig Tue Jun 28 13:03:06 2005
+++ plugins/vorbis/vorbis.cpp Wed Sep 14 17:34:12 2005
@@ -33,7 +33,10 @@
#ifdef WIN32
#include <winsock.h>
#else
+#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
+#include <arpa/inet.h>
#include <sys/param.h>
#endif

View File

@ -1,13 +0,0 @@
--- plugins/wav/wav.cpp.orig Wed Jun 15 06:15:18 2005
+++ plugins/wav/wav.cpp Wed Sep 14 17:30:30 2005
@@ -34,7 +34,10 @@
#ifdef WIN32
#include <winsock.h>
#else
+#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
+#include <arpa/inet.h>
#include <sys/param.h>
#endif

View File

@ -1,9 +0,0 @@
Tunepimp is a client library for MusicBrainz
MusicBrainz is the second generation incarnation of the CD Index.
This server is designed to enable Audio CD and MP3/Vorbis players
to download metadata about the music they are playing. All of the
data collected on the Musicbrainz server is made available to the
public under the OpenContent license.
WWW: http://www.musicbrainz.org/

View File

@ -1,26 +0,0 @@
bin/tp_tagger
bin/trm
include/tunepimp-0.4/tunepimp/context.h
include/tunepimp-0.4/tunepimp/decode_plugin.h
include/tunepimp-0.4/tunepimp/defs.h
include/tunepimp-0.4/tunepimp/fileio.h
include/tunepimp-0.4/tunepimp/metadata_plugin.h
include/tunepimp-0.4/tunepimp/tp_c.h
include/tunepimp-0.4/tunepimp/track.h
include/tunepimp-0.4/tunepimp/tunepimp.h
lib/tunepimp-0.4/libtunepimp-0.4.a
lib/tunepimp-0.4/libtunepimp-0.4.la
lib/tunepimp-0.4/libtunepimp-0.4.so
lib/tunepimp-0.4/libtunepimp-0.4.so.3
lib/tunepimp-0.4/tunepimp/plugins/flac.tpp
lib/tunepimp-0.4/tunepimp/plugins/mp3.tpp
lib/tunepimp-0.4/tunepimp/plugins/mp4.tpp
lib/tunepimp-0.4/tunepimp/plugins/mpc.tpp
lib/tunepimp-0.4/tunepimp/plugins/vorbis.tpp
lib/tunepimp-0.4/tunepimp/plugins/wav.tpp
lib/tunepimp-0.4/tunepimp/plugins/wma.tpp
@dirrm lib/tunepimp-0.4/tunepimp/plugins
@dirrm lib/tunepimp-0.4/tunepimp
@dirrm lib/tunepimp-0.4
@dirrm include/tunepimp-0.4/tunepimp
@dirrm include/tunepimp-0.4

View File

@ -1,55 +0,0 @@
# New ports collection makefile for: tunepimp
# Date Created: 11 Aug 2004
# Whom: Lauri Watts <lauri@kde.org>
#
# $FreeBSD$
#
PORTNAME= libtunepimp
PORTVERSION= 0.5.3
PORTREVISION= 9
PORTEPOCH= 1
CATEGORIES= audio
MASTER_SITES= http://ftp.musicbrainz.org/pub/musicbrainz/ \
ftp://ftp.au.musicbrainz.org/pub/musicbrainz/
MAINTAINER= bsdkaffee@gmail.com
COMMENT= Client library for musicbrainz
LIB_DEPENDS= FLAC:${PORTSDIR}/audio/flac \
expat:${PORTSDIR}/textproc/expat2 \
mad:${PORTSDIR}/audio/libmad \
mp4v2.10:${PORTSDIR}/multimedia/mp4v2 \
musicbrainz:${PORTSDIR}/audio/libmusicbrainz \
ogg:${PORTSDIR}/audio/libogg \
tag:${PORTSDIR}/audio/taglib \
vorbis:${PORTSDIR}/audio/libvorbis \
ofa:${PORTSDIR}/audio/libofa \
mpcdec:${PORTSDIR}/audio/musepack
DEPRECATED= MusicBrainz RDF webservice no longer functions
EXPIRATION_DATE= 2012-06-01
CONFLICTS= trm-0*
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -liconv
USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g ; \
s|^CPPFLAGS=|#CPPFLAGS=|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-lthr|${PTHREAD_LIBS}|g' \
${WRKSRC}/lib/threads/posix/Makefile.in
@${REINPLACE_CMD} -e 's|<mp4\.h>|<mp4v2/mp4v2.h>|g' \
${WRKSRC}/plugins/mp4/mp4.cpp
post-configure:
@${REINPLACE_CMD} -e 's|\(^LDFLAGS =.*\)|\1 ${PTHREAD_LIBS} -liconv|g' \
${WRKSRC}/examples/Makefile
@${REINPLACE_CMD} -e 's|plugins/wv|plugins/tta|' \
${WRKSRC}/plugins/tta/Makefile
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (libtunepimp-0.5.3.tar.gz) = 341744a0be386387632fc4bb906b97d2b3346137beb2c776a41dedaeeb0f2468
SIZE (libtunepimp-0.5.3.tar.gz) = 1097005

View File

@ -1,56 +0,0 @@
--- configure.orig 2006-11-28 21:34:18.000000000 +0100
+++ configure 2010-09-11 11:46:56.333821556 +0200
@@ -21669,9 +21669,9 @@
fi
-{ echo "$as_me:$LINENO: checking for mpc_decoder_decode in -lmpcdec" >&5
-echo $ECHO_N "checking for mpc_decoder_decode in -lmpcdec... $ECHO_C" >&6; }
-if test "${ac_cv_lib_mpcdec_mpc_decoder_decode+set}" = set; then
+{ echo "$as_me:$LINENO: checking for mpc_demux_decode in -lmpcdec" >&5
+echo $ECHO_N "checking for mpc_demux_decode in -lmpcdec... $ECHO_C" >&6; }
+if test "${ac_cv_lib_mpcdec_mpc_demux_decode+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
@@ -21689,11 +21689,11 @@
#ifdef __cplusplus
extern "C"
#endif
-char mpc_decoder_decode ();
+char mpc_demux_decode ();
int
main ()
{
-return mpc_decoder_decode ();
+return mpc_demux_decode ();
;
return 0;
}
@@ -21732,21 +21732,21 @@
ac_status=$?
echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; }; then
- ac_cv_lib_mpcdec_mpc_decoder_decode=yes
+ ac_cv_lib_mpcdec_mpc_demux_decode=yes
else
echo "$as_me: failed program was:" >&5
sed 's/^/| /' conftest.$ac_ext >&5
- ac_cv_lib_mpcdec_mpc_decoder_decode=no
+ ac_cv_lib_mpcdec_mpc_demux_decode=no
fi
rm -f core conftest.err conftest.$ac_objext \
conftest$ac_exeext conftest.$ac_ext
LIBS=$ac_check_lib_save_LIBS
fi
-{ echo "$as_me:$LINENO: result: $ac_cv_lib_mpcdec_mpc_decoder_decode" >&5
-echo "${ECHO_T}$ac_cv_lib_mpcdec_mpc_decoder_decode" >&6; }
-if test $ac_cv_lib_mpcdec_mpc_decoder_decode = yes; then
+{ echo "$as_me:$LINENO: result: $ac_cv_lib_mpcdec_mpc_demux_decode" >&5
+echo "${ECHO_T}$ac_cv_lib_mpcdec_mpc_demux_decode" >&6; }
+if test $ac_cv_lib_mpcdec_mpc_demux_decode = yes; then
have_mpcdec=yes
fi

View File

@ -1,10 +0,0 @@
--- include/tunepimp-0.5/metadata.h.orig 2010-06-07 10:40:42.479449473 +0300
+++ include/tunepimp-0.5/metadata.h 2010-06-07 10:41:25.477086516 +0300
@@ -29,6 +29,7 @@
#include <string>
#include <cstdio>
+#include <cstring>
#include "defs.h"
#include "tp_c.h"

View File

@ -1,25 +0,0 @@
--- lib/metadata.cpp.orig 2006-11-18 12:52:33.000000000 +0200
+++ lib/metadata.cpp 2010-06-07 10:43:10.556325912 +0300
@@ -26,6 +26,7 @@
----------------------------------------------------------------------------*/
#include <math.h>
#include <stdio.h>
+#include <stdlib.h>
#include "metadata.h"
#include "../config.h"
using namespace std;
@@ -35,6 +36,14 @@ extern "C"
#include "astrcmp.h"
}
+#ifndef min
+#define min(a,b) ((a) < (b) ? (a) : (b))
+#endif
+
+#ifndef max
+#define max(a,b) ((a) > (b) ? (a) : (b))
+#endif
+
const int numAlbumTypeStrings = 11;
const char *albumTypeStrings[] =
{

View File

@ -1,28 +0,0 @@
--- lib/utf8/utf8util.cpp.orig 2006-11-18 12:52:26.000000000 +0200
+++ lib/utf8/utf8util.cpp 2010-06-07 10:39:57.243921985 +0300
@@ -26,6 +26,7 @@
----------------------------------------------------------------------------*/
#include <stdio.h>
+#include <stdlib.h>
#include "utf8util.h"
#include "utf8.h"
#ifdef WIN32
@@ -38,7 +39,7 @@ string utf8Encode(const string &from)
char *dest;
string to;
- to.clear();
+ to = "";
ret = utf8_encode(from.c_str(), &dest);
if (ret >= 0)
{
@@ -54,7 +55,7 @@ string utf8Decode(const string &from)
char *dest;
string to;
- to.clear();
+ to = "";
ret = utf8_decode(from.c_str(), &dest);
if (ret >= 0)
{

View File

@ -1,10 +0,0 @@
--- lib/c_wrapper.cpp.orig 2010-06-07 10:43:52.147054247 +0300
+++ lib/c_wrapper.cpp 2010-06-07 10:44:16.392713467 +0300
@@ -42,6 +42,7 @@
#define TR_OBJ_CHECKV(o) Track *obj = (Track *)t; \
if (obj == NULL) return;
+#include <stdlib.h>
#include <deque>
class NotifyData

View File

@ -1,11 +0,0 @@
--- lib/fileio.cpp.orig 2006-11-18 11:52:33.000000000 +0100
+++ lib/fileio.cpp 2010-06-20 18:37:34.000000000 +0200
@@ -28,6 +28,8 @@
#include <assert.h>
#include <errno.h>
+#include <stdlib.h>
#include <string>
+#include <string.h>
#ifndef WIN32
#include <unistd.h>
#endif

View File

@ -1,15 +0,0 @@
--- lib/protocol.cpp.orig 2010-06-07 10:47:20.653619576 +0300
+++ lib/protocol.cpp 2010-06-07 10:47:55.249722982 +0300
@@ -8,11 +8,11 @@
-------------------------------------------------------------------*/
#include <stdio.h>
#include <stdlib.h>
+#include <string.h>
#include <string>
#include <map>
#include <expat.h>
#include <curl/curl.h>
-#include <curl/types.h>
#include <curl/easy.h>
using namespace std;

View File

@ -1,10 +0,0 @@
--- lib/readmeta.cpp.orig 2010-06-07 10:45:38.729200377 +0300
+++ lib/readmeta.cpp 2010-06-07 10:46:01.634953724 +0300
@@ -31,6 +31,7 @@
#endif
#include <stdio.h>
+#include <stdlib.h>
#ifndef WIN32
#include <unistd.h>
#endif

View File

@ -1,10 +0,0 @@
--- lib/tunepimp.cpp.orig 2010-06-07 10:42:02.279074189 +0300
+++ lib/tunepimp.cpp 2010-06-07 10:42:26.892724626 +0300
@@ -31,6 +31,7 @@
#endif
#include <stdio.h>
+#include <stdlib.h>
#include <map>
using namespace std;

View File

@ -1,13 +0,0 @@
--- plugins/flac/flac.cpp.orig Tue Jun 28 13:03:06 2005
+++ plugins/flac/flac.cpp Wed Sep 14 17:35:23 2005
@@ -33,7 +33,10 @@
#ifdef WIN32
#include <winsock.h>
#else
+#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
+#include <arpa/inet.h>
#include <sys/param.h>
#endif

View File

@ -1,13 +0,0 @@
--- plugins/mp3/mp3.cpp.orig Tue Jul 12 06:44:06 2005
+++ plugins/mp3/mp3.cpp Wed Sep 14 17:32:42 2005
@@ -33,7 +33,10 @@
#ifdef WIN32
#include <winsock.h>
#else
+#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
+#include <arpa/inet.h>
#include <sys/param.h>
#endif

View File

@ -1,23 +0,0 @@
--- plugins/mp4/mp4.cpp.orig 2006-11-18 12:51:08.000000000 +0200
+++ plugins/mp4/mp4.cpp 2010-06-07 10:36:19.151889361 +0300
@@ -231,9 +231,7 @@ mp4ReadMetadata(metadata_t *mdata, const
strcpy(mdata->fileFormat, fileName + strlen(fileName) - 3);
- if (!MP4Close(mp4file))
- return 0;
-
+ MP4Close(mp4file);
return 1;
}
@@ -315,8 +313,7 @@ mp4WriteMetadata(const metadata_t *mdata
sprintf(temp, "%d", mdata->nonAlbum);
MP4SetMetadataFreeForm(mp4file, "MusicBrainz Non-Album", (u_int8_t *)temp, strlen(temp) + 1);
- if (!MP4Close(mp4file))
- return 0;
+ MP4Close(mp4file);
#ifndef WIN32
if (!MP4Optimize(utf8ToEncoding(fileName, encoding).c_str()))

View File

@ -1,165 +0,0 @@
--- plugins/mpc/mpcdecode.cpp.orig 2006-11-18 11:51:08.000000000 +0100
+++ plugins/mpc/mpcdecode.cpp 2010-09-11 11:46:56.335821789 +0200
@@ -29,8 +29,9 @@
#include <assert.h>
#include <time.h>
#include "fileio.h"
+#include "config.h"
-#include <mpcdec/mpcdec.h>
+#include <mpc/mpcdec.h>
extern char *mpcErrorString;
@@ -40,35 +41,35 @@
} reader_data;
static mpc_int32_t
-read_impl(void *data, void *ptr, mpc_int32_t size)
+read_impl(mpc_reader *data, void *ptr, mpc_int32_t size)
{
- reader_data *d = (reader_data *) data;
+ reader_data *d = (reader_data *) data->data;
return tread(ptr, 1, size, d->file);
}
static mpc_bool_t
-seek_impl(void *data, mpc_int32_t offset)
+seek_impl(mpc_reader *data, mpc_int32_t offset)
{
- reader_data *d = (reader_data *) data;
+ reader_data *d = (reader_data *) data->data;
return !tseek(d->file, offset, SEEK_SET);
}
static mpc_int32_t
-tell_impl(void *data)
+tell_impl(mpc_reader *data)
{
- reader_data *d = (reader_data *) data;
+ reader_data *d = (reader_data *) data->data;
return ttell(d->file);
}
static mpc_int32_t
-get_size_impl(void *data)
+get_size_impl(mpc_reader *data)
{
- reader_data *d = (reader_data *) data;
+ reader_data *d = (reader_data *) data->data;
return d->size;
}
static mpc_bool_t
-canseek_impl(void *data)
+canseek_impl(mpc_reader *data)
{
return true;
}
@@ -76,7 +77,7 @@
typedef struct mpc_decode_struct_t {
TFILE *file;
reader_data rdata;
- mpc_decoder decoder;
+ mpc_demux *decoder;
mpc_reader reader;
mpc_streaminfo info;
MPC_SAMPLE_FORMAT buffer[MPC_DECODER_BUFFER_LENGTH];
@@ -114,27 +115,21 @@
ds->reader.canseek = canseek_impl;
ds->reader.data = &ds->rdata;
- /* read file's streaminfo data */
- mpc_streaminfo_init(&ds->info);
- if (mpc_streaminfo_read(&ds->info, &ds->reader) != ERROR_CODE_OK) {
- mpcErrorString = "Not a valid Musepack file.";
- goto error;
- }
-
- /* instantiate a decoder with our file reader */
- mpc_decoder_setup(&ds->decoder, &ds->reader);
- if (!mpc_decoder_initialize(&ds->decoder, &ds->info)) {
- mpcErrorString = "Error initializing decoder.";
- goto error;
- }
-
+ ds->decoder = mpc_demux_init(&ds->reader);
+ if (!ds->decoder) {
+ mpcErrorString = "Error initializing decoder.";
+ goto error;
+ }
+
+ mpc_demux_get_info(ds->decoder, &ds->info);
+
return ds;
error:
- if (ds)
- delete ds;
-
- return NULL;
+ if (ds) {
+ mpc_demux_exit(ds->decoder);
+ delete ds;
+ }
}
extern "C" int
@@ -144,7 +139,8 @@
return 0;
if (duration)
- *duration = (ds->info.pcm_samples * 1000) / ds->info.sample_freq;
+ *duration = ((ds->info.samples - ds->info.beg_silence) * 1000)
+ / ds->info.sample_freq;
if (samplesPerSecond)
*samplesPerSecond = ds->info.sample_freq;
if (bitsPerSample)
@@ -173,6 +169,8 @@
return -1;
unsigned status, maxSamples = maxBytes / 2 / ds->info.channels, samples, offset;
+ mpc_frame_info frame;
+ mpc_status err;
if (ds->samples > 0) {
samples = ds->samples;
@@ -182,15 +180,18 @@
goto convert;
}
- status = mpc_decoder_decode(&ds->decoder, ds->buffer, 0, 0);
-
- if (status == (unsigned)(-1)) { //decode error
- mpcErrorString = "Error decoding file.";
- return -1;
+ frame.buffer = ds->buffer;
+ err = mpc_demux_decode(ds->decoder, &frame);
+
+ if (err != MPC_STATUS_OK) { //decode error
+ mpcErrorString = "Error decoding file.";
+ return -1;
}
- else if (status == 0) { //EOF
- return 0;
+ else if (frame.bits == -1) { //EOF
+ return 0;
}
+
+ status = frame.samples;
if (status > maxSamples) {
ds->samples = status - maxSamples;
@@ -230,8 +231,10 @@
extern "C" void
mpcDecodeEnd(mpc_decode_struct_t *ds)
{
- if (ds)
- delete ds;
+ if (ds) {
+ mpc_demux_exit(ds->decoder);
+ delete ds;
+ }
}

View File

@ -1,13 +0,0 @@
--- plugins/vorbis/vorbis.cpp.orig Tue Jun 28 13:03:06 2005
+++ plugins/vorbis/vorbis.cpp Wed Sep 14 17:34:12 2005
@@ -33,7 +33,10 @@
#ifdef WIN32
#include <winsock.h>
#else
+#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
+#include <arpa/inet.h>
#include <sys/param.h>
#endif

View File

@ -1,13 +0,0 @@
--- plugins/wav/wav.cpp.orig 2006-11-18 12:51:46.000000000 +0200
+++ plugins/wav/wav.cpp 2010-06-07 10:36:19.157879953 +0300
@@ -34,7 +34,10 @@
#ifdef WIN32
#include <winsock.h>
#else
+#include <sys/types.h>
+#include <sys/socket.h>
#include <netinet/in.h>
+#include <arpa/inet.h>
#include <sys/param.h>
#endif

View File

@ -1,10 +0,0 @@
--- plugins/mp3/id3_2_3_meta.cpp.orig 2010-06-07 10:50:49.216186011 +0300
+++ plugins/mp3/id3_2_3_meta.cpp 2010-06-07 10:51:05.523284779 +0300
@@ -26,6 +26,7 @@
----------------------------------------------------------------------------*/
#include <stdio.h>
+#include <stdlib.h>
#include <assert.h>
#include <ctype.h>
#include <musicbrainz/mb_c.h>

View File

@ -1,10 +0,0 @@
--- plugins/mp3/id3_meta.cpp.orig 2010-06-07 10:50:19.617800314 +0300
+++ plugins/mp3/id3_meta.cpp 2010-06-07 10:50:31.369156541 +0300
@@ -26,6 +26,7 @@
----------------------------------------------------------------------------*/
#include <stdio.h>
+#include <stdlib.h>
#include <time.h>
#include <ctype.h>
#include <musicbrainz/mb_c.h>

View File

@ -1,10 +0,0 @@
--- plugins/wma/wma.cpp.orig 2010-06-07 10:48:29.988820849 +0300
+++ plugins/wma/wma.cpp 2010-06-07 10:48:44.871996634 +0300
@@ -27,6 +27,7 @@
#include <string.h>
#include <stdio.h>
+#include <stdlib.h>
#include <wmafile.h>
#include "metadata.h"
#include "plugin.h"

View File

@ -1,10 +0,0 @@
--- plugins/wma/wmafile.cpp.orig 2010-06-07 10:49:09.287654896 +0300
+++ plugins/wma/wmafile.cpp 2010-06-07 10:49:27.385665056 +0300
@@ -19,6 +19,7 @@
* USA *
***************************************************************************/
+#include <string.h>
#include <tstring.h>
#include <wmafile.h>
#include <wmatag.h>

View File

@ -1,9 +0,0 @@
Tunepimp is a client library for MusicBrainz
MusicBrainz is the second generation incarnation of the CD Index.
This server is designed to enable Audio CD and MP3/Vorbis players
to download metadata about the music they are playing. All of the
data collected on the Musicbrainz server is made available to the
public under the OpenContent license.
WWW: http://www.musicbrainz.org/

View File

@ -1,27 +0,0 @@
bin/puid
include/tunepimp-0.5/context.h
include/tunepimp-0.5/decode_plugin.h
include/tunepimp-0.5/defs.h
include/tunepimp-0.5/fileio.h
include/tunepimp-0.5/metadata.h
include/tunepimp-0.5/metadata_plugin.h
include/tunepimp-0.5/tp_c.h
include/tunepimp-0.5/track.h
include/tunepimp-0.5/tunepimp.h
lib/libtunepimp.a
lib/libtunepimp.la
lib/libtunepimp.so
lib/libtunepimp.so.5
lib/tunepimp/plugins/flac.tpp
lib/tunepimp/plugins/mp3.tpp
lib/tunepimp/plugins/mp4.tpp
lib/tunepimp/plugins/mpc.tpp
lib/tunepimp/plugins/speex.tpp
lib/tunepimp/plugins/tta.tpp
lib/tunepimp/plugins/vorbis.tpp
lib/tunepimp/plugins/wav.tpp
lib/tunepimp/plugins/wma.tpp
lib/tunepimp/plugins/wv.tpp
@dirrm lib/tunepimp/plugins
@dirrm lib/tunepimp
@dirrm include/tunepimp-0.5