Update to 0.9.5.1. pthread and xsplay are still disabled.

This commit is contained in:
CHOI Junho 2001-04-02 13:57:05 +00:00
parent fffa2569fb
commit f13ef8bc1f
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=40752
8 changed files with 39 additions and 67 deletions

View File

@ -1,6 +1,6 @@
# New ports collection makefile for: splay
# Date created: 1 Apr 1997
# Whom: junker@jazz.snu.ac.kr
# Whom: cjh
#
# $FreeBSD$
#
@ -8,14 +8,13 @@
#
PORTNAME= splay
PORTVERSION= 0.8.2
PORTVERSION= 0.9.5.1
CATEGORIES= audio
MASTER_SITES= ftp://ftp.kr.FreeBSD.org/pub/FreeBSD-kr/distfiles/
MASTER_SITES= ftp://splay.sourceforge.net/pub/splay/
MAINTAINER= cjh@kr.freebsd.org
MAINTAINER= cjh@FreeBSD.org
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-xsplay --without-pthread
MAN1= splay.1
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (splay-0.8.2.tar.gz) = 4031830584fddf315881798e074f7207
MD5 (splay-0.9.5.1.tar.gz) = 147b6e8a9cd272e35498c29a0efbeed3

View File

@ -1,34 +0,0 @@
diff -uNr ../../splay-0.8.2/mpegsound/httpinput.cc ./mpegsound/httpinput.cc
--- ../../splay-0.8.2/mpegsound/httpinput.cc Fri Mar 6 17:43:55 1998
+++ ./mpegsound/httpinput.cc Fri Mar 20 11:00:16 1998
@@ -13,6 +13,7 @@
#include <sys/stat.h>
#include <unistd.h>
+#include <errno.h>
#include "mpegsound.h"
diff -uNr ../../splay-0.8.2/mpegsound/rawplayer.cc ./mpegsound/rawplayer.cc
--- ../../splay-0.8.2/mpegsound/rawplayer.cc Fri Mar 6 17:43:55 1998
+++ ./mpegsound/rawplayer.cc Fri Mar 20 11:00:29 1998
@@ -13,7 +13,7 @@
#include <fcntl.h>
#include <unistd.h>
#include <sys/ioctl.h>
-#include <sys/soundcard.h>
+#include <machine/soundcard.h>
#include "mpegsound.h"
diff -uNr ../../splay-0.8.2/src/splay/splay.cc ./src/splay/splay.cc
--- ../../splay-0.8.2/src/splay/splay.cc Fri Mar 6 17:43:55 1998
+++ ./src/splay/splay.cc Fri Mar 20 11:01:55 1998
@@ -12,6 +12,7 @@
#include <string.h>
#include <unistd.h>
+#include <stdlib.h>
#include <mpegsound.h>

View File

@ -1,15 +0,0 @@
--- Makefile.in.orig Sat Apr 4 17:32:23 1998
+++ Makefile.in Sat Apr 4 17:38:18 1998
@@ -132,12 +132,6 @@
else file=splay.1; fi; \
echo " $(INSTALL_DATA) $$file $(mandir)/man$$sect/$$inst"; \
$(INSTALL_DATA) $$file $(mandir)/man$$sect/$$inst
- @sect=1; \
- inst=`echo "xsplay" | sed '$(transform)'`.1; \
- if test -f $(srcdir)/xsplay.1; then file=$(srcdir)/xsplay.1; \
- else file=xsplay.1; fi; \
- echo " $(INSTALL_DATA) $$file $(mandir)/man$$sect/$$inst"; \
- $(INSTALL_DATA) $$file $(mandir)/man$$sect/$$inst
uninstall-man:
$(NORMAL_UNINSTALL)

View File

@ -1,11 +0,0 @@
--- mpegsound/mpeglayer3.cc.orig Sat Nov 27 16:44:49 1999
+++ mpegsound/mpeglayer3.cc Sat Nov 27 16:45:27 1999
@@ -769,7 +769,7 @@
for(i=0;i<e;)
{
const HUFFMANCODETABLE *h;
- register end;
+ register int end;
if (i<region1Start)
{

View File

@ -0,0 +1,11 @@
--- apps/Makefile.in.orig Mon Apr 2 22:49:53 2001
+++ apps/Makefile.in Mon Apr 2 22:50:05 2001
@@ -81,7 +81,7 @@
INCLUDES = -I../libs -I/usr/include/qt
xsplay_LDADD = -lqt $(LDADD)
-man_MANS = splay.1 xsplay.1
+man_MANS = splay.1
EXTRA_DIST = $(man_MANS)
LIBS = @LIBS@

View File

@ -0,0 +1,21 @@
--- configure.orig Mon Mar 19 17:51:43 2001
+++ configure Mon Apr 2 22:38:07 2001
@@ -1967,12 +1969,12 @@
fi
echo "$ac_t""$ac_cv_type_pid_t" 1>&6
-if test $ac_cv_type_pid_t = no; then
- cat >> confdefs.h <<\EOF
-#define pid_t int
-EOF
-
-fi
+#if test $ac_cv_type_pid_t = no; then
+# cat >> confdefs.h <<\EOF
+##define pid_t int
+#EOF
+#
+#fi
if test $ac_cv_prog_gcc = yes; then

View File

@ -11,4 +11,5 @@ You can use these libraries under Library GPL.
* This version of splay was not compiled with pthread library.
--
Port by CHOI Junho <junker@jazz.snu.ac.kr>
CHOI Junho <cjh@FreeBSD.org>
WWW: http://splay.sourceforge.net/