Backout previous commit. That is accidentally misplaced location...
This commit is contained in:
parent
131148f512
commit
f136f869dd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=60240
@ -1,6 +1,6 @@
|
||||
--- Makefile.in.orig Tue Feb 26 05:03:26 2002
|
||||
+++ Makefile.in Sat May 25 17:03:35 2002
|
||||
@@ -28,7 +28,7 @@
|
||||
--- Makefile.in.orig Mon Apr 30 17:22:35 2001
|
||||
+++ Makefile.in Tue May 1 19:58:50 2001
|
||||
@@ -27,7 +27,7 @@
|
||||
INSTALL_OPTS=@INSTALL_OPTS@
|
||||
COMMAND_OPTS=@COMMAND_OPTS@
|
||||
INIT_DIR=@init_dir@
|
||||
@ -9,33 +9,26 @@
|
||||
CGICFGDIR=$(CGIDIR)
|
||||
PERLDIR=@PERLDIR@
|
||||
|
||||
@@ -132,18 +132,29 @@
|
||||
@@ -99,20 +99,20 @@
|
||||
|
||||
install-config:
|
||||
$(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/nagios.cfg $(DESTDIR)$(CFGDIR)/nagios.cfg-sample
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/cgi.cfg $(DESTDIR)$(CFGDIR)/cgi.cfg-sample
|
||||
- $(INSTALL) -m 660 $(INSTALL_OPTS) sample-config/resource.cfg $(DESTDIR)$(CFGDIR)/resource.cfg-sample
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/nagios.cfg $(DESTDIR)$(CFGDIR)/nagios.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/cgi.cfg $(DESTDIR)$(CFGDIR)/cgi.cfg.dist
|
||||
+ $(INSTALL) -m 660 $(INSTALL_OPTS) sample-config/resource.cfg $(DESTDIR)$(CFGDIR)/resource.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/checkcommands.cfg $(DESTDIR)$(CFGDIR)/checkcommands.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/contactgroups.cfg $(DESTDIR)$(CFGDIR)/contactgroups.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/contacts.cfg $(DESTDIR)$(CFGDIR)/contacts.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/dependencies.cfg $(DESTDIR)$(CFGDIR)/dependencies.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/escalations.cfg $(DESTDIR)$(CFGDIR)/escalations.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/hostgroups.cfg $(DESTDIR)$(CFGDIR)/hostgroups.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/hosts.cfg $(DESTDIR)$(CFGDIR)/hosts.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/misccommands.cfg $(DESTDIR)$(CFGDIR)/misccommands.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/services.cfg $(DESTDIR)$(CFGDIR)/services.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-extinfo/hostextinfo.cfg $(DESTDIR)$(CFGDIR)/hostextinfo.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-extinfo/serviceextinfo.cfg $(DESTDIR)$(CFGDIR)/serviceextinfo.cfg.dist
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) netsaint.cfg $(DESTDIR)$(CFGDIR)
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) hosts.cfg $(DESTDIR)$(CFGDIR)
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) commands.cfg $(DESTDIR)$(CFGDIR)
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) nscgi.cfg $(DESTDIR)$(CFGDIR)
|
||||
- $(INSTALL) -m 660 $(INSTALL_OPTS) resource.cfg $(DESTDIR)$(CFGDIR)
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) netsaint.cfg $(DESTDIR)$(CFGDIR)/netsaint.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) hosts.cfg $(DESTDIR)$(CFGDIR)/hosts.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) commands.cfg $(DESTDIR)$(CFGDIR)/commands.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) nscgi.cfg $(DESTDIR)$(CFGDIR)/nscgi.cfg.dist
|
||||
+ $(INSTALL) -m 660 $(INSTALL_OPTS) resource.cfg $(DESTDIR)$(CFGDIR)/resource.cfg.dist
|
||||
|
||||
install-init: install-daemoninit
|
||||
|
||||
install-daemoninit:
|
||||
- $(INSTALL) -m 774 $(INIT_OPTS) daemon-init $(DESTDIR)$(INIT_DIR)/nagios
|
||||
+ $(INSTALL) -m 774 $(INIT_OPTS) daemon-init $(DESTDIR)$(INIT_DIR)/nagios.sh
|
||||
- $(INSTALL) -m 774 $(INIT_OPTS) daemon-init $(DESTDIR)$(INIT_DIR)/netsaint
|
||||
+ $(INSTALL) -m 774 $(INIT_OPTS) daemon-init $(DESTDIR)$(INIT_DIR)/netsaint.sh
|
||||
|
||||
install-commandmode:
|
||||
$(INSTALL) -m 775 $(COMMAND_OPTS) -d $(DESTDIR)$(LOGDIR)/rw
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- base/Makefile.in.orig Sat Apr 20 22:34:02 2002
|
||||
+++ base/Makefile.in Sun May 19 08:35:09 2002
|
||||
@@ -102,7 +102,6 @@
|
||||
--- base/Makefile.in.orig Sun Feb 18 22:33:22 2001
|
||||
+++ base/Makefile.in Thu Mar 1 21:58:39 2001
|
||||
@@ -86,7 +86,6 @@
|
||||
devclean: clean
|
||||
|
||||
install:
|
||||
strip nagios
|
||||
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
|
||||
$(INSTALL) -m 774 $(INSTALL_OPTS) nagios $(DESTDIR)$(BINDIR)
|
||||
$(INSTALL) -m 774 $(INSTALL_OPTS) netsaint $(DESTDIR)$(BINDIR)
|
||||
|
||||
|
||||
|
@ -4,20 +4,20 @@
|
||||
ac_help=
|
||||
ac_default_prefix=/usr/local
|
||||
# Any additions from configure.in:
|
||||
-ac_default_prefix=/usr/local/nagios
|
||||
+#ac_default_prefix=/usr/local/nagios
|
||||
-ac_default_prefix=/usr/local/netsaint
|
||||
+#ac_default_prefix=/usr/local/netsaint
|
||||
ac_help="$ac_help
|
||||
--with-nagios-user=<user> sets user name to run nagios"
|
||||
--with-netsaint-user=<user> sets user name to run netsaint"
|
||||
ac_help="$ac_help
|
||||
@@ -562,9 +562,9 @@
|
||||
# Prefer explicitly selected file to automatically selected ones.
|
||||
if test -z "$CONFIG_SITE"; then
|
||||
if test "x$prefix" != xNONE; then
|
||||
- CONFIG_SITE="$prefix/share/config.site $prefix/etc/config.site"
|
||||
+ CONFIG_SITE="$prefix/share/nagios/config.site $prefix/etc/nagios/config.site"
|
||||
+ CONFIG_SITE="$prefix/share/netsaint/config.site $prefix/etc/netsaint/config.site"
|
||||
else
|
||||
- CONFIG_SITE="$ac_default_prefix/share/config.site $ac_default_prefix/etc/config.site"
|
||||
+ CONFIG_SITE="$ac_default_prefix/share/nagios/config.site $ac_default_prefix/etc/nagios/config.site"
|
||||
+ CONFIG_SITE="$ac_default_prefix/share/netsaint/config.site $ac_default_prefix/etc/netsaint/config.site"
|
||||
fi
|
||||
fi
|
||||
for ac_site_file in $CONFIG_SITE; do
|
||||
|
@ -2,9 +2,9 @@
|
||||
+++ configure.in Tue May 1 19:36:54 2001
|
||||
@@ -1,7 +1,7 @@
|
||||
dnl Process this -*-m4-*- file with autoconf to produce a configure script.
|
||||
AC_INIT(base/nagios.c)
|
||||
AC_CONFIG_HEADER(common/config.h common/snprintf.h base/nagios.h cgi/cgiutils.h)
|
||||
-AC_PREFIX_DEFAULT(/usr/local/nagios)
|
||||
AC_INIT(base/netsaint.c)
|
||||
AC_CONFIG_HEADER(common/config.h common/snprintf.h base/netsaint.h cgi/cgiutils.h)
|
||||
-AC_PREFIX_DEFAULT(/usr/local/netsaint)
|
||||
+AC_PREFIX_DEFAULT(/usr/local)
|
||||
|
||||
dnl Figure out how to invoke "install" and what install options to use.
|
||||
|
@ -1,25 +1,27 @@
|
||||
--- daemon-init.in.orig Thu Apr 18 06:27:13 2002
|
||||
+++ daemon-init.in Sun May 19 08:39:29 2002
|
||||
@@ -68,11 +68,8 @@
|
||||
--- daemon-init.in.orig Sat Mar 24 19:58:26 2001
|
||||
+++ daemon-init.in Tue May 1 19:38:52 2001
|
||||
@@ -68,12 +68,9 @@
|
||||
|
||||
|
||||
# Source function library
|
||||
-# Solaris doesn't have an rc.d directory, so do a test first
|
||||
-if [ -f /etc/rc.d/init.d/functions ]; then
|
||||
- . /etc/rc.d/init.d/functions
|
||||
-elif [ -f /etc/init.d/functions ]; then
|
||||
- . /etc/init.d/functions
|
||||
-#if [ -f /etc/rc.d/init.d/functions ]; then
|
||||
-#. /etc/rc.d/init.d/functions
|
||||
-#elif [ -f /etc/init.d/functions ]; then
|
||||
-#. /etc/init.d/functions
|
||||
-#fi
|
||||
+if [ -f @sysconfdir@/functions ]; then
|
||||
+. @sysconfdir@/functions
|
||||
fi
|
||||
+fi
|
||||
|
||||
prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
@@ -102,7 +99,7 @@
|
||||
|
||||
start)
|
||||
echo "Starting network monitor: nagios"
|
||||
- su -l $Nagios -c "touch $NagiosVar/nagios.log $NagiosSav"
|
||||
+ su -m $Nagios -c "touch $NagiosVar/nagios.log $NagiosSav"
|
||||
rm -f $NagiosCmd
|
||||
$NagiosBin -d $NagiosCfg
|
||||
if [ -d $NagiosLckDir ]; then touch $NagiosLckDir/$NagiosLckFile; fi
|
||||
echo "Starting network monitor: netsaint"
|
||||
- su $Netsaint -c "touch $NetsaintVar/netsaint.log $NetsaintSav"
|
||||
+ su -m $Netsaint -c "touch $NetsaintVar/netsaint.log $NetsaintSav"
|
||||
rm -f $NetsaintCmd
|
||||
$NetsaintBin -d $NetsaintCfg
|
||||
if [ -d $NetsaintLckDir ]; then touch $NetsaintLckDir/$NetsaintLckFile; fi
|
||||
|
11
net-mgmt/netsaint/files/patch-aj
Normal file
11
net-mgmt/netsaint/files/patch-aj
Normal file
@ -0,0 +1,11 @@
|
||||
--- html/main.html.orig Sat Mar 2 01:41:54 2002
|
||||
+++ html/main.html Wed Mar 13 09:12:58 2002
|
||||
@@ -27,7 +27,7 @@
|
||||
|
||||
<P>
|
||||
<div align="center">
|
||||
-<IMG SRC="images/logofullsize.gif" BORDER="0" ALT="NetSaint" width="238" height="227"><br>
|
||||
+<IMG SRC="images/bsd_logofullsize.gif" BORDER="0" ALT="NetSaint" width="238" height="227"><br>
|
||||
Copyright (c) 1999-2002 Ethan Galstad<br>
|
||||
<a href="mailto:netsaint@netsaint.org">netsaint@netsaint.org</a>
|
||||
</div>
|
11
net-mgmt/netsaint/files/patch-ak
Normal file
11
net-mgmt/netsaint/files/patch-ak
Normal file
@ -0,0 +1,11 @@
|
||||
--- html/side.html.in.org Sun Sep 16 11:36:54 2001
|
||||
+++ html/side.html.in Sun Sep 16 11:39:53 2001
|
||||
@@ -44,7 +44,7 @@
|
||||
<table width="150" border="0">
|
||||
<tr>
|
||||
<td>
|
||||
- <div align="center"><a href="http://www.netsaint.org" target="_top"><img src="images/sblogo.gif" width="130" height="125" border="0"></a></div>
|
||||
+ <div align="center"><a href="http://www.netsaint.org" target="_top"><img src="images/bsd_sblogo.gif" width="110" height="95" border="0"></a></div>
|
||||
</td>
|
||||
</tr>
|
||||
</table>
|
@ -3,8 +3,8 @@
|
||||
if [ $? = 0 ]; then
|
||||
echo "You need to upgrade to RELENG_3, RELENG_4, or HEAD sometime"
|
||||
echo "after July 8, 2000 around 5:15AM UTC, so that ps(1) will"
|
||||
echo "return an error code if a PID does not exist. Nagios needs this!"
|
||||
echo "return an error code if a PID does not exist. Netsaint needs this!"
|
||||
exit
|
||||
else
|
||||
echo "Great, you have a working ps(1)! Nagios can build."
|
||||
echo "Great, you have a working ps(1)! Netsaint can build."
|
||||
fi
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Makefile.in.orig Tue Feb 26 05:03:26 2002
|
||||
+++ Makefile.in Sat May 25 17:03:35 2002
|
||||
@@ -28,7 +28,7 @@
|
||||
--- Makefile.in.orig Mon Apr 30 17:22:35 2001
|
||||
+++ Makefile.in Tue May 1 19:58:50 2001
|
||||
@@ -27,7 +27,7 @@
|
||||
INSTALL_OPTS=@INSTALL_OPTS@
|
||||
COMMAND_OPTS=@COMMAND_OPTS@
|
||||
INIT_DIR=@init_dir@
|
||||
@ -9,33 +9,26 @@
|
||||
CGICFGDIR=$(CGIDIR)
|
||||
PERLDIR=@PERLDIR@
|
||||
|
||||
@@ -132,18 +132,29 @@
|
||||
@@ -99,20 +99,20 @@
|
||||
|
||||
install-config:
|
||||
$(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/nagios.cfg $(DESTDIR)$(CFGDIR)/nagios.cfg-sample
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/cgi.cfg $(DESTDIR)$(CFGDIR)/cgi.cfg-sample
|
||||
- $(INSTALL) -m 660 $(INSTALL_OPTS) sample-config/resource.cfg $(DESTDIR)$(CFGDIR)/resource.cfg-sample
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/nagios.cfg $(DESTDIR)$(CFGDIR)/nagios.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/cgi.cfg $(DESTDIR)$(CFGDIR)/cgi.cfg.dist
|
||||
+ $(INSTALL) -m 660 $(INSTALL_OPTS) sample-config/resource.cfg $(DESTDIR)$(CFGDIR)/resource.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/checkcommands.cfg $(DESTDIR)$(CFGDIR)/checkcommands.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/contactgroups.cfg $(DESTDIR)$(CFGDIR)/contactgroups.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/contacts.cfg $(DESTDIR)$(CFGDIR)/contacts.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/dependencies.cfg $(DESTDIR)$(CFGDIR)/dependencies.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/escalations.cfg $(DESTDIR)$(CFGDIR)/escalations.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/hostgroups.cfg $(DESTDIR)$(CFGDIR)/hostgroups.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/hosts.cfg $(DESTDIR)$(CFGDIR)/hosts.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/misccommands.cfg $(DESTDIR)$(CFGDIR)/misccommands.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-object/services.cfg $(DESTDIR)$(CFGDIR)/services.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-extinfo/hostextinfo.cfg $(DESTDIR)$(CFGDIR)/hostextinfo.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) sample-config/template-extinfo/serviceextinfo.cfg $(DESTDIR)$(CFGDIR)/serviceextinfo.cfg.dist
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) netsaint.cfg $(DESTDIR)$(CFGDIR)
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) hosts.cfg $(DESTDIR)$(CFGDIR)
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) commands.cfg $(DESTDIR)$(CFGDIR)
|
||||
- $(INSTALL) -m 664 $(INSTALL_OPTS) nscgi.cfg $(DESTDIR)$(CFGDIR)
|
||||
- $(INSTALL) -m 660 $(INSTALL_OPTS) resource.cfg $(DESTDIR)$(CFGDIR)
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) netsaint.cfg $(DESTDIR)$(CFGDIR)/netsaint.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) hosts.cfg $(DESTDIR)$(CFGDIR)/hosts.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) commands.cfg $(DESTDIR)$(CFGDIR)/commands.cfg.dist
|
||||
+ $(INSTALL) -m 664 $(INSTALL_OPTS) nscgi.cfg $(DESTDIR)$(CFGDIR)/nscgi.cfg.dist
|
||||
+ $(INSTALL) -m 660 $(INSTALL_OPTS) resource.cfg $(DESTDIR)$(CFGDIR)/resource.cfg.dist
|
||||
|
||||
install-init: install-daemoninit
|
||||
|
||||
install-daemoninit:
|
||||
- $(INSTALL) -m 774 $(INIT_OPTS) daemon-init $(DESTDIR)$(INIT_DIR)/nagios
|
||||
+ $(INSTALL) -m 774 $(INIT_OPTS) daemon-init $(DESTDIR)$(INIT_DIR)/nagios.sh
|
||||
- $(INSTALL) -m 774 $(INIT_OPTS) daemon-init $(DESTDIR)$(INIT_DIR)/netsaint
|
||||
+ $(INSTALL) -m 774 $(INIT_OPTS) daemon-init $(DESTDIR)$(INIT_DIR)/netsaint.sh
|
||||
|
||||
install-commandmode:
|
||||
$(INSTALL) -m 775 $(COMMAND_OPTS) -d $(DESTDIR)$(LOGDIR)/rw
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- base/Makefile.in.orig Sat Apr 20 22:34:02 2002
|
||||
+++ base/Makefile.in Sun May 19 08:35:09 2002
|
||||
@@ -102,7 +102,6 @@
|
||||
--- base/Makefile.in.orig Sun Feb 18 22:33:22 2001
|
||||
+++ base/Makefile.in Thu Mar 1 21:58:39 2001
|
||||
@@ -86,7 +86,6 @@
|
||||
devclean: clean
|
||||
|
||||
install:
|
||||
strip nagios
|
||||
- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
|
||||
$(INSTALL) -m 774 $(INSTALL_OPTS) nagios $(DESTDIR)$(BINDIR)
|
||||
$(INSTALL) -m 774 $(INSTALL_OPTS) netsaint $(DESTDIR)$(BINDIR)
|
||||
|
||||
|
||||
|
@ -4,20 +4,20 @@
|
||||
ac_help=
|
||||
ac_default_prefix=/usr/local
|
||||
# Any additions from configure.in:
|
||||
-ac_default_prefix=/usr/local/nagios
|
||||
+#ac_default_prefix=/usr/local/nagios
|
||||
-ac_default_prefix=/usr/local/netsaint
|
||||
+#ac_default_prefix=/usr/local/netsaint
|
||||
ac_help="$ac_help
|
||||
--with-nagios-user=<user> sets user name to run nagios"
|
||||
--with-netsaint-user=<user> sets user name to run netsaint"
|
||||
ac_help="$ac_help
|
||||
@@ -562,9 +562,9 @@
|
||||
# Prefer explicitly selected file to automatically selected ones.
|
||||
if test -z "$CONFIG_SITE"; then
|
||||
if test "x$prefix" != xNONE; then
|
||||
- CONFIG_SITE="$prefix/share/config.site $prefix/etc/config.site"
|
||||
+ CONFIG_SITE="$prefix/share/nagios/config.site $prefix/etc/nagios/config.site"
|
||||
+ CONFIG_SITE="$prefix/share/netsaint/config.site $prefix/etc/netsaint/config.site"
|
||||
else
|
||||
- CONFIG_SITE="$ac_default_prefix/share/config.site $ac_default_prefix/etc/config.site"
|
||||
+ CONFIG_SITE="$ac_default_prefix/share/nagios/config.site $ac_default_prefix/etc/nagios/config.site"
|
||||
+ CONFIG_SITE="$ac_default_prefix/share/netsaint/config.site $ac_default_prefix/etc/netsaint/config.site"
|
||||
fi
|
||||
fi
|
||||
for ac_site_file in $CONFIG_SITE; do
|
||||
|
@ -2,9 +2,9 @@
|
||||
+++ configure.in Tue May 1 19:36:54 2001
|
||||
@@ -1,7 +1,7 @@
|
||||
dnl Process this -*-m4-*- file with autoconf to produce a configure script.
|
||||
AC_INIT(base/nagios.c)
|
||||
AC_CONFIG_HEADER(common/config.h common/snprintf.h base/nagios.h cgi/cgiutils.h)
|
||||
-AC_PREFIX_DEFAULT(/usr/local/nagios)
|
||||
AC_INIT(base/netsaint.c)
|
||||
AC_CONFIG_HEADER(common/config.h common/snprintf.h base/netsaint.h cgi/cgiutils.h)
|
||||
-AC_PREFIX_DEFAULT(/usr/local/netsaint)
|
||||
+AC_PREFIX_DEFAULT(/usr/local)
|
||||
|
||||
dnl Figure out how to invoke "install" and what install options to use.
|
||||
|
@ -1,25 +1,27 @@
|
||||
--- daemon-init.in.orig Thu Apr 18 06:27:13 2002
|
||||
+++ daemon-init.in Sun May 19 08:39:29 2002
|
||||
@@ -68,11 +68,8 @@
|
||||
--- daemon-init.in.orig Sat Mar 24 19:58:26 2001
|
||||
+++ daemon-init.in Tue May 1 19:38:52 2001
|
||||
@@ -68,12 +68,9 @@
|
||||
|
||||
|
||||
# Source function library
|
||||
-# Solaris doesn't have an rc.d directory, so do a test first
|
||||
-if [ -f /etc/rc.d/init.d/functions ]; then
|
||||
- . /etc/rc.d/init.d/functions
|
||||
-elif [ -f /etc/init.d/functions ]; then
|
||||
- . /etc/init.d/functions
|
||||
-#if [ -f /etc/rc.d/init.d/functions ]; then
|
||||
-#. /etc/rc.d/init.d/functions
|
||||
-#elif [ -f /etc/init.d/functions ]; then
|
||||
-#. /etc/init.d/functions
|
||||
-#fi
|
||||
+if [ -f @sysconfdir@/functions ]; then
|
||||
+. @sysconfdir@/functions
|
||||
fi
|
||||
+fi
|
||||
|
||||
prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
@@ -102,7 +99,7 @@
|
||||
|
||||
start)
|
||||
echo "Starting network monitor: nagios"
|
||||
- su -l $Nagios -c "touch $NagiosVar/nagios.log $NagiosSav"
|
||||
+ su -m $Nagios -c "touch $NagiosVar/nagios.log $NagiosSav"
|
||||
rm -f $NagiosCmd
|
||||
$NagiosBin -d $NagiosCfg
|
||||
if [ -d $NagiosLckDir ]; then touch $NagiosLckDir/$NagiosLckFile; fi
|
||||
echo "Starting network monitor: netsaint"
|
||||
- su $Netsaint -c "touch $NetsaintVar/netsaint.log $NetsaintSav"
|
||||
+ su -m $Netsaint -c "touch $NetsaintVar/netsaint.log $NetsaintSav"
|
||||
rm -f $NetsaintCmd
|
||||
$NetsaintBin -d $NetsaintCfg
|
||||
if [ -d $NetsaintLckDir ]; then touch $NetsaintLckDir/$NetsaintLckFile; fi
|
||||
|
11
net/netsaint/files/patch-aj
Normal file
11
net/netsaint/files/patch-aj
Normal file
@ -0,0 +1,11 @@
|
||||
--- html/main.html.orig Sat Mar 2 01:41:54 2002
|
||||
+++ html/main.html Wed Mar 13 09:12:58 2002
|
||||
@@ -27,7 +27,7 @@
|
||||
|
||||
<P>
|
||||
<div align="center">
|
||||
-<IMG SRC="images/logofullsize.gif" BORDER="0" ALT="NetSaint" width="238" height="227"><br>
|
||||
+<IMG SRC="images/bsd_logofullsize.gif" BORDER="0" ALT="NetSaint" width="238" height="227"><br>
|
||||
Copyright (c) 1999-2002 Ethan Galstad<br>
|
||||
<a href="mailto:netsaint@netsaint.org">netsaint@netsaint.org</a>
|
||||
</div>
|
11
net/netsaint/files/patch-ak
Normal file
11
net/netsaint/files/patch-ak
Normal file
@ -0,0 +1,11 @@
|
||||
--- html/side.html.in.org Sun Sep 16 11:36:54 2001
|
||||
+++ html/side.html.in Sun Sep 16 11:39:53 2001
|
||||
@@ -44,7 +44,7 @@
|
||||
<table width="150" border="0">
|
||||
<tr>
|
||||
<td>
|
||||
- <div align="center"><a href="http://www.netsaint.org" target="_top"><img src="images/sblogo.gif" width="130" height="125" border="0"></a></div>
|
||||
+ <div align="center"><a href="http://www.netsaint.org" target="_top"><img src="images/bsd_sblogo.gif" width="110" height="95" border="0"></a></div>
|
||||
</td>
|
||||
</tr>
|
||||
</table>
|
@ -3,8 +3,8 @@
|
||||
if [ $? = 0 ]; then
|
||||
echo "You need to upgrade to RELENG_3, RELENG_4, or HEAD sometime"
|
||||
echo "after July 8, 2000 around 5:15AM UTC, so that ps(1) will"
|
||||
echo "return an error code if a PID does not exist. Nagios needs this!"
|
||||
echo "return an error code if a PID does not exist. Netsaint needs this!"
|
||||
exit
|
||||
else
|
||||
echo "Great, you have a working ps(1)! Nagios can build."
|
||||
echo "Great, you have a working ps(1)! Netsaint can build."
|
||||
fi
|
||||
|
Loading…
Reference in New Issue
Block a user