Add view3ds 1.0.0, a simple realtime 3DS file previewer based on the Lib3ds

library.
This commit is contained in:
Maxim Sobolev 2001-01-18 19:06:25 +00:00
parent a89235c55d
commit f12751a5d7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=37305
7 changed files with 73 additions and 0 deletions

View File

@ -206,6 +206,7 @@
SUBDIR += vcdgear
SUBDIR += vcg
SUBDIR += vid
SUBDIR += view3ds
SUBDIR += whirlgif
SUBDIR += wmgrabimage
SUBDIR += wmicons

24
graphics/view3ds/Makefile Normal file
View File

@ -0,0 +1,24 @@
# New ports collection makefile for: view3ds
# Date created: 18 January 2001
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= view3ds
PORTVERSION= 1.0.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= lib3ds
MAINTAINER= sobomax@FreeBSD.org
USE_X_PREFIX= yes
USE_QT2= yes
USE_MESA= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= LDFLAGS="-lm" \
QTDIR=${X11BASE}
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (view3ds-1.0.0.tar.gz) = d2b297379865111654537dd141e0e79a

View File

@ -0,0 +1,42 @@
$FreeBSD$
--- configure 2001/01/18 18:11:47 1.1
+++ configure 2001/01/18 18:15:35
@@ -2939,10 +2939,10 @@
echo "$ac_t""no" 1>&6
else
echo "$ac_t""yes" 1>&6
- qt_includes="$QTDIR/include"
+ qt_includes="$QTDIR/include/qt2"
qt_libraries="$QTDIR/lib"
qt_binaries="$QTDIR/bin"
- MOC="$qt_binaries/moc";
+ MOC="$qt_binaries/moc2";
UIC="$qt_binaries/uic";
fi
fi
@@ -3012,9 +3012,9 @@
saved_LIBS="$LIBS"
CPPFLAGS="$saved_CPPFLAGS -I$qt_includes"
if test -n "$qt_libraries"; then
- LIBS="$saved_LIBS -L$qt_libraries -lqt"
+ LIBS="$saved_LIBS -L$qt_libraries -lqt2"
else
- LIBS="$saved_LIBS -lqt -lm $X11_LIBS"
+ LIBS="$saved_LIBS -lqt2 -lm $X11_LIBS"
fi
echo $ac_n "checking for QT includes ($qt_includes)""... $ac_c" 1>&6
echo "configure:3021: checking for QT includes ($qt_includes)" >&5
@@ -3086,9 +3086,9 @@
rm -f conftest*
if test "$qt_libraries_found" = "yes"; then
if test -n "$qt_libraries"; then
- QT_LIBS="-L$qt_libraries -lqt -lm $X11_LIBS";
+ QT_LIBS="-L$qt_libraries -lqt2 -lm $X11_LIBS";
else
- QT_LIBS="-lqt -lm $X11_LIBS";
+ QT_LIBS="-lqt2 -lm $X11_LIBS";
fi
echo "$ac_t""yes" 1>&6
else

View File

@ -0,0 +1 @@
A simple realtime 3DS file previewer based on the Lib3ds Library

View File

@ -0,0 +1,3 @@
A simple realtime 3DS file previewer based on the Lib3ds Library.
WWW: http://lib3ds.sourceforge.net/

View File

@ -0,0 +1 @@
bin/view3ds