lang/basic256: update to 2.0.0.1
While here: * Reorder some variables * dos2unix only on the necessary files (thanks tcberner@) so resources file doesn't break. * Add missing USES=gl
This commit is contained in:
parent
12ca925c42
commit
f11d8eed71
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=534884
@ -1,10 +1,9 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= basic256
|
||||
PORTVERSION= 1.1.4.0
|
||||
PORTREVISION= 3
|
||||
PORTVERSION= 2.0.0.1
|
||||
CATEGORIES= lang
|
||||
MASTER_SITES= SF/kidbasic/${PORTNAME}
|
||||
MASTER_SITES= SF/kidbasic/
|
||||
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
|
||||
|
||||
MAINTAINER= fernape@FreeBSD.org
|
||||
@ -16,17 +15,16 @@ BUILD_DEPENDS= espeak:audio/espeak \
|
||||
sqlite3:databases/sqlite3 \
|
||||
flex:textproc/flex
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
USES= bison compiler:c++11-lang dos2unix qmake qt:5 sdl
|
||||
USES= bison compiler:c++11-lib dos2unix gl qmake qt:5 sdl
|
||||
DOS2UNIX_FILES= BASIC256.pro Interpreter.cpp
|
||||
USE_SDL= sdl mixer
|
||||
USE_GL+= gl
|
||||
USE_QT= buildtools core gui multimedia network printsupport sql widgets serialport
|
||||
QMAKE_ARGS+= LOCALBASE="${LOCALBASE}"
|
||||
QMAKE_SOURCE_PATH= BASIC256.pro
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/BASIC256.pro
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (basic256_1.1.4.0.orig.tar.gz) = 9df3ac4535448c1bd721364829e1bf4df7087c9b2c8d789e1fb5903e58c043ba
|
||||
SIZE (basic256_1.1.4.0.orig.tar.gz) = 2611721
|
||||
TIMESTAMP = 1588759626
|
||||
SHA256 (basic256_2.0.0.1.orig.tar.gz) = 720e08c9b7a60cbcf6cc342dcf25d8c98e271903e0b1ab96422968fa981d041f
|
||||
SIZE (basic256_2.0.0.1.orig.tar.gz) = 1321457
|
||||
|
@ -1,62 +1,65 @@
|
||||
--- BASIC256.pro.orig 2014-11-05 17:03:39 UTC
|
||||
--- BASIC256.pro.orig 2020-05-07 12:32:08 UTC
|
||||
+++ BASIC256.pro
|
||||
@@ -13,13 +13,6 @@ CONFIG += qt debug_and_release
|
||||
OBJECTS_DIR = tmp/obj
|
||||
MOC_DIR = tmp/moc
|
||||
@@ -15,13 +15,6 @@ CONFIG += console
|
||||
OBJECTS_DIR = tmp/obj
|
||||
MOC_DIR = tmp/moc
|
||||
|
||||
-QT += webkit
|
||||
-QT += gui
|
||||
-QT += sql
|
||||
-QT += widgets
|
||||
-QT += printsupport
|
||||
-QT += serialport
|
||||
-
|
||||
RESOURCES += resources/resource.qrc
|
||||
RC_FILE = resources/basic256.rc
|
||||
TRANSLATIONS = Translations/basic256_en.ts \
|
||||
@@ -86,7 +79,7 @@ unix:!macx {
|
||||
-#QT += webkitwidgets
|
||||
-#QT += webkit
|
||||
-QT += gui
|
||||
-QT += sql
|
||||
-QT += widgets
|
||||
-QT += printsupport
|
||||
-QT += serialport
|
||||
|
||||
RESOURCES += resources/resource.qrc
|
||||
TRANSLATIONS = Translations/basic256_en.ts \
|
||||
@@ -90,15 +83,21 @@ unix:!macx {
|
||||
|
||||
## TTS Option 2 - use the espeak library
|
||||
DEFINES += ESPEAK
|
||||
- INCLUDEPATH += /usr/include/espeak
|
||||
+ INCLUDEPATH += $$LOCALBASE/include/espeak
|
||||
LIBS += -lespeak
|
||||
DEFINES += ESPEAK
|
||||
- INCLUDEPATH += /usr/include/espeak
|
||||
+ INCLUDEPATH += $$LOCALBASE/include/espeak
|
||||
LIBS += -lespeak
|
||||
LIBS += -lm
|
||||
|
||||
LIBS += -lm
|
||||
@@ -101,8 +94,10 @@ unix:!macx {
|
||||
|
||||
# Sound - QT Mobility Multimedia AudioOut
|
||||
DEFINES += SOUND_QMOBILITY
|
||||
- QT += multimedia
|
||||
- INCLUDEPATH += QtMultimediaKit
|
||||
########
|
||||
# Sound class - How Sound statement works
|
||||
########
|
||||
- QT += multimedia
|
||||
- INCLUDEPATH += QtMultimediaKit
|
||||
+ INCLUDEPATH += $$LOCALBASE/include/qt5/QtMultimedia
|
||||
+ INCLUDEPATH += $$LOCALBASE/include/qt5/QtNetwork
|
||||
+ INCLUDEPATH += $$LOCALBASE/include/qt5/QtPrintSupport
|
||||
+ INCLUDEPATH += $$LOCALBASE/include/qt5/QtSerialPort
|
||||
+ INCLUDEPATH += QtMobility
|
||||
+ INCLUDEPATH += $$LOCALBASE/include/qt5/QtSql
|
||||
+ INCLUDEPATH += $$LOCALBASE/include/qt5/QtWidgets
|
||||
+ INCLUDEPATH += QtMobility
|
||||
+ LIBS += -L$$LOCALBASE/lib -L$$LOCALBASE/lib/qt5 -lQt5Gui -lQt5Core -lQt5Widgets -lQt5Sql -lQt5Multimedia -lQt5PrintSupport -lQt5SerialPort
|
||||
INCLUDEPATH += QtMobility
|
||||
INCLUDEPATH += QtMobility
|
||||
|
||||
|
||||
@@ -110,19 +105,19 @@ unix:!macx {
|
||||
@@ -106,19 +105,19 @@ unix:!macx {
|
||||
# rules for make install
|
||||
########
|
||||
exampleFiles.files = ./Examples
|
||||
- exampleFiles.path = /usr/share/basic256
|
||||
+ exampleFiles.path = $$PREFIX/share/basic256
|
||||
INSTALLS += exampleFiles
|
||||
exampleFiles.files = ./Examples
|
||||
- exampleFiles.path = /usr/share/basic256
|
||||
+ exampleFiles.path = $$PREFIX/share/basic256
|
||||
INSTALLS += exampleFiles
|
||||
|
||||
helpHTMLFiles.files = ./wikihelp/help
|
||||
- helpHTMLFiles.path = /usr/share/basic256
|
||||
+ helpHTMLFiles.path = $$PREFIX/share/basic256
|
||||
INSTALLS += helpHTMLFiles
|
||||
helpHTMLFiles.files = ./wikihelp/help
|
||||
- helpHTMLFiles.path = /usr/share/basic256
|
||||
+ helpHTMLFiles.path = $$PREFIX/share/basic256
|
||||
INSTALLS += helpHTMLFiles
|
||||
|
||||
transFiles.files = ./Translations/*.qm
|
||||
- transFiles.path = /usr/share/basic256
|
||||
+ transFiles.path = $$PREFIX/share/basic256
|
||||
INSTALLS += transFiles
|
||||
transFiles.files = ./Translations/*.qm
|
||||
- transFiles.path = /usr/share/basic256
|
||||
+ transFiles.path = $$PREFIX/share/basic256
|
||||
INSTALLS += transFiles
|
||||
|
||||
# main program executable
|
||||
- target.path = /usr/bin
|
||||
+ target.path = $$PREFIX/bin
|
||||
INSTALLS += target
|
||||
- target.path = /usr/bin
|
||||
+ target.path = $$PREFIX/bin
|
||||
INSTALLS += target
|
||||
|
||||
}
|
||||
|
@ -1,17 +0,0 @@
|
||||
Drop 'using namespace std' to avoid errors when building in C++11 mode. This
|
||||
can happen on FreeBSD 10+ and Qt 5.6+, where Qt may end up passing -std=gnu++11
|
||||
and lead the call to bind(2) becoming a call to std::bind().
|
||||
|
||||
Interpreter.cpp:4282:105: error: invalid operands to binary expression ('__bind<int &, sockaddr *, unsigned long>' and 'int')
|
||||
|
||||
Submitted upstream: https://sourceforge.net/p/kidbasic/patches/30/
|
||||
--- Interpreter.cpp.orig 2016-09-03 10:00:06 UTC
|
||||
+++ Interpreter.cpp
|
||||
@@ -66,7 +66,6 @@ InpOut32OutType Out32 = NULL;
|
||||
|
||||
#include <QtWidgets/QMessageBox>
|
||||
|
||||
-using namespace std;
|
||||
|
||||
#include "LEX/basicParse.tab.h"
|
||||
#include "WordCodes.h"
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user