New port: devel/pmccabe

C/C++ code complexity estimator and related tools.

QA page:	http://codelabs.ru/fbsd/ports/qa/devel/pmccabe/2.6
Feature safe:	yes
This commit is contained in:
Eygene Ryabinkin 2012-11-10 09:53:50 +00:00
parent 304742240d
commit f11416edfa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=307266
5 changed files with 63 additions and 0 deletions

View File

@ -3140,6 +3140,7 @@
SUBDIR += pit
SUBDIR += pkgconf
SUBDIR += plan9port
SUBDIR += pmccabe
SUBDIR += pmd
SUBDIR += pmk
SUBDIR += poco

36
devel/pmccabe/Makefile Normal file
View File

@ -0,0 +1,36 @@
# $FreeBSD$
PORTNAME= pmccabe
PORTVERSION= 2.6
CATEGORIES= devel
MASTER_SITES= http://ftp.de.debian.org/debian/pool/main/p/pmccabe/ \
http://dist.codelabs.ru/fbsd/pmccabe/
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= rea@FreeBSD.org
COMMENT= Code complexity estimator
LICENSE= GPLv2
WRKSRC= ${WRKDIR}/${PORTNAME}
BINARIES= decomment pmccabe
SCRIPTS= codechanges vifn
MAN1= codechanges.1 decomment.1 pmccabe.1 vifn.1
PLIST_FILES= ${BINARIES:S,^,bin/,} \
${SCRIPTS:S,^,bin/,}
do-install:
.for f in ${BINARIES}
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
.for f in ${SCRIPTS}
${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin
.endfor
.if !defined(NO_INSTALL_MANPAGES)
. for f in ${MAN1}
${INSTALL_MAN} ${WRKSRC}/${f} ${MANPREFIX}/man/man1
. endfor
.endif
.include <bsd.port.mk>

2
devel/pmccabe/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (pmccabe_2.6.tar.gz) = e490fe7c9368fec3613326265dd44563dc47182d142f579a40eca0e5d20a7028
SIZE (pmccabe_2.6.tar.gz) = 59726

View File

@ -0,0 +1,13 @@
Prunes bash'ism.
--- testsuite.orig 2012-11-07 13:50:33.152011945 +0400
+++ testsuite 2012-11-07 13:50:50.403002720 +0400
@@ -26,7 +26,7 @@
TEST1()
{
- typeset f
+ local f
f=$1
shift
./pmccabe -vt $* > $f.out 2>&1

11
devel/pmccabe/pkg-descr Normal file
View File

@ -0,0 +1,11 @@
pmccabe calculates McCabe-style cyclomatic complexity for C and C++
source code. Per-function complexity may be used for spotting likely
trouble spots and for estimating testing effort.
pmccabe also includes a non-commented line counter, decomment which
only removes comments from source code; codechanges, a program to
calculate the amount of change which has occurred between two source
trees or files; and vifn, to invoke vi given a function name rather
than a file name.
WWW: http://www.parisc-linux.org/~bame/pmccabe/