Add spdlog, another c++ logging library.

This commit is contained in:
Vanilla I. Shu 2017-01-14 03:37:20 +00:00
parent 2b9e5e4528
commit f0f6581fb0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=431455
6 changed files with 77 additions and 0 deletions

View File

@ -50,6 +50,7 @@
SUBDIR += R-cran-sourcetools
SUBDIR += R-cran-tibble
SUBDIR += R-cran-tidyr
SUBDIR += spdlog
SUBDIR += SpecTcl
SUBDIR += aap
SUBDIR += aarch64-binutils

20
devel/spdlog/Makefile Normal file
View File

@ -0,0 +1,20 @@
# Created by: vanilla@
# $FreeBSD$
PORTNAME= spdlog
PORTVERSION= 0.11.0
DISTVERSIONPREFIX= v
CATEGORIES= devel
MAINTAINER= vanilla@FreeBSD.org
COMMENT= Super fast C++ logging library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= gabime
USES= cmake dos2unix pathfix
.include <bsd.port.mk>

3
devel/spdlog/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1483448051
SHA256 (gabime-spdlog-v0.11.0_GH0.tar.gz) = 8c0f1810fb6b7d23fef70c2ea8b6fa6768ac8d18d6e0de39be1f48865e22916e
SIZE (gabime-spdlog-v0.11.0_GH0.tar.gz) = 146346

View File

@ -0,0 +1,11 @@
--- CMakeLists.txt.orig 2017-01-14 03:31:12 UTC
+++ CMakeLists.txt
@@ -36,7 +36,7 @@ endif()
# * https://github.com/forexample/package-example
set(generated_dir "${CMAKE_CURRENT_BINARY_DIR}/generated")
-set(config_install_dir "lib/cmake/${PROJECT_NAME}")
+set(config_install_dir "share/cmake/Modules/${PROJECT_NAME}")
set(include_install_dir "include")
set(pkgconfig_install_dir "libdata/pkgconfig")

3
devel/spdlog/pkg-descr Normal file
View File

@ -0,0 +1,3 @@
Super fast C++ logging library.
WWW: https://github.com/gabime/spdlog

39
devel/spdlog/pkg-plist Normal file
View File

@ -0,0 +1,39 @@
include/spdlog/async_logger.h
include/spdlog/common.h
include/spdlog/details/async_log_helper.h
include/spdlog/details/async_logger_impl.h
include/spdlog/details/file_helper.h
include/spdlog/details/log_msg.h
include/spdlog/details/logger_impl.h
include/spdlog/details/mpmc_bounded_q.h
include/spdlog/details/null_mutex.h
include/spdlog/details/os.h
include/spdlog/details/pattern_formatter_impl.h
include/spdlog/details/registry.h
include/spdlog/details/spdlog_impl.h
include/spdlog/fmt/bundled/format.cc
include/spdlog/fmt/bundled/format.h
include/spdlog/fmt/bundled/ostream.cc
include/spdlog/fmt/bundled/ostream.h
include/spdlog/fmt/bundled/printf.h
include/spdlog/fmt/fmt.h
include/spdlog/fmt/ostr.h
include/spdlog/formatter.h
include/spdlog/logger.h
include/spdlog/sinks/android_sink.h
include/spdlog/sinks/ansicolor_sink.h
include/spdlog/sinks/base_sink.h
include/spdlog/sinks/dist_sink.h
include/spdlog/sinks/file_sinks.h
include/spdlog/sinks/msvc_sink.h
include/spdlog/sinks/null_sink.h
include/spdlog/sinks/ostream_sink.h
include/spdlog/sinks/sink.h
include/spdlog/sinks/stdout_sinks.h
include/spdlog/sinks/syslog_sink.h
include/spdlog/spdlog.h
include/spdlog/tweakme.h
libdata/pkgconfig/spdlog.pc
share/cmake/Modules/spdlog/spdlogConfig.cmake
share/cmake/Modules/spdlog/spdlogConfigVersion.cmake
share/cmake/Modules/spdlog/spdlogTargets.cmake