Back from the Attic

Point to the new home and master_site

Submitted by:	scf@
This commit is contained in:
Baptiste Daroussin 2011-08-01 15:25:04 +00:00
parent 458a4172b5
commit f0de4761aa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=278716
5 changed files with 66 additions and 0 deletions

32
print/nenscript/Makefile Normal file
View File

@ -0,0 +1,32 @@
# New ports collection makefile for: nenscript
# Date created: 10 November 1999
# Whom: cjm2
#
# $FreeBSD$
#
PORTNAME= nenscript
PORTVERSION= 1.13.3
CATEGORIES= print
MASTER_SITES= http://www.ai.mit.edu/projects/im/magnus/nenscript/
MAINTAINER= ports@FreeBSD.org
COMMENT= A clone of the proprietary enscript program from Adobe Systems
USE_BZIP2= yes
MAKEFILE= makefile
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
MAN1= nenscript.1
.include <bsd.port.pre.mk>
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nenscript ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/nenscript.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/readme ${DOCSDIR}
.endif
.include <bsd.port.post.mk>

2
print/nenscript/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (nenscript-1.13.3.tar.bz2) = 4e8811598891f956cbd54de0fb99744f71f9d68fe143d025ec91983df557e46e
SIZE (nenscript-1.13.3.tar.bz2) = 24664

View File

@ -0,0 +1,11 @@
--- main.c.orig 2008-07-19 14:32:26.000000000 -0500
+++ main.c 2008-07-19 14:34:12.000000000 -0500
@@ -601,7 +601,7 @@
exit (1);
}
#else
- sprintf (cmd, "%s %s", LPR, printername);
+ snprintf (cmd, sizeof(cmd), "%s %s", LPR, printername);
if ((outputstream = popen (cmd, "w")) == NULL) {
perror (LPR);
exit (1);

18
print/nenscript/pkg-descr Normal file
View File

@ -0,0 +1,18 @@
A clone of the proprietary enscript program from Adobe Systems. For those
who have never used enscript, it is a good ASCII to Postscript converter.
The main features of nenscript are:
. produces Postscript output which fully conforms to
the Document Structuring Conventions
. support for normal and "gaudy" output
. support for single or double column output
. allows insertion of titles and headers in any font.
. multiple copies of a document
Features additional to nenscript are:
. automatic wrapping of long lines
. availability under MSDOS
. executable is self contained - no additional files required
WWW: http://www.ai.mit.edu/projects/im/magnus/nenscript/

View File

@ -0,0 +1,3 @@
bin/nenscript
%%PORTDOCS%%%%DOCSDIR%%/readme
%%PORTDOCS%%@dirrm %%DOCSDIR%%