- Update to 0.41
PR: 110008 Submitted by: Anderson S. Ferreira <anderson@cnpm.embrapa.br> (maintainer)
This commit is contained in:
parent
14b47cc711
commit
f06efcbd45
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=186858
@ -6,11 +6,11 @@
|
||||
#
|
||||
|
||||
PORTNAME= klamav
|
||||
PORTVERSION= 0.37
|
||||
PORTVERSION= 0.41
|
||||
CATEGORIES= security
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= klamav
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
|
||||
|
||||
MAINTAINER= anderson@cnpm.embrapa.br
|
||||
COMMENT= A KDE 3 front-end to Clam Anti-Virus
|
||||
@ -18,17 +18,21 @@ COMMENT= A KDE 3 front-end to Clam Anti-Virus
|
||||
LIB_DEPENDS= clamav:${PORTSDIR}/security/clamav \
|
||||
sqlite3:${PORTSDIR}/databases/sqlite3
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}-${PORTVERSION}
|
||||
|
||||
PREFIX= ${KDE_PREFIX}
|
||||
DOCSDIR= ${PREFIX}/share/doc/HTML/en/klamav02
|
||||
|
||||
USE_BZIP2= yes
|
||||
USE_GZIP= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOME= pkgconfig
|
||||
USE_GETTEXT= yes
|
||||
INSTALLS_ICONS= yes
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
|
||||
CONFIGURE_ENV= LDFLAGS=${PTHREAD_LIBS}
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
USE_AUTOTOOLS+= aclocal:19
|
||||
|
||||
CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS} -lintl -L${PREFIX}/lib"
|
||||
CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} \
|
||||
--without-included-sqlite
|
||||
|
||||
@ -40,4 +44,8 @@ USE_KDELIBS_VER= 3
|
||||
IGNORE= klamav doesn't compile on FreeBSD 4.X
|
||||
.endif
|
||||
|
||||
pre-configure:
|
||||
@${CP} ${LTMAIN} ${WRKSRC}/admin
|
||||
@${CP} ${LIBTOOL_M4} ${WRKSRC}/admin
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
SHA256 (klamav-0.37.tar.bz2) = 8953f106fe9a192cfc5079dc4c2571a35c706744671d7e24955fde2b9cc46fd0
|
||||
MD5 (klamav-0.37.tar.bz2) = 555a06b78d98a1950ca8c660fd7990a3
|
||||
SIZE (klamav-0.37.tar.bz2) = 1134003
|
||||
MD5 (klamav-0.41-source.tar.gz) = 4878b88f6b069dcef0f5825f9bca624a
|
||||
SHA256 (klamav-0.41-source.tar.gz) = 7419db65041097129929064f065ae623e8e04a67a550ef24dff3d20223802340
|
||||
SIZE (klamav-0.41-source.tar.gz) = 1783244
|
||||
|
3
security/klamav/files/ltmain.sh
Normal file
3
security/klamav/files/ltmain.sh
Normal file
@ -0,0 +1,3 @@
|
||||
#!/bin/sh
|
||||
|
||||
ln -s /usr/local/bin/libtool
|
@ -1,11 +0,0 @@
|
||||
--- configure Thu Mar 9 08:15:40 2006
|
||||
+++ configure Thu Mar 9 08:16:11 2006
|
||||
@@ -9,6 +9,8 @@
|
||||
## M4sh Initialization. ##
|
||||
## --------------------- ##
|
||||
|
||||
+PKGCONFIGFOUND=yes
|
||||
+
|
||||
# Be Bourne compatible
|
||||
if test -n "${ZSH_VERSION+set}" && (emulate sh) >/dev/null 2>&1; then
|
||||
emulate sh
|
11
security/klamav/files/patch-freshklam.cpp
Normal file
11
security/klamav/files/patch-freshklam.cpp
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/freshklam.cpp.orig Tue Mar 6 11:05:52 2007
|
||||
+++ src/freshklam.cpp Tue Mar 6 11:06:44 2007
|
||||
@@ -122,6 +122,8 @@
|
||||
software_layout->setColStretch(0, 1);
|
||||
software_layout->setColStretch(1, 1);
|
||||
|
||||
+ software_group->hide();
|
||||
+
|
||||
|
||||
//Dazuko
|
||||
QWidget *dazuko_hlp = new QWidget( software_group );
|
@ -1,15 +1,6 @@
|
||||
--- src/klamd.cpp Wed Mar 8 15:47:12 2006
|
||||
+++ src/klamd.cpp Wed Mar 8 15:49:18 2006
|
||||
@@ -699,7 +699,7 @@
|
||||
|
||||
|
||||
dazukoLoaded = FALSE;
|
||||
- QString lsmodCommand="lsmod";
|
||||
+ QString lsmodCommand="kldstat";
|
||||
lsmodproc = new KProcIO();
|
||||
QString curpath = (QString) getenv("PATH");
|
||||
lsmodproc->setEnvironment("PATH",curpath + ":/usr/local/sbin:/usr/sbin:/sbin:/usr/local/bin:/usr/bin:/bin");
|
||||
@@ -730,7 +730,7 @@
|
||||
--- src/klamd.cpp.orig Tue Mar 6 13:12:00 2007
|
||||
+++ src/klamd.cpp Tue Mar 6 13:13:55 2007
|
||||
@@ -742,7 +742,7 @@
|
||||
{
|
||||
if (!(dazukoLoaded)){
|
||||
int result;
|
||||
@ -18,12 +9,12 @@
|
||||
i18n( "Load Module" ),
|
||||
i18n( "Load Module" ),
|
||||
i18n( "Delete2" ));
|
||||
@@ -803,7 +803,7 @@
|
||||
@@ -815,7 +815,7 @@
|
||||
//
|
||||
// //kdDebug() << release << endl;
|
||||
// QString insmodCommand="insmod /lib/modules/" + release + "/dazuko.o";
|
||||
- QString insmodCommand="modprobe dazuko";
|
||||
+ QString insmodCommand="kldload /usr/local/modules/dazuko.ko";
|
||||
+ QString insmodCommand="kldload dazuko.ko";
|
||||
//QString insmodCommand="insmod /opt/kde/bin/dazuko.o";
|
||||
KProcIO *insmodproc = new KProcIO();
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- po/cs.po Tue Jun 6 11:34:08 2006
|
||||
+++ po/cs.po Tue Jun 6 11:35:12 2006
|
||||
@@ -1089,12 +1089,12 @@
|
||||
--- po/cs.po.orig Tue Mar 6 11:34:52 2007
|
||||
+++ po/cs.po Tue Mar 6 11:36:11 2007
|
||||
@@ -987,12 +987,12 @@
|
||||
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
|
||||
"to gain real-time access to files. If you don't want this message to appear "
|
||||
"in future, put the following command in your initialization scripts: "
|
||||
@ -15,9 +15,9 @@
|
||||
|
||||
#: klamd.cpp:734 klamd.cpp:735
|
||||
msgid "Load Module"
|
||||
--- po/de.po Tue Jun 6 11:34:08 2006
|
||||
+++ po/de.po Tue Jun 6 11:35:33 2006
|
||||
@@ -1080,7 +1080,7 @@
|
||||
--- po/de.po.orig Tue Mar 6 11:34:52 2007
|
||||
+++ po/de.po Tue Mar 6 11:36:32 2007
|
||||
@@ -985,7 +985,7 @@
|
||||
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
|
||||
"to gain real-time access to files. If you don't want this message to appear "
|
||||
"in future, put the following command in your initialization scripts: "
|
||||
@ -26,9 +26,9 @@
|
||||
msgstr ""
|
||||
"Es muß das Modul mit dem Namen \"dazuko\" geladen werden. Dies ermöglicht "
|
||||
"einen verbesserten Zugriffn auf die Datein. Wenn sie nicht möchten, dass "
|
||||
--- po/es.po Tue Jun 6 11:34:08 2006
|
||||
+++ po/es.po Tue Jun 6 11:36:05 2006
|
||||
@@ -747,12 +747,12 @@
|
||||
--- po/es.po.orig Tue Mar 6 11:34:52 2007
|
||||
+++ po/es.po Tue Mar 6 11:36:53 2007
|
||||
@@ -991,12 +991,12 @@
|
||||
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
|
||||
"to gain real-time access to files. If you don't want this message to appear "
|
||||
"in future, put the following command in your initialization scripts: "
|
||||
@ -41,10 +41,10 @@
|
||||
-"inicialización: 'modprobe dazuko.o'. Necesita la clave de administrador."
|
||||
+"inicialización: 'kldload dazuko.ko'. Necesita la clave de administrador."
|
||||
|
||||
#: klamd.cpp:718 klamd.cpp:719
|
||||
#: klamd.cpp:734 klamd.cpp:735
|
||||
msgid "Load Module"
|
||||
--- po/fr.po Tue Jun 6 11:34:08 2006
|
||||
+++ po/fr.po Tue Jun 6 11:37:06 2006
|
||||
--- po/fr.po.orig Tue Mar 6 11:34:52 2007
|
||||
+++ po/fr.po Tue Mar 6 11:38:07 2007
|
||||
@@ -1018,8 +1018,8 @@
|
||||
msgstr "Il y a eu un problème au moment de détecter l'état de 'dazuko'."
|
||||
|
||||
@ -56,9 +56,9 @@
|
||||
|
||||
#: klamd.cpp:734
|
||||
#: klamd.cpp:735
|
||||
--- po/hu.po Tue Jun 6 11:34:08 2006
|
||||
+++ po/hu.po Tue Jun 6 11:37:27 2006
|
||||
@@ -1086,12 +1086,12 @@
|
||||
--- po/hu.po.orig Tue Mar 6 11:34:52 2007
|
||||
+++ po/hu.po Tue Mar 6 11:39:07 2007
|
||||
@@ -983,12 +983,12 @@
|
||||
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
|
||||
"to gain real-time access to files. If you don't want this message to appear "
|
||||
"in future, put the following command in your initialization scripts: "
|
||||
@ -73,9 +73,9 @@
|
||||
"jelszót meg kell adni."
|
||||
|
||||
#: klamd.cpp:734 klamd.cpp:735
|
||||
--- po/it.po Tue Jun 6 11:34:08 2006
|
||||
+++ po/it.po Tue Jun 6 11:37:39 2006
|
||||
@@ -1067,7 +1067,7 @@
|
||||
--- po/it.po.orig Tue Mar 6 11:34:52 2007
|
||||
+++ po/it.po Tue Mar 6 11:39:49 2007
|
||||
@@ -972,7 +972,7 @@
|
||||
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
|
||||
"to gain real-time access to files. If you don't want this message to appear "
|
||||
"in future, put the following command in your initialization scripts: "
|
||||
@ -84,9 +84,9 @@
|
||||
msgstr ""
|
||||
|
||||
#: klamd.cpp:734 klamd.cpp:735
|
||||
--- po/pl.po Tue Jun 6 11:34:08 2006
|
||||
+++ po/pl.po Tue Jun 6 11:38:36 2006
|
||||
@@ -1083,12 +1083,12 @@
|
||||
--- po/pl.po.orig Tue Mar 6 11:34:52 2007
|
||||
+++ po/pl.po Tue Mar 6 11:40:20 2007
|
||||
@@ -988,12 +988,12 @@
|
||||
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
|
||||
"to gain real-time access to files. If you don't want this message to appear "
|
||||
"in future, put the following command in your initialization scripts: "
|
||||
@ -101,9 +101,9 @@
|
||||
"chwilę pojawi się pytanie o hasło administratora."
|
||||
|
||||
#: klamd.cpp:734 klamd.cpp:735
|
||||
--- po/pt_BR.po Tue Jun 6 11:34:08 2006
|
||||
+++ po/pt_BR.po Tue Jun 6 11:39:23 2006
|
||||
@@ -1151,12 +1151,12 @@
|
||||
--- po/pt_BR.po.orig Tue Mar 6 11:34:52 2007
|
||||
+++ po/pt_BR.po Tue Mar 6 11:40:44 2007
|
||||
@@ -1046,12 +1046,12 @@
|
||||
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
|
||||
"to gain real-time access to files. If you don't want this message to appear "
|
||||
"in future, put the following command in your initialization scripts: "
|
||||
@ -118,9 +118,9 @@
|
||||
"função."
|
||||
|
||||
#: klamd.cpp:734 klamd.cpp:735
|
||||
--- po/ru.po Tue Jun 6 11:34:08 2006
|
||||
+++ po/ru.po Tue Jun 6 11:41:25 2006
|
||||
@@ -1081,7 +1081,7 @@
|
||||
--- po/ru.po.orig Tue Mar 6 11:34:52 2007
|
||||
+++ po/ru.po Tue Mar 6 11:41:18 2007
|
||||
@@ -986,7 +986,7 @@
|
||||
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
|
||||
"to gain real-time access to files. If you don't want this message to appear "
|
||||
"in future, put the following command in your initialization scripts: "
|
||||
@ -129,9 +129,9 @@
|
||||
msgstr ""
|
||||
"Необходимо запустить модуль, называемый dazuko. Этот модуль разрешит KlamAV "
|
||||
"получать доступ в реальном времени к файлам. Далее Вас попросят ввести "
|
||||
--- po/zh_CN.po Tue Jun 6 11:34:08 2006
|
||||
+++ po/zh_CN.po Tue Jun 6 11:42:02 2006
|
||||
@@ -581,7 +581,7 @@
|
||||
--- po/zh_CN.po.orig Tue Mar 6 11:34:52 2007
|
||||
+++ po/zh_CN.po Tue Mar 6 11:41:44 2007
|
||||
@@ -960,7 +960,7 @@
|
||||
"I need to load a module called 'dazuko' first. This module will allow KlamAV "
|
||||
"to gain real-time access to files. If you don't want this message to appear "
|
||||
"in future, put the following command in your initialization scripts: "
|
||||
@ -139,4 +139,4 @@
|
||||
+"'kldload dazuko.ko'. You will next be asked for the root password."
|
||||
msgstr ""
|
||||
|
||||
#: klamd.cpp:718 klamd.cpp:719
|
||||
#: klamd.cpp:734 klamd.cpp:735
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- src/freshklam.cpp Fri Mar 10 11:03:46 2006
|
||||
+++ src/freshklam.cpp Fri Mar 10 11:04:15 2006
|
||||
@@ -165,7 +165,7 @@
|
||||
|
||||
|
||||
|
||||
-
|
||||
+ software_group->hide();
|
||||
|
||||
|
||||
//Virus Database Directory
|
Loading…
Reference in New Issue
Block a user