Add ROTE, a simple library for VT102 terminal emulation.

WWW: http://rote.sourceforge.net/
This commit is contained in:
Alexey Dokuchaev 2005-06-10 05:07:21 +00:00
parent 5140032e03
commit f048ecd2d8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=137143
5 changed files with 51 additions and 0 deletions

View File

@ -1370,6 +1370,7 @@
SUBDIR += robodoc
SUBDIR += root
SUBDIR += root-doc
SUBDIR += rote
SUBDIR += rpc2
SUBDIR += rtplib
SUBDIR += ruby-amstd

25
devel/rote/Makefile Normal file
View File

@ -0,0 +1,25 @@
# New ports collection makefile for: ROTE
# Date created: 10 Jun 2005
# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= rote
PORTVERSION= 0.2.6
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= danfe@FreeBSD.org
COMMENT= A simple library for VT102 terminal emulation
GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
PLIST_FILES= bin/rote-config include/rote/rote.h lib/librote.so.0.2.6 \
lib/librote.so.0 lib/librote.so
PLIST_DIRS= include/rote
.include <bsd.port.mk>

2
devel/rote/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (rote-0.2.6.tar.gz) = a80074dc2fbabd6e204bc07a61e57120
SIZE (rote-0.2.6.tar.gz) = 61440

View File

@ -0,0 +1,15 @@
--- rote.c.orig Wed Oct 6 19:18:49 2004
+++ rote.c Fri Jun 10 11:57:27 2005
@@ -21,8 +21,11 @@
#include "rote.h"
#include "roteprivate.h"
+#include <sys/types.h>
+#include <sys/ioctl.h>
+#include <termios.h>
+#include <libutil.h>
#include <stdlib.h>
-#include <pty.h>
#include <stdio.h>
#include <string.h>

8
devel/rote/pkg-descr Normal file
View File

@ -0,0 +1,8 @@
ROTE is a simple C library for VT102 terminal emulation. It allows the
programmer to set up virtual 'screens' and send them data. The virtual
screens will emulate the behavior of a VT102 terminal, interpreting escape
sequences, control characters and such. The library supports ncurses as
well so that you may render the virtual screen to the real screen when you
need to.
WWW: http://rote.sourceforge.net/