add PySide2 - Python Binding for Qt5
keeping the organization of the old pyside ports, this is split in pyside2, pyside2-tools and shiboken2
This commit is contained in:
parent
1dd26d4dfd
commit
f0475de1f8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=492517
@ -5393,6 +5393,8 @@
|
||||
SUBDIR += pyrex
|
||||
SUBDIR += pyside
|
||||
SUBDIR += pyside-tools
|
||||
SUBDIR += pyside2
|
||||
SUBDIR += pyside2-tools
|
||||
SUBDIR += pyst
|
||||
SUBDIR += pysvn
|
||||
SUBDIR += pythk
|
||||
@ -6233,6 +6235,7 @@
|
||||
SUBDIR += shflags
|
||||
SUBDIR += shfmt
|
||||
SUBDIR += shiboken
|
||||
SUBDIR += shiboken2
|
||||
SUBDIR += shmap
|
||||
SUBDIR += shtk
|
||||
SUBDIR += shtool
|
||||
|
36
devel/pyside2-tools/Makefile
Normal file
36
devel/pyside2-tools/Makefile
Normal file
@ -0,0 +1,36 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pyside2-tools
|
||||
DISTVERSION= 5.12.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_QT}
|
||||
MASTER_SITE_SUBDIR= official_releases/QtForPython/shiboken2/PySide2-${DISTVERSION}-src
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= pyside-setup-everywhere-src-${DISTVERSION}
|
||||
|
||||
MAINTAINER= cmt@FreeBSD.org
|
||||
COMMENT= Pyside2 development tools
|
||||
|
||||
LICENSE= BSD3CLAUSE GPLv2
|
||||
LICENSE_COMB= multi
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
|
||||
git>0:devel/git
|
||||
LIB_DEPENDS= libshiboken2-${PYTHON_VERSION}.so:devel/shiboken2@${PY_FLAVOR} \
|
||||
libpyside2-${PYTHON_VERSION}.so:devel/pyside2@${PY_FLAVOR}
|
||||
|
||||
USES= cmake gl python qt:5 shebangfix tar:xz
|
||||
USE_GL= gl
|
||||
USE_PYTHON= flavors
|
||||
USE_QT= 3d buildtools_build charts core datavis3d declarative \
|
||||
designer gui help location multimedia network opengl \
|
||||
printsupport qmake_build script scripttools scxml sensors \
|
||||
speech sql svg testlib uitools webchannel webengine \
|
||||
websockets widgets x11extras xml xmlpatterns
|
||||
|
||||
SHEBANG_FILES= pyside_tool.py pyside2-uic
|
||||
python_OLD_COMMAND= "/usr/bin/env python"
|
||||
|
||||
WRKSRC= ${WRKDIR}/pyside-setup-everywhere-src-${DISTVERSION}/sources/pyside2-tools
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/pyside2-tools/distinfo
Normal file
3
devel/pyside2-tools/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1549662944
|
||||
SHA256 (pyside-setup-everywhere-src-5.12.1.tar.xz) = 6e26b6240b97558b8bf3c97810e950ef4121a03a1ebdecfb649992a505f18059
|
||||
SIZE (pyside-setup-everywhere-src-5.12.1.tar.xz) = 5411300
|
11
devel/pyside2-tools/files/patch-CMakeLists.txt
Normal file
11
devel/pyside2-tools/files/patch-CMakeLists.txt
Normal file
@ -0,0 +1,11 @@
|
||||
--- CMakeLists.txt.orig 2019-02-08 21:32:23 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -60,7 +60,7 @@ install(DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/pyside2u
|
||||
# Man pages for pyside2-uic
|
||||
if (NOT WIN32)
|
||||
file(GLOB manpages "${CMAKE_CURRENT_SOURCE_DIR}/pyside2uic/*.1")
|
||||
- install(FILES ${manpages} DESTINATION share/man/man1)
|
||||
+ install(FILES ${manpages} DESTINATION man/man1)
|
||||
endif()
|
||||
|
||||
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/cmake_uninstall.cmake"
|
9
devel/pyside2-tools/files/patch-pylupdate_CMakeLists.txt
Normal file
9
devel/pyside2-tools/files/patch-pylupdate_CMakeLists.txt
Normal file
@ -0,0 +1,9 @@
|
||||
--- pylupdate/CMakeLists.txt.orig 2019-02-08 22:28:59 UTC
|
||||
+++ pylupdate/CMakeLists.txt
|
||||
@@ -40,5 +40,5 @@ install(TARGETS pyside2-lupdate RUNTIME DESTINATION bi
|
||||
# Man pages
|
||||
if (NOT WIN32)
|
||||
file(GLOB manpages "${CMAKE_CURRENT_SOURCE_DIR}/*.1")
|
||||
- install(FILES ${manpages} DESTINATION share/man/man1)
|
||||
+ install(FILES ${manpages} DESTINATION man/man1)
|
||||
endif()
|
9
devel/pyside2-tools/files/patch-pyrcc_CMakeLists.txt
Normal file
9
devel/pyside2-tools/files/patch-pyrcc_CMakeLists.txt
Normal file
@ -0,0 +1,9 @@
|
||||
--- pyrcc/CMakeLists.txt.orig 2019-02-08 22:29:24 UTC
|
||||
+++ pyrcc/CMakeLists.txt
|
||||
@@ -14,5 +14,5 @@ install(TARGETS pyside2-rcc RUNTIME DESTINATION bin)
|
||||
# Man pages
|
||||
if (NOT WIN32)
|
||||
file(GLOB manpages "${CMAKE_CURRENT_SOURCE_DIR}/*.1")
|
||||
- install(FILES ${manpages} DESTINATION share/man/man1)
|
||||
+ install(FILES ${manpages} DESTINATION man/man1)
|
||||
endif()
|
4
devel/pyside2-tools/pkg-descr
Normal file
4
devel/pyside2-tools/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
PySide2 is the Python Qt 5 bindings project. This package contains the
|
||||
PySide2 development tools.
|
||||
|
||||
WWW: https://wiki.qt.io/Qt_for_Python
|
37
devel/pyside2-tools/pkg-plist
Normal file
37
devel/pyside2-tools/pkg-plist
Normal file
@ -0,0 +1,37 @@
|
||||
bin/pyside2-lupdate
|
||||
bin/pyside2-rcc
|
||||
bin/pyside2-uic
|
||||
bin/pyside_tool.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/Compiler/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/Compiler/compiler.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/Compiler/indenter.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/Compiler/misc.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/Compiler/proxy_type.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/Compiler/qobjectcreator.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/Compiler/qtproxies.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/driver.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/exceptions.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/icon_cache.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/objcreator.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v2/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v2/as_string.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v2/ascii_upper.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v2/invoke.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v2/load_plugin.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v2/proxy_base.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v2/string_io.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v3/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v3/as_string.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v3/ascii_upper.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v3/invoke.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v3/load_plugin.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v3/proxy_base.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/port_v3/string_io.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/properties.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/uiparser.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/widget-plugins/qtdeclarative.py
|
||||
%%PYTHON_SITELIBDIR%%/pyside2uic/widget-plugins/qtwebkit.py
|
||||
man/man1/pyside2-lupdate.1.gz
|
||||
man/man1/pyside2-rcc.1.gz
|
||||
man/man1/pyside2-uic.1.gz
|
83
devel/pyside2/Makefile
Normal file
83
devel/pyside2/Makefile
Normal file
@ -0,0 +1,83 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= pyside2
|
||||
DISTVERSION= 5.12.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_QT}
|
||||
MASTER_SITE_SUBDIR= official_releases/QtForPython/shiboken2/PySide2-${DISTVERSION}-src
|
||||
DISTNAME= pyside-setup-everywhere-src-${DISTVERSION}
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= cmt@FreeBSD.org
|
||||
COMMENT= Python Qt bindings for Qt 5.12+
|
||||
|
||||
LICENSE= LGPL3
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
|
||||
git>0:devel/git
|
||||
LIB_DEPENDS= libshiboken2-${PYTHON_VERSION}.so:devel/shiboken2@${PY_FLAVOR}
|
||||
|
||||
USES= cmake gl python qt:5 tar:xz
|
||||
USE_GL= gl
|
||||
USE_LDCONFIG= yes
|
||||
USE_PYTHON= flavors
|
||||
USE_QT= 3d buildtools_build charts core datavis3d declarative \
|
||||
designer gui help location multimedia network opengl \
|
||||
printsupport qmake_build script scripttools scxml sensors \
|
||||
speech sql svg testlib uitools webchannel webengine \
|
||||
websockets widgets x11extras xml xmlpatterns
|
||||
|
||||
PLIST_SUB= DISTVERSION=${DISTVERSION} \
|
||||
PYTHON_VERSION=${PYTHON_VERSION}
|
||||
|
||||
WRKSRC= ${WRKDIR}/pyside-setup-everywhere-src-${DISTVERSION}/sources/pyside2
|
||||
|
||||
post-stage:
|
||||
@${RM} -r ${STAGEDIR}/${PYTHON_SITELIBDIR}/CMakeFiles \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/tests \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/CMakeFiles \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/Qt3DAnimation \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/Qt3DCore \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/Qt3DExtras \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/Qt3DInput \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/Qt3DLogic \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/Qt3DRender \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtCharts \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtConcurrent \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtCore \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtDataVisualization \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtGui \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtHelp \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtLocation \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtMultimedia \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtMultimediaWidgets \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtNetwork \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtOpenGL \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtPositioning \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtPrintSupport \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtQml \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtQuick \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtQuickWidgets \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtScript \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtScriptTools \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtScxml \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtSensors \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtSql \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtSvg \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtTest \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtTextToSpeech \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtUiTools \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtWebChannel \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtWebEngine \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtWebEngineCore \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtWebEngineWidgets \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtWebSockets \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtWidgets \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtX11Extras \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtXml \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/QtXmlPatterns \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/PySide2/support \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/libpyside \
|
||||
${STAGEDIR}/${PYTHON_SITELIBDIR}/plugins
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/pyside2/distinfo
Normal file
3
devel/pyside2/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1549662883
|
||||
SHA256 (pyside-setup-everywhere-src-5.12.1.tar.xz) = 6e26b6240b97558b8bf3c97810e950ef4121a03a1ebdecfb649992a505f18059
|
||||
SIZE (pyside-setup-everywhere-src-5.12.1.tar.xz) = 5411300
|
10
devel/pyside2/files/patch-cmake_Macros_PySideModules.cmake
Normal file
10
devel/pyside2/files/patch-cmake_Macros_PySideModules.cmake
Normal file
@ -0,0 +1,10 @@
|
||||
--- cmake/Macros/PySideModules.cmake.orig 2018-12-17 07:28:47 UTC
|
||||
+++ cmake/Macros/PySideModules.cmake
|
||||
@@ -124,6 +124,7 @@ macro(create_pyside_module)
|
||||
COMMAND "${SHIBOKEN_BINARY}" ${GENERATOR_EXTRA_FLAGS}
|
||||
"${pyside2_BINARY_DIR}/${module_NAME}_global.h"
|
||||
--include-paths=${shiboken_include_dirs}
|
||||
+ --include-paths="${CMAKE_INSTALL_PREFIX}/include"
|
||||
${shiboken_framework_include_dirs_option}
|
||||
--typesystem-paths=${pyside_binary_dir}${PATH_SEP}${pyside2_SOURCE_DIR}${PATH_SEP}${${module_TYPESYSTEM_PATH}}
|
||||
--output-directory=${CMAKE_CURRENT_BINARY_DIR}
|
5
devel/pyside2/pkg-descr
Normal file
5
devel/pyside2/pkg-descr
Normal file
@ -0,0 +1,5 @@
|
||||
PySide is the Python Qt bindings project, providing access to the complete
|
||||
Qt 5.12+ framework as well as to generator tools for rapidly generating
|
||||
Python bindings for any C++ libraries.
|
||||
|
||||
WWW: https://wiki.qt.io/Qt_for_Python
|
182
devel/pyside2/pkg-plist
Normal file
182
devel/pyside2/pkg-plist
Normal file
@ -0,0 +1,182 @@
|
||||
include/PySide2/Qt3DAnimation/pyside2_qt3danimation_python.h
|
||||
include/PySide2/Qt3DCore/pyside2_qt3dcore_python.h
|
||||
include/PySide2/Qt3DExtras/pyside2_qt3dextras_python.h
|
||||
include/PySide2/Qt3DInput/pyside2_qt3dinput_python.h
|
||||
include/PySide2/Qt3DLogic/pyside2_qt3dlogic_python.h
|
||||
include/PySide2/Qt3DRender/pyside2_qt3drender_python.h
|
||||
include/PySide2/QtCharts/pyside2_qtcharts_python.h
|
||||
include/PySide2/QtConcurrent/pyside2_qtconcurrent_python.h
|
||||
include/PySide2/QtCore/pyside2_qtcore_python.h
|
||||
include/PySide2/QtDataVisualization/pyside2_qtdatavisualization_python.h
|
||||
include/PySide2/QtGui/pyside2_qtgui_python.h
|
||||
include/PySide2/QtGui/qpytextobject.h
|
||||
include/PySide2/QtHelp/pyside2_qthelp_python.h
|
||||
include/PySide2/QtLocation/pyside2_qtlocation_python.h
|
||||
include/PySide2/QtMultimedia/pyside2_qtmultimedia_python.h
|
||||
include/PySide2/QtMultimediaWidgets/pyside2_qtmultimediawidgets_python.h
|
||||
include/PySide2/QtNetwork/pyside2_qtnetwork_python.h
|
||||
include/PySide2/QtOpenGL/pyside2_qtopengl_python.h
|
||||
include/PySide2/QtPositioning/pyside2_qtpositioning_python.h
|
||||
include/PySide2/QtPrintSupport/pyside2_qtprintsupport_python.h
|
||||
include/PySide2/QtQml/pyside2_qtqml_python.h
|
||||
include/PySide2/QtQuick/pyside2_qtquick_python.h
|
||||
include/PySide2/QtQuickWidgets/pyside2_qtquickwidgets_python.h
|
||||
include/PySide2/QtScript/pyside2_qtscript_python.h
|
||||
include/PySide2/QtScriptTools/pyside2_qtscripttools_python.h
|
||||
include/PySide2/QtScxml/pyside2_qtscxml_python.h
|
||||
include/PySide2/QtSensors/pyside2_qtsensors_python.h
|
||||
include/PySide2/QtSql/pyside2_qtsql_python.h
|
||||
include/PySide2/QtSvg/pyside2_qtsvg_python.h
|
||||
include/PySide2/QtTest/pyside2_qttest_python.h
|
||||
include/PySide2/QtTextToSpeech/pyside2_qttexttospeech_python.h
|
||||
include/PySide2/QtUiTools/pyside2_qtuitools_python.h
|
||||
include/PySide2/QtWebChannel/pyside2_qtwebchannel_python.h
|
||||
include/PySide2/QtWebEngine/pyside2_qtwebengine_python.h
|
||||
include/PySide2/QtWebEngineCore/pyside2_qtwebenginecore_python.h
|
||||
include/PySide2/QtWebEngineWidgets/pyside2_qtwebenginewidgets_python.h
|
||||
include/PySide2/QtWebSockets/pyside2_qtwebsockets_python.h
|
||||
include/PySide2/QtWidgets/pyside2_qtwidgets_python.h
|
||||
include/PySide2/QtX11Extras/pyside2_qtx11extras_python.h
|
||||
include/PySide2/QtXml/pyside2_qtxml_python.h
|
||||
include/PySide2/QtXmlPatterns/pyside2_qtxmlpatterns_python.h
|
||||
include/PySide2/destroylistener.h
|
||||
include/PySide2/dynamicqmetaobject.h
|
||||
include/PySide2/pyside.h
|
||||
include/PySide2/pyside2_global.h
|
||||
include/PySide2/pysideclassinfo.h
|
||||
include/PySide2/pysidemacros.h
|
||||
include/PySide2/pysidemetafunction.h
|
||||
include/PySide2/pysideproperty.h
|
||||
include/PySide2/pysideqflags.h
|
||||
include/PySide2/pysidesignal.h
|
||||
include/PySide2/pysideweakref.h
|
||||
include/PySide2/signalmanager.h
|
||||
lib/cmake/PySide2-%%DISTVERSION%%/PySide2Config-%%PYTHON_VERSION%%.cmake
|
||||
lib/cmake/PySide2-%%DISTVERSION%%/PySide2Config.cmake
|
||||
lib/cmake/PySide2-%%DISTVERSION%%/PySide2ConfigVersion.cmake
|
||||
lib/libpyside2-%%PYTHON_VERSION%%.so
|
||||
lib/libpyside2-%%PYTHON_VERSION%%.so.5.12
|
||||
lib/libpyside2-%%PYTHON_VERSION%%.so.%%DISTVERSION%%
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/Qt3DAnimation.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/Qt3DCore.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/Qt3DExtras.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/Qt3DInput.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/Qt3DLogic.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/Qt3DRender.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtCharts.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtConcurrent.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtCore.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtDataVisualization.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtGui.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtHelp.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtLocation.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtMultimedia.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtMultimediaWidgets.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtNetwork.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtOpenGL.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtPositioning.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtPrintSupport.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtQml.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtQuick.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtQuickWidgets.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtScript.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtScriptTools.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtScxml.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtSensors.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtSql.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtSvg.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtTest.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtTextToSpeech.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtUiTools.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtWebChannel.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtWebEngine.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtWebEngineCore.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtWebEngineWidgets.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtWebSockets.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtWidgets.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtX11Extras.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtXml.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/QtXmlPatterns.so
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/_config.py
|
||||
%%PYTHON_SITELIBDIR%%/PySide2/_git_pyside_version.py
|
||||
libdata/pkgconfig/pyside2.pc
|
||||
share/PySide2/glue/qtcharts.cpp
|
||||
share/PySide2/glue/qtcore.cpp
|
||||
share/PySide2/glue/qtdatavisualization.cpp
|
||||
share/PySide2/glue/qtgui.cpp
|
||||
share/PySide2/glue/qtmultimedia.cpp
|
||||
share/PySide2/glue/qtnetwork.cpp
|
||||
share/PySide2/glue/qtopengl.cpp
|
||||
share/PySide2/glue/qtqml.cpp
|
||||
share/PySide2/glue/qtquick.cpp
|
||||
share/PySide2/glue/qtscript.cpp
|
||||
share/PySide2/glue/qtuitools.cpp
|
||||
share/PySide2/glue/qtwidgets.cpp
|
||||
share/PySide2/glue/qtxml.cpp
|
||||
share/PySide2/glue/qtxmlpatterns.cpp
|
||||
share/PySide2/typesystems/core_common.xml
|
||||
share/PySide2/typesystems/datavisualization_common.xml
|
||||
share/PySide2/typesystems/glue/plugins.h
|
||||
share/PySide2/typesystems/glue/qeasingcurve_glue.cpp
|
||||
share/PySide2/typesystems/glue/qeasingcurve_glue.h
|
||||
share/PySide2/typesystems/glue/qscript_value_iterator_glue.cpp
|
||||
share/PySide2/typesystems/gui_common.xml
|
||||
share/PySide2/typesystems/opengl_common.xml
|
||||
share/PySide2/typesystems/typesystem_3danimation.xml
|
||||
share/PySide2/typesystems/typesystem_3dcore.xml
|
||||
share/PySide2/typesystems/typesystem_3dextras.xml
|
||||
share/PySide2/typesystems/typesystem_3dinput.xml
|
||||
share/PySide2/typesystems/typesystem_3dlogic.xml
|
||||
share/PySide2/typesystems/typesystem_3drender.xml
|
||||
share/PySide2/typesystems/typesystem_charts.xml
|
||||
share/PySide2/typesystems/typesystem_concurrent.xml
|
||||
share/PySide2/typesystems/typesystem_core.xml
|
||||
share/PySide2/typesystems/typesystem_core_common.xml
|
||||
share/PySide2/typesystems/typesystem_core_mac.xml
|
||||
share/PySide2/typesystems/typesystem_core_win.xml
|
||||
share/PySide2/typesystems/typesystem_core_x11.xml
|
||||
share/PySide2/typesystems/typesystem_datavisualization.xml
|
||||
share/PySide2/typesystems/typesystem_gui.xml
|
||||
share/PySide2/typesystems/typesystem_gui_common.xml
|
||||
share/PySide2/typesystems/typesystem_gui_mac.xml
|
||||
share/PySide2/typesystems/typesystem_gui_win.xml
|
||||
share/PySide2/typesystems/typesystem_gui_x11.xml
|
||||
share/PySide2/typesystems/typesystem_help.xml
|
||||
share/PySide2/typesystems/typesystem_location.xml
|
||||
share/PySide2/typesystems/typesystem_multimedia.xml
|
||||
share/PySide2/typesystems/typesystem_multimedia_common.xml
|
||||
share/PySide2/typesystems/typesystem_multimedia_forward_declarations.xml
|
||||
share/PySide2/typesystems/typesystem_multimediawidgets.xml
|
||||
share/PySide2/typesystems/typesystem_network.xml
|
||||
share/PySide2/typesystems/typesystem_opengl.xml
|
||||
share/PySide2/typesystems/typesystem_positioning.xml
|
||||
share/PySide2/typesystems/typesystem_printsupport.xml
|
||||
share/PySide2/typesystems/typesystem_qml.xml
|
||||
share/PySide2/typesystems/typesystem_quick.xml
|
||||
share/PySide2/typesystems/typesystem_quickwidgets.xml
|
||||
share/PySide2/typesystems/typesystem_script.xml
|
||||
share/PySide2/typesystems/typesystem_scripttools.xml
|
||||
share/PySide2/typesystems/typesystem_scxml.xml
|
||||
share/PySide2/typesystems/typesystem_sensors.xml
|
||||
share/PySide2/typesystems/typesystem_sql.xml
|
||||
share/PySide2/typesystems/typesystem_svg.xml
|
||||
share/PySide2/typesystems/typesystem_test.xml
|
||||
share/PySide2/typesystems/typesystem_texttospeech.xml
|
||||
share/PySide2/typesystems/typesystem_uitools.xml
|
||||
share/PySide2/typesystems/typesystem_webchannel.xml
|
||||
share/PySide2/typesystems/typesystem_webengine.xml
|
||||
share/PySide2/typesystems/typesystem_webenginecore.xml
|
||||
share/PySide2/typesystems/typesystem_webenginewidgets.xml
|
||||
share/PySide2/typesystems/typesystem_websockets.xml
|
||||
share/PySide2/typesystems/typesystem_widgets.xml
|
||||
share/PySide2/typesystems/typesystem_widgets_common.xml
|
||||
share/PySide2/typesystems/typesystem_widgets_mac.xml
|
||||
share/PySide2/typesystems/typesystem_widgets_win.xml
|
||||
share/PySide2/typesystems/typesystem_widgets_x11.xml
|
||||
share/PySide2/typesystems/typesystem_x11extras.xml
|
||||
share/PySide2/typesystems/typesystem_xml.xml
|
||||
share/PySide2/typesystems/typesystem_xmlpatterns.xml
|
||||
share/PySide2/typesystems/webkitwidgets_common.xml
|
||||
share/PySide2/typesystems/widgets_common.xml
|
||||
share/PySide2/typesystems/xml_common.xml
|
41
devel/shiboken2/Makefile
Normal file
41
devel/shiboken2/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= shiboken2
|
||||
DISTVERSION= 5.12.1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ${MASTER_SITE_QT}
|
||||
MASTER_SITE_SUBDIR= official_releases/QtForPython/shiboken2/PySide2-${DISTVERSION}-src
|
||||
DISTNAME= pyside-setup-everywhere-src-${DISTVERSION}
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
||||
MAINTAINER= cmt@FreeBSD.org
|
||||
COMMENT= Python binding generator for C++ libraries
|
||||
|
||||
LICENSE= GPLv2 LGPL21 LGPL3
|
||||
LICENSE_COMB= multi
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR} \
|
||||
git>0:devel/git
|
||||
LIB_DEPENDS= libclang.so:devel/llvm${LLVM_DEFAULT} \
|
||||
libxslt.so:textproc/libxslt
|
||||
|
||||
USES= cmake gnome python qt:5 shebangfix tar:xz
|
||||
USE_GNOME= libxml2
|
||||
USE_PYTHON= flavors
|
||||
USE_QT= buildtools_build core gui network qmake_build testlib \
|
||||
xml xmlpatterns
|
||||
|
||||
SHEBANG_FILES= shiboken_tool.py
|
||||
python_OLD_COMMAND= "/usr/bin/env python"
|
||||
|
||||
CONFIGURE_ENV+= LLVM_CONFIG=${LOCALBASE}/bin/llvm-config${LLVM_DEFAULT}
|
||||
CMAKE_ARGS+= "-DCMAKE_CXX_FLAGS=-lexecinfo" \
|
||||
"-DCMAKE_STANDARD_LIBRARIES=-lexecinfo" \
|
||||
"-DCMAKE_CXX_STANDARD_LIBRARIES=-lexecinfo"
|
||||
|
||||
PLIST_SUB= DISTVERSION=${DISTVERSION} \
|
||||
PYTHON_VERSION=${PYTHON_VERSION}
|
||||
|
||||
WRKSRC= ${WRKDIR}/pyside-setup-everywhere-src-${DISTVERSION}/sources/shiboken2
|
||||
|
||||
.include <bsd.port.mk>
|
3
devel/shiboken2/distinfo
Normal file
3
devel/shiboken2/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1549662926
|
||||
SHA256 (pyside-setup-everywhere-src-5.12.1.tar.xz) = 6e26b6240b97558b8bf3c97810e950ef4121a03a1ebdecfb649992a505f18059
|
||||
SIZE (pyside-setup-everywhere-src-5.12.1.tar.xz) = 5411300
|
9
devel/shiboken2/files/patch-data_shiboken2.pc.in
Normal file
9
devel/shiboken2/files/patch-data_shiboken2.pc.in
Normal file
@ -0,0 +1,9 @@
|
||||
--- data/shiboken2.pc.in.orig 2018-12-17 07:28:47 UTC
|
||||
+++ data/shiboken2.pc.in
|
||||
@@ -9,5 +9,5 @@ python_include_dir=@SBK_PYTHON_INCLUDE_DIR@
|
||||
Name: shiboken2
|
||||
Description: Support library for Python bindings created with the Shiboken2 generator.
|
||||
Version: @shiboken2_VERSION@
|
||||
-Libs: @SBK_PYTHON_LIBRARIES@ -L${libdir} -lshiboken2@shiboken2_SUFFIX@@PYTHON_SHARED_LIBRARY_SUFFIX@@LIBRARY_OUTPUT_SUFFIX@
|
||||
+Libs: @SBK_PYTHON_LIBRARIES@ -L${libdir} -lshiboken2@shiboken2_SUFFIX@@PYTHON_SHARED_LIBRARY_SUFFIX@@LIBRARY_OUTPUT_SUFFIX@ -lexecinfo
|
||||
Cflags: -I@SBK_PYTHON_INCLUDE_DIR@ -I${includedir}/@shiboken2_SUFFIX@@SBK_PKG_CONFIG_PY_DEBUG_DEFINITION@
|
9
devel/shiboken2/files/patch-doc_CMakeLists.txt
Normal file
9
devel/shiboken2/files/patch-doc_CMakeLists.txt
Normal file
@ -0,0 +1,9 @@
|
||||
--- doc/CMakeLists.txt.orig 2019-02-08 21:36:33 UTC
|
||||
+++ doc/CMakeLists.txt
|
||||
@@ -20,5 +20,5 @@ endif()
|
||||
|
||||
if (NOT WIN32)
|
||||
file(GLOB manpages "${CMAKE_CURRENT_SOURCE_DIR}/*.1")
|
||||
- install(FILES ${manpages} DESTINATION share/man/man1)
|
||||
+ install(FILES ${manpages} DESTINATION man/man1)
|
||||
endif()
|
11
devel/shiboken2/files/patch-libshiboken_helper.h
Normal file
11
devel/shiboken2/files/patch-libshiboken_helper.h
Normal file
@ -0,0 +1,11 @@
|
||||
--- libshiboken/helper.h.orig 2018-12-17 07:28:47 UTC
|
||||
+++ libshiboken/helper.h
|
||||
@@ -90,7 +90,7 @@ class AutoArrayPointer
|
||||
T* data;
|
||||
};
|
||||
|
||||
-typedef unsigned long long ThreadId;
|
||||
+typedef pthread_t ThreadId;
|
||||
LIBSHIBOKEN_API ThreadId currentThreadId();
|
||||
LIBSHIBOKEN_API ThreadId mainThreadId();
|
||||
|
4
devel/shiboken2/pkg-descr
Normal file
4
devel/shiboken2/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
Shiboken2 is generator to build Python bindings for any C++ library.
|
||||
It is part of the PySide2 Python Qt bindings project.
|
||||
|
||||
WWW: https://wiki.qt.io/PySide2
|
52
devel/shiboken2/pkg-plist
Normal file
52
devel/shiboken2/pkg-plist
Normal file
@ -0,0 +1,52 @@
|
||||
bin/shiboken2
|
||||
bin/shiboken_tool.py
|
||||
include/shiboken2/autodecref.h
|
||||
include/shiboken2/basewrapper.h
|
||||
include/shiboken2/bindingmanager.h
|
||||
include/shiboken2/bufferprocs_py37.h
|
||||
include/shiboken2/gilstate.h
|
||||
include/shiboken2/helper.h
|
||||
include/shiboken2/pep384impl.h
|
||||
include/shiboken2/python25compat.h
|
||||
include/shiboken2/qapp_macro.h
|
||||
include/shiboken2/sbkarrayconverter.h
|
||||
include/shiboken2/sbkconverter.h
|
||||
include/shiboken2/sbkdbg.h
|
||||
include/shiboken2/sbkenum.h
|
||||
include/shiboken2/sbkmodule.h
|
||||
include/shiboken2/sbkpython.h
|
||||
include/shiboken2/sbkstring.h
|
||||
include/shiboken2/sbkversion.h
|
||||
include/shiboken2/shiboken.h
|
||||
include/shiboken2/shibokenbuffer.h
|
||||
include/shiboken2/shibokenmacros.h
|
||||
include/shiboken2/signature.h
|
||||
include/shiboken2/threadstatesaver.h
|
||||
include/shiboken2/typespec.h
|
||||
include/shiboken2/voidptr.h
|
||||
lib/cmake/Shiboken2-%%DISTVERSION%%/Shiboken2Config-%%PYTHON_VERSION%%.cmake
|
||||
lib/cmake/Shiboken2-%%DISTVERSION%%/Shiboken2Config.cmake
|
||||
lib/cmake/Shiboken2-%%DISTVERSION%%/Shiboken2ConfigVersion.cmake
|
||||
lib/libshiboken2-%%PYTHON_VERSION%%.so
|
||||
lib/libshiboken2-%%PYTHON_VERSION%%.so.5.12
|
||||
lib/libshiboken2-%%PYTHON_VERSION%%.so.%%DISTVERSION%%
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/_config.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/_git_shiboken_module_version.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/shiboken2.so
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/support/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/support/signature/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/support/signature/backport_inspect.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/support/signature/errorhandler.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/support/signature/layout.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/support/signature/lib/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/support/signature/lib/enum_sig.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/support/signature/loader.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/support/signature/mapping.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/support/signature/parser.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2/support/signature/typing27.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2_generator/__init__.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2_generator/_config.py
|
||||
%%PYTHON_SITELIBDIR%%/shiboken2_generator/_git_shiboken_generator_version.py
|
||||
libdata/pkgconfig/shiboken2.pc
|
||||
man/man1/shiboken2.1.gz
|
Loading…
Reference in New Issue
Block a user