biology/stacks: Upgrade to 2.3

Approved by:    jrm (mentor, implicit)
This commit is contained in:
Jason W. Bacon 2019-01-12 15:53:00 +00:00
parent c9f2c7ed76
commit f03dcf6979
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=490062
4 changed files with 14 additions and 38 deletions

View File

@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= stacks
DISTVERSION= 1.48
PORTREVISION= 3
CATEGORIES= biology
DISTVERSION= 2.3
CATEGORIES= biology perl5 python
MASTER_SITES= http://catchenlab.life.illinois.edu/stacks/source/
MAINTAINER= jwb@FreeBSD.org
@ -13,7 +12,9 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= compiler:openmp gmake python shebangfix
SHEBANG_FILES= scripts/*.pl scripts/*.py
SHEBANG_FILES= scripts/*.pl scripts/*.py \
scripts/stacks-integrate-alignments scripts/stacks-gdb
GNU_CONFIGURE= yes
LDFLAGS+= -lpthread
@ -21,7 +22,7 @@ LDFLAGS+= -lpthread
.include <bsd.port.pre.mk>
.if ${ARCH} != amd64 && ${ARCH} != i386
USE_GCC= yes
USE_GCC= yes
.endif
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1520376299
SHA256 (stacks-1.48.tar.gz) = e9f6251f5f609f9dd0bb1de17a51f69ce1a9af531548c4d2456a89783b1dcd1e
SIZE (stacks-1.48.tar.gz) = 895195
TIMESTAMP = 1547306940
SHA256 (stacks-2.3.tar.gz) = 2a5befaf11ca2f191afcd42a3a3392290d6a116d7fe737b69a2c4d5b77f40c99
SIZE (stacks-2.3.tar.gz) = 10962586

View File

@ -1,20 +0,0 @@
--- htslib/Makefile.orig 2016-09-16 15:40:03 UTC
+++ htslib/Makefile
@@ -22,13 +22,13 @@
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
# DEALINGS IN THE SOFTWARE.
-CC = gcc
-AR = ar
-RANLIB = ranlib
+CC ?= gcc
+AR ?= ar
+RANLIB ?= ranlib
CPPFLAGS =
# TODO: probably update cram code to make it compile cleanly with -Wc++-compat
-CFLAGS = -g -Wall -O2
+CFLAGS ?= -g -Wall -O2
EXTRA_CFLAGS_PIC = -fpic
LDFLAGS =
LIBS =

View File

@ -2,24 +2,19 @@ bin/clone_filter
bin/count_fixed_catalog_snps.py
bin/cstacks
bin/denovo_map.pl
bin/exec_velvet.pl
bin/export_sql.pl
bin/genotypes
bin/index_radtags.pl
bin/gstacks
bin/integrate_alignments.py
bin/kmer_filter
bin/load_radtags.pl
bin/load_sequences.pl
bin/phasedstacks
bin/populations
bin/process_radtags
bin/process_shortreads
bin/pstacks
bin/ref_map.pl
bin/rxstacks
bin/sort_read_pairs.pl
bin/sstacks
bin/stacks_export_notify.pl
bin/stacks-dist-extract
bin/stacks-gdb
bin/stacks-integrate-alignments
bin/tsv2bam
bin/ustacks
%%DATADIR%%/php/CatalogClass.php
%%DATADIR%%/php/Locus.php