Update uriparser to version 0.8.4.
It looks like the latest release doesn't build because of a missing #include. The source file depends on AF_INET and AF_INET6, which of course requires <sys/socket.h>. Submitted by: Torsten Zühlsdorff PR: 203972 Differential Revision: https://reviews.freebsd.org/D4001
This commit is contained in:
parent
c4b634878e
commit
f038799285
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=400218
@ -2,18 +2,22 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= uriparser
|
||||
PORTVERSION= 0.7.9
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.8.4
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= SF/${PORTNAME}/Sources/${PORTVERSION}
|
||||
|
||||
MAINTAINER= ed@FreeBSD.org
|
||||
COMMENT= URI parsing library
|
||||
|
||||
LICENSE= BSD3CLAUSE
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-doc --disable-test
|
||||
INSTALL_TARGET= install-strip
|
||||
USES= libtool pathfix tar:bzip2
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
MAKE_JOBS_UNSAFE=yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,2 @@
|
||||
SHA256 (uriparser-0.7.9.tar.bz2) = a1d8f1007757ca1cf68b49edbac50876100cdee23a54cf1214f257b9ce51100d
|
||||
SIZE (uriparser-0.7.9.tar.bz2) = 430215
|
||||
SHA256 (uriparser-0.8.4.tar.bz2) = ce7ccda4136974889231e8426a785e7578e66a6283009cfd13f1b24a5e657b23
|
||||
SIZE (uriparser-0.8.4.tar.bz2) = 358408
|
||||
|
10
net/uriparser/files/patch-tool_uriparse.c
Normal file
10
net/uriparser/files/patch-tool_uriparse.c
Normal file
@ -0,0 +1,10 @@
|
||||
--- tool/uriparse.c
|
||||
+++ tool/uriparse.c
|
||||
@@ -36,6 +36,7 @@
|
||||
* ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
|
||||
* OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
*/
|
||||
+#include <sys/socket.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <uriparser/Uri.h>
|
@ -1,3 +1,4 @@
|
||||
bin/uriparse
|
||||
include/uriparser/Uri.h
|
||||
include/uriparser/UriBase.h
|
||||
include/uriparser/UriDefsAnsi.h
|
||||
@ -7,5 +8,5 @@ include/uriparser/UriIp4.h
|
||||
lib/liburiparser.a
|
||||
lib/liburiparser.so
|
||||
lib/liburiparser.so.1
|
||||
lib/liburiparser.so.1.0.14
|
||||
lib/liburiparser.so.1.0.20
|
||||
libdata/pkgconfig/liburiparser.pc
|
||||
|
Loading…
Reference in New Issue
Block a user