New port: x11/hhpc: Small and easy to use console text editor

PR:		224345
Submitted by:	Dmitri Goutnik <dg@syrec.org>
Approved by:	adamw (mentor)
Differential Revision:	https://reviews.freebsd.org/D13499
This commit is contained in:
Yuri Victorovich 2017-12-18 22:39:38 +00:00
parent 594d6b95bb
commit f0294bafaa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=456690
5 changed files with 71 additions and 0 deletions

View File

@ -106,6 +106,7 @@
SUBDIR += gtkterm2
SUBDIR += guake
SUBDIR += gxkb
SUBDIR += hhpc
SUBDIR += hs-X11
SUBDIR += hs-X11-xft
SUBDIR += hs-xmobar

31
x11/hhpc/Makefile Normal file
View File

@ -0,0 +1,31 @@
# Created by: Dmitri Goutnik <dg@syrec.org>
# $FreeBSD$
PORTNAME= hhpc
DISTVERSIONPREFIX= v
DISTVERSION= 0.3.1
CATEGORIES= x11
MAINTAINER= dg@syrec.org
COMMENT= Small X11 utility to hide the mouse pointer when unused
LICENSE= BSD3CLAUSE
USES= gmake localbase pkgconfig
USE_XORG= x11
USE_GITHUB= yes
GH_ACCOUNT= aktau
ALL_TARGET= release
PLIST_FILES= bin/hhpc
PORTDOCS= README.md
OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hhpc ${STAGEDIR}${PREFIX}/bin/
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

3
x11/hhpc/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1513268001
SHA256 (aktau-hhpc-v0.3.1_GH0.tar.gz) = f75cc4c4542d833e2aa9fbc3bfd2b658b6a21354d5d546dad49eb0efc6134417
SIZE (aktau-hhpc-v0.3.1_GH0.tar.gz) = 5487

View File

@ -0,0 +1,23 @@
--- Makefile.orig 2014-08-25 15:37:45 UTC
+++ Makefile
@@ -51,7 +51,7 @@ CFLAGS_COMMON ?= \
-pedantic \
-std=c99
-CFLAGS ?= $(CFLAGS_COMMON)
+CFLAGS += $(CFLAGS_COMMON)
CC ?= cc $(CFLAGS)
@@ -66,10 +66,7 @@ debug: CFLAGS += $(WARN) \
-DDEBUG
debug: $(EXECUTABLE)
-release: CFLAGS += \
- -s \
- -O2 \
- -DNDEBUG
+release: CFLAGS += -DNDEBUG
release: $(EXECUTABLE)
$(EXECUTABLE): $(OBJECTS)

13
x11/hhpc/pkg-descr Normal file
View File

@ -0,0 +1,13 @@
hhpc is an utility that hides the mouse pointer in X11. It functions by
grabbing your mouse pointer at startup and replacing its bitmap with an
empty one (thus hiding it). Then, it waits for the X server to notify it
when a user tries to move or click the pointer. At this point, hhpc
relinquishes control, replays the action the user just tried to execute and
waits for the specified number of seconds (flag -i) before trying to grab
the pointer and hide it again.
Should hhpc not work out for you, unclutter is a good alternative. hhpc was
created because unclutter doesn't seem to interoperate properly with
hardware accelerated surfaces like those of video players using VAAPI.
WWW: https://github.com/aktau/hhpc