TreeLine helps you organise all your sticky notes, lists of books, movies,

website logins, personal contacts, or things to do.

It stores almost any kind of information. A tree structure makes it easy to
keep things organised. Each node in the tree can contain several fields,
forming a mini-database. The output format for each node can be defined, and
the output can be shown on the screen, printed, or exported to html.

PR:		ports/68920
Submitted by:	Tobias Roth <ports@fsck.ch>
This commit is contained in:
Pav Lucistnik 2004-07-13 22:49:36 +00:00
parent 631138154b
commit efbc142d7b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=113589
6 changed files with 149 additions and 0 deletions

View File

@ -107,6 +107,7 @@
SUBDIR += superkaramba
SUBDIR += taskjuggler
SUBDIR += teapot
SUBDIR += treeline
SUBDIR += tuxcards
SUBDIR += wmpinboard
SUBDIR += xcalendar

View File

@ -0,0 +1,59 @@
# New ports collection makefile for: treeline
# Date created: Wed Jul 7 20:50:24 CEST 2004
# Whom: Tobias Roth <ports@fsck.ch>
#
# $FreeBSD$
#
PORTNAME= treeline
PORTVERSION= 0.8.1
CATEGORIES= deskutils python
MASTER_SITES= http://www.bellz.org/treeline/ \
http://depot.fsck.ch/mirror/distfiles/
MAINTAINER= ports@fsck.ch
COMMENT= TreeLine is a structured information storage program
BUILD_DEPENDS= pyuic:${PORTSDIR}/x11-toolkits/py-qt
RUN_DEPENDS= ${BUILD_DEPENDS}
.if defined(WITH_ASPELL)
BUILD_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
.endif
.if defined(WITH_ISPELL)
BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
.if defined(WITH_PYXML)
BUILD_DEPENDS+= ${PYXML}
.else
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
.endif
WRKSRC= ${WRKDIR}/TreeLine
USE_QT_VER= 3
USE_PYTHON= 2.3+
NO_BUILD= yes
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "You may use the following build options:"
@${ECHO_MSG} "WITH_ASPELL=yes install with aspell support"
@${ECHO_MSG} " or"
@${ECHO_MSG} "WITH_ISPELL=yes install with ispell support"
@${ECHO_MSG} "WITH_PYXML=yes use textproc/py-xml instead of"
@${ECHO_MSG} " textproc/expat2"
@${ECHO_MSG} ""
do-install:
@cd ${WRKSRC} && ${PYTHON_CMD} install.py -p ${PREFIX} -x
post-install:
${RM} ${DOCSDIR}/INSTALL ${DOCSDIR}/LICENSE
.if defined(NOPORTDOCS)
${RM} ${DOCSDIR}/*
${RMDIR} ${DOCSDIR}
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1,2 @@
MD5 (treeline-0.8.1.tar.gz) = 5875be618f78e07ab1ee0862224f345d
SIZE (treeline-0.8.1.tar.gz) = 125190

View File

@ -0,0 +1,13 @@
--- install.py.orig Wed Jul 7 19:59:06 2004
+++ install.py Wed Jul 7 19:59:19 2004
@@ -247,10 +247,6 @@
'dataFilePath = None', \
'dataFilePath = \'%s\' # modified by install script\n' \
% dataDir)
- if os.path.isdir('icons'):
- iconDir = os.path.join(prefixDir, 'share', 'icons')
- print ' Copying icon files to %s' % iconDir
- copyDir('icons', iconDir)
if siteCustomReqd:
createSiteCustomize()
createWrapper(pyDir, progName)

View File

@ -0,0 +1,9 @@
TreeLine helps you organise all your sticky notes, lists of books, movies,
website logins, personal contacts, or things to do.
It stores almost any kind of information. A tree structure makes it easy to
keep things organised. Each node in the tree can contain several fields,
forming a mini-database. The output format for each node can be defined, and
the output can be shown on the screen, printed, or exported to html.
WWW: http://www.bellz.org/treeline/

View File

@ -0,0 +1,65 @@
bin/treeline
lib/python2.3/site-packages/sitecustomize.py
lib/python2.3/site-packages/sitecustomize.pyc
lib/treeline/docparam.py
lib/treeline/docparam.pyc
lib/treeline/fieldformat.py
lib/treeline/fieldformat.pyc
lib/treeline/formatlist.py
lib/treeline/formatlist.pyc
lib/treeline/genboolean.py
lib/treeline/genboolean.pyc
lib/treeline/gendate.py
lib/treeline/gendate.pyc
lib/treeline/gennumber.py
lib/treeline/gennumber.pyc
lib/treeline/gentime.py
lib/treeline/gentime.pyc
lib/treeline/helpview.py
lib/treeline/helpview.pyc
lib/treeline/numbering.py
lib/treeline/numbering.pyc
lib/treeline/option.py
lib/treeline/option.pyc
lib/treeline/optiondlg.py
lib/treeline/optiondlg.pyc
lib/treeline/printpreview.py
lib/treeline/printpreview.pyc
lib/treeline/recentfiles.py
lib/treeline/recentfiles.pyc
lib/treeline/sitecustomize.py
lib/treeline/sitecustomize.pyc
lib/treeline/spellcheck.py
lib/treeline/spellcheck.pyc
lib/treeline/textedit2.py
lib/treeline/textedit2.pyc
lib/treeline/textedit3.py
lib/treeline/textedit3.pyc
lib/treeline/tmpcontrol.py
lib/treeline/tmpcontrol.pyc
lib/treeline/treedialogs.py
lib/treeline/treedialogs.pyc
lib/treeline/treedoc.py
lib/treeline/treedoc.pyc
lib/treeline/treeformat.py
lib/treeline/treeformat.pyc
lib/treeline/treeitem.py
lib/treeline/treeitem.pyc
lib/treeline/treeline.py
lib/treeline/treeline.pyc
lib/treeline/treemainwin.py
lib/treeline/treemainwin.pyc
lib/treeline/treerightviews.py
lib/treeline/treerightviews.pyc
lib/treeline/treeview.py
lib/treeline/treeview.pyc
lib/treeline/undo.py
lib/treeline/undo.pyc
lib/treeline/xpm.py
lib/treeline/xpm.pyc
%%PORTDOCS%%%%DOCSDIR%%/README.html
%%PORTDOCS%%%%DOCSDIR%%/readme.trl
%%PORTDOCS%%%%DOCSDIR%%/sample.trl
%%PORTDOCS%%%%DOCSDIR%%/sample_table.trl
@dirrm lib/treeline
%%PORTDOCS%%@dirrm %%DOCSDIR%%