devel/phasar: New port: LLVM-based static analysis framework

This commit is contained in:
Yuri Victorovich 2023-01-15 15:13:58 -08:00
parent ab01a5018d
commit efb86e0226
7 changed files with 369 additions and 0 deletions

View File

@ -4030,6 +4030,7 @@
SUBDIR += performance
SUBDIR += perlconsole
SUBDIR += phabricator
SUBDIR += phasar
SUBDIR += php-Psr_Log
SUBDIR += php-composer
SUBDIR += php-composer2

41
devel/phasar/Makefile Normal file
View File

@ -0,0 +1,41 @@
PORTNAME= phasar
DISTVERSIONPREFIX= v
DISTVERSION= 1222
CATEGORIES= devel science
MAINTAINER= yuri@FreeBSD.org
COMMENT= LLVM-based static analysis framework
WWW= https://phasar.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LIB_DEPENDS= libboost_graph.so:devel/boost-libs \
libcurl.so:ftp/curl
RUN_DEPENDS= bash:shells/bash
USES= cmake:testing compiler:c++17-lang llvm:lib,min=14,max=14 localbase:ldflags python shebangfix sqlite
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= secure-software-engineering
GH_TUPLE= google:googletest:e2239ee:googletest/external/googletest \
nlohmann:json:4f8fba1:json/external/json \
pboettch:json-schema-validator:27fc1d0:json_schema_validator/external/json-schema-validator
SHEBANG_GLOB= *.py *.sh
CMAKE_OFF= PHASAR_BUILD_UNITTESTS
post-patch: # workaround for https://github.com/secure-software-engineering/phasar/issues/564
# fix up the config directory location
@${REINPLACE_CMD} \
-e 's|std::string PhasarConfDir = std::string(EnvHome) + "/.config/phasar/"|std::string PhasarConfDir = "${PREFIX}/etc/phasar/"|; s|if (EnvHome) {|if (true) {|' \
${WRKSRC}/lib/Config/Configuration.cpp
post-install: # workaround for https://github.com/secure-software-engineering/phasar/issues/566
@${RM} -r \
${STAGEDIR}${PREFIX}/include/gtest \
${STAGEDIR}${PREFIX}/include/nlohmann
.include <bsd.port.mk>

9
devel/phasar/distinfo Normal file
View File

@ -0,0 +1,9 @@
TIMESTAMP = 1673681295
SHA256 (secure-software-engineering-phasar-v1222_GH0.tar.gz) = 799a9054a00776c8a65cff32095ff5ac7c8c36143e6283631e6174f6d041813a
SIZE (secure-software-engineering-phasar-v1222_GH0.tar.gz) = 7322368
SHA256 (google-googletest-e2239ee_GH0.tar.gz) = 47a8ca2e1be737588628cbc82726a7c4fed060ae0098709003845e3ef298da2f
SIZE (google-googletest-e2239ee_GH0.tar.gz) = 886254
SHA256 (nlohmann-json-4f8fba1_GH0.tar.gz) = a30659268f6834495168e3cba664ef38d4ad1f9f7e2f5382cd4711ec560b914a
SIZE (nlohmann-json-4f8fba1_GH0.tar.gz) = 7021765
SHA256 (pboettch-json-schema-validator-27fc1d0_GH0.tar.gz) = b2ebf1ee856ee64a2e72ffdc3e1fdd5ed62c8c40c68f861450843146d9769cb5
SIZE (pboettch-json-schema-validator-27fc1d0_GH0.tar.gz) = 54204

View File

@ -0,0 +1,25 @@
--- CMakeLists.txt.orig 2022-12-22 14:14:32 UTC
+++ CMakeLists.txt
@@ -114,11 +114,13 @@ if (NOT PHASAR_IN_TREE)
set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
endif()
+if (FALSE)
if (LLVM_ENABLE_LIBCXX)
set(PHASAR_STD_FILESYSTEM c++fs)
else()
set(PHASAR_STD_FILESYSTEM stdc++fs)
endif()
+endif()
### Adding external libraries
# Threads
@@ -334,7 +336,7 @@ install(DIRECTORY utils/
# Install the Phasar config files into ~/.config/phasar/
install(DIRECTORY config/
- DESTINATION $ENV{HOME}/.config/phasar
+ DESTINATION etc/phasar
PATTERN "config/*"
PERMISSIONS OWNER_WRITE OWNER_READ
GROUP_WRITE GROUP_READ

View File

@ -0,0 +1,13 @@
- workaround for https://github.com/secure-software-engineering/phasar/issues/562
--- include/phasar/PhasarLLVM/ControlFlow/Resolver/RTAResolver.h.orig 2023-01-15 17:55:03 UTC
+++ include/phasar/PhasarLLVM/ControlFlow/Resolver/RTAResolver.h
@@ -17,6 +17,8 @@
#ifndef PHASAR_PHASARLLVM_CONTROLFLOW_RESOLVER_RTARESOLVER_H_
#define PHASAR_PHASARLLVM_CONTROLFLOW_RESOLVER_RTARESOLVER_H_
+#include <vector>
+
#include "phasar/PhasarLLVM/ControlFlow/Resolver/CHAResolver.h"
namespace llvm {

5
devel/phasar/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
PhASAR is a LLVM-based static analysis framework written in C++. It allows users
to specify arbitrary data-flow problems which are then solved in a
fully-automated manner on the specified LLVM IR target code. Computing points-to
information, call-graph(s), etc. is done by the framework, thus you can focus on
what matters.

275
devel/phasar/pkg-plist Normal file
View File

@ -0,0 +1,275 @@
bin/DB/phasar-create-db-scheme.sql
bin/DB/phasar-sql2cpp.py
bin/json-schema-validate
bin/myphasartool
bin/phasar-compile2llvmIR.py
bin/phasar-llvm
bin/phasar-mkconfig.sh
bin/phasar-plot-pamm.py
bin/readme-json-schema
%%ETCDIR%%/DOTGraphConfig.json
%%ETCDIR%%/README.txt
%%ETCDIR%%/TaintConfigSchema.json
%%ETCDIR%%/glibc_function_list_v1-04.05.17.conf
%%ETCDIR%%/llvm_intrinsics_function_list_v1-04.05.17.conf
%%ETCDIR%%/phasar-source-sink-function.json
include/phasar/Config/Configuration.h
include/phasar/Config/Version.h
include/phasar/Controller/AnalysisController.h
include/phasar/Controller/AnalysisControllerEmitterOptions.h
include/phasar/DB/Hexastore.h
include/phasar/DB/LLVMProjectIRDB.h
include/phasar/DB/ProjectIRDBBase.h
include/phasar/DB/Queries.h
include/phasar/PhasarClang/ClangController.h
include/phasar/PhasarClang/RandomChangeASTConsumer.h
include/phasar/PhasarClang/RandomChangeFrontendAction.h
include/phasar/PhasarClang/RandomChangeVisitor.h
include/phasar/PhasarLLVM/AnalysisStrategy/AnalysisSetup.h
include/phasar/PhasarLLVM/AnalysisStrategy/DemandDrivenAnalysis.h
include/phasar/PhasarLLVM/AnalysisStrategy/HelperAnalyses.h
include/phasar/PhasarLLVM/AnalysisStrategy/HelperAnalysisConfig.h
include/phasar/PhasarLLVM/AnalysisStrategy/IncrementalUpdateAnalysis.h
include/phasar/PhasarLLVM/AnalysisStrategy/ModuleWiseAnalysis.h
include/phasar/PhasarLLVM/AnalysisStrategy/Strategies.def
include/phasar/PhasarLLVM/AnalysisStrategy/Strategies.h
include/phasar/PhasarLLVM/AnalysisStrategy/VariationalAnalysis.h
include/phasar/PhasarLLVM/ControlFlow/CFGBase.h
include/phasar/PhasarLLVM/ControlFlow/ICFGBase.h
include/phasar/PhasarLLVM/ControlFlow/LLVMBasedBackwardCFG.h
include/phasar/PhasarLLVM/ControlFlow/LLVMBasedBackwardICFG.h
include/phasar/PhasarLLVM/ControlFlow/LLVMBasedCFG.h
include/phasar/PhasarLLVM/ControlFlow/LLVMBasedICFG.h
include/phasar/PhasarLLVM/ControlFlow/Resolver/CHAResolver.h
include/phasar/PhasarLLVM/ControlFlow/Resolver/CallGraphAnalysisType.def
include/phasar/PhasarLLVM/ControlFlow/Resolver/CallGraphAnalysisType.h
include/phasar/PhasarLLVM/ControlFlow/Resolver/DTAResolver.h
include/phasar/PhasarLLVM/ControlFlow/Resolver/NOResolver.h
include/phasar/PhasarLLVM/ControlFlow/Resolver/OTFResolver.h
include/phasar/PhasarLLVM/ControlFlow/Resolver/RTAResolver.h
include/phasar/PhasarLLVM/ControlFlow/Resolver/Resolver.h
include/phasar/PhasarLLVM/ControlFlow/SpecialMemberFunctionType.def
include/phasar/PhasarLLVM/ControlFlow/SpecialMemberFunctionType.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/EdgeFunctionComposer.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/EdgeFunctions.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/FlowEdgeFunctionCache.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/FlowFunctions.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IDETabulationProblem.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/BranchSwitchInstFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/CallToRetFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/CheckOperandsFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/FlowFunctionBase.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/GEPInstFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/GenerateFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/IdentityFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/MapTaintedValuesToCallee.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/MapTaintedValuesToCaller.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/MemSetInstFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/MemTransferInstFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/PHINodeFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/ReturnInstFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/StoreInstFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/VAEndInstFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/FlowFunctions/VAStartInstFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/Stats/LcovRetValWriter.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/Stats/LcovWriter.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/Stats/LineNumberEntry.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/Stats/LineNumberWriter.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/Stats/TraceStats.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/Stats/TraceStatsWriter.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/Utils/DataFlowUtils.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSFieldSensTaintAnalysis/Utils/Log.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSIDESolverConfig.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/IFDSTabulationProblem.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/InitialSeeds.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/JoinLattice.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/LLVMFlowFunctions.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/LLVMZeroValue.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/AbstractMemoryLocation.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/AbstractMemoryLocationFactory.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/ComposeEdgeFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/DebugEdgeIdentity.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/EdgeDomain.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/GenEdgeFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/Helpers.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/JoinConstEdgeFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/JoinEdgeFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/KillIfSanitizedEdgeFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/TransferEdgeFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/XTaintAnalysisBase.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/ExtendedTaintAnalysis/XTaintEdgeFunctionBase.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEExtendedTaintAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/AllBot.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/BinaryEdgeFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/ConstantHelper.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/EdgeValue.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/EdgeValueSet.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/GenConstant.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/IDEGeneralizedLCA.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/JoinEdgeFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/LCAEdgeFunctionComposer.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/MapFactsToCalleeFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/MapFactsToCallerFlowFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEGeneralizedLCA/TypecastEdgeFunction.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEInstInteractionAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDELinearConstantAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDEProtoAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDESecureHeapPropagation.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDESolverTest.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IDETypeStateAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IFDSConstAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IFDSFieldSensTaintAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IFDSProtoAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IFDSSignAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IFDSSolverTest.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IFDSTaintAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IFDSTypeAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/IFDSUninitializedVariables.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/TypeStateDescriptions/CSTDFILEIOTypeStateDescription.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/TypeStateDescriptions/OpenSSLEVPKDFCTXDescription.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/TypeStateDescriptions/OpenSSLEVPKDFDescription.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/TypeStateDescriptions/OpenSSLSecureHeapDescription.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/TypeStateDescriptions/OpenSSLSecureMemoryDescription.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Problems/TypeStateDescriptions/TypeStateDescription.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Solver/IDESolver.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Solver/IFDSSolver.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Solver/JumpFunctions.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Solver/PathEdge.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/Solver/SolverResults.h
include/phasar/PhasarLLVM/DataFlowSolver/IfdsIde/SpecialSummaries.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/CallString.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/Contexts/CallStringCTX.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/InterMonoProblem.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/IntraMonoProblem.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/Problems/InterMonoFullConstantPropagation.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/Problems/InterMonoSolverTest.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/Problems/InterMonoTaintAnalysis.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/Problems/IntraMonoFullConstantPropagation.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/Problems/IntraMonoSolverTest.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/Problems/IntraMonoUninitVariables.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/Solver/InterMonoSolver.h
include/phasar/PhasarLLVM/DataFlowSolver/Mono/Solver/IntraMonoSolver.h
include/phasar/PhasarLLVM/Domain/AnalysisDomain.h
include/phasar/PhasarLLVM/Domain/ExtendedValue.h
include/phasar/PhasarLLVM/Domain/LLVMAnalysisDomain.h
include/phasar/PhasarLLVM/Passes/ExampleModulePass.h
include/phasar/PhasarLLVM/Passes/GeneralStatisticsAnalysis.h
include/phasar/PhasarLLVM/Passes/ValueAnnotationPass.h
include/phasar/PhasarLLVM/Pointer/DynamicPointsToSetPtr.h
include/phasar/PhasarLLVM/Pointer/LLVMBasedPointsToAnalysis.h
include/phasar/PhasarLLVM/Pointer/LLVMPointsToGraph.h
include/phasar/PhasarLLVM/Pointer/LLVMPointsToInfo.h
include/phasar/PhasarLLVM/Pointer/LLVMPointsToSet.h
include/phasar/PhasarLLVM/Pointer/LLVMPointsToUtils.h
include/phasar/PhasarLLVM/Pointer/PointerAnalysisType.def
include/phasar/PhasarLLVM/Pointer/PointerAnalysisType.h
include/phasar/PhasarLLVM/Pointer/PointsToInfo.h
include/phasar/PhasarLLVM/Pointer/PointsToSetOwner.h
include/phasar/PhasarLLVM/Pointer/TypeGraphs/CachedTypeGraph.h
include/phasar/PhasarLLVM/Pointer/TypeGraphs/LazyTypeGraph.h
include/phasar/PhasarLLVM/Pointer/TypeGraphs/TypeGraph.h
include/phasar/PhasarLLVM/TaintConfig/TaintConfig.h
include/phasar/PhasarLLVM/TaintConfig/TaintConfigUtilities.h
include/phasar/PhasarLLVM/TypeHierarchy/LLVMTypeHierarchy.h
include/phasar/PhasarLLVM/TypeHierarchy/LLVMVFTable.h
include/phasar/PhasarLLVM/TypeHierarchy/TypeHierarchy.h
include/phasar/PhasarLLVM/TypeHierarchy/VFTable.h
include/phasar/PhasarLLVM/Utils/Annotation.h
include/phasar/PhasarLLVM/Utils/BasicBlockOrdering.h
include/phasar/PhasarLLVM/Utils/BinaryDomain.h
include/phasar/PhasarLLVM/Utils/ByRef.h
include/phasar/PhasarLLVM/Utils/DOTGraph.h
include/phasar/PhasarLLVM/Utils/DataFlowAnalysisType.def
include/phasar/PhasarLLVM/Utils/DataFlowAnalysisType.h
include/phasar/PhasarLLVM/Utils/IOFormat.def
include/phasar/PhasarLLVM/Utils/IOFormat.h
include/phasar/PhasarLLVM/Utils/LLVMBasedContainerConfig.h
include/phasar/PhasarLLVM/Utils/LLVMCXXShorthands.h
include/phasar/PhasarLLVM/Utils/LLVMIRToSrc.h
include/phasar/PhasarLLVM/Utils/LLVMShorthands.h
include/phasar/PhasarLLVM/Utils/LatticeDomain.h
include/phasar/PhasarLLVM/Utils/Printer.h
include/phasar/PhasarLLVM/Utils/Scopes.h
include/phasar/PhasarLLVM/Utils/SummaryStrategy.h
include/phasar/PhasarPass/Options.h
include/phasar/PhasarPass/PhasarPass.h
include/phasar/PhasarPass/PhasarPrinterPass.h
include/phasar/PhasarPass/RegisterPasses.h
include/phasar/Utils/BitVectorSet.h
include/phasar/Utils/DebugOutput.h
include/phasar/Utils/EnumFlags.h
include/phasar/Utils/EquivalenceClassMap.h
include/phasar/Utils/IO.h
include/phasar/Utils/Logger.h
include/phasar/Utils/MaybeUniquePtr.h
include/phasar/Utils/MemoryResource.h
include/phasar/Utils/NlohmannLogging.h
include/phasar/Utils/PAMM.h
include/phasar/Utils/PAMMMacros.h
include/phasar/Utils/SeverityLevel.def
include/phasar/Utils/Soundness.def
include/phasar/Utils/Soundness.h
include/phasar/Utils/StableVector.h
include/phasar/Utils/Table.h
include/phasar/Utils/TypeTraits.h
include/phasar/Utils/Utilities.h
lib/cmake/nlohmann_json/nlohmann_jsonConfig.cmake
lib/cmake/nlohmann_json/nlohmann_jsonConfigVersion.cmake
lib/cmake/nlohmann_json/nlohmann_jsonTargets.cmake
lib/cmake/nlohmann_json_schema_validator/nlohmann_json_schema_validatorConfig.cmake
lib/cmake/nlohmann_json_schema_validator/nlohmann_json_schema_validatorConfigVersion.cmake
lib/cmake/nlohmann_json_schema_validator/nlohmann_json_schema_validatorTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/nlohmann_json_schema_validator/nlohmann_json_schema_validatorTargets.cmake
lib/cmake/phasar/phasarConfig.cmake
lib/cmake/phasar/phasarConfigVersion.cmake
lib/cmake/phasar/phasar_analysis_strategy-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_analysis_strategy-targets.cmake
lib/cmake/phasar/phasar_clang-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_clang-targets.cmake
lib/cmake/phasar/phasar_config-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_config-targets.cmake
lib/cmake/phasar/phasar_controlflow-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_controlflow-targets.cmake
lib/cmake/phasar/phasar_controller-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_controller-targets.cmake
lib/cmake/phasar/phasar_db-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_db-targets.cmake
lib/cmake/phasar/phasar_ifdside-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_ifdside-targets.cmake
lib/cmake/phasar/phasar_mono-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_mono-targets.cmake
lib/cmake/phasar/phasar_pass-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_pass-targets.cmake
lib/cmake/phasar/phasar_passes-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_passes-targets.cmake
lib/cmake/phasar/phasar_phasarllvm_utils-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_phasarllvm_utils-targets.cmake
lib/cmake/phasar/phasar_pointer-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_pointer-targets.cmake
lib/cmake/phasar/phasar_taintconfig-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_taintconfig-targets.cmake
lib/cmake/phasar/phasar_typehierarchy-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_typehierarchy-targets.cmake
lib/cmake/phasar/phasar_utils-targets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/phasar/phasar_utils-targets.cmake
lib/libnlohmann_json_schema_validator.so
lib/libnlohmann_json_schema_validator.so.1
lib/libnlohmann_json_schema_validator.so.2.1.0
lib/libphasar_analysis_strategy.so
lib/libphasar_clang.so
lib/libphasar_config.so
lib/libphasar_controlflow.so
lib/libphasar_controller.so
lib/libphasar_db.so
lib/libphasar_ifdside.so
lib/libphasar_mono.so
lib/libphasar_pass.so
lib/libphasar_passes.so
lib/libphasar_phasarllvm_utils.so
lib/libphasar_pointer.so
lib/libphasar_taintconfig.so
lib/libphasar_typehierarchy.so
lib/libphasar_utils.so
libdata/pkgconfig/nlohmann_json.pc
@dir bin/CodeGen/output
@dir bin/CodeGen/template