- Update to 1.20
- Restrict to Perl 5.8+ due to new dependency upon graphics/p5-GD-Graph - Mark as deprecated as per vendor and expire in the new year - Remove now-unnecessary patch PR: ports/99010 Submitted by: aaron Reviewed by: maintainer Approved by: maintainer, tobez (implicit)
This commit is contained in:
parent
46c6b6b898
commit
ef89d2a4d2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=165570
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= GIFgraph
|
||||
PORTVERSION= 1.10
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.20
|
||||
CATEGORIES= graphics perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= GIFgraph
|
||||
@ -19,11 +18,20 @@ COMMENT= A Perl package to generate PNG charts
|
||||
|
||||
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD
|
||||
|
||||
DEPRECATED= This module is simply a wrapper around GD::Graph and is deprecated. One should simply use graphics/p5-GD-Graph
|
||||
EXPIRATION_DATE= 2007-01-01
|
||||
|
||||
PERL_CONFIGURE= YES
|
||||
|
||||
MAN3= GIFgraph.3 GIFgraph::colour.3
|
||||
MAN3= GIFgraph.3
|
||||
|
||||
post-patch:
|
||||
${FIND} ${WRKSRC} -name '*.orig' -delete
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${PERL_LEVEL} < 500800 # inherited from graphics/p5-GD-Graph
|
||||
IGNORE= requires at least Perl 5.8. Please install lang/perl.58 and try again
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (GIFgraph-1.10.tar.gz) = 1bba4331bc82dd9e669a4dee592e5f02
|
||||
SHA256 (GIFgraph-1.10.tar.gz) = 58518c0142588ca6ec6747822f543b3e9701b49935d2119d084e6b59ae1a04a6
|
||||
SIZE (GIFgraph-1.10.tar.gz) = 109925
|
||||
MD5 (GIFgraph-1.20.tar.gz) = b4171f7d88c01acb0df5c5d515b24714
|
||||
SHA256 (GIFgraph-1.20.tar.gz) = de97b948d3b6c0b4380ff0bd0c59784741c89f87e486988ac62b18eac8ccc823
|
||||
SIZE (GIFgraph-1.20.tar.gz) = 29434
|
||||
|
@ -1,42 +0,0 @@
|
||||
--- GIFgraph./axestype.pm Wed Aug 26 03:37:14 1998
|
||||
+++ GIFgraph/axestype.pm Tue Jan 23 19:21:04 2001
|
||||
@@ -116,7 +116,7 @@
|
||||
$self->draw_data($self->{graph}, $data);
|
||||
$self->draw_legend($self->{graph});
|
||||
|
||||
- return $self->{graph}->gif
|
||||
+ return $self->{graph}->png
|
||||
}
|
||||
|
||||
sub set_x_label_font($) # (fontname)
|
||||
--- GIFgraph./pie.pm Wed Aug 26 03:28:51 1998
|
||||
+++ GIFgraph/pie.pm Tue Jan 23 19:23:09 2001
|
||||
@@ -53,7 +53,7 @@
|
||||
$self->draw_pie($self->{graph});
|
||||
$self->draw_data($data, $self->{graph});
|
||||
|
||||
- return $self->{graph}->gif;
|
||||
+ return $self->{graph}->png;
|
||||
}
|
||||
|
||||
sub set_label_font($) # (fontname)
|
||||
--- GIFgraph.pm. Wed Aug 26 03:28:48 1998
|
||||
+++ GIFgraph.pm Tue Jan 23 19:31:49 2001
|
||||
@@ -373,7 +373,7 @@
|
||||
|
||||
open(GIFLOGO, $self->{logo}) || return;
|
||||
binmode(GIFLOGO) if ($GIFgraph::needs_binmode);
|
||||
- unless ( $glogo = newFromGif GD::Image(\*GIFLOGO) )
|
||||
+ unless ( $glogo = newFromPng GD::Image(\*GIFLOGO) )
|
||||
{
|
||||
warn "Problems reading $self->{logo}";
|
||||
close(GIFLOGO);
|
||||
@@ -465,7 +465,7 @@
|
||||
{
|
||||
my $s = shift;
|
||||
|
||||
- return $s->{graph}->gif;
|
||||
+ return $s->{graph}->png;
|
||||
}
|
||||
|
||||
} # End of package GIFgraph
|
@ -1,14 +1,13 @@
|
||||
%%SITE_PERL%%/GIFgraph/pie.pm
|
||||
%%SITE_PERL%%/GIFgraph/utils.pm
|
||||
%%SITE_PERL%%/GIFgraph/axestype.pm
|
||||
%%SITE_PERL%%/GIFgraph/colour.pm
|
||||
%%SITE_PERL%%/GIFgraph/bars.pm
|
||||
%%SITE_PERL%%/GIFgraph/linespoints.pm
|
||||
%%SITE_PERL%%/GIFgraph/area.pm
|
||||
%%SITE_PERL%%/GIFgraph/lines.pm
|
||||
%%SITE_PERL%%/GIFgraph/mixed.pm
|
||||
%%SITE_PERL%%/GIFgraph/points.pm
|
||||
%%SITE_PERL%%/GIFgraph.pm
|
||||
%%SITE_PERL%%/GIFgraph/Convert.pm
|
||||
%%SITE_PERL%%/GIFgraph/area.pm
|
||||
%%SITE_PERL%%/GIFgraph/axestype.pm
|
||||
%%SITE_PERL%%/GIFgraph/bars.pm
|
||||
%%SITE_PERL%%/GIFgraph/lines.pm
|
||||
%%SITE_PERL%%/GIFgraph/linespoints.pm
|
||||
%%SITE_PERL%%/GIFgraph/mixed.pm
|
||||
%%SITE_PERL%%/GIFgraph/pie.pm
|
||||
%%SITE_PERL%%/GIFgraph/points.pm
|
||||
%%SITE_PERL%%/%%PERL_ARCH%%/auto/GIFgraph/.packlist
|
||||
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/GIFgraph
|
||||
@dirrm %%SITE_PERL%%/GIFgraph
|
||||
|
Loading…
Reference in New Issue
Block a user