Update to 0.11.1 release:
- OPTIONS'ify - take maintainership Approved by: maintainer
This commit is contained in:
parent
ef91311262
commit
ef83e0ea7d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=165241
@ -6,90 +6,77 @@
|
||||
#
|
||||
|
||||
PORTNAME= opensc
|
||||
PORTVERSION= 0.9.6
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.11.1
|
||||
CATEGORIES= security devel
|
||||
MASTER_SITES= http://www.opensc-project.org/files/opensc/
|
||||
MASTER_SITES= http://www.opensc-project.org/files/${PORTNAME}/
|
||||
|
||||
MAINTAINER= simon@FreeBSD.org
|
||||
COMMENT= ISO 7816 Smartcard API
|
||||
COMMENT= Libraries and utilities to access smart cards
|
||||
|
||||
USE_GNOME= pkgconfig
|
||||
INSTALLS_SHLIB= yes
|
||||
OPTIONS= OPENCT "Install openct for direct OpenCT backend support" on \
|
||||
PCSC "Install pcsc-lite for PC/SC backend support" off
|
||||
|
||||
USE_AUTOTOOLS= libltdl:15
|
||||
USE_OPENSSL= yes
|
||||
USE_GMAKE= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= gnomehack pkgconfig
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
|
||||
LDFLAGS="${LDFLAGS}" \
|
||||
OPENSSL_CFLAGS="-I${OPENSSLINC}" \
|
||||
OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
|
||||
|
||||
DOC_FILES= README *.sh *.xsl *.css *.html api html tools
|
||||
|
||||
PORTDOCS= *
|
||||
|
||||
MANCOMPRESSED= no
|
||||
MAN1= pkcs15-crypt.1 pkcs15-init.1 pkcs15-tool.1 opensc-tool.1 \
|
||||
opensc-explorer.1 opensc-config.1 cryptoflex-tool.1 \
|
||||
pkcs11-tool.1 cardos-info.1
|
||||
MAN3= sc_select_file.3 sc_release_context.3 sc_read_record.3 \
|
||||
sc_read_binary.3 sc_pkcs15_compute_signature.3 sc_lock.3 \
|
||||
sc_list_files.3 sc_file_new.3 sc_file_free.3 sc_file.3 \
|
||||
sc_establish_context.3 sc_disconnect_card.3 \
|
||||
sc_detect_card_presence.3 sc_connect_card.3
|
||||
MAN5= pkcs15-profile.5
|
||||
MAN7= pkcs15.7 opensc.7
|
||||
|
||||
# Compilation Options
|
||||
#
|
||||
# Define boolean switches:
|
||||
# WITHOUT_PAM WITHOUT_PCSC_LITE WITHOUT_LDAP
|
||||
# WITH_DEBUG WITH_DOCBOOK WITH_FIREFOX_PLUGIN WITH_MOZILLA_PLUGIN
|
||||
#
|
||||
# Default: WITH_PAM, WITH_PCSC_LITE, WITH_LDAP.
|
||||
#
|
||||
CONFIGURE_ARGS= --prefix=${PREFIX} --disable-dependency-tracking
|
||||
|
||||
.if !defined(WITHOUT_PAM)
|
||||
CONFIGURE_ARGS+= --with-pam
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_PCSC_LITE)
|
||||
LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
|
||||
CONFIGURE_ARGS+= --with-pcsclite=${LOCALBASE}
|
||||
.endif
|
||||
|
||||
.if !defined(WITHOUT_LDAP)
|
||||
USE_OPENLDAP= yes
|
||||
CONFIGURE_ARGS+= --enable-ldap \
|
||||
--with-ldap-lib=openldap \
|
||||
--with-ldap-dir=${LOCALBASE}
|
||||
PLIST_SUB+= LDAP=""
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-ldap
|
||||
PLIST_SUB+= LDAP="@comment "
|
||||
.endif
|
||||
|
||||
.if defined(WITH_FIREFOX_PLUGIN)
|
||||
RUN_DEPENDS?= firefox:${PORTSDIR}/www/firefox
|
||||
PLUGIN_DIR?= lib/firefox/plugins
|
||||
CONFIGURE_ARGS+= --with-plugin-dir="${PREFIX}/${PLUGIN_DIR}"
|
||||
.elif defined(WITH_MOZILLA_PLUGIN)
|
||||
RUN_DEPENDS?= mozilla:${PORTSDIR}/www/mozilla
|
||||
PLUGIN_DIR?= lib/browser_plugins
|
||||
CONFIGURE_ARGS+= --with-plugin-dir="${PREFIX}/${PLUGIN_DIR}"
|
||||
.endif
|
||||
|
||||
.if defined(WITH_DEBUG)
|
||||
CONFIGURE_ARGS+= --enable-debug
|
||||
.endif
|
||||
|
||||
.if !defined(WITH_DOCBOOK)
|
||||
CONFIGURE_ARGS+= --without-docbook
|
||||
.endif
|
||||
|
||||
.if defined(WITH_OPENCT)
|
||||
CONFIGURE_ARGS+= --with-openct=${LOCALBASE}
|
||||
RUN_DEPENDS+= openct-tool:${PORTSDIR}/security/openct
|
||||
BUILD_DEPENDS+= ${RUN_DEPENDS}
|
||||
.endif
|
||||
MAN1= cardos-info.1 cryptoflex-tool.1 netkey-tool.1 \
|
||||
opensc-config.1 opensc-explorer.1 opensc-tool.1 \
|
||||
pkcs11-tool.1 pkcs15-crypt.1 pkcs15-init.1 pkcs15-tool.1
|
||||
MAN3= sc_app_info_t.3 sc_append_record.3 sc_asn1_decode.3 \
|
||||
sc_asn1_encode.3 sc_asn1_entry.3 sc_asn1_find_tag.3 \
|
||||
sc_asn1_print_tags.3 sc_asn1_put_tag.3 sc_asn1_read_tag.3 \
|
||||
sc_asn1_skip_tag.3 sc_asn1_verify_tag.3 sc_base64_decode.3 \
|
||||
sc_base64_encode.3 sc_card_ctl.3 sc_card_t.3 \
|
||||
sc_card_valid.3 sc_check_sw.3 sc_connect_card.3 \
|
||||
sc_copy_asn1_entry.3 sc_create_file.3 sc_delete_file.3 \
|
||||
sc_delete_record.3 sc_der_clear.3 sc_der_copy.3 \
|
||||
sc_detect_card_presence.3 sc_disconnect_card.3 \
|
||||
sc_enum_apps.3 sc_establish_context.3 sc_file_dup.3 \
|
||||
sc_file_free.3 sc_file_new.3 sc_file_t.3 \
|
||||
sc_find_app_by_aid.3 sc_find_pkcs15_app.3 sc_format_apdu.3 \
|
||||
sc_format_asn1_entry.3 sc_free_apps.3 sc_get_cache_dir.3 \
|
||||
sc_get_challenge.3 sc_get_data.3 sc_list_files.3 \
|
||||
sc_lock.3 sc_make_cache_dir.3 sc_put_data.3 \
|
||||
sc_read_binary.3 sc_read_record.3 sc_release_context.3 \
|
||||
sc_select_file.3 sc_set_card_driver.3 sc_strerror.3 \
|
||||
sc_transmit_apdu.3 sc_unlock.3 sc_update_binary.3 \
|
||||
sc_update_dir.3 sc_update_record.3 sc_wait_for_event.3 \
|
||||
sc_write_binary.3 sc_write_record.3
|
||||
MAN5= pkcs15-profile.5
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
#
|
||||
#
|
||||
#post-patch:
|
||||
# ${REINPLACE_CMD} -e "s,ulong,u_long," ${WRKSRC}/src/openscd/openscd.c
|
||||
|
||||
.if !defined(WITHOUT_OPENCT) || exists(${LOCALBASE}/lib/libopenct.so)
|
||||
LIB_DEPENDS+= openct.1:${PORTSDIR}/security/openct
|
||||
.endif
|
||||
|
||||
.if defined(WITH_PCSC) || exists(${LOCALBASE}/lib/libpcsclite.so)
|
||||
LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
${INSTALL_DATA} ${WRKSRC}/etc/opensc.conf ${PREFIX}/etc/opensc.conf-sample
|
||||
.ifndef(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@(cd ${WRKSRC}/doc && ${CP} -R ${DOC_FILES} ${DOCSDIR})
|
||||
.endif
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (opensc-0.9.6.tar.gz) = 38fdd64566cc6fc83338d659e816b4fb
|
||||
SHA256 (opensc-0.9.6.tar.gz) = 53d7d4ffa4599b13f1805801805d8913fee8edec69a082ff9e9aa29d6193a526
|
||||
SIZE (opensc-0.9.6.tar.gz) = 1002151
|
||||
MD5 (opensc-0.11.1.tar.gz) = 94ce00a6bda38fac10ab06f5d5d1a8c3
|
||||
SHA256 (opensc-0.11.1.tar.gz) = 6c2285b6a838903e2da9d72e997d4f3f5a59c7a31d47c98f864b350b116d365c
|
||||
SIZE (opensc-0.11.1.tar.gz) = 1263611
|
||||
|
@ -1,14 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- src/libopensc/Makefile.in.orig
|
||||
+++ src/libopensc/Makefile.in
|
||||
@@ -240,7 +240,7 @@
|
||||
|
||||
noinst_HEADERS = ctbcs.h internal.h esteid.h card-oberthur.h pinpad-ccid.h
|
||||
|
||||
-pkgconfigdir = @libdir@/pkgconfig
|
||||
+pkgconfigdir = @prefix@/libdata/pkgconfig
|
||||
pkgconfig_DATA = libopensc.pc libpkcs15init.pc \
|
||||
libscam.pc libscconf.pc libscldap.pc
|
||||
|
@ -1,12 +1,17 @@
|
||||
libopensc is a library for accessing SmartCard devices using PC/SC
|
||||
Lite middleware package. It is also the core library of the OpenSC
|
||||
project. Basic functionality (e.g. SELECT FILE, READ BINARY) should
|
||||
work on any ISO 7816-4 compatible SmartCard. Encryption and decryption
|
||||
using private keys on the SmartCard is possible with PKCS #15
|
||||
compatible cards, such as the FINEID (Finnish Electronic IDentity)
|
||||
card. Swedish Posten eID cards have also been confirmed to work.
|
||||
OpenSC provides a set of libraries and utilities to
|
||||
access smart cards. Its main focus is on cards that
|
||||
support cryptographic operations, and facilitate their
|
||||
use in security applications such as mail encryption,
|
||||
authentication, and digital signature.
|
||||
|
||||
WWW: http://www.opensc.org/
|
||||
OpenSC implements the PKCS#11 API so applications
|
||||
supporting this API such as Mozilla Firefox and
|
||||
Thunderbird can use it.
|
||||
|
||||
Bruce
|
||||
bms@FreeBSD.org
|
||||
OpenSC implements the PKCS#15 standard and aims to be
|
||||
compatible with every software that does so, too.
|
||||
|
||||
WWW: http://www.opensc-project.org/opensc/
|
||||
|
||||
- Alex Dupre
|
||||
ale@FreeBSD.org
|
||||
|
4
security/opensc/pkg-message
Normal file
4
security/opensc/pkg-message
Normal file
@ -0,0 +1,4 @@
|
||||
********************************************************
|
||||
Before using OpenSC, you should create the configuration
|
||||
file, by copying the installed sample.
|
||||
********************************************************
|
@ -1,86 +1,65 @@
|
||||
%%DATADIR%%/starcos.profile
|
||||
%%DATADIR%%/pkcs15.profile
|
||||
%%DATADIR%%/oberthur.profile
|
||||
%%DATADIR%%/miocos.profile
|
||||
%%DATADIR%%/jcop.profile
|
||||
%%DATADIR%%/gpk.profile
|
||||
%%DATADIR%%/flex.profile
|
||||
%%DATADIR%%/etoken.profile
|
||||
%%DATADIR%%/cyberflex.profile
|
||||
@dirrm %%DATADIR%%
|
||||
libdata/pkgconfig/libopensc.pc
|
||||
libdata/pkgconfig/libpkcs15init.pc
|
||||
libdata/pkgconfig/libscam.pc
|
||||
libdata/pkgconfig/libscconf.pc
|
||||
libdata/pkgconfig/libscldap.pc
|
||||
lib/security/pam_opensc.a
|
||||
lib/security/pam_opensc.la
|
||||
lib/security/pam_opensc.so
|
||||
@dirrmtry lib/security
|
||||
lib/pkcs11/libpkcs11.a
|
||||
lib/pkcs11/libpkcs11.la
|
||||
lib/pkcs11/libpkcs11.so
|
||||
lib/pkcs11/libpkcs11.so.1
|
||||
lib/pkcs11/opensc-pkcs11.a
|
||||
lib/pkcs11/opensc-pkcs11.la
|
||||
lib/pkcs11/opensc-pkcs11.so
|
||||
lib/pkcs11/pkcs11-spy.a
|
||||
lib/pkcs11/pkcs11-spy.la
|
||||
lib/pkcs11/pkcs11-spy.so
|
||||
@dirrm lib/pkcs11
|
||||
lib/opensc/engine_pkcs11.a
|
||||
lib/opensc/engine_pkcs11.la
|
||||
lib/opensc/engine_pkcs11.so
|
||||
lib/opensc/engine_opensc.a
|
||||
lib/opensc/engine_opensc.la
|
||||
lib/opensc/engine_opensc.so
|
||||
@dirrm lib/opensc
|
||||
%%LDAP%%lib/libscldap.a
|
||||
%%LDAP%%lib/libscldap.la
|
||||
%%LDAP%%lib/libscldap.so
|
||||
%%LDAP%%lib/libscldap.so.1
|
||||
lib/libopensc.a
|
||||
lib/libopensc.la
|
||||
lib/libopensc.so
|
||||
lib/libopensc.so.1
|
||||
lib/libpkcs15init.a
|
||||
lib/libpkcs15init.la
|
||||
lib/libpkcs15init.so
|
||||
lib/libpkcs15init.so.1
|
||||
lib/libscam.a
|
||||
lib/libscam.la
|
||||
lib/libscam.so
|
||||
lib/libscam.so.1
|
||||
lib/libscconf.a
|
||||
lib/libscconf.la
|
||||
lib/libscconf.so
|
||||
lib/libscconf.so.1
|
||||
include/opensc/ui.h
|
||||
include/opensc/types.h
|
||||
include/opensc/scldap.h
|
||||
include/opensc/scconf.h
|
||||
bin/cardos-info
|
||||
bin/cryptoflex-tool
|
||||
bin/eidenv
|
||||
bin/netkey-tool
|
||||
bin/opensc-config
|
||||
bin/opensc-explorer
|
||||
bin/opensc-tool
|
||||
bin/piv-tool
|
||||
bin/pkcs11-tool
|
||||
bin/pkcs15-crypt
|
||||
bin/pkcs15-init
|
||||
bin/pkcs15-tool
|
||||
etc/opensc.conf-sample
|
||||
include/opensc/asn1.h
|
||||
include/opensc/cardctl.h
|
||||
include/opensc/emv.h
|
||||
include/opensc/errors.h
|
||||
include/opensc/log.h
|
||||
include/opensc/opensc.h
|
||||
include/opensc/pkcs11.h
|
||||
include/opensc/pkcs15-init.h
|
||||
include/opensc/pkcs15.h
|
||||
include/opensc/rsaref/win32.h
|
||||
include/opensc/rsaref/unix.h
|
||||
include/opensc/rsaref/pkcs11t.h
|
||||
include/opensc/rsaref/pkcs11f.h
|
||||
include/opensc/rsaref/pkcs11.h
|
||||
include/opensc/scconf.h
|
||||
include/opensc/types.h
|
||||
include/opensc/ui.h
|
||||
libdata/pkgconfig/libopensc.pc
|
||||
libdata/pkgconfig/libpkcs15init.pc
|
||||
libdata/pkgconfig/libscconf.pc
|
||||
lib/libopensc.a
|
||||
lib/libopensc.la
|
||||
lib/libopensc.so
|
||||
lib/libopensc.so.2
|
||||
lib/libpkcs15init.a
|
||||
lib/libpkcs15init.la
|
||||
lib/libpkcs15init.so
|
||||
lib/libpkcs15init.so.2
|
||||
lib/libscconf.a
|
||||
lib/libscconf.la
|
||||
lib/libscconf.so
|
||||
lib/libscconf.so.2
|
||||
lib/opensc-pkcs11.a
|
||||
lib/opensc-pkcs11.la
|
||||
lib/opensc-pkcs11.so
|
||||
lib/pkcs11-spy.a
|
||||
lib/pkcs11-spy.la
|
||||
lib/pkcs11-spy.so
|
||||
%%DATADIR%%/cardos.profile
|
||||
%%DATADIR%%/cyberflex.profile
|
||||
%%DATADIR%%/flex.profile
|
||||
%%DATADIR%%/gpk.profile
|
||||
%%DATADIR%%/incrypto34.profile
|
||||
%%DATADIR%%/jcop.profile
|
||||
%%DATADIR%%/miocos.profile
|
||||
%%DATADIR%%/oberthur.profile
|
||||
%%DATADIR%%/pkcs15.profile
|
||||
%%DATADIR%%/setcos.profile
|
||||
%%DATADIR%%/starcos.profile
|
||||
@dirrm include/opensc/rsaref
|
||||
include/opensc/pkcs15.h
|
||||
include/opensc/pkcs15-init.h
|
||||
include/opensc/pkcs11.h
|
||||
include/opensc/opensc.h
|
||||
include/opensc/log.h
|
||||
include/opensc/errors.h
|
||||
include/opensc/emv.h
|
||||
include/opensc/cardctl.h
|
||||
include/opensc/asn1.h
|
||||
@dirrm include/opensc
|
||||
bin/pkcs15-tool
|
||||
bin/pkcs15-init
|
||||
bin/pkcs15-crypt
|
||||
bin/pkcs11-tool
|
||||
bin/opensc-tool
|
||||
bin/opensc-explorer
|
||||
bin/opensc-config
|
||||
bin/cryptoflex-tool
|
||||
bin/cardos-info
|
||||
@dirrm %%DATADIR%%
|
||||
|
Loading…
Reference in New Issue
Block a user