Update to 1.4.3
Hand maintainership to submitter PR: 55106 55107 Submitted by: Alexey Dokuchaev <danfe@regency.nsu.ru> Approved by: fjoe (mentor) (implicit)
This commit is contained in:
parent
704f7ef9ae
commit
ef5b6dbf5c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=86054
@ -6,16 +6,17 @@
|
||||
#
|
||||
|
||||
PORTNAME= svgalib
|
||||
PORTVERSION= 1.4.2
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 1.4.3
|
||||
PORTREVISION= 0
|
||||
CATEGORIES= graphics devel
|
||||
MASTER_SITES= http://www.svgalib.org/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= danfe@regency.nsu.ru
|
||||
COMMENT= A low level console graphics library
|
||||
|
||||
USE_GMAKE= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
MANCOMPRESSED= yes
|
||||
|
||||
ALL_TARGET= shared static
|
||||
|
||||
@ -29,7 +30,7 @@ BROKEN= "3.* isn't supported - please upgrade to use the port"
|
||||
|
||||
.for i in 1 2 3 4 5 6 7 8 9
|
||||
.if exists(${FILESDIR}/man${i})
|
||||
MAN${i}!= /bin/cat ${FILESDIR}/man${i}
|
||||
MAN${i}!= ${CAT} ${FILESDIR}/man${i}
|
||||
.endif
|
||||
.endfor
|
||||
|
||||
|
@ -1 +1 @@
|
||||
MD5 (svgalib-1.4.2.tar.gz) = 4576058f43adbc2c433aeba25603fd82
|
||||
MD5 (svgalib-1.4.3.tar.gz) = 7d2778e3beebc07dd7c74668f6887c6f
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- Makefile.cfg.orig Fri Jul 21 11:21:34 2000
|
||||
+++ Makefile.cfg Fri Aug 25 05:05:04 2000
|
||||
--- Makefile.cfg.orig Tue May 29 21:39:13 2001
|
||||
+++ Makefile.cfg Thu Jul 31 18:12:15 2003
|
||||
@@ -9,8 +9,8 @@
|
||||
# to n means yes!
|
||||
|
||||
MAJOR_VER = 1
|
||||
-MINOR_VER = 4.2
|
||||
-MINOR_VER = 4.3
|
||||
-VERSION = $(MAJOR_VER).$(MINOR_VER)
|
||||
+MINOR_VER =
|
||||
+VERSION = $(MAJOR_VER)
|
||||
@ -41,7 +41,7 @@
|
||||
# Comment this out if you want to keep old shared images. Old header files,
|
||||
# library stubs and static libraries CANNOT be kept in public locations
|
||||
@@ -126,20 +126,20 @@
|
||||
#INCLUDE_ET4000_DRIVER = y
|
||||
INCLUDE_ET4000_DRIVER = y
|
||||
INCLUDE_CIRRUS_DRIVER = y
|
||||
INCLUDE_TVGA_DRIVER = y
|
||||
-#INCLUDE_OAK_DRIVER = y
|
||||
@ -69,8 +69,17 @@
|
||||
INCLUDE_MX_DRIVER = y
|
||||
INCLUDE_PARADISE_DRIVER = y
|
||||
INCLUDE_RAGE_DRIVER = y
|
||||
@@ -154,15 +154,15 @@
|
||||
#INCLUDE_ET4000_DRIVER_TEST = y
|
||||
@@ -150,7 +150,7 @@
|
||||
INCLUDE_NEO_DRIVER = y
|
||||
INCLUDE_R128_DRIVER = y
|
||||
INCLUDE_G400_DRIVER = y
|
||||
-INCLUDE_FBDEV_DRIVER = y
|
||||
+#INCLUDE_FBDEV_DRIVER = y
|
||||
INCLUDE_SAVAGE_DRIVER = y
|
||||
#
|
||||
# Comment out any adapter you don't want to autodetect.
|
||||
@@ -158,15 +158,15 @@
|
||||
INCLUDE_ET4000_DRIVER_TEST = y
|
||||
INCLUDE_CIRRUS_DRIVER_TEST = y
|
||||
INCLUDE_TVGA_DRIVER_TEST = y
|
||||
-#INCLUDE_OAK_DRIVER_TEST = y
|
||||
@ -92,8 +101,8 @@
|
||||
INCLUDE_CHIPS_DRIVER_TEST = y
|
||||
INCLUDE_APM_DRIVER_TEST = y
|
||||
INCLUDE_NV3_DRIVER_TEST = y
|
||||
@@ -177,7 +177,7 @@
|
||||
INCLUDE_NEO_DRIVER_TEST = y
|
||||
@@ -185,7 +185,7 @@
|
||||
INCLUDE_SAVAGE_DRIVER_TEST = y
|
||||
|
||||
#Might be too dangerous:
|
||||
-INCLUDE_VESA_DRIVER_TEST = y
|
||||
|
@ -1,14 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- doc/Makefile 2001/06/19 15:18:58 1.1
|
||||
+++ doc/Makefile 2001/06/19 15:19:16
|
||||
@@ -91,7 +91,7 @@
|
||||
bfile=`echo $$file | sed 's/.gz$$//'`; \
|
||||
gunzip < $$file > $(mandir)/$$bfile; \
|
||||
chmod 644 $(mandir)/$$bfile; \
|
||||
- chown root.bin $(mandir)/$$bfile; \
|
||||
+ chown root:bin $(mandir)/$$bfile; \
|
||||
done; \
|
||||
done
|
||||
endif
|
@ -1,13 +1,13 @@
|
||||
This is a low level console graphics library, originally based on VGAlib 1.2 by
|
||||
Tommy Frandsen. VGAlib supported a number of standard VGA graphics modes,
|
||||
as well high resolution/high color modes on many popular graphics adapters. As
|
||||
of now, support for many more chipsets has been added.
|
||||
Tommy Frandsen. VGAlib supported a number of standard VGA graphics modes, as
|
||||
well as high resolution/high color modes on many popular graphics adapters. As
|
||||
of now, support for many more chipsets had been added.
|
||||
|
||||
It supports transparent virtual console switching, that is, you can switch
|
||||
consoles to and from text and graphics mode consoles using alt-[function key].
|
||||
Also, svgalib corrects most of VGAlib's textmode corruption behaviour by
|
||||
catching SIGSEGV, SIGFPE, SIGILL, and other fatal signals and ensuring that
|
||||
a program is running in the currently visible virtual console before setting a
|
||||
Also, SVGAlib corrects most of VGAlib's textmode corruption behaviour by
|
||||
catching SIGSEGV, SIGFPE, SIGILL, and other fatal signals and ensuring that a
|
||||
program is running in the currently visible virtual console before setting a
|
||||
graphics mode.
|
||||
|
||||
WWW: http://www.svgalib.org/
|
||||
|
Loading…
Reference in New Issue
Block a user