devel/libcircllhist: Update to g20211005 and unbreak LDFLAGS

- take up maintainership of this unmaintained port
 - license has changed to APACHE20
 - upstream has moved, switch to new upstream
 - generate and install documentation
 - disable git-based version generation (tries to pick up the ports tree's git)
 - regenerate patch
 - make portlint and portclippy happy

PR:		258906
This commit is contained in:
Robert Clausecker 2021-10-08 14:24:31 +02:00 committed by Mikael Urankar
parent a385a94464
commit ef377af9f7
5 changed files with 74 additions and 15 deletions

View File

@ -1,27 +1,36 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= libcircllhist
PORTVERSION= g20200417
PORTREVISION= 1
PORTVERSION= g20211005
CATEGORIES= devel
MAINTAINER= ports@FreeBSD.org
MAINTAINER= fuz@fuz.su
COMMENT= Circonus log-linear histogram C implementation
LICENSE= BSD3CLAUSE
BROKEN_aarch64= fails to configure: error: cannot compute sizeof (char)
USE_GITHUB= yes
GH_ACCOUNT= circonus-labs
GH_TAGNAME= b7c6248
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= autoreconf gmake
GNU_CONFIGURE= yes
USE_GITHUB= yes
GH_ACCOUNT= openhistogram
GH_TAGNAME= 79fab69ee82597e3940cab017d7b0cd50ef3e9c1
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
ALL_TARGET= all
OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
DOCS_ALL_TARGET= docs
post-install:
${LN} -s libcircllhist.so.0.0.1 \
${STAGEDIR}${PREFIX}/lib/libcircllhist.so.0
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/circllhist_print
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcircllhist.so.0.0.1
post-install-DOCS-on:
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/docs && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1587128311
SHA256 (circonus-labs-libcircllhist-g20200417-b7c6248_GH0.tar.gz) = 031e50cea34db21828bda678144113b54867204c30833418fd99b93e752a939c
SIZE (circonus-labs-libcircllhist-g20200417-b7c6248_GH0.tar.gz) = 86689
TIMESTAMP = 1633445699
SHA256 (openhistogram-libcircllhist-g20211005-79fab69ee82597e3940cab017d7b0cd50ef3e9c1_GH0.tar.gz) = 4faa404abfc814a575cc0f3b3a29889b4fcc59fe2fbe4a54d411058161350b37
SIZE (openhistogram-libcircllhist-g20211005-79fab69ee82597e3940cab017d7b0cd50ef3e9c1_GH0.tar.gz) = 106859

View File

@ -0,0 +1,11 @@
--- buildtools/mkversion.sh.orig 2021-10-05 14:58:58 UTC
+++ buildtools/mkversion.sh
@@ -1,6 +1,7 @@
#!/bin/sh
-STATUS=`git status 2>&1`
+#STATUS=`git status 2>&1`
+false
if [ $? -eq 0 ]; then
echo "Building version info from git"
HASH=`git show --format=%H | head -1`

View File

@ -1,4 +1,4 @@
--- configure.ac.orig 2019-10-16 20:36:24 UTC
--- configure.ac.orig 2020-04-17 12:58:31 UTC
+++ configure.ac
@@ -31,19 +31,19 @@ AC_PATH_PROG(CTFMERGE, ctfmerge)

View File

@ -4,4 +4,43 @@ lib/libcircllhist.a
lib/libcircllhist.so
lib/libcircllhist.so.0
lib/libcircllhist.so.0.0.1
%%PORTDOCS%%%%DOCSDIR%%/html/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/html/bc_s.png
%%PORTDOCS%%%%DOCSDIR%%/html/bdwn.png
%%PORTDOCS%%%%DOCSDIR%%/html/circllhist_8h.html
%%PORTDOCS%%%%DOCSDIR%%/html/circllhist_8h_source.html
%%PORTDOCS%%%%DOCSDIR%%/html/classes.html
%%PORTDOCS%%%%DOCSDIR%%/html/closed.png
%%PORTDOCS%%%%DOCSDIR%%/html/dir_68267d1309a1af8e8297ef4c3efbcdba.html
%%PORTDOCS%%%%DOCSDIR%%/html/doc.png
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/html/doxygen.svg
%%PORTDOCS%%%%DOCSDIR%%/html/dynsections.js
%%PORTDOCS%%%%DOCSDIR%%/html/files.html
%%PORTDOCS%%%%DOCSDIR%%/html/folderclosed.png
%%PORTDOCS%%%%DOCSDIR%%/html/folderopen.png
%%PORTDOCS%%%%DOCSDIR%%/html/functions.html
%%PORTDOCS%%%%DOCSDIR%%/html/functions_vars.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_defs.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_func.html
%%PORTDOCS%%%%DOCSDIR%%/html/globals_type.html
%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/html/jquery.js
%%PORTDOCS%%%%DOCSDIR%%/html/menu.js
%%PORTDOCS%%%%DOCSDIR%%/html/menudata.js
%%PORTDOCS%%%%DOCSDIR%%/html/nav_f.png
%%PORTDOCS%%%%DOCSDIR%%/html/nav_g.png
%%PORTDOCS%%%%DOCSDIR%%/html/nav_h.png
%%PORTDOCS%%%%DOCSDIR%%/html/open.png
%%PORTDOCS%%%%DOCSDIR%%/html/splitbar.png
%%PORTDOCS%%%%DOCSDIR%%/html/structhist__allocator.html
%%PORTDOCS%%%%DOCSDIR%%/html/structhist__bucket.html
%%PORTDOCS%%%%DOCSDIR%%/html/sync_off.png
%%PORTDOCS%%%%DOCSDIR%%/html/sync_on.png
%%PORTDOCS%%%%DOCSDIR%%/html/tab_a.png
%%PORTDOCS%%%%DOCSDIR%%/html/tab_b.png
%%PORTDOCS%%%%DOCSDIR%%/html/tab_h.png
%%PORTDOCS%%%%DOCSDIR%%/html/tab_s.png
%%PORTDOCS%%%%DOCSDIR%%/html/tabs.css
share/lua/5.1/ffi_libcircllhist.lua