New port: audio/rtaudio: C++ classes that provide a common API for realtime audio input/output
PR: 223414 Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D12936
This commit is contained in:
parent
4813d17d9f
commit
ef0062d20a
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=453464
@ -698,6 +698,7 @@
|
||||
SUBDIR += rosegarden
|
||||
SUBDIR += rplay
|
||||
SUBDIR += rsynth
|
||||
SUBDIR += rtaudio
|
||||
SUBDIR += rtmidi
|
||||
SUBDIR += rubberband
|
||||
SUBDIR += ruby-smf
|
||||
|
20
audio/rtaudio/Makefile
Normal file
20
audio/rtaudio/Makefile
Normal file
@ -0,0 +1,20 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= rtaudio
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 5.0.0
|
||||
CATEGORIES= audio
|
||||
|
||||
MAINTAINER= yuri@FreeBSD.org
|
||||
COMMENT= C++ classes that provide a common API for realtime audio input/output
|
||||
|
||||
LICENSE= MIT
|
||||
|
||||
USES= autoreconf libtool pkgconfig
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= thestk
|
||||
GNU_CONFIGURE= yes
|
||||
USE_LDCONFIG= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
.include <bsd.port.mk>
|
3
audio/rtaudio/distinfo
Normal file
3
audio/rtaudio/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1509775215
|
||||
SHA256 (thestk-rtaudio-v5.0.0_GH0.tar.gz) = 14d1936c88585cacf081a896438f04f158c115c0fc9eec9364214040c4328376
|
||||
SIZE (thestk-rtaudio-v5.0.0_GH0.tar.gz) = 211279
|
11
audio/rtaudio/files/patch-configure.ac
Normal file
11
audio/rtaudio/files/patch-configure.ac
Normal file
@ -0,0 +1,11 @@
|
||||
--- configure.ac.orig 2017-11-04 06:06:02 UTC
|
||||
+++ configure.ac
|
||||
@@ -142,7 +142,7 @@ case $host in
|
||||
AS_IF([test "$api" == ""], [
|
||||
AC_MSG_RESULT(using OSS)
|
||||
api="$api -D__LINUX_OSS__"
|
||||
- LIBS="$LIBS -lossaudio"
|
||||
+ LIBS="$LIBS"
|
||||
AC_CHECK_LIB(pthread, pthread_create, , AC_MSG_ERROR(RtAudio requires the pthread library!))])
|
||||
;;
|
||||
|
6
audio/rtaudio/pkg-descr
Normal file
6
audio/rtaudio/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
A set of C++ classes that provide a common API for realtime audio input/output
|
||||
across Linux (native ALSA, JACK, PulseAudio and OSS), Macintosh OS X
|
||||
(CoreAudio and JACK), and Windows (DirectSound, ASIO and WASAPI) operating
|
||||
systems.
|
||||
|
||||
WWW: https://github.com/thestk/rtaudio
|
6
audio/rtaudio/pkg-plist
Normal file
6
audio/rtaudio/pkg-plist
Normal file
@ -0,0 +1,6 @@
|
||||
include/rtaudio/RtAudio.h
|
||||
lib/librtaudio.a
|
||||
lib/librtaudio.so
|
||||
lib/librtaudio.so.6
|
||||
lib/librtaudio.so.6.0.0
|
||||
libdata/pkgconfig/rtaudio.pc
|
Loading…
Reference in New Issue
Block a user