Update to 2.0.20
Changes: https://github.com/jasper-software/jasper/blob/master/NEWS PR: 248912 Exp-run by: antoine Security: 6842ac7e-d250-11ea-b9b7-08002728f74c MFH: 2020Q3
This commit is contained in:
parent
22772c937b
commit
eeeed9e282
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=548374
@ -2,8 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= jasper
|
||||
PORTVERSION= 2.0.16
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.0.20
|
||||
DISTVERSIONPREFIX= version-
|
||||
CATEGORIES= graphics
|
||||
|
||||
@ -17,9 +16,8 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
|
||||
|
||||
USES= cmake jpeg localbase
|
||||
|
||||
CMAKE_ARGS= -DCMAKE_SKIP_RPATH=true \
|
||||
-DJAS_ENABLE_AUTOMATIC_DEPENDENCIES=false \
|
||||
-DJAS_ENABLE_JPEG=true
|
||||
CMAKE_OFF= JAS_ENABLE_AUTOMATIC_DEPENDENCIES
|
||||
CMAKE_ON= JAS_ENABLE_LIBJPEG
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
DOCSDIR= ${PREFIX}/share/doc/JasPer
|
||||
@ -31,11 +29,9 @@ OPTIONS_DEFINE= OPENGL DOCS
|
||||
OPTIONS_DEFAULT=OPENGL
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
DOCS_CMAKE_BOOL= JAS_ENABLE_DOC
|
||||
OPENGL_CMAKE_BOOL= JAS_ENABLE_OPENGL
|
||||
OPENGL_USE= GL=gl,glu,glut XORG=x11,xext,xi,xmu
|
||||
OPENGL_USES= gl xorg
|
||||
|
||||
post-install-DOCS-off:
|
||||
rm -rf ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1595416525
|
||||
SHA256 (jasper-software-jasper-version-2.0.16_GH0.tar.gz) = f1d8b90f231184d99968f361884e2054a1714fdbbd9944ba1ae4ebdcc9bbfdb1
|
||||
SIZE (jasper-software-jasper-version-2.0.16_GH0.tar.gz) = 1311944
|
||||
TIMESTAMP = 1599329835
|
||||
SHA256 (jasper-software-jasper-version-2.0.20_GH0.tar.gz) = d55843ce52afa9bfe90f30118329578501040f30d48a027459a68a962695e506
|
||||
SIZE (jasper-software-jasper-version-2.0.20_GH0.tar.gz) = 1318727
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- CMakeLists.txt.orig 2019-03-12 18:04:35 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -267,8 +267,8 @@ message("JAS_HAVE_LIBJPEG: ${JAS_HAVE_LIBJPEG}")
|
||||
# Check for the OpenGL and GLUT libraries.
|
||||
################################################################################
|
||||
|
||||
-find_package(OpenGL ${JAS_REQUIRED})
|
||||
message("JAS_ENABLE_OPENGL: ${JAS_ENABLE_OPENGL}")
|
||||
+find_package(OpenGL ${JAS_OPENGL_REQUIRED})
|
||||
message("OpenGL library found: ${OPENGL_FOUND}")
|
||||
if (JAS_ENABLE_OPENGL AND OPENGL_FOUND)
|
||||
set(JAS_HAVE_OPENGL 0)
|
@ -0,0 +1,11 @@
|
||||
--- build/cmake/modules/JasOpenGL.cmake.orig 2020-09-05 14:52:22 UTC
|
||||
+++ build/cmake/modules/JasOpenGL.cmake
|
||||
@@ -4,7 +4,7 @@
|
||||
|
||||
if (JAS_ENABLE_OPENGL)
|
||||
set(OpenGL_GL_PREFERENCE GLVND)
|
||||
- find_package(OpenGL ${JAS_REQUIRED})
|
||||
+ find_package(OpenGL ${JAS_OPENGL_REQUIRED})
|
||||
message("OpenGL library found: ${OPENGL_FOUND}")
|
||||
else()
|
||||
set(OPENGL_FOUND false)
|
@ -3,6 +3,7 @@ bin/imginfo
|
||||
bin/jasper
|
||||
%%OPENGL%%bin/jiv
|
||||
include/jasper/jas_cm.h
|
||||
include/jasper/jas_compiler.h
|
||||
include/jasper/jas_config.h
|
||||
include/jasper/jas_debug.h
|
||||
include/jasper/jas_dll.h
|
||||
|
Loading…
Reference in New Issue
Block a user