MFH: r526626 r527958

www/gitea: Update to 1.10.4

Changes:	https://github.com/go-gitea/gitea/releases/tag/v1.10.4
PR:		244246
Submitted by:	stb@lassitu.de (maintainer)

gitea: Update to 1.11.2, contains security fixes

https://blog.gitea.io/2020/02/gitea-1.11.0-is-released
https://blog.gitea.io/2020/02/gitea-1.11.1-is-released
https://blog.gitea.io/2020/02/gitea-1.11.2-is-released

PR:		244025
Submitted by:	maintainer
Security:	yes (see links above)

Approved by:	portmgr (with hat)
This commit is contained in:
Adam Weinberger 2020-03-07 18:42:56 +00:00
parent a88e27fda8
commit eee63c5b8b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2020Q1/; revision=527962
4 changed files with 2728 additions and 2597 deletions

View File

@ -2,8 +2,11 @@
PORTNAME= gitea
DISTVERSIONPREFIX= v
DISTVERSION= 1.10.3
DISTVERSION= 1.11.2
CATEGORIES= www
MASTER_SITES= https://github.com/go-gitea/gitea/releases/download/${DISTVERSIONPREFIX}${DISTVERSION}/
DISTNAME= gitea-src-${DISTVERSION}
NO_WRKSUBDIR= yes
MAINTAINER= stb@lassitu.de
COMMENT= Compact self-hosted Git service
@ -11,34 +14,37 @@ COMMENT= Compact self-hosted Git service
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= git:devel/git
RUN_DEPENDS= git:devel/git \
git-lfs:devel/git-lfs
USES= go:modules
USE_GITHUB= yes
GH_ACCOUNT= go-gitea
USES= gmake go:no_targets
USE_RC_SUBR= gitea
GO_BUILDFLAGS= -tags "${GO_TAGS}" -ldflags '-X "main.Version=${PORTVERSION}"'
GO_TARGET= :${PREFIX}/sbin/${PORTNAME}
SUB_FILES+= app.ini.sample
SUB_LIST+= GITUSER=${USERS}
USERS= git
GROUPS= git
OPTIONS_DEFINE= CERT PAM SQLITE
OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
OPTIONS_DEFINE= BINDATA PAM SQLITE
OPTIONS_DEFAULT= PAM SQLITE
CERT_DESC= Automatic creation of self-signed certificates
PAM_DESC= Authentication using PAM
BINDATA_DESC= Build a single monolithic binary, with all assets included
PAM_DESC= Enable support for PAM
CERT_VARS= GO_TAGS+=cert
BINDATA_VARS= GO_TAGS+=bindata
PAM_VARS= GO_TAGS+=pam
SQLITE_VARS= GO_TAGS+="sqlite sqlite_unlock_notify"
.include <bsd.port.options.mk>
# active option removes files from plist
.if ${PORT_OPTIONS:MBINDATA}
PLIST_SUB+= BINDATA="@comment "
.else
PLIST_SUB+= BINDATA=""
.endif
.if ${OPSYS} == FreeBSD
DAEMONARGS= -S -l \$${gitea_facility} -s \$${gitea_priority} -T \$${name}
.else
@ -47,14 +53,31 @@ DAEMONARGS= -f
SUB_LIST+= DAEMONARGS="${DAEMONARGS}"
post-install:
# use sane defaults for path, overriden with actual PREFIX in start script
EXTRA_LDFLAGS= -X code.gitea.io/gitea/modules/setting.CustomPath=${PREFIX}/etc/gitea
EXTRA_LDFLAGS+= -X code.gitea.io/gitea/modules/setting.AppWorkPath=${PREFIX}/share/gitea
# Default LDFLAGS are incompatible with build
MAKE_ARGS= GOPATH=${WRKDIR} TAGS="${GO_TAGS}" LDFLAGS="${EXTRA_LDFLAGS}"
ALL_TARGET= backend
MAKE_JOBS_UNSAFE= yes
post-patch:
${ECHO_CMD} ${DISTVERSION} >${WRKSRC}/VERSION
# Too lazy to figure out why go install won't work.
do-install:
# Go binary is statically linked and cannot be stripped, so use
# INSTALL_SCRIPT.
${INSTALL_SCRIPT} ${WRKSRC}/gitea ${STAGEDIR}${PREFIX}/sbin
@${MKDIR} ${STAGEDIR}${ETCDIR}/conf
${INSTALL_DATA} ${WRKDIR}/app.ini.sample ${STAGEDIR}${ETCDIR}/conf/app.ini.sample
${INSTALL_DATA} ${GO_WRKSRC}/custom/conf/app.ini.sample ${STAGEDIR}${ETCDIR}/conf/app.ini.defaults
cd ${GO_WRKSRC} && ${COPYTREE_SHARE} "options public templates" ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/custom/conf/app.ini.sample ${STAGEDIR}${ETCDIR}/conf/app.ini.defaults
@${MKDIR} ${STAGEDIR}${DESTDIR}/var/db/${PORTNAME}
@${MKDIR} ${STAGEDIR}${DESTDIR}/var/log/${PORTNAME}
@${MKDIR} ${STAGEDIR}${DESTDIR}/var/run/${PORTNAME}
do-install-BINDATA-off:
cd ${WRKSRC} && ${COPYTREE_SHARE} "options public templates" ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1579517964
SHA256 (go-gitea-gitea-v1.10.3_GH0.tar.gz) = 564b676163077dfc2c1d0175c9766cf118b8fc917f49e7e7e2e5b2b33d8b6539
SIZE (go-gitea-gitea-v1.10.3_GH0.tar.gz) = 30145162
TIMESTAMP = 1583582463
SHA256 (gitea-src-1.11.2.tar.gz) = 777ad27929809811e17e2d0a539d2a47163e382473cefa680debcb0777aa2cba
SIZE (gitea-src-1.11.2.tar.gz) = 69381797

View File

@ -1,24 +0,0 @@
From 33540a1f603772f9d4b761f416f5c10dade23e96 Mon Sep 17 00:00:00 2001
From: Tobias Klauser <tklauser@distanz.ch>
Date: Fri, 25 Oct 2019 21:13:51 +0200
Subject: [PATCH] unix: don't use non-existing uint128 type on freebsd/arm64
CL 179099 introduced type FpReg on freebsd, on freebsd/arm64 using a
type uint128. This type doesn't exist in Go.
Change-Id: Ie7f065f38f2cc2c163abdfa7dddad886b8edbe3b
Reviewed-on: https://go-review.googlesource.com/c/sys/+/203419
Run-TryBot: Tobias Klauser <tobias.klauser@gmail.com>
TryBot-Result: Gobot Gobot <gobot@golang.org>
Reviewed-by: Brad Fitzpatrick <bradfitz@golang.org>
--- vendor/golang.org/x/sys/unix/ztypes_freebsd_arm64.go.orig 2019-08-18 13:42:05 UTC
+++ vendor/golang.org/x/sys/unix/ztypes_freebsd_arm64.go
@@ -397,7 +397,7 @@ type Reg struct {
}
type FpReg struct {
- Fp_q [32]uint128
+ Fp_q [512]uint8
Fp_sr uint32
Fp_cr uint32
}

File diff suppressed because it is too large Load Diff