- Fix patch broken in r292221

PR:		ports/187472
Redported by:	Jeremy Chadwick <jdc@koitsu.org>
This commit is contained in:
Steve Wills 2014-03-23 15:31:43 +00:00
parent 5256c01b0d
commit eedf7913ee
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=348863
4 changed files with 34 additions and 34 deletions

View File

@ -177,7 +177,7 @@ RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
# Ruby 1.9
#
RUBY_RELVERSION= 1.9.3
RUBY_PORTREVISION= 1
RUBY_PORTREVISION= 2
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 484
@ -193,7 +193,7 @@ RUBY21= "@comment "
# Ruby 2.0
#
RUBY_RELVERSION= 2.0.0
RUBY_PORTREVISION= 4
RUBY_PORTREVISION= 5
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 353
@ -209,7 +209,7 @@ RUBY21= "@comment "
# Ruby 2.1
#
RUBY_RELVERSION= 2.1.1
RUBY_PORTREVISION= 0
RUBY_PORTREVISION= 1
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 0

View File

@ -1,6 +1,6 @@
--- configure.in.orig 2013-02-11 14:33:14.000000000 +0000
+++ configure.in 2013-02-11 14:30:13.000000000 +0000
@@ -1129,11 +1129,11 @@
--- configure.in.orig 2014-03-20 05:49:55.847385089 +0000
+++ configure.in 2014-03-20 05:50:09.238383528 +0000
@@ -1139,11 +1139,11 @@
[superux*], [ ac_cv_func_setitimer=no
],
[ LIBS="-lm $LIBS"])
@ -17,7 +17,7 @@
if test "${enable_win95}" = maybe; then
AC_HAVE_LIBRARY(unicows, [enable_win95=yes], [enable_win95=no])
fi
@@ -1828,7 +1828,7 @@
@@ -1789,7 +1789,7 @@
fi
if test x"$enable_pthread" = xyes; then
@ -26,15 +26,15 @@
AC_CHECK_LIB($pthread_lib, pthread_kill,
rb_with_pthread=yes, rb_with_pthread=no)
if test "$rb_with_pthread" = "yes"; then break; fi
@@ -1836,6 +1836,7 @@
if test x"$rb_with_pthread" = xyes; then
AC_DEFINE(_REENTRANT)
AC_DEFINE(_THREAD_SAFE)
@@ -1803,6 +1803,7 @@
[c], [],
[root], [],
[c_r], [MAINLIBS="-pthread $MAINLIBS"],
+ [pthread], [MAINLIBS="-pthread $MAINLIBS"],
AC_DEFINE(HAVE_LIBPTHREAD)
AC_CHECK_HEADERS(pthread_np.h, [], [], [@%:@include <pthread.h>])
AS_CASE([$pthread_lib],
@@ -2080,7 +2081,6 @@
[AS_CASE(["$target_os"],
[openbsd*], [LIBS="-pthread $LIBS"],
[LIBS="-l$pthread_lib $LIBS"])])
@@ -2041,7 +2042,6 @@
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
@ -42,7 +42,7 @@
else
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED="ld -Bshareable"
fi
@@ -2385,6 +2385,7 @@
@@ -2348,6 +2348,7 @@
[freebsd*|dragonfly*], [
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR)$(MINOR)'

View File

@ -1,5 +1,5 @@
--- configure.in.orig 2014-02-17 23:37:01.241643774 +0000
+++ configure.in 2014-02-17 23:38:03.349639470 +0000
--- configure.in.orig 2014-03-20 05:47:33.807394460 +0000
+++ configure.in 2014-03-20 05:47:49.855394229 +0000
@@ -1386,11 +1386,11 @@
AC_CHECK_DECLS([sys_nerr], [], [], [$ac_includes_default
@%:@include <errno.h>])
@ -26,14 +26,14 @@
AC_CHECK_LIB($pthread_lib, pthread_kill,
rb_with_pthread=yes, rb_with_pthread=no)
if test "$rb_with_pthread" = "yes"; then break; fi
@@ -2089,6 +2089,7 @@
if test x"$rb_with_pthread" = xyes; then
AC_DEFINE(_REENTRANT)
AC_DEFINE(_THREAD_SAFE)
@@ -2095,6 +2095,7 @@
[c], [],
[root], [],
[c_r], [MAINLIBS="-pthread $MAINLIBS"],
+ [pthread], [MAINLIBS="-pthread $MAINLIBS"],
AC_DEFINE(HAVE_LIBPTHREAD)
AC_CHECK_HEADERS(pthread_np.h, [], [], [@%:@include <pthread.h>])
AS_CASE([$pthread_lib],
[AS_CASE(["$target_os"],
[openbsd*], [LIBS="-pthread $LIBS"],
[LIBS="-l$pthread_lib $LIBS"])])
@@ -2326,7 +2327,6 @@
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_binary_elf" = yes; then

View File

@ -1,5 +1,5 @@
--- configure.in.orig 2014-02-21 23:32:34.000000000 +0000
+++ configure.in 2014-02-24 14:54:59.432610152 +0000
--- configure.in.orig 2014-03-20 05:40:57.873422152 +0000
+++ configure.in 2014-03-20 05:40:57.873422152 +0000
@@ -1084,10 +1084,10 @@
],
[ LIBS="-lm $LIBS"])
@ -33,14 +33,14 @@
AC_CHECK_LIB($pthread_lib, pthread_kill,
rb_with_pthread=yes, rb_with_pthread=no)
if test "$rb_with_pthread" = "yes"; then break; fi
@@ -2431,6 +2431,7 @@
if test x"$rb_with_pthread" = xyes; then
AC_DEFINE(_REENTRANT)
AC_DEFINE(_THREAD_SAFE)
@@ -2437,6 +2437,7 @@
[c], [],
[root], [],
[c_r], [MAINLIBS="-pthread $MAINLIBS"],
+ [pthread], [MAINLIBS="-pthread $MAINLIBS"],
AC_DEFINE(HAVE_LIBPTHREAD)
AC_CHECK_HEADERS(pthread_np.h, [], [], [@%:@include <pthread.h>])
AS_CASE([$pthread_lib],
[AS_CASE(["$target_os"],
[openbsd*|mirbsd*], [LIBS="-pthread $LIBS"],
[LIBS="-l$pthread_lib $LIBS"])])
@@ -2668,7 +2669,6 @@
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_binary_elf" = yes; then