ports-mgmt/fastest_sites: Fix runtime with modern bsd.sites.mk
fastest_sites currently can't parse entries like https://archives.fedoraproject.org/pub/archive/fedora/linux/%SUBDIR%/:DEFAULT,SOURCE => Checking servers for MASTER_SITE_FEDORA_LINUX (6 servers) Traceback (most recent call last): File "/usr/local/bin/fastest_sites", line 164, in <module> latency_list = FindFastest(varname, sitelist) File "/usr/local/bin/fastest_sites", line 110, in FindFastest AsyncConnect(url, callback) File "/usr/local/bin/fastest_sites", line 53, in __init__ self.ParseURL() File "/usr/local/bin/fastest_sites", line 64, in ParseURL (scheme, remainder) = self._url.split(":", 2) ValueError: too many values to unpack PR: 224854
This commit is contained in:
parent
11002e833a
commit
ee6d254d2d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=459259
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= fastest_sites
|
||||
PORTVERSION= 20110317
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= ports-mgmt
|
||||
MASTER_SITES= http://www.semicomplete.com/files/fastest_sites/
|
||||
EXTRACT_SUFX= .py
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- fastest_sites-20110317.py.orig 2018-01-03 06:06:26 UTC
|
||||
+++ fastest_sites-20110317.py
|
||||
@@ -61,7 +61,7 @@ class AsyncConnect(asyncore.dispatcher):
|
||||
|
||||
def ParseURL(self):
|
||||
#print "Url: %s" % self._url
|
||||
- (scheme, remainder) = self._url.split(":", 2)
|
||||
+ (scheme, remainder) = self._url.split(":", 1)
|
||||
(host, unused_path) = urllib.splithost(remainder)
|
||||
self._host = host
|
||||
self._port = AsyncConnect.schemes[scheme.lower()]
|
Loading…
Reference in New Issue
Block a user