Add ruby-fltk, a Ruby extension module to use FLTK.

This commit is contained in:
Akinori MUSHA 2000-08-25 16:38:12 +00:00
parent 06ce9953ba
commit ede4bd603b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=31974
10 changed files with 175 additions and 0 deletions

View File

@ -62,6 +62,7 @@
SUBDIR += qt21
SUBDIR += qt22
SUBDIR += rep-gtk
SUBDIR += ruby-fltk
SUBDIR += ruby-gtk
SUBDIR += ruby-qt
SUBDIR += ruby-qt-i18n

View File

@ -0,0 +1,48 @@
# New ports collection makefile for: Ruby-FLTK
# Date created: 25 Aug 2000
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
#
# $FreeBSD$
#
PORTNAME= fltk
PORTVERSION= 20000618
CATEGORIES= x11-toolkits ruby
MASTER_SITES= http://kt-www.jaist.ac.jp:8000/~ttate/ftp/
PKGNAMEPREFIX= ruby-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
USE_MESA= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
INSTALL_TARGET= site-install
CONFIGURE_ARGS= --with-fltk-dir="${X11BASE}" --with-gl-dir="${X11BASE}"
MAKE_ARGS= LOCAL_LIBS="-lgcc"
PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
RUBY?= ${LOCALBASE}/bin/ruby
RUBY_VER?= 1.4
RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
do-configure:
@cd ${WRKSRC}; \
${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/examples/ruby/fltk
${INSTALL_DATA} ${WRKSRC}/test/adjuster.rb ${PREFIX}/share/examples/ruby/fltk/
${MKDIR} ${PREFIX}/share/doc/ruby/fltk/ja
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/ruby/fltk/
${INSTALL_DATA} ${WRKSRC}/README.jp ${PREFIX}/share/doc/ruby/fltk/ja/
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (ruby/ruby-fltk-20000618.tar.gz) = 26d910c0b49f79c743fc52e14c27db06

View File

@ -0,0 +1,51 @@
--- extconf.rb.orig Sun Jun 18 21:04:07 2000
+++ extconf.rb Fri Aug 25 03:54:53 2000
@@ -12,40 +12,17 @@
if( ARGV.include?("--help") )
print <<EOF
- --with-fltk specify the fltk install prefix.
- --with-fltk-incdir specify the directory which contains fltk header files.
- --with-fltk-libdir specify the directory which contains fltk library.
- --with-gl specify the GL install prefix.
- --with-gl-incdir specify the directory which contains GL header files.
- --with-gl-libdir specify the directory which contains GL library.
+ --with-fltk-dir specify the fltk install prefix.
+ --with-fltk-include specify the directory which contains fltk header files.
+ --with-fltk-lib specify the directory which contains fltk library.
+ --with-gl-dir specify the GL install prefix.
+ --with-gl-include specify the directory which contains GL header files.
+ --with-gl-lib specify the directory which contains GL library.
EOF
end
-if( fltk_prefix = with_config("fltk") )
- $CFLAGS += " -I" + File.join(fltk_prefix,"include")
- $LDFLAGS += " -L" + File.join(fltk_prefix,"lib")
-end
-
-if( fltk_incdir = with_config("fltk-incdir") )
- $CFLAGS += " -I" + fltk_incdir
-end
-
-if( fltk_libdir = with_config("fltk-libdir") )
- $LDFLAGS += " -L" + fltk_libdir
-end
-
-if( gl_prefix = with_config("gl") )
- $CFLAGS += " -I" + File.join(gl_prefix,"include")
- $LDFLAGS += " -L" + File.join(gl_prefix,"lib")
-end
-
-if( gl_incdir = with_config("gl-incdir") )
- $CFLAGS += " -I" + gl_incdir
-end
-
-if( gl_libdir = with_config("gl-libdir") )
- $LDFLAGS += " -L" + gl_libdir
-end
+dir_config("fltk")
+dir_config("gl")
if( have_header("FL/Fl.H") &&
have_library("GL",nil) &&

View File

@ -0,0 +1,11 @@
--- README.jp.orig Fri Jun 9 23:00:00 2000
+++ README.jp Fri Aug 25 04:32:41 2000
@@ -8,7 +8,7 @@
FltkとはFast Light Tool Kitの略であり、その名の
通り速く軽い X Window System 上のGUIライブラリです。
Fltk自体はBill Spitzak(spitzak@d2.com)さんが作成
-されておりGPLに従って配布されています。
+されておりLGPLに従って配布されています。
2. インストール

View File

@ -0,0 +1,29 @@
--- README.orig Fri Jun 9 23:00:17 2000
+++ README Fri Aug 25 04:33:13 2000
@@ -5,9 +5,9 @@
1. What's Fltk
--------------
-Fltk mean "Fast Light Tool Kit". Fltk is written
-by Bill Spitzak(spitzak@d2.com), distrebuted
-under GPL.
+Fltk means "Fast Light Tool Kit". Fltk is written
+by Bill Spitzak(spitzak@d2.com), distributed
+under LGPL.
2. Installation
@@ -31,11 +31,11 @@
4. Non-Guarantee
----------------
-The author can't guarantee the obstacles occured
+The author can't guarantee the obstacles occurred
by the programs and documentations. But I try to
fix any bugs as quickly as possible.
5. Reporting
-------------
-I wish your bug reports and some patches.
+I'd appreciate your bug reports and patches.
Please mail to me <ttate@jaist.ac.jp>.

View File

@ -0,0 +1,22 @@
--- test/adjuster.rb.orig Sun Jun 18 20:09:26 2000
+++ test/adjuster.rb Fri Aug 25 14:37:17 2000
@@ -8,16 +8,16 @@
def end
super
show
- callback(proc{|w| print "eixt!\n"; exit})
+ callback(proc{|w| print "exit!\n"; exit})
end
end
$win = MainWindow.new(200,200)
$val = Fltk::Adjuster.new(0,0,200,100)
$val.value(0)
-$val.label("ÃÍ = " + $val.value.to_s)
+$val.label("value = " + $val.value.to_s)
$val.callback(proc{|w|
- $val.label("ÃÍ = " + $val.value.to_s)
+ $val.label("value = " + $val.value.to_s)
$win.redraw
})
$win.end

View File

@ -0,0 +1 @@
A Ruby extension module to use FLTK

View File

@ -0,0 +1,4 @@
Ruby/FLTK is a Ruby extension module to use FLTK.
Author: Takaaki Tateishi <ttate@jaist.ac.jp>
WWW: http://kt-www.jaist.ac.jp:8000/~ttate/lang/ruby/ruby-fltk.html

View File

@ -0,0 +1,7 @@
lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/fltk.so
share/examples/ruby/fltk/adjuster.rb
@dirrm share/examples/ruby/fltk
share/doc/ruby/fltk/README
share/doc/ruby/fltk/ja/README.jp
@dirrm share/doc/ruby/fltk/ja
@dirrm share/doc/ruby/fltk