- Update to 0.6.0
- Remove patches merged upstream - Pet portlint PR: 229441 Submitted by: danilo
This commit is contained in:
parent
87301620f1
commit
ede005c86c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=486471
@ -2,9 +2,8 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= flameshot
|
||||
PORTVERSION= 0.5.0
|
||||
PORTVERSION= 0.6.0
|
||||
DISTVERSIONPREFIX= v
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= deskutils
|
||||
|
||||
MAINTAINER= nivit@FreeBSD.org
|
||||
@ -13,18 +12,15 @@ COMMENT= Powerful yet simple to use screenshot software
|
||||
LICENSE= GPLv3
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USES= compiler:c++11-lang gl qmake qt:5
|
||||
|
||||
GH_ACCOUNT= lupoDharkael
|
||||
|
||||
INSTALL_ICONS= yes
|
||||
|
||||
USES= compiler:c++11-lang qmake qt:5
|
||||
USE_GITHUB= yes
|
||||
USE_GL= gl
|
||||
USE_QT= core dbus gui linguist network widgets \
|
||||
USE_QT= core dbus gui linguist network svg widgets \
|
||||
buildtools_build
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},1' \
|
||||
${WRKSRC}/${PORTNAME}.pro
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1516551815
|
||||
SHA256 (lupoDharkael-flameshot-v0.5.0_GH0.tar.gz) = 32d593c14c37286d9f64873c4ef9a07eb084723c92b2280d5c22152547c1e3f0
|
||||
SIZE (lupoDharkael-flameshot-v0.5.0_GH0.tar.gz) = 464600
|
||||
TIMESTAMP = 1535060289
|
||||
SHA256 (lupoDharkael-flameshot-v0.6.0_GH0.tar.gz) = 61b3a1969d6e17d80d5d90a3fce53ca5ae78fa21f9a45e5a19b0b32ea815a589
|
||||
SIZE (lupoDharkael-flameshot-v0.6.0_GH0.tar.gz) = 641561
|
||||
|
@ -1,35 +0,0 @@
|
||||
--- flameshot.pro.orig 2017-12-20 13:41:48 UTC
|
||||
+++ flameshot.pro
|
||||
@@ -177,27 +177,27 @@ unix: {
|
||||
packaging {
|
||||
USRPATH = /usr
|
||||
} else {
|
||||
- USRPATH = /usr/local
|
||||
+ USRPATH = %%LOCALBASE%%
|
||||
}
|
||||
|
||||
target.path = $${BASEDIR}$${USRPATH}/bin/
|
||||
|
||||
- qmfile.path = $${BASEDIR}/usr/share/flameshot/translations/
|
||||
+ qmfile.path = $${BASEDIR}$${USRPATH}/share/flameshot/translations/
|
||||
qmfile.files = $${TRANSLATIONS_FILES}
|
||||
|
||||
- dbus.path = $${BASEDIR}/usr/share/dbus-1/interfaces/
|
||||
+ dbus.path = $${BASEDIR}$${USRPATH}/share/dbus-1/interfaces/
|
||||
dbus.files = dbus/org.dharkael.Flameshot.xml
|
||||
|
||||
icon.path = $${BASEDIR}$${USRPATH}/share/icons/
|
||||
icon.files = img/flameshot.png
|
||||
|
||||
- completion.path = /usr/share/bash-completion/completions/
|
||||
+ completion.path = $${BASEDIR}$${USRPATH}/share/bash-completion/completions/
|
||||
completion.files = docs/bash-completion/flameshot
|
||||
|
||||
desktopentry.path = $${BASEDIR}$${USRPATH}/share/applications
|
||||
desktopentryinit.path = $${BASEDIR}$${USRPATH}/share/applications
|
||||
desktopentryconfig.path = $${BASEDIR}$${USRPATH}/share/applications
|
||||
- servicedbus.path = $${BASEDIR}/usr/share/dbus-1/services/
|
||||
+ servicedbus.path = $${BASEDIR}$${USRPATH}/share/dbus-1/services/
|
||||
|
||||
packaging {
|
||||
desktopentry.files = docs/desktopEntry/package/flameshot.desktop
|
@ -1,25 +0,0 @@
|
||||
From 48106975fb120fa7b6b1abb136183cb84bc957c9 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Schuller <peter.schuller@infidyne.com>
|
||||
Date: Mon, 22 Jan 2018 12:15:21 -0800
|
||||
Subject: [PATCH] Fix case statement (so we build with clang). (#101)
|
||||
|
||||
--- src/utils/screengrabber.cpp.orig 2017-12-20 13:41:48 UTC
|
||||
+++ src/utils/screengrabber.cpp
|
||||
@@ -35,7 +35,7 @@ QPixmap ScreenGrabber::grabEntireDesktop(bool &ok) {
|
||||
QPixmap res;
|
||||
// handle screenshot based on DE
|
||||
switch (m_info.windowManager()) {
|
||||
- case m_info.GNOME: {
|
||||
+ case DesktopInfo::GNOME: {
|
||||
// https://github.com/GNOME/gnome-shell/blob/695bfb96160033be55cfb5ac41c121998f98c328/data/org.gnome.Shell.Screenshot.xml
|
||||
QString path = FileNameHandler().generateAbsolutePath("/tmp") + ".png";
|
||||
QDBusInterface gnomeInterface(QStringLiteral("org.gnome.Shell"),
|
||||
@@ -48,7 +48,7 @@ QPixmap ScreenGrabber::grabEntireDesktop(bool &ok) {
|
||||
ok = false;
|
||||
}
|
||||
break;
|
||||
- } case m_info.KDE: {
|
||||
+ } case DesktopInfo::KDE: {
|
||||
// https://github.com/KDE/spectacle/blob/517a7baf46a4ca0a45f32fd3f2b1b7210b180134/src/PlatformBackends/KWinWaylandImageGrabber.cpp#L145
|
||||
QDBusInterface kwinInterface(QStringLiteral("org.kde.KWin"),
|
||||
QStringLiteral("/Screenshot"),
|
@ -1,10 +1,18 @@
|
||||
bin/flameshot
|
||||
share/applications/flameshot-config.desktop
|
||||
share/applications/flameshot-init.desktop
|
||||
share/applications/flameshot.desktop
|
||||
share/bash-completion/completions/flameshot
|
||||
share/dbus-1/interfaces/org.dharkael.Flameshot.xml
|
||||
share/dbus-1/services/org.dharkael.Flameshot.service
|
||||
%%DATADIR%%/translations/Internationalization_ca.qm
|
||||
%%DATADIR%%/translations/Internationalization_es.qm
|
||||
share/icons/flameshot.png
|
||||
%%DATADIR%%/translations/Internationalization_fr.qm
|
||||
%%DATADIR%%/translations/Internationalization_ka.qm
|
||||
%%DATADIR%%/translations/Internationalization_pl.qm
|
||||
%%DATADIR%%/translations/Internationalization_ru.qm
|
||||
%%DATADIR%%/translations/Internationalization_tr.qm
|
||||
%%DATADIR%%/translations/Internationalization_zh_CN.qm
|
||||
%%DATADIR%%/translations/Internationalization_zh_TW.qm
|
||||
share/icons/hicolor/128x128/apps/flameshot.png
|
||||
share/icons/hicolor/48x48/apps/flameshot.png
|
||||
share/icons/hicolor/scalable/apps/flameshot.svg
|
||||
share/metainfo/flameshot.appdata.xml
|
||||
|
Loading…
Reference in New Issue
Block a user