Change installation prefix and names of startup scripts for easy migration.

Permit running www/zope and www/zope28 at the same time on the same host.
Use static pkg-plist instead dynamic one.

PR:		86397
Submitted by:	Denis Shaposhnikov (maintainer)
This commit is contained in:
Vsevolod Stakhov 2005-09-21 22:20:35 +00:00
parent e348f65ac4
commit edcea35a0e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=143310
35 changed files with 36755 additions and 570 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= zope
PORTVERSION= 2.8.1
PORTREVISION= 1
CATEGORIES= www python zope
MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/
DISTNAME= Zope-${PORTVERSION}-final
@ -17,7 +18,7 @@ MAINTAINER= dsh@vlink.ru
COMMENT= An object-based web application platform
USE_PYTHON= yes
USE_RC_SUBR= ${PORTNAME}.sh zeo.sh
USE_RC_SUBR= ${PORTNAME}28.sh zeo28.sh
USE_REINPLACE= yes
# Note: the notes that follow reflect the decisions of prior maintainers
@ -27,7 +28,7 @@ USE_REINPLACE= yes
# Change these, if you like, via the environment.
ZOPE_USER?= www
WEBBASEDIR?= www
SZOPEBASEDIR?= ${WEBBASEDIR}/Zope
SZOPEBASEDIR?= ${WEBBASEDIR}/Zope28
# Do not change anything below this line.
@ -67,8 +68,8 @@ post-patch:
${WRKSRC}/configure
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d/
${INSTALL_SCRIPT} ${WRKDIR}/zeo.sh ${PREFIX}/etc/rc.d/
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}28.sh ${PREFIX}/etc/rc.d
${INSTALL_SCRIPT} ${WRKDIR}/zeo28.sh ${PREFIX}/etc/rc.d
${MV} ${ZOPEBASEDIR}/skel/etc/zope.conf.in \
${ZOPEBASEDIR}/skel/etc/zope.conf.sample.in
@ -77,10 +78,7 @@ post-install:
${CP} ${FILESDIR}/Products_00readme-freebsd.txt \
${ZOPEBASEDIR}/Products/00readme-freebsd.txt
${FIND} ${ZOPEBASEDIR} ! -type d | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
${FIND} -d ${ZOPEBASEDIR} -type d | \
${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
${FIND} ${ZOPEBASEDIR} -type f -print0 | ${XARGS} -0 -- ${CHMOD} a-w
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}

View File

@ -0,0 +1,10 @@
--- lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py.orig Thu Aug 11 09:11:19 2005
+++ lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py Wed Sep 7 12:19:37 2005
@@ -12,6 +12,7 @@
from Testing.makerequest import makerequest
+from __future__ import generators
import Zope2
Zope2.startup()

View File

@ -1,53 +0,0 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD: /tmp/pcvs/ports/www/zope210/files/Attic/zeo.sh.in,v 1.1 2005-09-18 21:33:04 vsevolod Exp $
# PROVIDE: zeo
# REQUIRE: DAEMON
# BEFORE: zope
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zeo
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zeo_enable=${zeo_enable:-"NO"} # Enable zeo server
zeo_instances=${zeo_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zeo"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zeo_enable; then
case "$1" in
start)
echo "Starting Zeo"
;;
stop)
echo "Stopping Zeo"
;;
restart)
echo "Restarting Zeo"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zeo_instances
do
if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zeoctl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zeoctl $1
fi
done
fi

View File

@ -0,0 +1,53 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD$
# PROVIDE: zeo28
# REQUIRE: DAEMON
# BEFORE: zope28
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope28_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zeo28
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zeo28_enable=${zeo28_enable:-"NO"} # Enable zeo server
zeo28_instances=${zeo28_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zeo28"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zeo28_enable; then
case "$1" in
start)
echo "Starting Zeo 2.8"
;;
stop)
echo "Stopping Zeo 2.8"
;;
restart)
echo "Restarting Zeo 2.8"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zeo28_instances
do
if [ -r ${instance}/etc/zeo.conf -a -x ${instance}/bin/zeoctl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zeoctl $1
fi
done
fi

View File

@ -1,53 +0,0 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD: /tmp/pcvs/ports/www/zope210/files/Attic/zope.sh.in,v 1.7 2005-09-18 21:33:04 vsevolod Exp $
# PROVIDE: zope
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zope
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zope_enable=${zope_enable:-"NO"} # Enable zope
zope_instances=${zope_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zope"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zope_enable; then
case "$1" in
start)
echo "Starting Zope"
;;
stop)
echo "Stopping Zope"
;;
restart)
echo "Restarting Zope"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zope_instances
do
if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zopectl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zopectl $1
fi
done
fi

View File

@ -0,0 +1,53 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD$
# PROVIDE: zope28
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope28_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zope28
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zope28_enable=${zope28_enable:-"NO"} # Enable zope
zope28_instances=${zope28_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zope28"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zope28_enable; then
case "$1" in
start)
echo "Starting Zope 2.8"
;;
stop)
echo "Stopping Zope 2.8"
;;
restart)
echo "Restarting Zope 2.8"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zope28_instances
do
if [ -r ${instance}/etc/zope.conf -a -x ${instance}/bin/zopectl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zopectl $1
fi
done
fi

7229
www/zope210/pkg-plist Normal file

File diff suppressed because it is too large Load Diff

View File

@ -7,6 +7,7 @@
PORTNAME= zope
PORTVERSION= 2.8.1
PORTREVISION= 1
CATEGORIES= www python zope
MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/
DISTNAME= Zope-${PORTVERSION}-final
@ -17,7 +18,7 @@ MAINTAINER= dsh@vlink.ru
COMMENT= An object-based web application platform
USE_PYTHON= yes
USE_RC_SUBR= ${PORTNAME}.sh zeo.sh
USE_RC_SUBR= ${PORTNAME}28.sh zeo28.sh
USE_REINPLACE= yes
# Note: the notes that follow reflect the decisions of prior maintainers
@ -27,7 +28,7 @@ USE_REINPLACE= yes
# Change these, if you like, via the environment.
ZOPE_USER?= www
WEBBASEDIR?= www
SZOPEBASEDIR?= ${WEBBASEDIR}/Zope
SZOPEBASEDIR?= ${WEBBASEDIR}/Zope28
# Do not change anything below this line.
@ -67,8 +68,8 @@ post-patch:
${WRKSRC}/configure
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d/
${INSTALL_SCRIPT} ${WRKDIR}/zeo.sh ${PREFIX}/etc/rc.d/
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}28.sh ${PREFIX}/etc/rc.d
${INSTALL_SCRIPT} ${WRKDIR}/zeo28.sh ${PREFIX}/etc/rc.d
${MV} ${ZOPEBASEDIR}/skel/etc/zope.conf.in \
${ZOPEBASEDIR}/skel/etc/zope.conf.sample.in
@ -77,10 +78,7 @@ post-install:
${CP} ${FILESDIR}/Products_00readme-freebsd.txt \
${ZOPEBASEDIR}/Products/00readme-freebsd.txt
${FIND} ${ZOPEBASEDIR} ! -type d | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
${FIND} -d ${ZOPEBASEDIR} -type d | \
${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
${FIND} ${ZOPEBASEDIR} -type f -print0 | ${XARGS} -0 -- ${CHMOD} a-w
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}

View File

@ -0,0 +1,10 @@
--- lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py.orig Thu Aug 11 09:11:19 2005
+++ lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py Wed Sep 7 12:19:37 2005
@@ -12,6 +12,7 @@
from Testing.makerequest import makerequest
+from __future__ import generators
import Zope2
Zope2.startup()

View File

@ -1,53 +0,0 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD: /tmp/pcvs/ports/www/zope211/files/Attic/zeo.sh.in,v 1.1 2005-09-18 21:33:04 vsevolod Exp $
# PROVIDE: zeo
# REQUIRE: DAEMON
# BEFORE: zope
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zeo
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zeo_enable=${zeo_enable:-"NO"} # Enable zeo server
zeo_instances=${zeo_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zeo"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zeo_enable; then
case "$1" in
start)
echo "Starting Zeo"
;;
stop)
echo "Stopping Zeo"
;;
restart)
echo "Restarting Zeo"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zeo_instances
do
if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zeoctl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zeoctl $1
fi
done
fi

View File

@ -0,0 +1,53 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD$
# PROVIDE: zeo28
# REQUIRE: DAEMON
# BEFORE: zope28
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope28_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zeo28
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zeo28_enable=${zeo28_enable:-"NO"} # Enable zeo server
zeo28_instances=${zeo28_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zeo28"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zeo28_enable; then
case "$1" in
start)
echo "Starting Zeo 2.8"
;;
stop)
echo "Stopping Zeo 2.8"
;;
restart)
echo "Restarting Zeo 2.8"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zeo28_instances
do
if [ -r ${instance}/etc/zeo.conf -a -x ${instance}/bin/zeoctl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zeoctl $1
fi
done
fi

View File

@ -1,53 +0,0 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD: /tmp/pcvs/ports/www/zope211/files/Attic/zope.sh.in,v 1.7 2005-09-18 21:33:04 vsevolod Exp $
# PROVIDE: zope
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zope
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zope_enable=${zope_enable:-"NO"} # Enable zope
zope_instances=${zope_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zope"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zope_enable; then
case "$1" in
start)
echo "Starting Zope"
;;
stop)
echo "Stopping Zope"
;;
restart)
echo "Restarting Zope"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zope_instances
do
if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zopectl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zopectl $1
fi
done
fi

View File

@ -0,0 +1,53 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD$
# PROVIDE: zope28
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope28_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zope28
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zope28_enable=${zope28_enable:-"NO"} # Enable zope
zope28_instances=${zope28_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zope28"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zope28_enable; then
case "$1" in
start)
echo "Starting Zope 2.8"
;;
stop)
echo "Stopping Zope 2.8"
;;
restart)
echo "Restarting Zope 2.8"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zope28_instances
do
if [ -r ${instance}/etc/zope.conf -a -x ${instance}/bin/zopectl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zopectl $1
fi
done
fi

7229
www/zope211/pkg-plist Normal file

File diff suppressed because it is too large Load Diff

View File

@ -7,6 +7,7 @@
PORTNAME= zope
PORTVERSION= 2.8.1
PORTREVISION= 1
CATEGORIES= www python zope
MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/
DISTNAME= Zope-${PORTVERSION}-final
@ -17,7 +18,7 @@ MAINTAINER= dsh@vlink.ru
COMMENT= An object-based web application platform
USE_PYTHON= yes
USE_RC_SUBR= ${PORTNAME}.sh zeo.sh
USE_RC_SUBR= ${PORTNAME}28.sh zeo28.sh
USE_REINPLACE= yes
# Note: the notes that follow reflect the decisions of prior maintainers
@ -27,7 +28,7 @@ USE_REINPLACE= yes
# Change these, if you like, via the environment.
ZOPE_USER?= www
WEBBASEDIR?= www
SZOPEBASEDIR?= ${WEBBASEDIR}/Zope
SZOPEBASEDIR?= ${WEBBASEDIR}/Zope28
# Do not change anything below this line.
@ -67,8 +68,8 @@ post-patch:
${WRKSRC}/configure
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d/
${INSTALL_SCRIPT} ${WRKDIR}/zeo.sh ${PREFIX}/etc/rc.d/
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}28.sh ${PREFIX}/etc/rc.d
${INSTALL_SCRIPT} ${WRKDIR}/zeo28.sh ${PREFIX}/etc/rc.d
${MV} ${ZOPEBASEDIR}/skel/etc/zope.conf.in \
${ZOPEBASEDIR}/skel/etc/zope.conf.sample.in
@ -77,10 +78,7 @@ post-install:
${CP} ${FILESDIR}/Products_00readme-freebsd.txt \
${ZOPEBASEDIR}/Products/00readme-freebsd.txt
${FIND} ${ZOPEBASEDIR} ! -type d | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
${FIND} -d ${ZOPEBASEDIR} -type d | \
${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
${FIND} ${ZOPEBASEDIR} -type f -print0 | ${XARGS} -0 -- ${CHMOD} a-w
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}

View File

@ -0,0 +1,10 @@
--- lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py.orig Thu Aug 11 09:11:19 2005
+++ lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py Wed Sep 7 12:19:37 2005
@@ -12,6 +12,7 @@
from Testing.makerequest import makerequest
+from __future__ import generators
import Zope2
Zope2.startup()

View File

@ -1,53 +0,0 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD: /tmp/pcvs/ports/www/zope213/files/Attic/zeo.sh.in,v 1.1 2005-09-18 21:33:04 vsevolod Exp $
# PROVIDE: zeo
# REQUIRE: DAEMON
# BEFORE: zope
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zeo
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zeo_enable=${zeo_enable:-"NO"} # Enable zeo server
zeo_instances=${zeo_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zeo"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zeo_enable; then
case "$1" in
start)
echo "Starting Zeo"
;;
stop)
echo "Stopping Zeo"
;;
restart)
echo "Restarting Zeo"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zeo_instances
do
if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zeoctl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zeoctl $1
fi
done
fi

View File

@ -0,0 +1,53 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD$
# PROVIDE: zeo28
# REQUIRE: DAEMON
# BEFORE: zope28
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope28_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zeo28
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zeo28_enable=${zeo28_enable:-"NO"} # Enable zeo server
zeo28_instances=${zeo28_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zeo28"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zeo28_enable; then
case "$1" in
start)
echo "Starting Zeo 2.8"
;;
stop)
echo "Stopping Zeo 2.8"
;;
restart)
echo "Restarting Zeo 2.8"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zeo28_instances
do
if [ -r ${instance}/etc/zeo.conf -a -x ${instance}/bin/zeoctl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zeoctl $1
fi
done
fi

View File

@ -1,53 +0,0 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD: /tmp/pcvs/ports/www/zope213/files/Attic/zope.sh.in,v 1.7 2005-09-18 21:33:04 vsevolod Exp $
# PROVIDE: zope
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zope
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zope_enable=${zope_enable:-"NO"} # Enable zope
zope_instances=${zope_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zope"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zope_enable; then
case "$1" in
start)
echo "Starting Zope"
;;
stop)
echo "Stopping Zope"
;;
restart)
echo "Restarting Zope"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zope_instances
do
if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zopectl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zopectl $1
fi
done
fi

View File

@ -0,0 +1,53 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD$
# PROVIDE: zope28
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope28_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zope28
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zope28_enable=${zope28_enable:-"NO"} # Enable zope
zope28_instances=${zope28_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zope28"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zope28_enable; then
case "$1" in
start)
echo "Starting Zope 2.8"
;;
stop)
echo "Stopping Zope 2.8"
;;
restart)
echo "Restarting Zope 2.8"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zope28_instances
do
if [ -r ${instance}/etc/zope.conf -a -x ${instance}/bin/zopectl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zopectl $1
fi
done
fi

7229
www/zope213/pkg-plist Normal file

File diff suppressed because it is too large Load Diff

View File

@ -7,6 +7,7 @@
PORTNAME= zope
PORTVERSION= 2.8.1
PORTREVISION= 1
CATEGORIES= www python zope
MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/
DISTNAME= Zope-${PORTVERSION}-final
@ -17,7 +18,7 @@ MAINTAINER= dsh@vlink.ru
COMMENT= An object-based web application platform
USE_PYTHON= yes
USE_RC_SUBR= ${PORTNAME}.sh zeo.sh
USE_RC_SUBR= ${PORTNAME}28.sh zeo28.sh
USE_REINPLACE= yes
# Note: the notes that follow reflect the decisions of prior maintainers
@ -27,7 +28,7 @@ USE_REINPLACE= yes
# Change these, if you like, via the environment.
ZOPE_USER?= www
WEBBASEDIR?= www
SZOPEBASEDIR?= ${WEBBASEDIR}/Zope
SZOPEBASEDIR?= ${WEBBASEDIR}/Zope28
# Do not change anything below this line.
@ -67,8 +68,8 @@ post-patch:
${WRKSRC}/configure
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d/
${INSTALL_SCRIPT} ${WRKDIR}/zeo.sh ${PREFIX}/etc/rc.d/
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}28.sh ${PREFIX}/etc/rc.d
${INSTALL_SCRIPT} ${WRKDIR}/zeo28.sh ${PREFIX}/etc/rc.d
${MV} ${ZOPEBASEDIR}/skel/etc/zope.conf.in \
${ZOPEBASEDIR}/skel/etc/zope.conf.sample.in
@ -77,10 +78,7 @@ post-install:
${CP} ${FILESDIR}/Products_00readme-freebsd.txt \
${ZOPEBASEDIR}/Products/00readme-freebsd.txt
${FIND} ${ZOPEBASEDIR} ! -type d | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
${FIND} -d ${ZOPEBASEDIR} -type d | \
${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
${FIND} ${ZOPEBASEDIR} -type f -print0 | ${XARGS} -0 -- ${CHMOD} a-w
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}

View File

@ -0,0 +1,10 @@
--- lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py.orig Thu Aug 11 09:11:19 2005
+++ lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py Wed Sep 7 12:19:37 2005
@@ -12,6 +12,7 @@
from Testing.makerequest import makerequest
+from __future__ import generators
import Zope2
Zope2.startup()

View File

@ -1,53 +0,0 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD: /tmp/pcvs/ports/www/zope28/files/Attic/zeo.sh.in,v 1.1 2005-09-18 21:33:04 vsevolod Exp $
# PROVIDE: zeo
# REQUIRE: DAEMON
# BEFORE: zope
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zeo
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zeo_enable=${zeo_enable:-"NO"} # Enable zeo server
zeo_instances=${zeo_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zeo"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zeo_enable; then
case "$1" in
start)
echo "Starting Zeo"
;;
stop)
echo "Stopping Zeo"
;;
restart)
echo "Restarting Zeo"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zeo_instances
do
if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zeoctl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zeoctl $1
fi
done
fi

View File

@ -0,0 +1,53 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD$
# PROVIDE: zeo28
# REQUIRE: DAEMON
# BEFORE: zope28
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope28_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zeo28
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zeo28_enable=${zeo28_enable:-"NO"} # Enable zeo server
zeo28_instances=${zeo28_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zeo28"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zeo28_enable; then
case "$1" in
start)
echo "Starting Zeo 2.8"
;;
stop)
echo "Stopping Zeo 2.8"
;;
restart)
echo "Restarting Zeo 2.8"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zeo28_instances
do
if [ -r ${instance}/etc/zeo.conf -a -x ${instance}/bin/zeoctl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zeoctl $1
fi
done
fi

View File

@ -1,53 +0,0 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD: /tmp/pcvs/ports/www/zope28/files/Attic/zope.sh.in,v 1.7 2005-09-18 21:33:04 vsevolod Exp $
# PROVIDE: zope
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zope
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zope_enable=${zope_enable:-"NO"} # Enable zope
zope_instances=${zope_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zope"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zope_enable; then
case "$1" in
start)
echo "Starting Zope"
;;
stop)
echo "Stopping Zope"
;;
restart)
echo "Restarting Zope"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zope_instances
do
if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zopectl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zopectl $1
fi
done
fi

View File

@ -0,0 +1,53 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD$
# PROVIDE: zope28
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope28_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zope28
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zope28_enable=${zope28_enable:-"NO"} # Enable zope
zope28_instances=${zope28_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zope28"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zope28_enable; then
case "$1" in
start)
echo "Starting Zope 2.8"
;;
stop)
echo "Stopping Zope 2.8"
;;
restart)
echo "Restarting Zope 2.8"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zope28_instances
do
if [ -r ${instance}/etc/zope.conf -a -x ${instance}/bin/zopectl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zopectl $1
fi
done
fi

7229
www/zope28/pkg-plist Normal file

File diff suppressed because it is too large Load Diff

View File

@ -7,6 +7,7 @@
PORTNAME= zope
PORTVERSION= 2.8.1
PORTREVISION= 1
CATEGORIES= www python zope
MASTER_SITES= http://www.zope.org/Products/Zope/${PORTVERSION}/
DISTNAME= Zope-${PORTVERSION}-final
@ -17,7 +18,7 @@ MAINTAINER= dsh@vlink.ru
COMMENT= An object-based web application platform
USE_PYTHON= yes
USE_RC_SUBR= ${PORTNAME}.sh zeo.sh
USE_RC_SUBR= ${PORTNAME}28.sh zeo28.sh
USE_REINPLACE= yes
# Note: the notes that follow reflect the decisions of prior maintainers
@ -27,7 +28,7 @@ USE_REINPLACE= yes
# Change these, if you like, via the environment.
ZOPE_USER?= www
WEBBASEDIR?= www
SZOPEBASEDIR?= ${WEBBASEDIR}/Zope
SZOPEBASEDIR?= ${WEBBASEDIR}/Zope28
# Do not change anything below this line.
@ -67,8 +68,8 @@ post-patch:
${WRKSRC}/configure
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.sh ${PREFIX}/etc/rc.d/
${INSTALL_SCRIPT} ${WRKDIR}/zeo.sh ${PREFIX}/etc/rc.d/
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}28.sh ${PREFIX}/etc/rc.d
${INSTALL_SCRIPT} ${WRKDIR}/zeo28.sh ${PREFIX}/etc/rc.d
${MV} ${ZOPEBASEDIR}/skel/etc/zope.conf.in \
${ZOPEBASEDIR}/skel/etc/zope.conf.sample.in
@ -77,10 +78,7 @@ post-install:
${CP} ${FILESDIR}/Products_00readme-freebsd.txt \
${ZOPEBASEDIR}/Products/00readme-freebsd.txt
${FIND} ${ZOPEBASEDIR} ! -type d | \
${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
${FIND} -d ${ZOPEBASEDIR} -type d | \
${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
${FIND} ${ZOPEBASEDIR} -type f -print0 | ${XARGS} -0 -- ${CHMOD} a-w
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}

View File

@ -0,0 +1,10 @@
--- lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py.orig Thu Aug 11 09:11:19 2005
+++ lib/python/Products/SiteAccess/tests/testVirtualHostMonster.py Wed Sep 7 12:19:37 2005
@@ -12,6 +12,7 @@
from Testing.makerequest import makerequest
+from __future__ import generators
import Zope2
Zope2.startup()

View File

@ -1,53 +0,0 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD: /tmp/pcvs/ports/www/zope29/files/Attic/zeo.sh.in,v 1.1 2005-09-18 21:33:04 vsevolod Exp $
# PROVIDE: zeo
# REQUIRE: DAEMON
# BEFORE: zope
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zeo
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zeo_enable=${zeo_enable:-"NO"} # Enable zeo server
zeo_instances=${zeo_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zeo"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zeo_enable; then
case "$1" in
start)
echo "Starting Zeo"
;;
stop)
echo "Stopping Zeo"
;;
restart)
echo "Restarting Zeo"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zeo_instances
do
if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zeoctl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zeoctl $1
fi
done
fi

View File

@ -0,0 +1,53 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD$
# PROVIDE: zeo28
# REQUIRE: DAEMON
# BEFORE: zope28
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope28_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zeo28
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zeo28_enable=${zeo28_enable:-"NO"} # Enable zeo server
zeo28_instances=${zeo28_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zeo28"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zeo28_enable; then
case "$1" in
start)
echo "Starting Zeo 2.8"
;;
stop)
echo "Stopping Zeo 2.8"
;;
restart)
echo "Restarting Zeo 2.8"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zeo28_instances
do
if [ -r ${instance}/etc/zeo.conf -a -x ${instance}/bin/zeoctl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zeoctl $1
fi
done
fi

View File

@ -1,53 +0,0 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD: /tmp/pcvs/ports/www/zope29/files/Attic/zope.sh.in,v 1.7 2005-09-18 21:33:04 vsevolod Exp $
# PROVIDE: zope
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zope
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zope_enable=${zope_enable:-"NO"} # Enable zope
zope_instances=${zope_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zope"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zope_enable; then
case "$1" in
start)
echo "Starting Zope"
;;
stop)
echo "Stopping Zope"
;;
restart)
echo "Restarting Zope"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zope_instances
do
if [ -r ${instance}/etc/${name}.conf -a -x ${instance}/bin/zopectl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zopectl $1
fi
done
fi

View File

@ -0,0 +1,53 @@
#!/bin/sh
# Start or stop zope
# $FreeBSD$
# PROVIDE: zope28
# REQUIRE: DAEMON
# BEFORE: LOGIN
# KEYWORD: FreeBSD shutdown
#
prefix=%%PREFIX%%
# Define these zope28_* variables in one of these files:
# /etc/rc.conf
# /etc/rc.conf.local
# /etc/rc.conf.d/zope28
#
# DO NOT CHANGE THESE DEFAULT VALUES HERE
#
zope28_enable=${zope28_enable:-"NO"} # Enable zope
zope28_instances=${zope28_instances:-""} # List of instancehome dirs
. %%RC_SUBR%%
name="zope28"
rcvar=`set_rcvar`
load_rc_config $name
if checkyesno zope28_enable; then
case "$1" in
start)
echo "Starting Zope 2.8"
;;
stop)
echo "Stopping Zope 2.8"
;;
restart)
echo "Restarting Zope 2.8"
;;
*)
echo "Unknown action \"$1\""
;;
esac
for instance in $zope28_instances
do
if [ -r ${instance}/etc/zope.conf -a -x ${instance}/bin/zopectl ]; then
echo -n " Instance ${instance} -> "
${instance}/bin/zopectl $1
fi
done
fi

7229
www/zope29/pkg-plist Normal file

File diff suppressed because it is too large Load Diff