Add devel/py-pyfcm, a Python client for Firebase Cloud Messaging.

This commit is contained in:
Jimmy Olgeni 2017-12-22 13:45:31 +00:00
parent b945f4dc26
commit edc470eb23
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=456977
5 changed files with 41 additions and 0 deletions

View File

@ -4720,6 +4720,7 @@
SUBDIR += py-pyelftools
SUBDIR += py-pyev
SUBDIR += py-pyface
SUBDIR += py-pyfcm
SUBDIR += py-pyflakes
SUBDIR += py-pygdbmi
SUBDIR += py-pygit2

21
devel/py-pyfcm/Makefile Normal file
View File

@ -0,0 +1,21 @@
# $FreeBSD$
PORTNAME= pyfcm
PORTVERSION= 1.4.3
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Python client for Firebase Cloud Messaging
LICENSE= MIT
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${FLAVOR}
USES= python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
.include <bsd.port.mk>

3
devel/py-pyfcm/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1513940242
SHA256 (pyfcm-1.4.3.tar.gz) = dd66f890ea20178eaaa274d781809b672187d76b10f56cf7cbe4d54c8b6a01b0
SIZE (pyfcm-1.4.3.tar.gz) = 15209

View File

@ -0,0 +1,13 @@
--- README.rst.orig 2017-10-18 23:26:43 UTC
+++ README.rst
@@ -119,8 +119,8 @@ Send a data message.
# To send extra kwargs (keyword arguments not provided in any of the methods),
# pass it as a key value in a dictionary to the method being used
extra_kwargs = {
-        'priority': 'high'
-   }
+ 'priority': 'high'
+ }
result = push_service.notify_single_device(registration_id=registration_id, data_message=data_message, extra_kwargs=extra_kwargs)
# To process background notifications in iOS 10, set content_available

3
devel/py-pyfcm/pkg-descr Normal file
View File

@ -0,0 +1,3 @@
Python client for FCM - Firebase Cloud Messaging (Android & iOS)
WWW: http://olucurious.github.io/PyFCM/