Upgrade to 0.99.

PR:		ports/24933
Submitted by:	maintainer
This commit is contained in:
Vanilla I. Shu 2001-02-09 16:14:28 +00:00
parent 55b40c3f1f
commit edbfa7fec8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=38132
12 changed files with 313 additions and 72 deletions

View File

@ -7,7 +7,7 @@
# "?=" and "+=" are for including this Makefile from japanese/jpilot
PORTNAME= jpilot
PORTVERSION= 0.98.1
PORTVERSION= 0.99
CATEGORIES+= palm comms
MASTER_SITES= http://jpilot.org/
@ -18,12 +18,14 @@ LIB_DEPENDS= pisock.3:${PORTSDIR}/palm/pilot-link \
PREFIX= ${LOCALBASE}/pilot
USE_GTK= yes
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS+=--with-pilot-prefix=${PREFIX}
INSTALLS_SHLIB= yes
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/jpilot
${CP} ${WRKSRC}/docs/manual.html ${PREFIX}/share/doc/jpilot
${CP} ${WRKSRC}/docs/plugin.html ${PREFIX}/share/doc/jpilot
.endif

View File

@ -1 +1 @@
MD5 (jpilot-0.98.1.tar.gz) = a67a68a9e53757b34cbd2d3fc9c0e3bb
MD5 (jpilot-0.99.tar.gz) = a6c8c1a9bc74f8a3f8403c451fdaef0f

View File

@ -0,0 +1,18 @@
--- Expense/Makefile.in.orig Fri Dec 8 06:44:26 2000
+++ Expense/Makefile.in Fri Feb 9 23:46:37 2001
@@ -52,13 +52,13 @@
install:
./install-sh -d -m 755 $(prefix)/lib/jpilot; \
./install-sh -d -m 755 $(prefix)/lib/jpilot/plugins; \
- ../libtool --mode=install ./install-sh \
+ ../libtool --mode=install ./install-sh -c \
libexpense.la $(prefix)/lib/jpilot/plugins
local_install:
./install-sh -d -m 755 $(HOME)/.jpilot; \
./install-sh -d -m 755 $(HOME)/.jpilot/plugins; \
- ../libtool --mode=install ./install-sh \
+ ../libtool --mode=install ./install-sh -c \
libexpense.la $(HOME)/.jpilot/plugins
uninstall:

View File

@ -0,0 +1,18 @@
--- SyncTime/Makefile.in.orig Fri Dec 8 06:44:26 2000
+++ SyncTime/Makefile.in Fri Feb 9 23:46:00 2001
@@ -52,13 +52,13 @@
install:
./install-sh -d -m 755 $(prefix)/lib/jpilot; \
./install-sh -d -m 755 $(prefix)/lib/jpilot/plugins; \
- ../libtool --mode=install ./install-sh \
+ ../libtool --mode=install ./install-sh -c \
libsynctime.la $(prefix)/lib/jpilot/plugins
local_install:
./install-sh -d -m 755 $(HOME)/.jpilot; \
./install-sh -d -m 755 $(HOME)/.jpilot/plugins; \
- ../libtool --mode=install ./install-sh \
+ ../libtool --mode=install ./install-sh -c \
libsynctime.la $(HOME)/.jpilot/plugins
uninstall:

View File

@ -1,20 +1,33 @@
--- Makefile.in.orig Wed Mar 1 18:00:14 2000
+++ Makefile.in Sun Mar 12 11:37:58 2000
--- Makefile.in.orig Mon Dec 18 16:53:30 2000
+++ Makefile.in Thu Dec 21 21:22:37 2000
@@ -43,7 +43,7 @@
INTLLIBS = @INTLLIBS@
# Targets
-all: po_dir intl_dir jpilot
+all: po_dir intl_dir jpilot libplugin
-all: po_dir intl_dir jpilot jpilot-sync jpilot-dump
+all: po_dir intl_dir jpilot jpilot-sync jpilot-dump synctime expense
jpilot: jpilot.o datebook.o address.o todo.o memo.o \
utils.o sync.o prefs.o log.o plugins.o \
@@ -192,6 +192,8 @@
./install-sh -c -m 755 empty/AddressDB.pdb $(prefix)/share/jpilot/
./install-sh -c -m 755 empty/ToDoDB.pdb $(prefix)/share/jpilot/
./install-sh -c -m 755 empty/MemoDB.pdb $(prefix)/share/jpilot/
+ ./install-sh -c -m 644 libplugin.a $(prefix)/lib/
+ ./install-sh -c -m 644 docs/plugin.html $(prefix)/share/doc/jpilot/plugin.html
cd intl; make install
cd po; make install
@@ -210,6 +210,12 @@
intl_dir:
cd intl; $(MAKE)
+synctime:
+ cd SyncTime; $(MAKE)
+
+expense:
+ cd Expense; $(MAKE)
+
clean:
rm -f *.o *~ config.cache
@@ -236,6 +242,8 @@
./install-sh -c -m 755 empty/MemoDB.pdb $(prefix)/share/jpilot/
cd intl; $(MAKE) install
cd po; $(MAKE) install
+ cd SyncTime; $(MAKE) install
+ cd Expense; $(MAKE) install
uninstall:
rm $(prefix)/share/jpilot/*

View File

@ -1,11 +0,0 @@
--- configure.orig Sat Mar 4 16:10:48 2000
+++ configure Sat Mar 4 16:10:54 2000
@@ -3779,7 +3779,7 @@
echo $ac_n "checking for dlopen""... $ac_c" 1>&6
echo "configure:3781: checking for dlopen" >&5
save_LIBS="$LIBS"
- LIBS="$LIBS -ldl"
+ LIBS="$LIBS"
cat > conftest.$ac_ext <<EOF
#line 3785 "configure"
#include "confdefs.h"

View File

@ -1,11 +0,0 @@
--- SyncTime/Makefile.in.orig Sat Feb 12 20:35:13 2000
+++ SyncTime/Makefile.in Sat Mar 4 16:11:28 2000
@@ -27,7 +27,7 @@
echo; echo "WARNING - SyncTime is currently broken for PalmOS 3.3"; echo
libsynctime.so: synctime.o libplugin.a
- ld -shared -ldl -o libsynctime.so synctime.o -L. -lplugin
+ ld -shared -o libsynctime.so synctime.o -L. -lplugin
synctime.o: synctime.c libplugin.h
$(CC) $(OPTIONS) $(GTKFLAGS) $(PILOT_FLAGS) -c synctime.c

View File

@ -1,25 +0,0 @@
--- jpilot.c Sat Feb 12 21:33:21 2000
+++ jpilot.c.orig Fri May 19 19:49:10 2000
@@ -609,6 +609,11 @@
bad_sync_exit_status(exit_status);
}
}
+ /*Look for finish message */
+ Pstr1 = strstr(buf, "Finished");
+ if (Pstr1) {
+ cb_app_button(NULL, GINT_TO_POINTER(REDRAW));
+ }
}
}
--- sync.c Thu Feb 24 03:20:33 2000
+++ sync.c.orig Fri May 19 19:48:43 2000
@@ -107,7 +107,7 @@
waitpid(-1, NULL, WNOHANG);
/*refresh the screen after a sync */
- cb_app_button(NULL, GINT_TO_POINTER(REDRAW));
+ /*cb_app_button(NULL, GINT_TO_POINTER(REDRAW));*/
return;
}

View File

@ -0,0 +1,202 @@
--- configure.orig Fri Feb 9 23:35:45 2001
+++ configure Fri Feb 9 23:35:48 2001
@@ -5185,3 +5185,199 @@
test "$no_create" = yes || ${CONFIG_SHELL-/bin/sh} $CONFIG_STATUS || exit 1
+
+if test "$no_recursion" != yes; then
+
+ # Remove --cache-file and --srcdir arguments so they do not pile up.
+ ac_sub_configure_args=
+ ac_prev=
+ for ac_arg in $ac_configure_args; do
+ if test -n "$ac_prev"; then
+ ac_prev=
+ continue
+ fi
+ case "$ac_arg" in
+ -cache-file | --cache-file | --cache-fil | --cache-fi \
+ | --cache-f | --cache- | --cache | --cach | --cac | --ca | --c)
+ ac_prev=cache_file ;;
+ -cache-file=* | --cache-file=* | --cache-fil=* | --cache-fi=* \
+ | --cache-f=* | --cache-=* | --cache=* | --cach=* | --cac=* | --ca=* | --c=*)
+ ;;
+ -srcdir | --srcdir | --srcdi | --srcd | --src | --sr)
+ ac_prev=srcdir ;;
+ -srcdir=* | --srcdir=* | --srcdi=* | --srcd=* | --src=* | --sr=*)
+ ;;
+ *) ac_sub_configure_args="$ac_sub_configure_args $ac_arg" ;;
+ esac
+ done
+
+ for ac_config_dir in SyncTime; do
+
+ # Do not complain, so a configure script can configure whichever
+ # parts of a large source tree are present.
+ if test ! -d $srcdir/$ac_config_dir; then
+ continue
+ fi
+
+ echo configuring in $ac_config_dir
+
+ case "$srcdir" in
+ .) ;;
+ *)
+ if test -d ./$ac_config_dir || mkdir ./$ac_config_dir; then :;
+ else
+ { echo "configure: error: can not create `pwd`/$ac_config_dir" 1>&2; exit 1; }
+ fi
+ ;;
+ esac
+
+ ac_popdir=`pwd`
+ cd $ac_config_dir
+
+ # A "../" for each directory in /$ac_config_dir.
+ ac_dots=`echo $ac_config_dir|sed -e 's%^\./%%' -e 's%[^/]$%&/%' -e 's%[^/]*/%../%g'`
+
+ case "$srcdir" in
+ .) # No --srcdir option. We are building in place.
+ ac_sub_srcdir=$srcdir ;;
+ /*) # Absolute path.
+ ac_sub_srcdir=$srcdir/$ac_config_dir ;;
+ *) # Relative path.
+ ac_sub_srcdir=$ac_dots$srcdir/$ac_config_dir ;;
+ esac
+
+ # Check for guested configure; otherwise get Cygnus style configure.
+ if test -f $ac_sub_srcdir/configure; then
+ ac_sub_configure=$ac_sub_srcdir/configure
+ elif test -f $ac_sub_srcdir/configure.in; then
+ ac_sub_configure=$ac_configure
+ else
+ echo "configure: warning: no configuration information is in $ac_config_dir" 1>&2
+ ac_sub_configure=
+ fi
+
+ # The recursion is here.
+ if test -n "$ac_sub_configure"; then
+
+ # Make the cache file name correct relative to the subdirectory.
+ case "$cache_file" in
+ /*) ac_sub_cache_file=$cache_file ;;
+ *) # Relative path.
+ ac_sub_cache_file="$ac_dots$cache_file" ;;
+ esac
+ case "$ac_given_INSTALL" in
+ [/$]*) INSTALL="$ac_given_INSTALL" ;;
+ *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
+ esac
+
+ echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
+ # The eval makes quoting arguments work.
+ if eval ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir
+ then :
+ else
+ { echo "configure: error: $ac_sub_configure failed for $ac_config_dir" 1>&2; exit 1; }
+ fi
+ fi
+
+ cd $ac_popdir
+ done
+fi
+
+
+if test "$no_recursion" != yes; then
+
+ # Remove --cache-file and --srcdir arguments so they do not pile up.
+ ac_sub_configure_args=
+ ac_prev=
+ for ac_arg in $ac_configure_args; do
+ if test -n "$ac_prev"; then
+ ac_prev=
+ continue
+ fi
+ case "$ac_arg" in
+ -cache-file | --cache-file | --cache-fil | --cache-fi \
+ | --cache-f | --cache- | --cache | --cach | --cac | --ca | --c)
+ ac_prev=cache_file ;;
+ -cache-file=* | --cache-file=* | --cache-fil=* | --cache-fi=* \
+ | --cache-f=* | --cache-=* | --cache=* | --cach=* | --cac=* | --ca=* | --c=*)
+ ;;
+ -srcdir | --srcdir | --srcdi | --srcd | --src | --sr)
+ ac_prev=srcdir ;;
+ -srcdir=* | --srcdir=* | --srcdi=* | --srcd=* | --src=* | --sr=*)
+ ;;
+ *) ac_sub_configure_args="$ac_sub_configure_args $ac_arg" ;;
+ esac
+ done
+
+ for ac_config_dir in Expense; do
+
+ # Do not complain, so a configure script can configure whichever
+ # parts of a large source tree are present.
+ if test ! -d $srcdir/$ac_config_dir; then
+ continue
+ fi
+
+ echo configuring in $ac_config_dir
+
+ case "$srcdir" in
+ .) ;;
+ *)
+ if test -d ./$ac_config_dir || mkdir ./$ac_config_dir; then :;
+ else
+ { echo "configure: error: can not create `pwd`/$ac_config_dir" 1>&2; exit 1; }
+ fi
+ ;;
+ esac
+
+ ac_popdir=`pwd`
+ cd $ac_config_dir
+
+ # A "../" for each directory in /$ac_config_dir.
+ ac_dots=`echo $ac_config_dir|sed -e 's%^\./%%' -e 's%[^/]$%&/%' -e 's%[^/]*/%../%g'`
+
+ case "$srcdir" in
+ .) # No --srcdir option. We are building in place.
+ ac_sub_srcdir=$srcdir ;;
+ /*) # Absolute path.
+ ac_sub_srcdir=$srcdir/$ac_config_dir ;;
+ *) # Relative path.
+ ac_sub_srcdir=$ac_dots$srcdir/$ac_config_dir ;;
+ esac
+
+ # Check for guested configure; otherwise get Cygnus style configure.
+ if test -f $ac_sub_srcdir/configure; then
+ ac_sub_configure=$ac_sub_srcdir/configure
+ elif test -f $ac_sub_srcdir/configure.in; then
+ ac_sub_configure=$ac_configure
+ else
+ echo "configure: warning: no configuration information is in $ac_config_dir" 1>&2
+ ac_sub_configure=
+ fi
+
+ # The recursion is here.
+ if test -n "$ac_sub_configure"; then
+
+ # Make the cache file name correct relative to the subdirectory.
+ case "$cache_file" in
+ /*) ac_sub_cache_file=$cache_file ;;
+ *) # Relative path.
+ ac_sub_cache_file="$ac_dots$cache_file" ;;
+ esac
+ case "$ac_given_INSTALL" in
+ [/$]*) INSTALL="$ac_given_INSTALL" ;;
+ *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
+ esac
+
+ echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
+ # The eval makes quoting arguments work.
+ if eval ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir
+ then :
+ else
+ { echo "configure: error: $ac_sub_configure failed for $ac_config_dir" 1>&2; exit 1; }
+ fi
+ fi
+
+ cd $ac_popdir
+ done
+fi
+

View File

@ -0,0 +1,9 @@
--- configure.in.orig Fri Feb 9 23:52:19 2001
+++ configure.in Fri Feb 9 23:53:32 2001
@@ -233,4 +233,6 @@
AC_OUTPUT([Makefile intl/Makefile po/Makefile.in],
[sed -e "/POTFILES =/r po/POTFILES" po/Makefile.in > po/Makefile])
+AC_OUTPUT_SUBDIRS(Expense)
+AC_OUTPUT_SUBDIRS(SyncTime)
dnl AC_OUTPUT(Makefile)

View File

@ -1,7 +1,7 @@
J-Pilot is a desktop organizer application for the palm pilot that
runs under Linux, and Unix. It is similar in functionality to the
one that 3com distributes for a well known rampant legacy operating
system.
runs under Linux and Unix using X-Windows and GTK+. It is similar in
functionality to the one that 3com distributes and has many features
not found in the 3com desktop.
WWW: http://jpilot.org/

View File

@ -1,30 +1,56 @@
bin/jpilot
bin/jpilot-dump
bin/jpilot-sync
bin/jpilot-upgrade-99
lib/jpilot/plugins/libexpense.a
lib/jpilot/plugins/libexpense.so
lib/jpilot/plugins/libexpense.so.1
lib/jpilot/plugins/libsynctime.a
lib/jpilot/plugins/libsynctime.so
lib/jpilot/plugins/libsynctime.so.1
%%PORTDOCS%%share/doc/jpilot/manual.html
%%PORTDOCS%%share/doc/jpilot/plugin.html
share/jpilot/AddressDB.pdb
share/jpilot/DatebookDB.pdb
share/jpilot/MemoDB.pdb
share/jpilot/ToDoDB.pdb
share/jpilot/jpilotrc.blue
share/jpilot/jpilotrc.default
share/jpilot/jpilotrc.green
share/jpilot/jpilotrc.purple
share/jpilot/jpilotrc.steel
share/jpilot/DatebookDB.pdb
share/jpilot/AddressDB.pdb
share/jpilot/ToDoDB.pdb
share/jpilot/MemoDB.pdb
lib/libplugin.a
share/doc/jpilot/plugin.html
share/locale/ca/LC_MESSAGES/jpilot.mo
share/locale/cs/LC_MESSAGES/jpilot.mo
share/locale/da/LC_MESSAGES/jpilot.mo
share/locale/de/LC_MESSAGES/jpilot.mo
share/locale/es/LC_MESSAGES/jpilot.mo
share/locale/fr/LC_MESSAGES/jpilot.mo
share/locale/ja/LC_MESSAGES/jpilot.mo
share/locale/nl/LC_MESSAGES/jpilot.mo
share/locale/no/LC_MESSAGES/jpilot.mo
share/locale/sv/LC_MESSAGES/jpilot.mo
@dirrm share/jpilot
@dirrm share/doc/jpilot
%%PORTDOCS%%@dirrm share/doc/jpilot
@dirrm lib/jpilot/plugins
@dirrm lib/jpilot
@unexec rmdir %D/share/locale/ca/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/ca 2>/dev/null || true
@unexec rmdir %D/share/locale/cs/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/cs 2>/dev/null || true
@unexec rmdir %D/share/locale/da/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/da 2>/dev/null || true
@unexec rmdir %D/share/locale/de/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/de 2>/dev/null || true
@unexec rmdir %D/share/locale/es/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/es 2>/dev/null || true
@unexec rmdir %D/share/locale/fr/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/fr 2>/dev/null || true
@unexec rmdir %D/share/locale/ja/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/ja 2>/dev/null || true
@unexec rmdir %D/share/locale/nl/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/nl 2>/dev/null || true
@unexec rmdir %D/share/locale/no/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/no 2>/dev/null || true
@unexec rmdir %D/share/locale/sv/LC_MESSAGES 2>/dev/null || true
@unexec rmdir %D/share/locale/sv 2>/dev/null || true
@unexec rmdir %D/share/locale 2>/dev/null || true