New port: sysutils/fcode-utils
A set of utilities to process FCODE, OpenFirmware's byte code. This includes: - the tokenizer toke, - the detokenizer detok, - and a PCI rom header utility. WWW: https://www.openfirmware.info/FCODE_suite PR: 213114 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> (based on) Reviewed by: pawel
This commit is contained in:
parent
00662aa719
commit
edb625cebc
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=469447
@ -309,6 +309,7 @@
|
||||
SUBDIR += farbot
|
||||
SUBDIR += fastest_cvsup
|
||||
SUBDIR += fatback
|
||||
SUBDIR += fcode-utils
|
||||
SUBDIR += fconfig
|
||||
SUBDIR += fcron
|
||||
SUBDIR += fd
|
||||
|
41
sysutils/fcode-utils/Makefile
Normal file
41
sysutils/fcode-utils/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= fcode-utils
|
||||
PORTVERSION= 1.0.2
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= sysutils
|
||||
|
||||
MAINTAINER= pkubaj@anongoth.pl
|
||||
COMMENT= Utilities to process FCODE, OpenFirmware's byte code
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= gmake
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= openbios
|
||||
|
||||
MAKE_ARGS= CC=${CC}
|
||||
PLIST_FILES= bin/detok \
|
||||
bin/romheaders \
|
||||
bin/toke
|
||||
PORTDOCS= detok.html toke.html workbook.css
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
do-build:
|
||||
.for f in detok romheaders toke
|
||||
@${DO_MAKE_BUILD} -C ${WRKSRC}/${f}
|
||||
.endfor
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/detok/detok ${WRKSRC}/toke/toke \
|
||||
${WRKSRC}/romheaders/romheaders ${STAGEDIR}${PREFIX}/bin
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
cd ${WRKSRC}/documentation && \
|
||||
${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
3
sysutils/fcode-utils/distinfo
Normal file
3
sysutils/fcode-utils/distinfo
Normal file
@ -0,0 +1,3 @@
|
||||
TIMESTAMP = 1475063061
|
||||
SHA256 (openbios-fcode-utils-v1.0.2_GH0.tar.gz) = 8d9979c269a60a6e2b9dcfb50d1515d0e750e95d7d2690b36620a614b0c163bc
|
||||
SIZE (openbios-fcode-utils-v1.0.2_GH0.tar.gz) = 4308712
|
11
sysutils/fcode-utils/files/patch-shared_types.h
Normal file
11
sysutils/fcode-utils/files/patch-shared_types.h
Normal file
@ -0,0 +1,11 @@
|
||||
--- shared/types.h.orig 2008-07-11 23:21:43 UTC
|
||||
+++ shared/types.h
|
||||
@@ -39,7 +39,7 @@
|
||||
*
|
||||
**************************************************************************** */
|
||||
|
||||
-#if defined(__ppc__) && defined(__APPLE__)
|
||||
+#if defined(__ppc__) && defined(__APPLE__) || defined (__FreeBSD__)
|
||||
#include <sys/types.h>
|
||||
|
||||
typedef int8_t s8;
|
8
sysutils/fcode-utils/pkg-descr
Normal file
8
sysutils/fcode-utils/pkg-descr
Normal file
@ -0,0 +1,8 @@
|
||||
A set of utilities to process FCODE, OpenFirmware's byte code. This
|
||||
includes:
|
||||
|
||||
- the tokenizer toke,
|
||||
- the detokenizer detok,
|
||||
- and a PCI rom header utility.
|
||||
|
||||
WWW: https://www.openfirmware.info/FCODE_suite
|
Loading…
Reference in New Issue
Block a user