graphics/podofo: Add UNISTRING option to avoid potential dependency

- Bump PORTREVISION for dependency and package change
This commit is contained in:
Po-Chuan Hsieh 2022-12-30 16:40:05 +08:00
parent 0add79a2c9
commit eda03052dd
No known key found for this signature in database
GPG Key ID: 9A4BD10F002DD04B
2 changed files with 19 additions and 8 deletions

View File

@ -1,5 +1,6 @@
PORTNAME= podofo
PORTVERSION= 0.9.8
PORTREVISION= 1
CATEGORIES= graphics print
MASTER_SITES= SF
@ -26,9 +27,10 @@ CPE_VENDOR= podofo_project
DOS2UNIX_FILES= cmake/modules/FindFREETYPE.cmake
OPTIONS_DEFINE= IMPOSE JPEG PNG TIFF
OPTIONS_DEFAULT=JPEG PNG TIFF
OPTIONS_DEFINE= IMPOSE JPEG PNG TIFF UNISTRING
OPTIONS_DEFAULT=JPEG PNG TIFF UNISTRING
IMPOSE_DESC= Build impose tool (Lua required)
UNISTRING_DESC= Use libunistring for conversion
IMPOSE_CMAKE_BOOL= WANT_LUA
IMPOSE_CXXFLAGS= -I${LUA_INCDIR}
@ -40,5 +42,7 @@ PNG_CMAKE_BOOL= WANT_PNG
PNG_LIB_DEPENDS= libpng.so:graphics/png
TIFF_CMAKE_BOOL= WANT_TIFF
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
UNISTRING_CMAKE_BOOL= WANT_UNISTRING
UNISTRING_LIB_DEPENDS= libunistring.so:devel/libunistring
.include <bsd.port.mk>

View File

@ -1,4 +1,4 @@
--- CMakeLists.txt.orig 2021-01-05 16:56:54 UTC
--- CMakeLists.txt.orig 2022-05-03 12:18:23 UTC
+++ CMakeLists.txt
@@ -348,6 +348,7 @@ ELSE(LIBIDN_FOUND)
MESSAGE("Libidn not found. AES-256 Encryption support will be disabled")
@ -28,15 +28,22 @@
FIND_PACKAGE(PNG)
IF(PNG_FOUND)
@@ -378,6 +383,7 @@ ELSE(PNG_FOUND)
@@ -378,7 +383,9 @@ ELSE(PNG_FOUND)
MESSAGE("LibPng not found. PNG support will be disabled")
SET(PNG_LIBRARIES "")
ENDIF(PNG_FOUND)
+ENDIF(WANT_PNG)
+IF(WANT_UNISTRING)
FIND_PACKAGE(UNISTRING)
@@ -393,6 +399,7 @@ ENDIF(UNISTRING_FOUND)
IF(UNISTRING_FOUND)
@@ -389,10 +396,12 @@ ELSE(UNISTRING_FOUND)
MESSAGE("LibUnistring not found. Unistring support will be disabled")
SET(UNISTRING_LIBRARY "")
ENDIF(UNISTRING_FOUND)
+ENDIF(WANT_UNISTRING)
IF(NOT PODOFO_BUILD_LIB_ONLY)
@ -44,7 +51,7 @@
FIND_PACKAGE(CppUnit)
IF(CppUnit_FOUND)
@@ -402,6 +409,7 @@ IF(CppUnit_FOUND)
@@ -402,6 +411,7 @@ IF(CppUnit_FOUND)
ELSE(CppUnit_FOUND)
MESSAGE("Cppunit not found. No unit tests will be built.")
ENDIF(CppUnit_FOUND)
@ -52,7 +59,7 @@
ENDIF(NOT PODOFO_BUILD_LIB_ONLY)
@@ -442,6 +450,7 @@ ELSE(WANT_FONTCONFIG)
@@ -442,6 +452,7 @@ ELSE(WANT_FONTCONFIG)
ENDIF(WANT_FONTCONFIG)
IF(NOT PODOFO_BUILD_LIB_ONLY)
@ -60,7 +67,7 @@
FIND_PACKAGE(LUA)
IF(LUA_FOUND)
# If we have lua, we can build podofoimpose.
@@ -453,6 +462,7 @@ IF(LUA_FOUND)
@@ -453,6 +464,7 @@ IF(LUA_FOUND)
ELSE(LUA_FOUND)
MESSAGE("Lua not found - PoDoFoImpose and PoDoFoColor will be built without Lua support")
ENDIF(LUA_FOUND)