Update to 0.34

PR:		39456
Submitted by:	maintainer
This commit is contained in:
Patrick Li 2002-06-18 08:15:26 +00:00
parent 0ca81fd415
commit ed9ca0dc5a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61490
5 changed files with 10 additions and 62 deletions

View File

@ -7,10 +7,9 @@
#
PORTNAME= pdftohtml
PORTVERSION= 0.33a
PORTVERSION= 0.34
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://ports.tolkien.dk/pdftohtml/
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/}
@ -19,6 +18,13 @@ MAINTAINER= erwin@lansing.dk
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
pre-patch:
.for file in goo/Makefile xpdf/Makefile
@${MV} ${WRKSRC}/${file} ${WRKSRC}/${file}.orig
@${SED} -e "s|-O2||; s|-g||" ${WRKSRC}/${file}.orig \
> ${WRKSRC}/${file}
.endfor
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/pdftohtml ${PREFIX}/bin

View File

@ -1 +1 @@
MD5 (pdftohtml_0_33a.tar.gz) = 9910fb38210be5ea3ec2acc485244fdc
MD5 (pdftohtml_0_34.tar.gz) = f124178552a2e6a5b37b89643e679718

View File

@ -1,18 +0,0 @@
--- goo/Makefile.orig Sun Apr 21 18:26:03 2002
+++ goo/Makefile Tue Apr 23 23:14:45 2002
@@ -11,11 +11,11 @@
srcdir = .
-CFLAGS = -g -O2 -DHAVE_CONFIG_H -I.. -I$(srcdir)
-CXXFLAGS = -g -O2 -DHAVE_CONFIG_H -I.. -I$(srcdir)
+CFLAGS += -DHAVE_CONFIG_H -I.. -I$(srcdir)
+CXXFLAGS += -DHAVE_CONFIG_H -I.. -I$(srcdir)
-CC = gcc
-CXX = c++
+CC ?= cc
+CXX ?= c++
AR = ar rc
RANLIB = ranlib

View File

@ -1,18 +0,0 @@
--- src/Makefile.orig Sun Apr 21 18:25:42 2002
+++ src/Makefile Tue Apr 23 23:14:08 2002
@@ -10,13 +10,13 @@
GOOLIBDIR = ../goo
-CXXFLAGS = -g -DHAVE_DIRENT_H=1 -I.. -DHAVE_REWINDDIR=1 -DHAVE_POPEN=1 -I$(GOOSRCDIR) -I$(SRCDIR) -I$(XPDFSRCDIR)
+CXXFLAGS += -DHAVE_DIRENT_H=1 -I.. -DHAVE_REWINDDIR=1 -DHAVE_POPEN=1 -I$(GOOSRCDIR) -I$(SRCDIR) -I$(XPDFSRCDIR)
LDFLAGS =
OTHERLIBS =
-CXX = c++
+CC ?= cc
LIBPREFIX = lib
EXE =

View File

@ -1,22 +0,0 @@
--- xpdf/Makefile.orig Sun Apr 21 18:25:54 2002
+++ xpdf/Makefile Tue Apr 23 23:02:09 2002
@@ -9,16 +9,15 @@
SHELL = /bin/sh
-prefix = /usr/local
srcdir = .
GOOSRCDIR = $(srcdir)/../goo
GOOLIBDIR = ../goo
-CXXFLAGS = -g -O2 -DHAVE_CONFIG_H -I.. -I$(GOOSRCDIR) -I$(srcdir)
+CXXFLAGS += -DHAVE_CONFIG_H -I.. -I$(GOOSRCDIR) -I$(srcdir)
-CC = gcc
-CXX = c++
+CC ?= cc
+CXX ?= c++
AR = ar rc
RANLIB = ranlib