- Fix build with new lrintf math functions [1]

- Simplify COMMENT
- Update pkg-desc

Submitted by:	Dan Larsson [1]
This commit is contained in:
Michael Johnson 2005-01-19 05:31:03 +00:00
parent da06aac91e
commit ed9379928e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=126760
4 changed files with 64 additions and 7 deletions

View File

@ -14,7 +14,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= faac
MAINTAINER= ahze@FreeBSD.org
COMMENT= A LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder
COMMENT= MPEG-2 and MPEG-4 AAC audio decoder
LIB_DEPENDS= mp4v2.0:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2 \
sndfile.1:${PORTSDIR}/audio/libsndfile

View File

@ -0,0 +1,43 @@
--- configure.in.orig Fri Feb 6 17:04:39 2004
+++ configure.in Wed Jan 19 01:44:24 2005
@@ -49,6 +49,43 @@
fi
])
+dnl @synopsis AC_C99_FUNC_LRINTF
+dnl
+dnl Check whether C99's lrintf function is available.
+dnl @version 1.3 Feb 12 2002
+dnl @author Erik de Castro Lopo <erikd AT mega-nerd DOT com>
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this file for any
+dnl purpose is hereby granted without fee, provided that the above copyright
+dnl and this permission notice appear in all copies. No representations are
+dnl made about the suitability of this software for any purpose. It is
+dnl provided "as is" without express or implied warranty.
+dnl
+AC_DEFUN([AC_C99_FUNC_LRINTF],
+[AC_CACHE_CHECK(for lrintf,
+ ac_cv_c99_lrintf,
+[
+lrintf_save_CFLAGS=$CFLAGS
+CFLAGS="-O -lm"
+AC_TRY_LINK([
+#define _ISOC9X_SOURCE 1
+#define _ISOC99_SOURCE 1
+#define __USE_ISOC99 1
+#define __USE_ISOC9X 1
+
+#include <math.h>
+], if (!lrintf(3.14159)) lrintf(2.7183);, ac_cv_c99_lrintf=yes, ac_cv_c99_lrintf=no)
+
+CFLAGS=$lrintf_save_CFLAGS
+
+])
+
+if test "$ac_cv_c99_lrintf" = yes; then
+ AC_DEFINE(HAVE_LRINTF, 1,
+ [Define if you have C99's lrintf function.])
+fi
+])# AC_C99_FUNC_LRINTF
+AC_C99_FUNC_LRINTF

View File

@ -0,0 +1,16 @@
--- libfaad/common.h.orig Fri Feb 6 13:55:24 2004
+++ libfaad/common.h Wed Jan 19 01:52:32 2005
@@ -308,6 +308,7 @@
return i;
}
#elif (defined(__i386__) && defined(__GNUC__))
+ #ifndef HAVE_LRINTF
#define HAS_LRINTF
// from http://www.stereopsis.com/FPU.html
static INLINE int lrintf(float f)
@@ -320,6 +321,7 @@
: "m" (f));
return i;
}
+ #endif /* HAVE_LRINTF */
#endif

View File

@ -1,9 +1,7 @@
This is FAAD 2 - Freeware Advanced Audio Decoder 2.
FAAD2 (Freeware Advanced Audio Decoder) is a MPEG-2, MPEG-4 AAC decoder.
FAAD 2 is a LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder,
completely written from scratch.
FAAD2 is the fastest ISO AAC audio decoder available and can be used with
DRM (Digital Radio Mondiale), and supports HE (High Efficiency), Main,
LC, LD, LTP, PS (Parametric Stereo) AAC files.
WWW: http://www.audiocoding.com/
- Sean McGovern
sean@sfarc.net