Updated to 0.41

This commit is contained in:
Sergey Skvortsov 2003-06-02 10:02:04 +00:00
parent 7eae64cf3f
commit ed66ce00fe
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=81980
5 changed files with 17 additions and 53 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= DBD-InterBase
PORTVERSION= 0.40
PORTVERSION= 0.41
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= DBD
@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= DBI driver for InterBase RDBMS server
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
LIB_DEPENDS= gds:${PORTSDIR}/databases/firebird
RUN_DEPENDS= ${BUILD_DEPENDS}
@ -26,6 +26,5 @@ post-patch:
${WRKSRC}/Makefile.PL
MAN3= Bundle::DBD::InterBase.3 DBD::InterBase.3 DBD::InterBase::FAQ.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (DBD-InterBase-0.40.tar.gz) = 18926bed17a4d9c8f91c1460aceb1394
MD5 (DBD-InterBase-0.41.tar.gz) = dde9cfd991cd73eae925c82a42405e07

View File

@ -1,35 +0,0 @@
--- dbdimp.c Thu Aug 29 06:28:30 2002
+++ dbi-interbase/dbdimp.c Thu Sep 12 12:15:32 2002
@@ -1,5 +1,5 @@
/*
- $Id: dbdimp.c,v 1.96 2002/08/12 16:04:26 danielritz Exp $
+ $Id: dbdimp.c,v 1.97 2002/09/10 13:30:07 danielritz Exp $
Copyright (c) 1999-2002 Edwin Pratomo
Portions Copyright (c) 2001-2002 Daniel Ritz
@@ -1329,7 +1329,10 @@
#elif defined(__BORLANDC__) /* Borland compiler/library */
# define P_INT64_RPEC "%.*Lf"
# define P_INT64_FULL "%s%Ld%s"
-#else /* others: linux, xBSD, solaris, hp-ux, ... */
+#elif defined (__FreeBSD__) /* FreeBSD */
+# define P_INT64_RPEC "%.*Lf"
+# define P_INT64_FULL "%s%qd%s"
+#else /* others: linux, various unices */
# define P_INT64_RPEC "%.*Lf"
# define P_INT64_FULL "%s%lld%s"
#endif
@@ -2429,7 +2432,12 @@
# define S_INT64_NOSCALE "%%Ld.%%1Ld"
# define S_INT64_DEC_FULL ".%%%dLd%%1Ld"
# define S_INT64_DEC_NOSCALE ".%%1Ld"
-#else /* others: linux, xBSD, solaris, hp-ux, ... */
+#elif defined (__FreeBSD__) /* FreeBSD */
+# define S_INT64_FULL "%%qd.%%%dqd%%1qd"
+# define S_INT64_NOSCALE "%%qd.%%1qd"
+# define S_INT64_DEC_FULL ".%%%dqd%%1qd"
+# define S_INT64_DEC_NOSCALE ".%%1qd"
+#else /* others: linux, various unices */
# define S_INT64_FULL "%%lld.%%%dlld%%1lld"
# define S_INT64_NOSCALE "%%lld.%%1lld"
# define S_INT64_DEC_FULL ".%%%dlld%%1lld"

View File

@ -1,7 +1,7 @@
DBD::InterBase is a Perl module which works with the DBI module to
provide access to InterBase databases.
WWW: http://search.cpan.org/search?dist=DBD-InterBase
WWW: http://search.cpan.org/dist/DBD-InterBase/
-- Sergey Skvortsov
skv@FreeBSD.org

View File

@ -1,13 +1,13 @@
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBD/InterBase/.packlist
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bundle/DBD/InterBase.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/DBD/InterBase.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/DBD/InterBase/FAQ.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/DBD/InterBase/GetInfo.pm
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBD/InterBase/InterBase.bs
lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBD/InterBase/InterBase.so
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bundle/DBD 2>/dev/null || true
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Bundle 2>/dev/null || true
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/DBD/InterBase
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/DBD 2>/dev/null || true
@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBD/InterBase
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/DBD 2>/dev/null || true
%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/InterBase/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/Bundle/DBD/InterBase.pm
%%SITE_PERL%%/%%PERL_ARCH%%/DBD/InterBase.pm
%%SITE_PERL%%/%%PERL_ARCH%%/DBD/InterBase/FAQ.pm
%%SITE_PERL%%/%%PERL_ARCH%%/DBD/InterBase/GetInfo.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/InterBase/InterBase.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/InterBase/InterBase.so
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Bundle/DBD 2>/dev/null || true
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Bundle 2>/dev/null || true
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/DBD/InterBase
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/DBD 2>/dev/null || true
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD/InterBase
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/DBD 2>/dev/null || true