remove opera-devel, no development version is available now.
This commit is contained in:
parent
34fb1487fa
commit
ece611b4da
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=133836
1
MOVED
1
MOVED
@ -1454,3 +1454,4 @@ databases/pear-sqlite|databases/pecl-sqlite|2005-04-13|Project is now PECL exten
|
||||
www/flashplugin-mozilla-devel|www/flashplugin-mozilla|2005-04-20|Merged with flashplugin-mozilla
|
||||
www/flashplugin-firefox|www/flashplugin-mozilla|2005-04-20|Merged with flashplugin-mozilla
|
||||
games/baduki||2005-04-21|Abandoned
|
||||
www/opera-devel|www/opera|2005-04-21|stable version caught up with -devel
|
||||
|
@ -368,7 +368,6 @@
|
||||
SUBDIR += oops
|
||||
SUBDIR += openvrml
|
||||
SUBDIR += opera
|
||||
SUBDIR += opera-devel
|
||||
SUBDIR += osb-browser
|
||||
SUBDIR += osb-nrcit
|
||||
SUBDIR += osb-nrcore
|
||||
|
@ -1,92 +0,0 @@
|
||||
# New ports collection makefile for: opera
|
||||
# Date created: November 5th 2000
|
||||
# Whom: des
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= opera
|
||||
PORTVERSION= ${OPERA_VER}.${OPERA_DATE}
|
||||
CATEGORIES= www ipv6
|
||||
MASTER_SITES= http://ftp.scarlet.be/pub/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
ftp://ftp.planetmirror.com/pub/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
http://www.mehok.uni-miskolc.hu/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
ftp://ftp.heanet.ie/pub/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
ftp://opera.nsc.no/pub/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
http://ftp.task.gda.pl/pub/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
ftp://ftp.idilis.ro/mirrors/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
http://www.fastmirrors.org/pub/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
http://ftp.sunet.se/pub/www/clients/Opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
ftp://mirror.switch.ch/mirror/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
ftp://ftp.tiscali.nl/pub/mirrors/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
http://ftp.ankara.edu.tr/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
ftp://files.downloadthat.com/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/ \
|
||||
ftp://ftp.opera.com/pub/opera/unix/freebsd/${OPERA_VER:S/.//}${OPERA_MINVER}/${OPERA_REL}/en/static/
|
||||
PKGNAMESUFFIX= -devel
|
||||
DISTNAME= ${PORTNAME}-${OPERA_VER}-${OPERA_DATE}.1-static-qt.i386.freebsd-en
|
||||
|
||||
MAINTAINER= avleeuwen@piwebs.com
|
||||
COMMENT= A blazingly fast, full-featured, standards-compliant browser
|
||||
|
||||
OPERA_VER= 8.0
|
||||
OPERA_MINVER= 0b3
|
||||
OPERA_REL= beta
|
||||
OPERA_DATE= 20050316
|
||||
|
||||
DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
|
||||
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
|
||||
|
||||
USE_BZIP2= yes
|
||||
WANT_GNOME= yes
|
||||
USE_X_PREFIX= yes
|
||||
USE_REINPLACE= yes
|
||||
ONLY_FOR_ARCHS= i386
|
||||
|
||||
NO_BUILD= yes
|
||||
NO_FILTER_SHLIBS=yes
|
||||
|
||||
.ifndef(WITHOUT_ASPELL)
|
||||
LIB_DEPENDS+= aspell.16:${PORTSDIR}/textproc/aspell
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 500000
|
||||
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
|
||||
.endif
|
||||
|
||||
.if ${HAVE_GNOME:Mgnomehier}!=""
|
||||
PLIST_SUB+= GNOME=""
|
||||
.else
|
||||
PLIST_SUB+= GNOME="@comment "
|
||||
.endif
|
||||
|
||||
.if exists(${LOCALBASE}/bin/kde-config)
|
||||
PLIST_SUB+= KDE=""
|
||||
.else
|
||||
PLIST_SUB+= KDE="@comment "
|
||||
.endif
|
||||
|
||||
pre-everything::
|
||||
.if !defined(WITHOUT_ASPELL)
|
||||
@${ECHO_CMD} '===> The following options are available for this port:'
|
||||
@${ECHO_CMD} '===>'
|
||||
@${ECHO_CMD} '===> Define WITHOUT_ASPELL to not install aspell.'
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${CP} ${WRKSRC}/search.ini ${WRKSRC}/locale/en
|
||||
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g ; \
|
||||
s|%%LOCALBASE%%|${LOCALBASE}|g ; s|%%X11BASE%%|${X11BASE}|g' \
|
||||
${WRKSRC}/install.sh ${WRKSRC}/ini/pluginpath.ini \
|
||||
${WRKSRC}/ini/spellcheck.ini ${WRKSRC}/config/opera6rc
|
||||
@${FIND} ${WRKSRC} -name '*.orig' -delete
|
||||
@${FIND} ${WRKSRC} -name '*.bak' -delete
|
||||
|
||||
do-install:
|
||||
@(cd ${WRKSRC} && ./install.sh --prefix=${PREFIX})
|
||||
|
||||
post-install:
|
||||
@${CAT} ${PKGMESSAGE}
|
||||
|
||||
.include <bsd.port.post.mk>
|
@ -1,2 +0,0 @@
|
||||
MD5 (opera-8.0-20050316.1-static-qt.i386.freebsd-en.tar.bz2) = a3ebe5d451fa10d52ed4a14afa47252e
|
||||
SIZE (opera-8.0-20050316.1-static-qt.i386.freebsd-en.tar.bz2) = 4922147
|
@ -1,9 +0,0 @@
|
||||
--- config/opera6rc.orig Mon Jul 19 23:00:06 2004
|
||||
+++ config/opera6rc Mon Jul 19 23:00:16 2004
|
||||
@@ -1,5 +1,5 @@
|
||||
; Put any default settings here that are overridable by users
|
||||
|
||||
[User Prefs]
|
||||
-Language Files Directory=/usr/share/opera/locale/
|
||||
+Language Files Directory=%%PREFIX%%/share/opera/locale/
|
||||
|
@ -1,50 +0,0 @@
|
||||
--- ini/pluginpath.ini.orig Fri Dec 3 11:21:10 2004
|
||||
+++ ini/pluginpath.ini Fri Dec 3 22:55:00 2004
|
||||
@@ -3,40 +3,15 @@
|
||||
; This file is stored in UTF-8 encoding
|
||||
|
||||
[Paths]
|
||||
-$PWD/plugins=1
|
||||
$HOME/.opera/plugins=1
|
||||
-/usr/lib/opera/plugins=1
|
||||
-/usr/lib/opera/plugins=1
|
||||
-/usr/local/lib/opera/plugins=1
|
||||
-/opt/lib/opera/plugins=1
|
||||
+%%PREFIX%%/share/opera/plugins=1
|
||||
+%%LOCALBASE%%/share/opera/plugins=1
|
||||
|
||||
-; Adobe Acrobat
|
||||
-/usr/local/Acrobat5/Browsers/intellinux=1
|
||||
-/usr/local/Acrobat4/Browsers/intellinux=1
|
||||
-/usr/lib/Acrobat5/Browsers/intellinux=1
|
||||
-/usr/lib/Acrobat4/Browsers/intellinux=1
|
||||
-/usr/X11R6/lib/Acrobat5/Browsers/intellinux=1
|
||||
-/usr/X11R6/lib/Acrobat4/Browsers/intellinux=1
|
||||
-/opt/Acrobat5/Browsers/intellinux=1
|
||||
-/opt/Acrobat4/Browsers/intellinux=1
|
||||
-/usr/Acrobat5/Browsers/intellinux=1
|
||||
-/usr/Acrobat4/Browsers/intellinux=1
|
||||
+%%LOCALBASE%%/Acrobat5/Browsers/intellinux=1
|
||||
+%%LOCALBASE%%/Acrobat4/Browsers/intellinux=1
|
||||
|
||||
-; Realplayer
|
||||
-/usr/lib/RealPlayer8/Plugins=1
|
||||
-/usr/lib/realplay/plugins=1
|
||||
-/usr/lib/RealPlayer8=1
|
||||
-/usr/lib/realplay=1
|
||||
-
|
||||
-; Netscape Plug-in Paths
|
||||
-$HOME/.netscape6/plugins=1
|
||||
+%%LOCALBASE%%/lib/RealPlayer8/Plugins=1
|
||||
+%%X11BASE%%/lib/browser_plugins=1
|
||||
$HOME/.netscape/plugins=1
|
||||
-/opt/netscape/plugins=1
|
||||
-/usr/lib/netscape/plugins=1
|
||||
-/usr/local/netscape/plugins=1
|
||||
-/usr/local/lib/netscape/plugins=1
|
||||
-$HOME/.kde/.konqueror/nsplugins=1
|
||||
-
|
||||
-[KDE]
|
||||
-plugins=$HOME/.kde/share/config/kcmnspluginrc
|
||||
+%%LOCALBASE%%/lib/netscape-linux/plugins=1
|
||||
|
@ -1,9 +0,0 @@
|
||||
--- ini/spellcheck.ini.orig Thu May 13 13:51:43 2004
|
||||
+++ ini/spellcheck.ini Thu May 13 13:52:00 2004
|
||||
@@ -3,5 +3,6 @@
|
||||
; This file is stored in UTF-8 encoding
|
||||
|
||||
[Spell Check]
|
||||
+Spell Check Engine=%%PREFIX%%/share/opera/bin/spellcheck.so
|
||||
Default Language=en
|
||||
Default Encoding=iso8859-1
|
@ -1,372 +0,0 @@
|
||||
--- install.sh.orig Fri Feb 25 14:36:52 2005
|
||||
+++ install.sh Wed Mar 2 12:43:44 2005
|
||||
@@ -108,8 +108,8 @@
|
||||
|
||||
if test ${os} = 'FreeBSD' -o ${os} = 'OpenBSD'; then
|
||||
wrapper_dir="${prefix}/bin"
|
||||
- doc_dir="${prefix}/share/doc/opera"
|
||||
- share_dir="${prefix}/share/opera"
|
||||
+ doc_dir="${prefix}/share/doc/opera-devel"
|
||||
+ share_dir="${prefix}/share/opera-devel"
|
||||
exec_dir="${share_dir}/bin"
|
||||
plugin_dir="${share_dir}/plugins"
|
||||
else
|
||||
@@ -373,7 +373,7 @@
|
||||
mvv='' # SunOS mv (no -v verbose option)
|
||||
;;
|
||||
|
||||
- i[3456]86:FreeBSD|i[3456]86:NetBSD)
|
||||
+ i[3456]86:FreeBSD|amd64:FreeBSD|i[3456]86:NetBSD)
|
||||
cpf='-f'
|
||||
if test "$verbose" -gt '1'; then
|
||||
chmodv='-v'
|
||||
@@ -759,7 +759,7 @@
|
||||
debug_msg 0 "in generate_wrapper()"
|
||||
|
||||
case "${machine}:${os}" in
|
||||
- i[3456]86:Linux|x86_64:Linux|i[3456]86:FreeBSD|i[3456]86:NetBSD|i[3456]86:OpenBSD)
|
||||
+ i[3456]86:Linux|x86_64:Linux|i[3456]86:FreeBSD|amd64:FreeBSD|i[3456]86:NetBSD|i[3456]86:OpenBSD)
|
||||
wrapper_ibmjava="
|
||||
IBMJava2-142/jre \\
|
||||
IBMJava2-141/jre \\
|
||||
@@ -794,7 +794,7 @@
|
||||
error 'os'
|
||||
;;
|
||||
esac
|
||||
- wrapper_file="${wrapper_dir}/opera"
|
||||
+ wrapper_file="${wrapper_dir}/opera-devel"
|
||||
|
||||
wrapper_contain="#!/bin/sh
|
||||
|
||||
@@ -850,6 +850,9 @@
|
||||
OPERA_LD_PRELOAD=\"\${LD_PRELOAD}\"
|
||||
export OPERA_LD_PRELOAD
|
||||
|
||||
+OPERA_PERSONALDIR=\${HOME}/.opera-devel
|
||||
+export OPERA_PERSONALDIR
|
||||
+
|
||||
# Native Java enviroment
|
||||
if test -f \"\${OPERA_PERSONALDIR}/javapath.txt\"; then
|
||||
INIJAVA=\`cat \${OPERA_PERSONALDIR}/javapath.txt\`
|
||||
@@ -873,53 +876,12 @@
|
||||
|
||||
if test ! \"\${OPERA_JAVA_DIR}\"; then
|
||||
|
||||
- PREFIXES=\"
|
||||
- /usr
|
||||
- /usr/java
|
||||
- /usr/lib
|
||||
- /usr/local
|
||||
- /opt\"
|
||||
+ PREFIXES=\"%%LOCALBASE%%\"
|
||||
|
||||
for SUNJAVA in \\
|
||||
- jre1.5.0_01 \\
|
||||
- jdk1.5.0_01/jre \\
|
||||
- j2re1.4.2_06 \\
|
||||
- j2sdk1.4.2_06/jre \\
|
||||
- j2re1.4.2_04 \\
|
||||
- j2sdk1.4.2_04/jre \\
|
||||
- j2re1.4.2_03 \\
|
||||
- j2sdk1.4.2_03/jre \\
|
||||
- j2re1.4.2_02 \\
|
||||
- j2sdk1.4.2_02/jre \\
|
||||
- j2re1.4.2_01 \\
|
||||
- j2sdk1.4.2_01/jre \\
|
||||
- j2re1.4.2 \\
|
||||
- j2sdk1.4.2/jre \\
|
||||
- j2re1.4.1_01 \\
|
||||
- j2re1.4.1 \\
|
||||
- SUNJava2-1.4.1 \\
|
||||
- BlackdownJava2-1.4.1/jre \\
|
||||
- j2re1.4.0_01 \\
|
||||
- j2sdk1.4.0_01/jre \\
|
||||
- j2re1.4.0 \\
|
||||
- jre1.4.0 \\
|
||||
- j2se/1.4/jre \\
|
||||
- j2se/1.3/jre \\
|
||||
- j2se/jre \\
|
||||
- jre1.3.1_15 \\
|
||||
- jre1.3.1_04 \\
|
||||
- jre1.3.1_02 \\
|
||||
- jre1.3.1_01 \\
|
||||
- j2re1.3.1 \\
|
||||
- jre1.3.1 \\
|
||||
- j2re1.3 \\
|
||||
- j2se/1.3/jre \\
|
||||
- SunJava2-1.3/jre \\
|
||||
- java2re \\
|
||||
jdk1.2.2/jre \\
|
||||
- jdk1.2/jre \\
|
||||
- jre \\
|
||||
- java \\
|
||||
+ jdk1.3.1/jre \\
|
||||
+ jdk1.4.2/jre \\
|
||||
; do
|
||||
for PREFIX in \${PREFIXES}; do
|
||||
if test -f \"\${PREFIX}/\${SUNJAVA}/lib/${wrapper_sunjava_machine}/libjava.so\"; then OPERA_JAVA_DIR=\"\${PREFIX}/\${SUNJAVA}/lib/${wrapper_sunjava_machine}\" && break; fi
|
||||
@@ -970,11 +932,8 @@
|
||||
|
||||
# Acrobat Reader
|
||||
for BINDIR in \\
|
||||
- /usr/local/Acrobat[45]/bin \\
|
||||
- /usr/lib/Acrobat[45]/bin \\
|
||||
- /usr/X11R6/lib/Acrobat[45]/bin \\
|
||||
- /opt/Acrobat[45]/bin \\
|
||||
- /usr/Acrobat[45]/bin \\
|
||||
+ %%LOCALBASE%%/Acrobat4/bin \\
|
||||
+ %%LOCALBASE%%/Acrobat5/bin \\
|
||||
; do
|
||||
if test -d \${BINDIR} ; then PATH=\${PATH}:\${BINDIR}; fi
|
||||
done
|
||||
@@ -985,12 +944,13 @@
|
||||
LD_LIBRARY_PATH=\"\${OPERA_BINARYDIR}:\${LD_LIBRARY_PATH}\"
|
||||
export LD_LIBRARY_PATH
|
||||
|
||||
-# Spellchecker needs to find libaspell.so.15
|
||||
+# Spellchecker needs to find libaspell.so.16
|
||||
for LIBASPELL_DIR in \\
|
||||
+ %%LOCALBASE%%/lib \\
|
||||
/usr/local/lib \\
|
||||
/opkg/lib \\
|
||||
; do
|
||||
- if test -f \"\${LIBASPELL_DIR}/libaspell.so.15\"; then
|
||||
+ if test -f \"\${LIBASPELL_DIR}/libaspell.so.16\"; then
|
||||
LD_LIBRARY_PATH=\"\${LD_LIBRARY_PATH}:\${LIBASPELL_DIR}\"
|
||||
fi
|
||||
done
|
||||
@@ -1080,7 +1040,7 @@
|
||||
chop "${OPERADESTDIR}" "str_localdirshare"
|
||||
chop "${OPERADESTDIR}" "str_localdirplugin"
|
||||
|
||||
- backup ${wrapper_dir}/opera opera
|
||||
+ #backup ${wrapper_dir}/opera opera
|
||||
|
||||
# Executable
|
||||
debug_msg 1 "Executable"
|
||||
@@ -1115,7 +1075,7 @@
|
||||
|
||||
#cp $cpv $cpf wrapper.sh $wrapper_dir/opera
|
||||
generate_wrapper
|
||||
- chmod $chmodv 755 $wrapper_dir/opera
|
||||
+ chmod $chmodv 755 $wrapper_file
|
||||
|
||||
# Documentation
|
||||
debug_msg 1 "Documentation"
|
||||
@@ -1288,36 +1248,13 @@
|
||||
|
||||
if test -z "${OPERADESTDIR}"; then
|
||||
|
||||
- # System wide configuration files
|
||||
- config_dir='/usr/local/etc'
|
||||
- if can_write_to "$config_dir"; then
|
||||
- echo
|
||||
- echo "System wide configuration files:"
|
||||
- echo " $config_dir/opera6rc"
|
||||
- echo " $config_dir/opera6rc.fixed"
|
||||
- echo " cannot be prefixed"
|
||||
- if con_firm "Do you want to install them"; then
|
||||
- backup $config_dir/opera6rc opera6rc config
|
||||
- backup $config_dir/opera6rc.fixed opera6rc.fixed config
|
||||
- cp $cpv $cpf config/opera6rc $config_dir
|
||||
- cp $cpv $cpf config/opera6rc.fixed $config_dir
|
||||
- fi
|
||||
- else
|
||||
- echo
|
||||
- echo "User \"${USERNAME}\" does not have write access to $config_dir"
|
||||
- echo " System wide configuration files:"
|
||||
- echo " $config_dir/opera6rc"
|
||||
- echo " $config_dir/opera6rc.fixed"
|
||||
- echo " were not installed"
|
||||
- fi
|
||||
-
|
||||
# Shorcuts and Icons
|
||||
- icons
|
||||
+ #icons
|
||||
gnome
|
||||
kde 3
|
||||
- kde 2
|
||||
- kde1
|
||||
- mandrake
|
||||
+ #kde 2
|
||||
+ #kde1
|
||||
+ #mandrake
|
||||
|
||||
fi # OPERADESTDIR
|
||||
|
||||
@@ -1345,13 +1282,13 @@
|
||||
{
|
||||
# arg1 = location
|
||||
|
||||
- wmconfig_file="${1}/opera"
|
||||
+ wmconfig_file="${1}/opera-devel"
|
||||
|
||||
- wmconfig_contain='opera name "Opera"
|
||||
+ wmconfig_contain='opera name "Opera Beta"
|
||||
opera description "Opera Web Browser"
|
||||
opera icon "opera.xpm"
|
||||
opera mini-icon "opera.xpm"
|
||||
-opera exec "opera &"
|
||||
+opera exec "opera-devel &"
|
||||
opera group "Internet"'
|
||||
|
||||
echo "${wmconfig_contain}" > ${wmconfig_file}
|
||||
@@ -1362,12 +1299,12 @@
|
||||
{
|
||||
# arg1 = location
|
||||
|
||||
- desktop_file="${1}/opera.desktop"
|
||||
+ desktop_file="${1}/opera-devel.desktop"
|
||||
|
||||
desktop_contain='[Desktop Entry]
|
||||
-Name=Opera
|
||||
+Name=Opera Beta
|
||||
Comment=Web Browser
|
||||
-Exec=opera
|
||||
+Exec=opera-devel
|
||||
Icon=opera.xpm
|
||||
Terminal=0
|
||||
Type=Application'
|
||||
@@ -1446,72 +1383,36 @@
|
||||
|
||||
debug_msg 1 "in gnome()"
|
||||
|
||||
- if test -d /opt/gnome/; then
|
||||
-
|
||||
- # /opt/gnome share
|
||||
- if test -d /opt/gnome/share; then
|
||||
+ if test -d %%X11BASE%%/share/gnome/; then
|
||||
|
||||
- # /opt/gnome icon
|
||||
- if test ! -d /opt/gnome/share/pixmaps/; then
|
||||
- if test -w /opt/gnome/share; then
|
||||
- mkdir $mkdirv $mkdirp /opt/gnome/share/pixmaps/
|
||||
- chmod $chmodv 755 /opt/gnome/share/pixmaps
|
||||
- cp $cpv $share_dir/images/opera.xpm /opt/gnome/share/pixmaps/opera.xpm
|
||||
+ # %%X11BASE%%/share/gnome icon
|
||||
+ if test ! -d %%X11BASE%%/share/gnome/pixmaps/; then
|
||||
+ if test -w %%X11BASE%%/share/gnome; then
|
||||
+ mkdir $mkdirv $mkdirp %%X11BASE%%/share/gnome/pixmaps/
|
||||
+ chmod $chmodv 755 %%X11BASE%%/share/gnome/pixmaps
|
||||
+ cp $cpv $share_dir/images/opera.xpm %%X11BASE%%/share/gnome/pixmaps/opera.xpm
|
||||
fi
|
||||
- elif test -w /opt/gnome/share/pixmaps; then cp $cpv $share_dir/images/opera.xpm /opt/gnome/share/pixmaps/opera.xpm
|
||||
+ elif test -w %%X11BASE%%/share/gnome/pixmaps; then cp $cpv $share_dir/images/opera.xpm %%X11BASE%%/share/gnome/pixmaps/opera.xpm
|
||||
fi
|
||||
- # end /opt/gnome icon
|
||||
+ # end %%X11BASE%%/share/gnome icon
|
||||
|
||||
- # /opt/gnome link
|
||||
- if test -d /opt/gnome/share/gnome/apps/; then
|
||||
- if test -d /opt/gnome/share/gnome/apps/Internet/; then
|
||||
- if test -w /opt/gnome/share/gnome/apps/Internet; then
|
||||
- generate_desktop /opt/gnome/share/gnome/apps/Internet
|
||||
+ # %%X11BASE%%/share/gnome link
|
||||
+ if test -d %%X11BASE%%/share/gnome/apps/; then
|
||||
+ if test -d %%X11BASE%%/share/gnome/apps/Internet/; then
|
||||
+ if test -w %%X11BASE%%/share/gnome/apps/Internet; then
|
||||
+ generate_desktop %%X11BASE%%/share/gnome/apps/Internet
|
||||
fi
|
||||
- elif test -d /opt/gnome/share/gnome/apps/Networking/WWW/; then
|
||||
- if test -w /opt/gnome/share/gnome/apps/Networking/WWW; then
|
||||
- generate_desktop /opt/gnome/share/gnome/apps/Networking/WWW
|
||||
+ elif test -d %%X11BASE%%/share/gnome/apps/Networking/WWW/; then
|
||||
+ if test -w %%X11BASE%%/share/gnome/apps/Networking/WWW; then
|
||||
+ generate_desktop %%X11BASE%%/share/gnome/apps/Networking/WWW
|
||||
fi
|
||||
- elif test -w /opt/gnome/share/gnome/apps; then
|
||||
- mkdir $mkdirv $mkdirp /opt/gnome/share/gnome/apps/Internet/
|
||||
- chmod $chmodv 755 /opt/gnome/share/gnome/apps/Internet
|
||||
- generate_desktop /opt/gnome/share/gnome/apps/Internet
|
||||
+ elif test -w %%X11BASE%%/share/gnome/apps; then
|
||||
+ mkdir $mkdirv $mkdirp %%X11BASE%%/share/gnome/apps/Internet/
|
||||
+ chmod $chmodv 755 %%X11BASE%%/share/gnome/apps/Internet
|
||||
+ generate_desktop %%X11BASE%%/share/gnome/apps/Internet
|
||||
fi
|
||||
fi
|
||||
- # end /opt/gnome link
|
||||
- fi
|
||||
- # end /opt/gnome share
|
||||
-
|
||||
- elif test -d /usr/share/gnome/; then
|
||||
-
|
||||
- # /usr/share/gnome icon
|
||||
- if test ! -d /usr/share/gnome/pixmaps/; then
|
||||
- if test -w /usr/share/gnome; then
|
||||
- mkdir $mkdirv $mkdirp /usr/share/gnome/pixmaps/
|
||||
- chmod $chmodv 755 /usr/share/gnome/pixmaps
|
||||
- cp $cpv $share_dir/images/opera.xpm /usr/share/gnome/pixmaps/opera.xpm
|
||||
- fi
|
||||
- elif test -w /usr/share/gnome/pixmaps; then cp $cpv $share_dir/images/opera.xpm /usr/share/gnome/pixmaps/opera.xpm
|
||||
- fi
|
||||
- # end /usr/share/gnome icon
|
||||
-
|
||||
- # /usr/share/gnome link
|
||||
- if test -d /usr/share/gnome/apps/; then
|
||||
- if test -d /usr/share/gnome/apps/Internet/; then
|
||||
- if test -w /usr/share/gnome/apps/Internet; then
|
||||
- generate_desktop /usr/share/gnome/apps/Internet
|
||||
- fi
|
||||
- elif test -d /usr/share/gnome/apps/Networking/WWW/; then
|
||||
- if test -w /usr/share/gnome/apps/Networking/WWW; then
|
||||
- generate_desktop /usr/share/gnome/apps/Networking/WWW
|
||||
- fi
|
||||
- elif test -w /usr/share/gnome/apps; then
|
||||
- mkdir $mkdirv $mkdirp /usr/share/gnome/apps/Internet/
|
||||
- chmod $chmodv 755 /usr/share/gnome/apps/Internet
|
||||
- generate_desktop /usr/share/gnome/apps/Internet
|
||||
- fi
|
||||
- fi
|
||||
- # end /usr/share/gnome link
|
||||
+ # end %%X11BASE%%/share/gnome link
|
||||
fi
|
||||
# Add ximian here
|
||||
}
|
||||
@@ -1522,39 +1423,31 @@
|
||||
|
||||
debug_msg 1 "in kde()"
|
||||
|
||||
- if test -d /opt/kde${1}/share; then
|
||||
+ if test -d %%LOCALBASE%%/share; then
|
||||
|
||||
- DIR_HI=/opt/kde${1}/share/icons/hicolor
|
||||
+ DIR_HI=%%LOCALBASE%%/share/icons/hicolor
|
||||
if test -d "$DIR_HI" -a -w "$DIR_HI"; then
|
||||
if test -d "$DIR_HI"/48x48/apps -a -w "$DIR_HI"/48x48/apps; then cp $cpv $share_dir/images/opera_48x48.png $DIR_HI/48x48/apps/opera.png; fi
|
||||
if test -d "$DIR_HI"/32x32/apps -a -w "$DIR_HI"/32x32/apps; then cp $cpv $share_dir/images/opera_32x32.png $DIR_HI/32x32/apps/opera.png; fi
|
||||
if test -d "$DIR_HI"/22x22/apps -a -w "$DIR_HI"/22x22/apps; then cp $cpv $share_dir/images/opera_22x22.png $DIR_HI/22x22/apps/opera.png; fi
|
||||
fi
|
||||
|
||||
- DIR_LO=/opt/kde${1}/share/icons/locolor
|
||||
+ DIR_LO=%%LOCALBASE%%/share/icons/locolor
|
||||
if test -d $DIR_LO -a -w $DIR_LO; then
|
||||
if test -d $DIR_LO/32x32/apps -a -w $DIR_LO/32x32/apps; then cp $cpv $share_dir/images/opera_32x32.png $DIR_LO/32x32/apps/opera.png; fi
|
||||
if test -d $DIR_LO/22x22/apps -a -w $DIR_LO/22x22/apps; then cp $cpv $share_dir/images/opera_22x22.png $DIR_LO/22x22/apps/opera.png; fi
|
||||
if test -d $DIR_LO/16x16/apps -a -w $DIR_LO/16x16/apps; then cp $cpv $share_dir/images/opera_16x16.png $DIR_LO/16x16/apps/opera.png; fi
|
||||
fi
|
||||
|
||||
- if test -d /opt/kde${1}/share/applnk/; then
|
||||
- if test ! -d /opt/kde${1}/share/applnk/Internet/ -a -w /opt/kde${1}/share/applnk; then
|
||||
- mkdir $mkdirv $mkdirp /opt/kde${1}/share/applnk/Internet/
|
||||
- chmod $chmodv 755 /opt/kde${1}/share/applnk/Internet
|
||||
+ if test -d %%LOCALBASE%%/share/applnk/; then
|
||||
+ if test ! -d %%LOCALBASE%%/share/applnk/Internet/ -a -w %%LOCALBASE%%/share/applnk; then
|
||||
+ mkdir $mkdirv $mkdirp %%LOCALBASE%%/share/applnk/Internet/
|
||||
+ chmod $chmodv 755 %%LOCALBASE%%/share/applnk/Internet
|
||||
fi
|
||||
- if test -w /opt/kde${1}/share/applnk/Internet; then generate_desktop /opt/kde${1}/share/applnk/Internet ${1}; fi
|
||||
+ if test -w %%LOCALBASE%%/share/applnk/Internet; then generate_desktop %%LOCALBASE%%/share/applnk/Internet ${1}; fi
|
||||
fi
|
||||
|
||||
fi
|
||||
-
|
||||
- if test -d /usr/share/applnk/Networking; then
|
||||
- if test ! -d /usr/share/applnk/Networking/WWW/ -a -w /usr/share/applnk/Networking; then
|
||||
- mkdir $mkdirv $mkdirp /usr/share/applnk/Networking/WWW/
|
||||
- chmod $chmodv 755 /usr/share/applnk/Networking/WWW
|
||||
- fi
|
||||
- if test -w /usr/share/applnk/Networking/WWW; then generate_desktop /usr/share/applnk/Networking/WWW ${1}; fi
|
||||
- fi
|
||||
}
|
||||
|
||||
kde1()
|
@ -1,39 +0,0 @@
|
||||
--- search.ini.orig Tue Jan 4 22:01:32 2005
|
||||
+++ search.ini Mon Jan 24 20:45:39 2005
|
||||
@@ -409,8 +409,34 @@
|
||||
Nameid=0
|
||||
|
||||
[Search Engine 32]
|
||||
-Name=Google Linu&x
|
||||
-URL=http://www.google.com/linux?q=%s&sourceid=opera&num=%i&ie=utf-8&oe=utf-8
|
||||
+Name=Google &BSD
|
||||
+URL=http://www.google.com/bsd?q=%s&sourceid=opera&num=%i&ie=utf-8&oe=utf-8
|
||||
+Query=
|
||||
+Key=x
|
||||
+Is post=0
|
||||
+Has endseparator=0
|
||||
+Encoding=utf-8
|
||||
+Search Type=0
|
||||
+Verbtext=17063
|
||||
+Position=-1
|
||||
+Nameid=0
|
||||
+
|
||||
+[Search Engine 33]
|
||||
+Name=FreeBSD &PRs
|
||||
+URL=http://www.freebsd.org/cgi/query-pr.cgi?pr=%s
|
||||
+Query=
|
||||
+Key=x
|
||||
+Is post=0
|
||||
+Has endseparator=0
|
||||
+Encoding=utf-8
|
||||
+Search Type=0
|
||||
+Verbtext=17063
|
||||
+Position=-1
|
||||
+Nameid=0
|
||||
+
|
||||
+[Search Engine 34]
|
||||
+Name=FreshP&orts
|
||||
+URL=http://www.freshports.org/search.php?query=%s
|
||||
Query=
|
||||
Key=x
|
||||
Is post=0
|
@ -1,18 +0,0 @@
|
||||
Opera 7 is a substantial upgrade, with code rewritten from the rendering engine
|
||||
and up, resulting in the fastest, smallest, most full-featured desktop browser
|
||||
ever released.
|
||||
|
||||
-New rendering engine
|
||||
Opera's new rendering engine supports W3C's DOM (Document Object Model) level 2,
|
||||
non-standard dynamic HTML (DHTML), CSS1 and CSS2, ECMAScript, and has improved
|
||||
HTML 4.01 support, as well as complete support for WML 1.3 and 2.0. It is
|
||||
faster, smaller and can dynamically change documents through DOM.
|
||||
|
||||
-M2 -- new e-mail client
|
||||
Opera's new e-mail client, M2, automatically categorizes and sorts e-mail
|
||||
messages by contact and has an integrated spam filter. Innovative features such
|
||||
as QuickReply and QuickFind lets users answer or find e-mails at unrivalled
|
||||
speed. M2 supports POP3, IMAP, ESMTP, and threaded display of mailing lists.
|
||||
In addition, M2 supports news servers with password authentication.
|
||||
|
||||
WWW: http://www.opera.com/
|
@ -1,9 +0,0 @@
|
||||
***
|
||||
This port will use the ~/.opera-devel directory to save its personal settings.
|
||||
|
||||
If you are running FreeBSD 5.x and are experiencing a core dump when starting
|
||||
Opera, try updating the compat4x port.
|
||||
|
||||
*** THIS IS AN UNSTABLE PREVIEW VERSION OF OPERA. PLEASE DO NOT REPORT ***
|
||||
*** BUGS TO THE PORT MAINTAINER. ***
|
||||
***
|
@ -1,102 +0,0 @@
|
||||
@comment $FreeBSD$
|
||||
bin/opera-devel
|
||||
%%DOCSDIR%%/LICENSE
|
||||
%%DATADIR%%/bin/missingsyms.so
|
||||
%%DATADIR%%/bin/opera
|
||||
%%DATADIR%%/bin/spellcheck.so
|
||||
%%DATADIR%%/bin/works
|
||||
%%DATADIR%%/chartables.bin
|
||||
%%DATADIR%%/config/opera6rc
|
||||
%%DATADIR%%/config/opera6rc.fixed
|
||||
%%DATADIR%%/hhd.ssr
|
||||
%%DATADIR%%/html40_entities.dtd
|
||||
%%DATADIR%%/images/blank.gif
|
||||
%%DATADIR%%/images/drive.gif
|
||||
%%DATADIR%%/images/file.gif
|
||||
%%DATADIR%%/images/folder.gif
|
||||
%%DATADIR%%/images/link.gif
|
||||
%%DATADIR%%/images/opera.xpm
|
||||
%%DATADIR%%/images/opera_16x16.png
|
||||
%%DATADIR%%/images/opera_22x22.png
|
||||
%%DATADIR%%/images/opera_32x32.png
|
||||
%%DATADIR%%/images/opera_48x48.png
|
||||
%%DATADIR%%/images/operabanner.png
|
||||
%%DATADIR%%/ini/dialog.ini
|
||||
%%DATADIR%%/ini/fastforward.ini
|
||||
%%DATADIR%%/ini/filehandler.ini
|
||||
%%DATADIR%%/ini/pluginpath.ini
|
||||
%%DATADIR%%/ini/spellcheck.ini
|
||||
%%DATADIR%%/ini/standard_keyboard.ini
|
||||
%%DATADIR%%/ini/standard_menu.ini
|
||||
%%DATADIR%%/ini/standard_mouse.ini
|
||||
%%DATADIR%%/ini/standard_toolbar.ini
|
||||
%%DATADIR%%/ini/unix_keyboard.ini
|
||||
%%DATADIR%%/java/opera.jar
|
||||
%%DATADIR%%/java/opera.policy
|
||||
%%DATADIR%%/jsconsole.html
|
||||
%%DATADIR%%/lngcode.txt
|
||||
%%DATADIR%%/locale/en/default.adr
|
||||
%%DATADIR%%/locale/en/lngcode.txt
|
||||
%%DATADIR%%/locale/en/license.txt
|
||||
%%DATADIR%%/locale/en/search.ini
|
||||
%%DATADIR%%/locale/english.lng
|
||||
%%DATADIR%%/opera6.adr
|
||||
%%DATADIR%%/plugins/libnpp.so
|
||||
%%DATADIR%%/plugins/operamotifwrapper-1
|
||||
%%DATADIR%%/plugins/operamotifwrapper-2
|
||||
%%DATADIR%%/plugins/operaplugincleaner
|
||||
%%DATADIR%%/search.ini
|
||||
%%DATADIR%%/skin/standard_skin.zip
|
||||
%%DATADIR%%/skin/windows_skin.zip
|
||||
%%DATADIR%%/styles/OPF.css
|
||||
%%DATADIR%%/styles/about.css
|
||||
%%DATADIR%%/styles/cache.css
|
||||
%%DATADIR%%/styles/certinfo.css
|
||||
%%DATADIR%%/styles/csr.css
|
||||
%%DATADIR%%/styles/dir.css
|
||||
%%DATADIR%%/styles/drives.css
|
||||
%%DATADIR%%/styles/email.css
|
||||
%%DATADIR%%/styles/history.css
|
||||
%%DATADIR%%/styles/im.css
|
||||
%%DATADIR%%/styles/info.css
|
||||
%%DATADIR%%/styles/mime.css
|
||||
%%DATADIR%%/styles/mimehead.css
|
||||
%%DATADIR%%/styles/opf.css
|
||||
%%DATADIR%%/styles/plugins.css
|
||||
%%DATADIR%%/styles/user/accessibility.css
|
||||
%%DATADIR%%/styles/user/contrastbw.css
|
||||
%%DATADIR%%/styles/user/contrastwb.css
|
||||
%%DATADIR%%/styles/user/debugwithoutline.css
|
||||
%%DATADIR%%/styles/user/disabletables.css
|
||||
%%DATADIR%%/styles/user/hidecertainsizes.css
|
||||
%%DATADIR%%/styles/user/hidenonlinkimages.css
|
||||
%%DATADIR%%/styles/user/imageandlinkonly.css
|
||||
%%DATADIR%%/styles/user/nostalgia.css
|
||||
%%DATADIR%%/styles/user/showstructure.css
|
||||
%%DATADIR%%/styles/user/textonly.css
|
||||
%%DATADIR%%/styles/user/userstyle.ini
|
||||
%%DATADIR%%/styles/wml.css
|
||||
%%GNOME%%share/gnome/apps/Internet/opera-devel.desktop
|
||||
%%GNOME%%share/gnome/pixmaps/opera.xpm
|
||||
@dirrm %%DATADIR%%/styles/user
|
||||
@dirrm %%DATADIR%%/styles
|
||||
@dirrm %%DATADIR%%/skin
|
||||
@dirrm %%DATADIR%%/plugins
|
||||
@dirrm %%DATADIR%%/locale/en
|
||||
@dirrm %%DATADIR%%/locale
|
||||
@dirrm %%DATADIR%%/java
|
||||
@dirrm %%DATADIR%%/ini
|
||||
@dirrm %%DATADIR%%/images
|
||||
@dirrm %%DATADIR%%/config
|
||||
@dirrm %%DATADIR%%/bin
|
||||
@dirrm %%DATADIR%%
|
||||
@dirrm %%DOCSDIR%%
|
||||
|
||||
%%KDE%%@cwd %%LOCALBASE%%
|
||||
%%KDE%%share/applnk/Internet/opera-devel.desktop
|
||||
%%KDE%%share/icons/hicolor/22x22/apps/opera.png
|
||||
%%KDE%%share/icons/hicolor/32x32/apps/opera.png
|
||||
%%KDE%%share/icons/hicolor/48x48/apps/opera.png
|
||||
%%KDE%%share/icons/locolor/16x16/apps/opera.png
|
||||
%%KDE%%share/icons/locolor/22x22/apps/opera.png
|
||||
%%KDE%%share/icons/locolor/32x32/apps/opera.png
|
Loading…
Reference in New Issue
Block a user