- Update to 1.4.0
PR: ports/66180 Submitted by: klm <klm@uidzero.org> (maintainer)
This commit is contained in:
parent
0b8d5e8c75
commit
ec949d4e6e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=108223
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= webjob
|
||||
PORTVERSION= 1.3.0
|
||||
PORTVERSION= 1.4.0
|
||||
CATEGORIES= sysutils security
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= webjob
|
||||
@ -27,7 +27,7 @@ CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
|
||||
.if defined(NO_STATIC)
|
||||
CFLAGS+=
|
||||
.else
|
||||
CFLAGS+= -static
|
||||
CFLAGS+= -static
|
||||
.endif
|
||||
|
||||
MAN1= webjob.1
|
||||
|
@ -1,2 +1,2 @@
|
||||
MD5 (webjob-1.3.0.tgz) = 60225d5e50319c016005e2255a5d4564
|
||||
SIZE (webjob-1.3.0.tgz) = 160356
|
||||
MD5 (webjob-1.4.0.tgz) = 7fd5a78128fcd7bb6a793c73f77eb31d
|
||||
SIZE (webjob-1.4.0.tgz) = 182868
|
||||
|
@ -1,17 +0,0 @@
|
||||
diff -urP webjob-1.3.0/configure webjob-1.3.0.amd64/configure
|
||||
--- configure.orig Fri Jul 25 18:19:17 2003
|
||||
+++ configure Sun Apr 4 23:52:02 2004
|
||||
@@ -1413,6 +1413,13 @@
|
||||
_ACEOF
|
||||
|
||||
;;
|
||||
+amd64*)
|
||||
+
|
||||
+cat >>confdefs.h <<\_ACEOF
|
||||
+#define K_CPU_AMD64 1
|
||||
+_ACEOF
|
||||
+
|
||||
+ ;;
|
||||
ia64*)
|
||||
|
||||
cat >>confdefs.h <<\_ACEOF
|
@ -1,13 +0,0 @@
|
||||
diff -urP webjob-1.3.0/configure.in webjob-1.3.0.amd64/configure.in
|
||||
--- configure.in.orig Thu Jun 26 14:01:14 2003
|
||||
+++ configure.in Sun Apr 4 23:47:36 2004
|
||||
@@ -87,6 +87,9 @@
|
||||
alpha*)
|
||||
AC_DEFINE(K_CPU_ALPHA, 1, Define to 1 if the host cpu is alpha.)
|
||||
;;
|
||||
+amd64*)
|
||||
+ AC_DEFINE(K_CPU_AMD64, 1, Define to 1 if the host cpu is amd64.)
|
||||
+ ;;
|
||||
ia64*)
|
||||
AC_DEFINE(K_CPU_IA64, 1, Define to 1 if the host cpu is ia64.)
|
||||
;;
|
@ -1,13 +0,0 @@
|
||||
diff -urP webjob-1.3.0/src/config.h.in webjob-1.3.0.amd64/src/config.h.in
|
||||
--- src/config.h.in.orig Fri Jul 25 18:19:19 2003
|
||||
+++ src/config.h.in Sun Apr 4 23:52:03 2004
|
||||
@@ -161,6 +161,9 @@
|
||||
/* Define to 1 if the host cpu is alpha. */
|
||||
#undef K_CPU_ALPHA
|
||||
|
||||
+/* Define to 1 if the host cpu is amd64. */
|
||||
+#undef K_CPU_AMD64
|
||||
+
|
||||
/* Define to 1 if the host cpu is iX86. */
|
||||
#undef K_CPU_I386
|
||||
|
@ -1,57 +0,0 @@
|
||||
diff -urP webjob-1.3.0/src/http.c webjob-1.3.0.amd64/src/http.c
|
||||
--- src/http.c.orig Wed Jul 23 15:16:07 2003
|
||||
+++ src/http.c Sun Apr 4 23:49:52 2004
|
||||
@@ -144,7 +144,7 @@
|
||||
sprintf(pcRequest, "%s %s%s%s HTTP/1.1\r\n"
|
||||
"Host: %s:%d\r\n"
|
||||
"Content-Type: application/octet-stream\r\n"
|
||||
-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
|
||||
+#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
|
||||
"Content-Length: %u\r\n"
|
||||
#else
|
||||
"Content-Length: %lu\r\n"
|
||||
@@ -166,7 +166,7 @@
|
||||
sprintf(pcRequest, "%s %s%s%s HTTP/1.1\r\n"
|
||||
"Host: %s:%d\r\n"
|
||||
"Content-Type: application/octet-stream\r\n"
|
||||
-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
|
||||
+#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
|
||||
"Content-Length: %u\r\n"
|
||||
#else
|
||||
"Content-Length: %lu\r\n"
|
||||
@@ -1283,7 +1283,7 @@
|
||||
*/
|
||||
if (ui32ContentLength > (K_UINT32) HTTP_MAX_MEMORY_SIZE)
|
||||
{
|
||||
-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
|
||||
+#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
|
||||
snprintf(pcError, MESSAGE_SIZE, "%s: Content-Length = [%u] > [%u]: Length exceeds internally defined limit.",
|
||||
#else
|
||||
snprintf(pcError, MESSAGE_SIZE, "%s: Content-Length = [%lu] > [%lu]: Length exceeds internally defined limit.",
|
||||
@@ -1339,7 +1339,7 @@
|
||||
}
|
||||
if (ui32Offset != ui32ContentLength)
|
||||
{
|
||||
-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
|
||||
+#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
|
||||
snprintf(pcError, MESSAGE_SIZE, "%s: Actual-Length = [%u] != [%u]: Actual-Length vs Content-Length Mismatch.",
|
||||
#else
|
||||
snprintf(pcError, MESSAGE_SIZE, "%s: Actual-Length = [%lu] != [%lu]: Actual-Length vs Content-Length Mismatch.",
|
||||
@@ -1409,7 +1409,7 @@
|
||||
}
|
||||
if (ui32Offset != ui32ContentLength)
|
||||
{
|
||||
-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
|
||||
+#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
|
||||
snprintf(pcError, MESSAGE_SIZE, "%s: Actual-Length = [%u] != [%u]: Actual-Length vs Content-Length Mismatch.",
|
||||
#else
|
||||
snprintf(pcError, MESSAGE_SIZE, "%s: Actual-Length = [%lu] != [%lu]: Actual-Length vs Content-Length Mismatch.",
|
||||
@@ -2164,7 +2164,7 @@
|
||||
*/
|
||||
if (psURL->ui32DownloadLimit != 0 && psResponseHeader->ui32ContentLength > psURL->ui32DownloadLimit)
|
||||
{
|
||||
-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
|
||||
+#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
|
||||
snprintf(pcError, MESSAGE_SIZE, "%s: Content-Length = [%u] > [%u]: Length exceeds user defined limit.",
|
||||
#else
|
||||
snprintf(pcError, MESSAGE_SIZE, "%s: Content-Length = [%lu] > [%lu]: Length exceeds user defined limit.",
|
@ -1,12 +0,0 @@
|
||||
diff -urP webjob-1.3.0/src/ktypes.h webjob-1.3.0.amd64/src/ktypes.h
|
||||
--- src/ktypes.h.orig Sun Jun 15 22:49:21 2003
|
||||
+++ src/ktypes.h Sun Apr 4 23:50:01 2004
|
||||
@@ -11,7 +11,7 @@
|
||||
*/
|
||||
|
||||
#if defined(UNIX)
|
||||
- #if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
|
||||
+ #if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
|
||||
typedef char K_INT08;
|
||||
typedef unsigned char K_UINT08;
|
||||
typedef short K_INT16;
|
@ -1,12 +0,0 @@
|
||||
diff -urP webjob-1.3.0/src/webjob.c webjob-1.3.0.amd64/src/webjob.c
|
||||
--- src/webjob.c.orig Thu Jul 24 23:05:17 2003
|
||||
+++ src/webjob.c Sun Apr 4 23:50:08 2004
|
||||
@@ -1478,7 +1478,7 @@
|
||||
return ER;
|
||||
}
|
||||
|
||||
-#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64)
|
||||
+#if defined(K_CPU_ALPHA) || defined(K_CPU_IA64) || defined(K_CPU_AMD64)
|
||||
sprintf(acQuery, "VERSION=%s&SYSTEM=%s&CLIENTID=%s&FILENAME=%s&RUNTYPE=%s&STDOUT_LENGTH=%u&STDERR_LENGTH=%u&STDENV_LENGTH=%u",
|
||||
#else
|
||||
sprintf(acQuery, "VERSION=%s&SYSTEM=%s&CLIENTID=%s&FILENAME=%s&RUNTYPE=%s&STDOUT_LENGTH=%lu&STDERR_LENGTH=%lu&STDENV_LENGTH=%lu",
|
@ -1,9 +1,14 @@
|
||||
WebJob downloads a program over HTTP/HTTPS and executes it in one
|
||||
unified operation. The output, if any, may be directed to stdout/stderr
|
||||
or a Web resource. WebJob may be useful in incident response and
|
||||
intrusion analysis as it provides a mechanism to run known good
|
||||
diagnostic programs on a potentially compromised system. It can
|
||||
also support a variety of centralized management and host-based
|
||||
monitoring solutions.
|
||||
WebJob downloads a program or script from a remote WebJob server
|
||||
over HTTP/HTTPS and executes it in one unified operation. Any output
|
||||
produced by the program/script is packaged up and sent to a remote,
|
||||
possibly different, WebJob server. WebJob is useful because it
|
||||
provides a mechanism for running known good programs on damaged or
|
||||
potentially compromised systems. This makes it ideal for remote
|
||||
diagnostics, incident response, and evidence collection. WebJob
|
||||
also provides a framework that is conducive to centralized management.
|
||||
Therefore, it can support and help automate a large number of common
|
||||
administrative tasks and host-based monitoring scenarios such as
|
||||
periodic system checks, file updates, integrity monitoring,
|
||||
patch/package management, and so on.
|
||||
|
||||
WWW: http://webjob.sourceforge.net/WebJob/
|
||||
|
@ -1,2 +1,3 @@
|
||||
bin/webjob
|
||||
etc/nph-webjob.cfg.sample
|
||||
etc/webjob.cfg.sample
|
||||
|
Loading…
Reference in New Issue
Block a user