- Unbreak with gcc42
- Clean up a bit
This commit is contained in:
parent
eb62318cff
commit
ec7b6ca63f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=195593
@ -9,7 +9,8 @@ PORTNAME= rat
|
||||
PORTVERSION= 3.0.35
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= mbone audio
|
||||
MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/rat/releases/${PORTVERSION}/
|
||||
MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/rat/releases/${PORTVERSION}/ \
|
||||
CENKES
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= IPv4/v6 Multicast and unicast audio conferencing tool
|
||||
@ -20,22 +21,15 @@ WRKSRC= ${WRKDIR}/rat-3.0
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAN1= rat.1
|
||||
MANCOMPRESSED= no
|
||||
PLIST_FILES= bin/rat30
|
||||
|
||||
LATEST_LINK= rat30
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700042
|
||||
BROKEN= Does not compile with GCC 4.2
|
||||
.endif
|
||||
|
||||
do-build:
|
||||
(cd ${WRKSRC};${SETENV} ${MAKE_ENV} MAKE=${GMAKE} ${SH} ./Build rat)
|
||||
cd ${WRKSRC};${SETENV} ${MAKE_ENV} MAKE=${GMAKE} ${SH} ./Build rat
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/rat ${PREFIX}/bin/rat30
|
||||
${INSTALL_MAN} ${WRKSRC}/man/man1/rat.1 ${PREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/man/man1/rat.1 ${MAN1PREFIX}/man/man1/
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Makefile.orig Tue Sep 14 12:39:00 1999
|
||||
+++ Makefile Sat Mar 17 18:16:04 2007
|
||||
--- ./Makefile.orig 1999-09-14 14:39:00.000000000 +0400
|
||||
+++ ./Makefile 2007-07-14 20:49:46.000000000 +0400
|
||||
@@ -10,8 +10,8 @@
|
||||
# -DDEBUG_RTP -DREPEAT
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Makefile_FreeBSD_4.org Mon May 7 13:07:46 2001
|
||||
+++ Makefile_FreeBSD_4 Mon May 7 13:03:51 2001
|
||||
--- ./Makefile_FreeBSD_4.orig 2007-07-14 20:49:46.000000000 +0400
|
||||
+++ ./Makefile_FreeBSD_4 2007-07-14 20:49:46.000000000 +0400
|
||||
@@ -0,0 +1,6 @@
|
||||
+TCL_INC = ${LOCALBASE}/include/tcl8.2
|
||||
+TK_INC = ${LOCALBASE}/include/tk8.2
|
||||
|
12
audio/rat30/files/patch-src__codec_encoder.c
Normal file
12
audio/rat30/files/patch-src__codec_encoder.c
Normal file
@ -0,0 +1,12 @@
|
||||
--- ./src/codec_encoder.c.orig 2007-07-14 20:50:06.000000000 +0400
|
||||
+++ ./src/codec_encoder.c 2007-07-14 20:53:12.000000000 +0400
|
||||
@@ -48,7 +48,8 @@
|
||||
int i;
|
||||
sample *d;
|
||||
|
||||
- d = (sample *)c->data = (sample *)block_alloc(SAMPLES_PER_UNIT * BYTES_PER_SAMPLE);
|
||||
+ c->data = (sample *)block_alloc(SAMPLES_PER_UNIT * BYTES_PER_SAMPLE);
|
||||
+ d = (sample *)c->data;
|
||||
c->data_len = SAMPLES_PER_UNIT * BYTES_PER_SAMPLE;
|
||||
for (i=0; i < SAMPLES_PER_UNIT; i++) {
|
||||
*d++ = htons(*data);
|
@ -9,7 +9,8 @@ PORTNAME= rat
|
||||
PORTVERSION= 3.0.35
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= mbone audio
|
||||
MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/rat/releases/${PORTVERSION}/
|
||||
MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/rat/releases/${PORTVERSION}/ \
|
||||
CENKES
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= IPv4/v6 Multicast and unicast audio conferencing tool
|
||||
@ -20,22 +21,15 @@ WRKSRC= ${WRKDIR}/rat-3.0
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAN1= rat.1
|
||||
MANCOMPRESSED= no
|
||||
PLIST_FILES= bin/rat30
|
||||
|
||||
LATEST_LINK= rat30
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 700042
|
||||
BROKEN= Does not compile with GCC 4.2
|
||||
.endif
|
||||
|
||||
do-build:
|
||||
(cd ${WRKSRC};${SETENV} ${MAKE_ENV} MAKE=${GMAKE} ${SH} ./Build rat)
|
||||
cd ${WRKSRC};${SETENV} ${MAKE_ENV} MAKE=${GMAKE} ${SH} ./Build rat
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/bin/rat ${PREFIX}/bin/rat30
|
||||
${INSTALL_MAN} ${WRKSRC}/man/man1/rat.1 ${PREFIX}/man/man1
|
||||
${INSTALL_MAN} ${WRKSRC}/man/man1/rat.1 ${MAN1PREFIX}/man/man1/
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Makefile.orig Tue Sep 14 12:39:00 1999
|
||||
+++ Makefile Sat Mar 17 18:16:04 2007
|
||||
--- ./Makefile.orig 1999-09-14 14:39:00.000000000 +0400
|
||||
+++ ./Makefile 2007-07-14 20:49:46.000000000 +0400
|
||||
@@ -10,8 +10,8 @@
|
||||
# -DDEBUG_RTP -DREPEAT
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- Makefile_FreeBSD_4.org Mon May 7 13:07:46 2001
|
||||
+++ Makefile_FreeBSD_4 Mon May 7 13:03:51 2001
|
||||
--- ./Makefile_FreeBSD_4.orig 2007-07-14 20:49:46.000000000 +0400
|
||||
+++ ./Makefile_FreeBSD_4 2007-07-14 20:49:46.000000000 +0400
|
||||
@@ -0,0 +1,6 @@
|
||||
+TCL_INC = ${LOCALBASE}/include/tcl8.2
|
||||
+TK_INC = ${LOCALBASE}/include/tk8.2
|
||||
|
12
mbone/rat30/files/patch-src__codec_encoder.c
Normal file
12
mbone/rat30/files/patch-src__codec_encoder.c
Normal file
@ -0,0 +1,12 @@
|
||||
--- ./src/codec_encoder.c.orig 2007-07-14 20:50:06.000000000 +0400
|
||||
+++ ./src/codec_encoder.c 2007-07-14 20:53:12.000000000 +0400
|
||||
@@ -48,7 +48,8 @@
|
||||
int i;
|
||||
sample *d;
|
||||
|
||||
- d = (sample *)c->data = (sample *)block_alloc(SAMPLES_PER_UNIT * BYTES_PER_SAMPLE);
|
||||
+ c->data = (sample *)block_alloc(SAMPLES_PER_UNIT * BYTES_PER_SAMPLE);
|
||||
+ d = (sample *)c->data;
|
||||
c->data_len = SAMPLES_PER_UNIT * BYTES_PER_SAMPLE;
|
||||
for (i=0; i < SAMPLES_PER_UNIT; i++) {
|
||||
*d++ = htons(*data);
|
Loading…
Reference in New Issue
Block a user