math/hmat-oss: Disable compiler warnings as errors (remove -Werror)

PR:		266844
Reported by:	diizzy@
This commit is contained in:
Yuri Victorovich 2022-10-05 08:47:40 -07:00
parent eb4f12cbda
commit ec68d8b9d9
1 changed files with 14 additions and 0 deletions

View File

@ -0,0 +1,14 @@
--- CMakeLists.txt.orig 2022-10-05 15:44:52 UTC
+++ CMakeLists.txt
@@ -255,9 +255,9 @@ include(CheckCCompilerFlag)
include(CheckCXXCompilerFlag)
function(hmat_set_compiler_flags _TARGET_NAME)
- check_cxx_compiler_flag("-Werror -Wall" HAVE_COMPILER_WARNING_FLAGS)
+ check_cxx_compiler_flag("-Wall" HAVE_COMPILER_WARNING_FLAGS)
if(HAVE_COMPILER_WARNING_FLAGS)
- target_compile_options(${_TARGET_NAME} PRIVATE -Werror -Wall)
+ target_compile_options(${_TARGET_NAME} PRIVATE -Wall)
foreach(flag -Wno-sign-compare;-Wno-undefined-var-template;-Wno-unused-parameter)
string(REPLACE "-" "_" varname ${flag})
check_cxx_compiler_flag("${flag}" CXX${varname})