devel/bmake: disable cmd-interrupt test in batch builds

This fixes the build under modern poudriere, but continues to run the test
in all other environments so that we *can* catch issues here if they arise.

The breakage should get fixed on the poudriere or base sh(1) side, but this
will not necessarily be done soon.

Reported by:	mjg
Approved by:	portmgr (implicit, bulk fix)
MFH:		2020Q4 (blanket: trivial build fix)
This commit is contained in:
Kyle Evans 2020-10-05 03:42:16 +00:00
parent 0416aabda7
commit ec4cc8ce74
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=551474
2 changed files with 15 additions and 0 deletions

View File

@ -17,6 +17,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV+= CONFIG_SITE=${CONFIG_SITE}
.if defined(BATCH)
EXTRA_PATCHES= ${FILESDIR}/extrapatch-unit-tests_Makefile
.endif
post-patch: .SILENT
${REINPLACE_CMD} 's/^\.Nx/NetBSD/' ${WRKDIR}/bmake/bmake.1

View File

@ -0,0 +1,11 @@
--- unit-tests/Makefile.orig 2020-10-05 03:28:18 UTC
+++ unit-tests/Makefile
@@ -36,7 +36,7 @@
# src/tests/usr.bin/make/t_make.sh as well.
TESTS+= # archive # broken on FreeBSD, enabled in t_make.sh
TESTS+= archive-suffix
-TESTS+= cmd-interrupt
+TESTS+= # cmd-interrupt
TESTS+= cmdline
TESTS+= comment
TESTS+= cond-cmp-numeric