Update to 1.4.0.

This commit is contained in:
Joe Marcus Clarke 2008-07-06 19:48:31 +00:00
parent d58734c674
commit ebf457224c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=216409
6 changed files with 32 additions and 23 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= loudmouth
PORTVERSION= 1.2.3
PORTREVISION= 4
PORTVERSION= 1.4.0
CATEGORIES= net-im gnome
MASTER_SITES= http://ftp.imendio.com/pub/imendio/loudmouth/src/ \
${MASTER_SITE_GNOME}
@ -20,9 +19,9 @@ LIB_DEPENDS= idn.16:${PORTSDIR}/dns/libidn
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
USE_GNOME= gnomehack glib20
USE_GNOME= gnomehack glib20 ltverhack
CONFIGURE_ARGS= --disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"

View File

@ -1,3 +1,3 @@
MD5 (loudmouth-1.2.3.tar.bz2) = 7e25b0e13498dcb671d60d0cd62091b8
SHA256 (loudmouth-1.2.3.tar.bz2) = 41f775303e76436add3c0141e485246223a60bbbcf90a7e90ed2b5baf6e2602b
SIZE (loudmouth-1.2.3.tar.bz2) = 325864
MD5 (loudmouth-1.4.0.tar.bz2) = d9504bb4251d4e5b32cb379debda634d
SHA256 (loudmouth-1.4.0.tar.bz2) = 67cad76c18a138b9b55bf6ff88a5796128371cf9339b3761b36f79fb4e7459d7
SIZE (loudmouth-1.4.0.tar.bz2) = 381235

View File

@ -0,0 +1,12 @@
--- loudmouth/Makefile.in.orig 2008-07-06 15:44:25.000000000 -0400
+++ loudmouth/Makefile.in 2008-07-06 15:43:53.000000000 -0400
@@ -306,8 +306,7 @@ libloudmouthinclude_HEADERS = \
libloudmouth_1_la_LIBADD = \
$(LOUDMOUTH_LIBS) \
- $(LIBIDN_LIBS) \
- -lresolv
+ $(LIBIDN_LIBS)
libloudmouth_1_la_LDFLAGS = \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \

View File

@ -1,14 +1,13 @@
--- loudmouth/lm-sock.c.orig Mon Apr 16 23:37:43 2007
+++ loudmouth/lm-sock.c Mon Apr 16 23:38:08 2007
@@ -273,9 +273,11 @@
case EAI_FAIL:
return _("The nameserver encountered errors "
"looking up this address");
+#ifdef EAI_NODATA
case EAI_NODATA:
return _("The remote host exists but no address "
"is available");
+#endif
case EAI_NONAME:
return _("The remote address is unknown");
case EAI_FAMILY:
--- loudmouth/lm-sock.c.orig 2008-07-06 15:41:02.000000000 -0400
+++ loudmouth/lm-sock.c 2008-07-06 15:43:01.000000000 -0400
@@ -27,8 +27,10 @@
#include <errno.h>
#include <string.h>
#include <unistd.h>
+#include <sys/types.h>
#include <sys/socket.h>
#include <fcntl.h>
+#include <netinet/in_systm.h>
#include <netinet/in.h>
#include <netinet/ip.h>
#include <netinet/tcp.h>

View File

@ -2,4 +2,4 @@ Loudmouth is a lightweight and easy-to-use C library for programming with the
Jabber protocol. It's designed to be easy to get started with and yet
extensible to let you do anything the Jabber protocol allows.
WWW: http://developer.imendio.com/projects/loudmouth/
WWW: http://www.loudmouth-project.org/

View File

@ -24,7 +24,6 @@ share/gtk-doc/html/loudmouth/loudmouth-lm-message.html
share/gtk-doc/html/loudmouth/loudmouth-lm-message-node.html
share/gtk-doc/html/loudmouth/loudmouth-lm-proxy.html
share/gtk-doc/html/loudmouth/loudmouth-lm-ssl.html
share/gtk-doc/html/loudmouth/loudmouth-lm-utils.html
share/gtk-doc/html/loudmouth/loudmouth.devhelp
share/gtk-doc/html/loudmouth/loudmouth.devhelp2
share/gtk-doc/html/loudmouth/right.png