Several helpers CMake modules needed to build LXQt itself as well as other

components.

WWW: https://github.com/lxde/lxqt-build-tools

Obtained from:	LXQt devel repo
This commit is contained in:
Olivier Duchateau 2016-12-12 17:45:01 +00:00
parent 98273597d8
commit ebe1fd0a23
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=428424
7 changed files with 77 additions and 1 deletions

View File

@ -9,6 +9,7 @@
#
# Available LXQt components are:
#
# buildtools - Helpers CMake modules
# libfmqt - Libfm Qt bindings
# lxqt - LXQt core library
# qtxdg - Qt implementation of freedesktop.org xdg specs
@ -42,7 +43,11 @@ CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR=${MANDIRS} \
-DPULL_TRANSLATIONS:BOOL=OFF
# Available LXQt components are:
_USE_LXQT_ALL= libfmqt lxqt qtxdg
_USE_LXQT_ALL= buildtools libfmqt lxqt qtxdg
_DATAROOTDIR= ${LOCALBASE}/share
buildtools_BUILD_DEPENDS= ${_DATAROOTDIR}/cmake/lxqt-build-tools/lxqt-build-tools-config.cmake:devel/lxqt-build-tools
libfmqt_LIB_DEPENDS= libfm-qt.so:x11/libfm-qt

View File

@ -1567,6 +1567,7 @@
SUBDIR += luajava
SUBDIR += lutok
SUBDIR += lwp
SUBDIR += lxqt-build-tools
SUBDIR += m17n-db
SUBDIR += m17n-docs
SUBDIR += m17n-lib

View File

@ -0,0 +1,28 @@
# Created by: Olivier Duchateau
# $FreeBSD$
PORTNAME= lxqt-build-tools
PORTVERSION= 0.3.0
CATEGORIES= devel
MASTER_SITES= LXQT/${PORTNAME}
MAINTAINER= olivierd@FreeBSD.org
COMMENT= Helpers CMake modules for LXQt
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/BSD-3-Clause
USES= cmake:outsource lxqt pkgconfig tar:xz
USE_QT5= qmake_build buildtools_build core
.include <bsd.port.pre.mk>
# When the CXX compiler is GNU 4.2.1 (DragonFlyBSD seems to have >= 4.7.x)
# we get the following errors:
# cc1plus: error: unrecognized command line option "-flto"
# cc1plus: error: unrecognized command line option "-fuse-linker-plugin"
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000024
EXTRA_PATCHES= ${FILESDIR}/extra-patch-cmake_modules_LXQtCompilerSettings.cmake
.endif
.include <bsd.port.post.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1481464588
SHA256 (lxqt/lxqt-build-tools-0.3.0.tar.xz) = 850124c0b76be38859745542fa45cb65191034d32b4fbc9f3399c867db69c008
SIZE (lxqt/lxqt-build-tools-0.3.0.tar.xz) = 19024

View File

@ -0,0 +1,13 @@
--- cmake/modules/LXQtCompilerSettings.cmake.orig 2016-12-06 20:31:16 UTC
+++ cmake/modules/LXQtCompilerSettings.cmake
@@ -144,7 +144,9 @@ endif()
if (CMAKE_COMPILER_IS_GNUCXX OR LXQT_COMPILER_IS_CLANGCXX)
# -flto: use link-time optimizations to generate more efficient code
if (CMAKE_COMPILER_IS_GNUCXX)
- set(LTO_FLAGS "-flto -fuse-linker-plugin")
+ if (NOT ${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
+ set(LTO_FLAGS "-flto -fuse-linker-plugin")
+ endif ()
elseif (LXQT_COMPILER_IS_CLANGCXX)
# The link-time optimization of clang++/llvm seems to be too aggrassive.
# After testing, it breaks the signal/slots of QObject sometimes.

View File

@ -0,0 +1,4 @@
Several helpers CMake modules needed to build LXQt itself as well as other
components.
WWW: https://github.com/lxde/lxqt-build-tools

View File

@ -0,0 +1,22 @@
share/cmake/lxqt-build-tools/find-modules/FindFm.cmake
share/cmake/lxqt-build-tools/find-modules/FindGLIB.cmake
share/cmake/lxqt-build-tools/find-modules/FindMenuCache.cmake
share/cmake/lxqt-build-tools/find-modules/FindUDev.cmake
share/cmake/lxqt-build-tools/find-modules/FindXCB.cmake
share/cmake/lxqt-build-tools/find-modules/FindXdgUserDirs.cmake
share/cmake/lxqt-build-tools/lxqt-build-tools-config-version.cmake
share/cmake/lxqt-build-tools/lxqt-build-tools-config.cmake
share/cmake/lxqt-build-tools/modules/LXQtAppTranslationLoader.cpp.in
share/cmake/lxqt-build-tools/modules/LXQtCompilerSettings.cmake
share/cmake/lxqt-build-tools/modules/LXQtConfigVars.cmake
share/cmake/lxqt-build-tools/modules/LXQtCreatePkgConfigFile.cmake
share/cmake/lxqt-build-tools/modules/LXQtCreatePortableHeaders.cmake
share/cmake/lxqt-build-tools/modules/LXQtLibTranslationLoader.cpp.in
share/cmake/lxqt-build-tools/modules/LXQtPluginTranslationLoader.cpp.in
share/cmake/lxqt-build-tools/modules/LXQtTranslate.cmake
share/cmake/lxqt-build-tools/modules/LXQtTranslateDesktop.cmake
share/cmake/lxqt-build-tools/modules/LXQtTranslateTs.cmake
share/cmake/lxqt-build-tools/modules/LXQtTranslationLoader.cmake
share/cmake/lxqt-build-tools/modules/Qt5PatchedLinguistToolsMacros.cmake
share/cmake/lxqt-build-tools/modules/Qt5TranslationLoader.cmake
share/cmake/lxqt-build-tools/modules/Qt5TranslationLoader.cpp.in