Update www/cutelyst to latest release.
https://dantti.wordpress.com/2019/02/18/cutelyst-2-7-0-released-async-is-back/ Main new feature is support for async calls. While here, pet portlint and add a PLIST_SUB.
This commit is contained in:
parent
9ebdcff277
commit
eba5fde54f
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=493359
@ -2,8 +2,7 @@
|
||||
|
||||
PORTNAME= cutelyst
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 2.4.0
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 2.7.0
|
||||
CATEGORIES= www
|
||||
|
||||
MAINTAINER= adridg@FreeBSD.org
|
||||
@ -17,9 +16,12 @@ USE_GITHUB= yes
|
||||
USE_LDCONFIG= yes
|
||||
USE_QT= qmake_build buildtools_build \
|
||||
core network sql
|
||||
|
||||
CMAKE_ARGS= -DBUILD_ALL=OFF \
|
||||
-DBUILD_TESTS=OFF \
|
||||
-DMANDIR:PATH=man \
|
||||
-DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=TRUE
|
||||
|
||||
PLIST_SUB= SOVER=${DISTVERSION}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1527770048
|
||||
SHA256 (cutelyst-cutelyst-v2.4.0_GH0.tar.gz) = 85680f5a7d21ad49475067addb06a10c9902597df6ab697b1a92eeb2683cb85d
|
||||
SIZE (cutelyst-cutelyst-v2.4.0_GH0.tar.gz) = 449452
|
||||
TIMESTAMP = 1550569411
|
||||
SHA256 (cutelyst-cutelyst-v2.7.0_GH0.tar.gz) = f87c2f04b148a50f5df13aa5d75b45bf20e56be2e2cd6e17c2aef5231db4b467
|
||||
SIZE (cutelyst-cutelyst-v2.7.0_GH0.tar.gz) = 459601
|
||||
|
@ -2,33 +2,37 @@ FreeBSD isn't Linux, in spite of being a non-Apple UNIX.
|
||||
There's unreached code in the patch showing how we *could*
|
||||
do it if (when) libepoll-shim supports the whole API needed.
|
||||
|
||||
--- CMakeLists.txt.orig 2018-05-29 15:08:25 UTC
|
||||
--- CMakeLists.txt.orig 2019-02-15 20:30:30 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -161,10 +161,26 @@ install(EXPORT CutelystTargets
|
||||
add_subdirectory(Cutelyst)
|
||||
|
||||
if(UNIX AND NOT APPLE)
|
||||
- set(LINUX TRUE)
|
||||
+ # set(LINUX TRUE)
|
||||
+ set(LINUX FALSE) # FreeBSD isn't Linux
|
||||
@@ -166,7 +166,30 @@ if(UNIX AND NOT (APPLE OR HAIKU))
|
||||
endif()
|
||||
|
||||
if (LINUX)
|
||||
+ # Try to find the EPOLL implementation from libepoll-shim; while
|
||||
+ # epoll.h is found, and timerfd.h is found, the implementation
|
||||
+ # in timerfd is insufficient (missing timerfd_gettime), and besides
|
||||
+ # that there is also no eventfd.h.
|
||||
+ #
|
||||
+ # So switch off EPoll anyway.
|
||||
+ find_file(EPOLL_H sys/epoll.h
|
||||
+ HINTS libepoll-shim /usr/local/include/libepoll-shim
|
||||
+ )
|
||||
+ if (EPOLL_H)
|
||||
+ get_filename_component(EPOLL_SYS_DIR ${EPOLL_H} DIRECTORY)
|
||||
+ get_filename_component(EPOLL_DIR ${EPOLL_SYS_DIR} DIRECTORY)
|
||||
+ include_directories(${EPOLL_DIR})
|
||||
- add_subdirectory(EventLoopEPoll)
|
||||
+ if(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
|
||||
+ # FreeBSD isn't Linux, but it gets claimed as Linux, above.
|
||||
+ #
|
||||
+ # Try to find the EPOLL implementation from libepoll-shim; while
|
||||
+ # epoll.h is found, and timerfd.h is found, the implementation
|
||||
+ # in timerfd is insufficient (missing timerfd_gettime), and besides
|
||||
+ # that there is also no eventfd.h.
|
||||
+ #
|
||||
+ # So, do the work of finding EPOLL, but don't use that subdirectory.
|
||||
+ # Also, decide that we're not Linux after all.
|
||||
+ find_file(EPOLL_H sys/epoll.h
|
||||
+ HINTS libepoll-shim /usr/local/include/libepoll-shim
|
||||
+ )
|
||||
+ if (EPOLL_H)
|
||||
+ get_filename_component(EPOLL_SYS_DIR ${EPOLL_H} DIRECTORY)
|
||||
+ get_filename_component(EPOLL_DIR ${EPOLL_SYS_DIR} DIRECTORY)
|
||||
+ include_directories(${EPOLL_DIR})
|
||||
+ # add_subdirectory(EventLoopEPoll)
|
||||
+ endif()
|
||||
+ set(LINUX FALSE)
|
||||
+ else()
|
||||
+ # Real Linux
|
||||
+ add_subdirectory(EventLoopEPoll)
|
||||
+ endif()
|
||||
+
|
||||
add_subdirectory(EventLoopEPoll)
|
||||
endif()
|
||||
|
||||
add_subdirectory(wsgi)
|
||||
|
@ -25,6 +25,8 @@ include/cutelyst2-qt5/Cutelyst/Plugins/Session/sessionstorefile.h
|
||||
include/cutelyst2-qt5/Cutelyst/Plugins/StaticSimple/StaticSimple
|
||||
include/cutelyst2-qt5/Cutelyst/Plugins/StaticSimple/staticsimple.h
|
||||
include/cutelyst2-qt5/Cutelyst/Plugins/StatusMessage
|
||||
include/cutelyst2-qt5/Cutelyst/Plugins/UserAgent
|
||||
include/cutelyst2-qt5/Cutelyst/Plugins/useragent.h
|
||||
include/cutelyst2-qt5/Cutelyst/Plugins/Utils/LangSelect
|
||||
include/cutelyst2-qt5/Cutelyst/Plugins/Utils/Pagination
|
||||
include/cutelyst2-qt5/Cutelyst/Plugins/Utils/Sql
|
||||
@ -114,42 +116,46 @@ lib/cutelyst2-plugins/libActionRenderView.so
|
||||
lib/cutelyst2-plugins/libActionRoleACL.so
|
||||
lib/libCutelyst2Qt5.so
|
||||
lib/libCutelyst2Qt5.so.2
|
||||
lib/libCutelyst2Qt5.so.2.4.0
|
||||
lib/libCutelyst2Qt5.so.%%SOVER%%
|
||||
lib/libCutelyst2Qt5Authentication.so
|
||||
lib/libCutelyst2Qt5Authentication.so.2
|
||||
lib/libCutelyst2Qt5Authentication.so.2.4.0
|
||||
lib/libCutelyst2Qt5Authentication.so.%%SOVER%%
|
||||
lib/libCutelyst2Qt5Session.so
|
||||
lib/libCutelyst2Qt5Session.so.2
|
||||
lib/libCutelyst2Qt5Session.so.2.4.0
|
||||
lib/libCutelyst2Qt5Session.so.%%SOVER%%
|
||||
lib/libCutelyst2Qt5StaticSimple.so
|
||||
lib/libCutelyst2Qt5StaticSimple.so.2
|
||||
lib/libCutelyst2Qt5StaticSimple.so.2.4.0
|
||||
lib/libCutelyst2Qt5StaticSimple.so.%%SOVER%%
|
||||
lib/libCutelyst2Qt5StatusMessage.so
|
||||
lib/libCutelyst2Qt5StatusMessage.so.2
|
||||
lib/libCutelyst2Qt5StatusMessage.so.2.4.0
|
||||
lib/libCutelyst2Qt5StatusMessage.so.%%SOVER%%
|
||||
lib/libCutelyst2Qt5UserAgent.so
|
||||
lib/libCutelyst2Qt5UserAgent.so.2
|
||||
lib/libCutelyst2Qt5UserAgent.so.%%SOVER%%
|
||||
lib/libCutelyst2Qt5UtilsLangSelect.so
|
||||
lib/libCutelyst2Qt5UtilsLangSelect.so.2
|
||||
lib/libCutelyst2Qt5UtilsLangSelect.so.2.4.0
|
||||
lib/libCutelyst2Qt5UtilsLangSelect.so.%%SOVER%%
|
||||
lib/libCutelyst2Qt5UtilsPagination.so
|
||||
lib/libCutelyst2Qt5UtilsPagination.so.2
|
||||
lib/libCutelyst2Qt5UtilsPagination.so.2.4.0
|
||||
lib/libCutelyst2Qt5UtilsPagination.so.%%SOVER%%
|
||||
lib/libCutelyst2Qt5UtilsSql.so
|
||||
lib/libCutelyst2Qt5UtilsSql.so.2
|
||||
lib/libCutelyst2Qt5UtilsSql.so.2.4.0
|
||||
lib/libCutelyst2Qt5UtilsSql.so.%%SOVER%%
|
||||
lib/libCutelyst2Qt5UtilsValidator.so
|
||||
lib/libCutelyst2Qt5UtilsValidator.so.2
|
||||
lib/libCutelyst2Qt5UtilsValidator.so.2.4.0
|
||||
lib/libCutelyst2Qt5UtilsValidator.so.%%SOVER%%
|
||||
lib/libCutelyst2Qt5ViewJson.so
|
||||
lib/libCutelyst2Qt5ViewJson.so.2
|
||||
lib/libCutelyst2Qt5ViewJson.so.2.4.0
|
||||
lib/libCutelyst2Qt5ViewJson.so.%%SOVER%%
|
||||
lib/libCutelyst2Qt5Wsgi.so
|
||||
lib/libCutelyst2Qt5Wsgi.so.2
|
||||
lib/libCutelyst2Qt5Wsgi.so.2.4.0
|
||||
lib/libCutelyst2Qt5Wsgi.so.%%SOVER%%
|
||||
libdata/pkgconfig/Cutelyst2Qt5Authentication.pc
|
||||
libdata/pkgconfig/Cutelyst2Qt5Core.pc
|
||||
libdata/pkgconfig/Cutelyst2Qt5Session.pc
|
||||
libdata/pkgconfig/Cutelyst2Qt5StaticSimple.pc
|
||||
libdata/pkgconfig/Cutelyst2Qt5StatusMessage.pc
|
||||
libdata/pkgconfig/Cutelyst2Qt5UserAgent.pc
|
||||
libdata/pkgconfig/Cutelyst2Qt5UtilsLangSelect.pc
|
||||
libdata/pkgconfig/Cutelyst2Qt5UtilsPagination.pc
|
||||
libdata/pkgconfig/Cutelyst2Qt5UtilsSql.pc
|
||||
|
Loading…
Reference in New Issue
Block a user