- Update to 2.2

PR:		177273
Submitted by:	Ports Fury
This commit is contained in:
Martin Wilke 2013-03-23 18:00:59 +00:00
parent 2b89b4734d
commit eb62be4a99
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315060
5 changed files with 28 additions and 72 deletions

View File

@ -1,29 +1,40 @@
# New ports collection makefile for: xtrlock
# Date created: 18 May 2004
# Whom: Alexey Mikhailov <karma@ez.pereslavl.ru>
#
# Created by: Alexey Mikhailov <karma@ez.pereslavl.ru>
# $FreeBSD$
#
PORTNAME= xtrlock
PORTVERSION= 2.0.14
PORTVERSION= 2.2
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/x/xtrlock/
DISTNAME= ${PORTNAME}_2.0-${PORTVERSION:E}
MASTER_SITES= DEBIAN
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= X Transparent Lock
LICENSE= GPLv2 # or higher
LICENSE_FILE= ${WRKSRC}/debian/copyright
LICENSE= GPLv2 # (or later)
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_XORG= x11
WRKSRC= ${WRKDIR}/${PORTNAME}-2.0
MAKEFILE= ${FILESDIR}/Makefile
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lX11 -lcrypt
MAN1= xtrlock.1
PLIST_FILES= bin/xtrlock
post-extract:
@${LN} -sf xtrlock.man ${WRKSRC}/xtrlock.1
post-patch:
@${REINPLACE_CMD} -e \
's|<crypt.h>|<unistd.h>| ; \
s|<values.h>|<limits.h>|' ${WRKSRC}/xtrlock.c
do-build:
(cd ${WRKSRC} && ${CC} ${CFLAGS} -o xtrlock xtrlock.c ${LDFLAGS})
do-install:
(cd ${WRKSRC} && ${INSTALL_PROGRAM} xtrlock ${PREFIX}/bin)
(cd ${WRKSRC} && ${INSTALL_MAN} xtrlock.1 ${MANPREFIX}/man/man1)
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (xtrlock_2.0-14.tar.gz) = 2b25b6b91c33e61f1b9f6acf292cc34c58d8f04b00e4e3d2689c1b13c6714fbe
SIZE (xtrlock_2.0-14.tar.gz) = 7746
SHA256 (xtrlock_2.2.tar.gz) = eed63851f4ad9f3026fd0a73767c8d2e5e2b973e050d271be6ec5086faa11ef6
SIZE (xtrlock_2.2.tar.gz) = 20716

View File

@ -1,39 +0,0 @@
# Makefile for xtrlock - X Transparent Lock
# This Makefile provided for those of you who lack a functioning xmkmf.
#
# Copyright (C)1993,1994 Ian Jackson
#
# This is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2, or (at your option)
# any later version.
#
# This is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
#
# $FreeBSD$
#
LDLIBS=-lX11 -lcrypt
CC?=gcc
CFLAGS+=-I${LOCALBASE}/include -L${LOCALBASE}/lib
INSTALL=install -c
INSTALL_PROGRAM = ${INSTALL}
INSTPGMFLAGS = -s -o root -m4111
OBJS=xtrlock.o
xtrlock: xtrlock.o
${CC} ${CFLAGS} ${LDLIBS} -o xtrlock ${OBJS}
xtrlock.o: xtrlock.c lock.bitmap mask.bitmap patchlevel.h
${CC} -c ${CFLAGS} xtrlock.c
install: xtrlock install.man
$(INSTALL_PROGRAM) $(INSTPGMFLAGS) xtrlock ${PREFIX}/bin
install.man:
$(INSTALL) -m 644 xtrlock.man ${PREFIX}/man/man1/xtrlock.1
all: xtrlock

View File

@ -1,18 +0,0 @@
$FreeBSD$
--- xtrlock.c.orig Sun Aug 22 18:08:41 2004
+++ xtrlock.c Sun Aug 22 18:08:58 2004
@@ -31,11 +31,9 @@
#include <grp.h>
#include <limits.h>
#include <string.h>
-#include <crypt.h>
#include <unistd.h>
#include <math.h>
#include <ctype.h>
-#include <values.h>
#ifdef SHADOW_PWD
#include <shadow.h>

View File

@ -1 +1,3 @@
A minimal xlock with minimum usage of resources.
WWW: http://packages.qa.debian.org/x/xtrlock.html