Update to 4.0.4.
This commit is contained in:
parent
196453bfe4
commit
eb4a3f16dd
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=415346
@ -1,9 +1,9 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= gdt
|
||||
PORTVERSION= 4.0
|
||||
PORTVERSION= 4.0.4
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= SF/gds2/gds2/
|
||||
MASTER_SITES= SF/gds2
|
||||
DISTNAME= ${PORTNAME:tu}-${PORTVERSION}
|
||||
|
||||
MAINTAINER= hrs@FreeBSD.org
|
||||
@ -11,7 +11,7 @@ COMMENT= GDS2/GDT format translator
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
USES= shebangfix perl5
|
||||
USES= shebangfix perl5
|
||||
USE_PERL5= run
|
||||
SHEBANG_FILES= Examples/gdsinfo Examples/scalegds
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME:tu}-${PORTVERSION}
|
||||
@ -19,15 +19,15 @@ PLIST_FILES= bin/gdsinfo bin/gds2gdt bin/gdt2gds bin/scalegds
|
||||
|
||||
post-patch:
|
||||
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
|
||||
${WRKSRC}/Examples/gdsinfo ${WRKSRC}/Examples/scalegds
|
||||
${WRKSRC}/Examples/gdsinfo ${WRKSRC}/Examples/scalegds
|
||||
|
||||
pre-build:
|
||||
${INSTALL_DATA} ${FILESDIR}/Makefile ${WRKSRC}
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} \
|
||||
${WRKSRC}/Examples/gdsinfo \
|
||||
${WRKSRC}/Examples/scalegds \
|
||||
${STAGEDIR}${PREFIX}/bin
|
||||
${WRKSRC}/Examples/gdsinfo \
|
||||
${WRKSRC}/Examples/scalegds \
|
||||
${STAGEDIR}${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (GDT-4.0.tar.gz) = 3c1247aa1a8044002edc5db10136a0c9befbf0f49f8c86643189051090ef5fcb
|
||||
SIZE (GDT-4.0.tar.gz) = 46937
|
||||
TIMESTAMP = 1463381718
|
||||
SHA256 (GDT-4.0.4.tar.gz) = 950bbab650d9a75eeaad3305bac90981b9f5765cd1bf00a8ba077e8321ac26cb
|
||||
SIZE (GDT-4.0.4.tar.gz) = 47755
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Examples/gdsinfo.orig 2008-06-20 02:04:27.000000000 +0900
|
||||
+++ Examples/gdsinfo 2013-05-30 10:54:47.000000000 +0900
|
||||
@@ -75,10 +75,7 @@
|
||||
--- Examples/gdsinfo.orig 2016-05-16 17:46:24 UTC
|
||||
+++ Examples/gdsinfo
|
||||
@@ -75,10 +75,7 @@ $topCellNames =~ s/,/ /g;
|
||||
$topCellNames =~ s/\s+/ /g;
|
||||
|
||||
# help find gds2gdt
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- Examples/scalegds.orig 2013-05-30 10:59:09.000000000 +0900
|
||||
+++ Examples/scalegds 2013-05-30 10:58:01.000000000 +0900
|
||||
@@ -72,18 +72,14 @@
|
||||
--- Examples/scalegds.orig 2016-05-16 17:46:24 UTC
|
||||
+++ Examples/scalegds
|
||||
@@ -72,18 +72,14 @@ unless ($color)
|
||||
|
||||
my ($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst) = localtime(time);
|
||||
$mon++; $year += 1900;
|
||||
@ -21,7 +21,7 @@
|
||||
unless ($gdt2gds)
|
||||
{
|
||||
die $REVERSE_RED.ERROR."$COLOR_RESET unable to find gdt2gds in \$PATH";
|
||||
@@ -135,7 +131,7 @@
|
||||
@@ -135,7 +131,7 @@ my $fhJunk = new FileHandle; # not using
|
||||
|
||||
if ($inputFile =~ m/\.(gz|Z)$/)
|
||||
{
|
||||
@ -30,7 +30,7 @@
|
||||
unless ($zcat)
|
||||
{
|
||||
die $REVERSE_RED.ERROR."$COLOR_RESET unable to find zcat in \$PATH";
|
||||
@@ -145,7 +141,7 @@
|
||||
@@ -145,7 +141,7 @@ if ($inputFile =~ m/\.(gz|Z)$/)
|
||||
}
|
||||
elsif ($inputFile =~ m/\.bz2$/)
|
||||
{
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- gdsStream.h.orig Sun Apr 29 15:45:42 2007
|
||||
+++ gdsStream.h Sun Apr 29 15:45:54 2007
|
||||
@@ -3,8 +3,7 @@
|
||||
--- gdsStream.h.orig 2014-12-08 17:16:44 UTC
|
||||
+++ gdsStream.h
|
||||
@@ -4,8 +4,7 @@
|
||||
#define _gdsStream__
|
||||
|
||||
#include <stdio.h>
|
||||
|
Loading…
Reference in New Issue
Block a user