- Update to version 1.3.2
PR: 132753 Submitted by: Ports Fury
This commit is contained in:
parent
0ab35ef387
commit
eaf1e8b44c
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=230803
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= qbittorrent
|
||||
DISTVERSION= 1.0.0
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.3.2
|
||||
CATEGORIES= net-p2p
|
||||
MASTER_SITES= SF
|
||||
|
||||
@ -15,37 +14,35 @@ MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Bittorrent client written in C++ / Qt4 using libtorrent
|
||||
|
||||
LIB_DEPENDS= ccext2-1.6.0:${PORTSDIR}/devel/commoncpp \
|
||||
execinfo.1:${PORTSDIR}/devel/libexecinfo \
|
||||
zzip.13:${PORTSDIR}/devel/zziplib \
|
||||
curl.5:${PORTSDIR}/ftp/curl \
|
||||
torrent.1:${PORTSDIR}/net-p2p/rblibtorrent
|
||||
torrent-rasterbar.2:${PORTSDIR}/net-p2p/rblibtorrent-devel
|
||||
|
||||
USE_PYTHON= 2.3+
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= qmake_build uic_build moc_build rcc_build gui network xml
|
||||
QT_COMPONENTS= corelib gui network xml \
|
||||
moc_build qmake_build rcc_build uic_build
|
||||
QT_NONSTANDARD= yes
|
||||
INSTALLS_ICONS= yes
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-libtorrent-inc="${LOCALBASE}/include" \
|
||||
--with-libtorrent-lib="${LOCALBASE}/lib"
|
||||
CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}"
|
||||
MAKE_ENV= QMAKESPEC="${QMAKESPEC}"
|
||||
|
||||
OPTIONS= IMAGEMAGICK "Enable libmagick++ support" off
|
||||
CONFIGURE_ARGS= --prefix="${PREFIX}" \
|
||||
--with-libtorrent-inc="${LOCALBASE}/include" \
|
||||
--with-libtorrent-lib="${LOCALBASE}/lib" \
|
||||
--with-libcurl-inc="${LOCALBASE}/include" \
|
||||
--with-libcurl-lib="${LOCALBASE}/lib" \
|
||||
--with-libzzip-inc="${LOCALBASE}/include" \
|
||||
--with-libzzip-lib="${LOCALBASE}/lib"
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
MAN1= qbittorrent.1
|
||||
MANCOMPRESSED= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_IMAGEMAGICK)
|
||||
LIB_DEPENDS+= MagickWand.2:${PORTSDIR}/graphics/ImageMagick
|
||||
CONFIGURE_ARGS+=--with-libmagick-inc=${LOCALBASE}/include/ImageMagick
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-libmagick
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|bin/qmake|bin/${QMAKE:T}|' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|$$$$PREFIX/share/man|${MANPREFIX}/man|' \
|
||||
${WRKSRC}/src/src.pro
|
||||
@${ECHO_CMD} "LIBS+= -lexecinfo" >> ${WRKSRC}/src/src.pro
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${PREFIX}/bin/qbittorrent
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (qbittorrent-1.0.0.tar.gz) = e31fe47590dfa48c52d0e35d4627d630
|
||||
SHA256 (qbittorrent-1.0.0.tar.gz) = a247223dd2d3e2490d5c3cce4764d40aaf486548bf77835729d42e82e12aad25
|
||||
SIZE (qbittorrent-1.0.0.tar.gz) = 1384049
|
||||
MD5 (qbittorrent-1.3.2.tar.gz) = 680ea41e5601d5cd7990b303f9ad503c
|
||||
SHA256 (qbittorrent-1.3.2.tar.gz) = f0d269424272ab1d6ce2a161ff7c01ff8ced63f5a7cf25616bbde02298329a5d
|
||||
SIZE (qbittorrent-1.3.2.tar.gz) = 1660128
|
||||
|
@ -0,0 +1,14 @@
|
||||
--- src/createtorrent_imp.cpp.orig 2009-03-07 07:22:19.000000000 +0900
|
||||
+++ src/createtorrent_imp.cpp 2009-03-23 02:00:49.000000000 +0900
|
||||
@@ -245,7 +245,11 @@
|
||||
}
|
||||
if(abort) return;
|
||||
// calculate the hash for all pieces
|
||||
+#if defined(__GNUC__) && __GNUC__ <= 3
|
||||
+ set_piece_hashes(t, full_path.branch_path(), boost::bind(&sendProgressUpdateSignal, _1, t.num_pieces(), parent));
|
||||
+#else
|
||||
set_piece_hashes(t, full_path.branch_path(), boost::bind<void>(&sendProgressUpdateSignal, _1, t.num_pieces(), parent));
|
||||
+#endif
|
||||
// Set qBittorrent as creator and add user comment to
|
||||
// torrent_info structure
|
||||
t.set_creator(creator_str);
|
@ -1,28 +1,8 @@
|
||||
qBittorrent can now be considered as a good alternative to other bittorrent
|
||||
clients. It provides a lot of features such as:
|
||||
qBittorrent is a bittorrent client programmed in C++ / Qt4 that uses
|
||||
libtorrent (sometimes called rblibtorrent) by Arvid Norberg.
|
||||
|
||||
* A polished Graphical User Interface written with Qt4 toolkit.
|
||||
* UPnP / NAT-PMP port forwarding support.
|
||||
* Encryption support (compatible with Azureus).
|
||||
* Multiple simultaneous downloads / uploads.
|
||||
* Download from RSS streams.
|
||||
* An integrated search engine.
|
||||
* DHT (trackerless) support.
|
||||
* uTorrent Peer eXchange support (PeX).
|
||||
* Directory scanning with automated download of torrents inside.
|
||||
* Good internationalization (~25 languages supported).
|
||||
* Selective download of files in a torrent.
|
||||
* Media File previewing while downloading.
|
||||
* Torrent trackers edition and prioritizing.
|
||||
* Seeders / Leechers displayed in download list.
|
||||
* Styles support.
|
||||
* Files prioritizing in a torrent.
|
||||
* Torrent download in correct order.
|
||||
* System tray integration.
|
||||
* Tracker authentication support.
|
||||
* Unicode support.
|
||||
* Torrent downloading directly from their url.
|
||||
* Connection though a proxy.
|
||||
* IP Filtering similar to the one in eMule.
|
||||
It aims to be a good alternative to all other bittorrent clients
|
||||
out there. qBittorrent is fast, stable and provides unicode
|
||||
support as well as many features.
|
||||
|
||||
WWW: http://www.qbittorrent.org/
|
||||
|
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= qbittorrent
|
||||
DISTVERSION= 1.0.0
|
||||
PORTREVISION= 2
|
||||
PORTVERSION= 1.3.2
|
||||
CATEGORIES= net-p2p
|
||||
MASTER_SITES= SF
|
||||
|
||||
@ -15,37 +14,35 @@ MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Bittorrent client written in C++ / Qt4 using libtorrent
|
||||
|
||||
LIB_DEPENDS= ccext2-1.6.0:${PORTSDIR}/devel/commoncpp \
|
||||
execinfo.1:${PORTSDIR}/devel/libexecinfo \
|
||||
zzip.13:${PORTSDIR}/devel/zziplib \
|
||||
curl.5:${PORTSDIR}/ftp/curl \
|
||||
torrent.1:${PORTSDIR}/net-p2p/rblibtorrent
|
||||
torrent-rasterbar.2:${PORTSDIR}/net-p2p/rblibtorrent-devel
|
||||
|
||||
USE_PYTHON= 2.3+
|
||||
USE_QT_VER= 4
|
||||
QT_COMPONENTS= qmake_build uic_build moc_build rcc_build gui network xml
|
||||
QT_COMPONENTS= corelib gui network xml \
|
||||
moc_build qmake_build rcc_build uic_build
|
||||
QT_NONSTANDARD= yes
|
||||
INSTALLS_ICONS= yes
|
||||
HAS_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-libtorrent-inc="${LOCALBASE}/include" \
|
||||
--with-libtorrent-lib="${LOCALBASE}/lib"
|
||||
CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}"
|
||||
MAKE_ENV= QMAKESPEC="${QMAKESPEC}"
|
||||
|
||||
OPTIONS= IMAGEMAGICK "Enable libmagick++ support" off
|
||||
CONFIGURE_ARGS= --prefix="${PREFIX}" \
|
||||
--with-libtorrent-inc="${LOCALBASE}/include" \
|
||||
--with-libtorrent-lib="${LOCALBASE}/lib" \
|
||||
--with-libcurl-inc="${LOCALBASE}/include" \
|
||||
--with-libcurl-lib="${LOCALBASE}/lib" \
|
||||
--with-libzzip-inc="${LOCALBASE}/include" \
|
||||
--with-libzzip-lib="${LOCALBASE}/lib"
|
||||
INSTALLS_ICONS= yes
|
||||
|
||||
MAN1= qbittorrent.1
|
||||
MANCOMPRESSED= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(WITH_IMAGEMAGICK)
|
||||
LIB_DEPENDS+= MagickWand.2:${PORTSDIR}/graphics/ImageMagick
|
||||
CONFIGURE_ARGS+=--with-libmagick-inc=${LOCALBASE}/include/ImageMagick
|
||||
.else
|
||||
CONFIGURE_ARGS+=--disable-libmagick
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|bin/qmake|bin/${QMAKE:T}|' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} -e 's|$$$$PREFIX/share/man|${MANPREFIX}/man|' \
|
||||
${WRKSRC}/src/src.pro
|
||||
@${ECHO_CMD} "LIBS+= -lexecinfo" >> ${WRKSRC}/src/src.pro
|
||||
|
||||
post-install:
|
||||
@${STRIP_CMD} ${PREFIX}/bin/qbittorrent
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (qbittorrent-1.0.0.tar.gz) = e31fe47590dfa48c52d0e35d4627d630
|
||||
SHA256 (qbittorrent-1.0.0.tar.gz) = a247223dd2d3e2490d5c3cce4764d40aaf486548bf77835729d42e82e12aad25
|
||||
SIZE (qbittorrent-1.0.0.tar.gz) = 1384049
|
||||
MD5 (qbittorrent-1.3.2.tar.gz) = 680ea41e5601d5cd7990b303f9ad503c
|
||||
SHA256 (qbittorrent-1.3.2.tar.gz) = f0d269424272ab1d6ce2a161ff7c01ff8ced63f5a7cf25616bbde02298329a5d
|
||||
SIZE (qbittorrent-1.3.2.tar.gz) = 1660128
|
||||
|
14
net-p2p/qbittorrent/files/patch-src__createtorrent_imp.cpp
Normal file
14
net-p2p/qbittorrent/files/patch-src__createtorrent_imp.cpp
Normal file
@ -0,0 +1,14 @@
|
||||
--- src/createtorrent_imp.cpp.orig 2009-03-07 07:22:19.000000000 +0900
|
||||
+++ src/createtorrent_imp.cpp 2009-03-23 02:00:49.000000000 +0900
|
||||
@@ -245,7 +245,11 @@
|
||||
}
|
||||
if(abort) return;
|
||||
// calculate the hash for all pieces
|
||||
+#if defined(__GNUC__) && __GNUC__ <= 3
|
||||
+ set_piece_hashes(t, full_path.branch_path(), boost::bind(&sendProgressUpdateSignal, _1, t.num_pieces(), parent));
|
||||
+#else
|
||||
set_piece_hashes(t, full_path.branch_path(), boost::bind<void>(&sendProgressUpdateSignal, _1, t.num_pieces(), parent));
|
||||
+#endif
|
||||
// Set qBittorrent as creator and add user comment to
|
||||
// torrent_info structure
|
||||
t.set_creator(creator_str);
|
@ -1,28 +1,8 @@
|
||||
qBittorrent can now be considered as a good alternative to other bittorrent
|
||||
clients. It provides a lot of features such as:
|
||||
qBittorrent is a bittorrent client programmed in C++ / Qt4 that uses
|
||||
libtorrent (sometimes called rblibtorrent) by Arvid Norberg.
|
||||
|
||||
* A polished Graphical User Interface written with Qt4 toolkit.
|
||||
* UPnP / NAT-PMP port forwarding support.
|
||||
* Encryption support (compatible with Azureus).
|
||||
* Multiple simultaneous downloads / uploads.
|
||||
* Download from RSS streams.
|
||||
* An integrated search engine.
|
||||
* DHT (trackerless) support.
|
||||
* uTorrent Peer eXchange support (PeX).
|
||||
* Directory scanning with automated download of torrents inside.
|
||||
* Good internationalization (~25 languages supported).
|
||||
* Selective download of files in a torrent.
|
||||
* Media File previewing while downloading.
|
||||
* Torrent trackers edition and prioritizing.
|
||||
* Seeders / Leechers displayed in download list.
|
||||
* Styles support.
|
||||
* Files prioritizing in a torrent.
|
||||
* Torrent download in correct order.
|
||||
* System tray integration.
|
||||
* Tracker authentication support.
|
||||
* Unicode support.
|
||||
* Torrent downloading directly from their url.
|
||||
* Connection though a proxy.
|
||||
* IP Filtering similar to the one in eMule.
|
||||
It aims to be a good alternative to all other bittorrent clients
|
||||
out there. qBittorrent is fast, stable and provides unicode
|
||||
support as well as many features.
|
||||
|
||||
WWW: http://www.qbittorrent.org/
|
||||
|
Loading…
Reference in New Issue
Block a user