add iperf

A tool to measure maximum TCP and UDP bandwidth

PR:		27462
Submitted by:	Pete Fritchman <petef@databits.net>
This commit is contained in:
Ying-Chieh Liao 2001-05-27 17:42:23 +00:00
parent 0ed6d16f6e
commit eaef815e2a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=43158
15 changed files with 195 additions and 0 deletions

27
benchmarks/iperf/Makefile Normal file
View File

@ -0,0 +1,27 @@
# New ports collection makefile for: iperf
# Date Created: 20 May 2001
# Whom: Pete Fritchman <petef@databits.net>
#
# $FreeBSD$
#
PORTNAME= iperf
PORTVERSION= 1.2
CATEGORIES= net
MASTER_SITES= http://dast.nlanr.net/Projects/Iperf/
MAINTAINER= petef@databits.net
NO_CDROM= "can't charge a fee for the software"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/iperf ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/iperf
.for file in README doc/index.html doc/jperf.gif doc/lib.html doc/release.html \
doc/ui_license.html
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/iperf
.endfor
.endif
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (iperf-1.2.tar.gz) = b727074c779f8f3087dec5e455840201

View File

@ -0,0 +1,11 @@
--- cfg/Makefile.orig Sat May 19 23:54:00 2001
+++ cfg/Makefile Sat May 19 23:54:12 2001
@@ -31,7 +31,7 @@
#
all: configure
- ./configure
+ ./configure --cc=${CC} --cxx=${CXX}
clean:
-rm -f $(CLEAN_FILES)

View File

@ -0,0 +1,40 @@
--- cfg/configure.orig Sat May 19 23:45:26 2001
+++ cfg/configure Sat May 19 23:54:28 2001
@@ -90,6 +90,12 @@
| --cache-f=* | --cache-=* | --cache=* | --cach=* | --cac=* | --ca=* | --c=*)
cache_file="$ac_optarg" ;;
+ --cc=*)
+ ac_cv_prog_CC="$ac_optarg" ;;
+
+ --cxx=*)
+ ac_cv_prog_CXX="$ac_optarg" ;;
+
-datadir | --datadir | --datadi | --datad | --data | --dat | --da)
ac_prev=datadir ;;
-datadir=* | --datadir=* | --datadi=* | --datad=* | --data=* | --dat=* \
@@ -952,7 +958,7 @@
echo $ac_n "checking whether the C++ compiler ($CXX $CXXFLAGS $LDFLAGS) is a cross-compiler""... $ac_c" 1>&6
echo "configure:954: checking whether the C++ compiler ($CXX $CXXFLAGS $LDFLAGS) is a cross-compiler" >&5
echo "$ac_t""$ac_cv_prog_cxx_cross" 1>&6
-cross_compiling=$ac_cv_prog_cxx_cross
+cross_compiling="no"
echo $ac_n "checking whether we are using GNU C++""... $ac_c" 1>&6
echo "configure:959: checking whether we are using GNU C++" >&5
@@ -1065,14 +1071,7 @@
echo
-if test -z "$ac_cv_use_pthread"; then
- ac_cv_use_pthread="yes"
-fi
-echo "Make iperf multi-threaded (using pthreads)? [$ac_cv_use_pthread] "
-read tmp
-if test -n "$tmp"; then
- ac_cv_use_pthread="$tmp"
-fi
+ac_cv_use_pthread="no"
if test "$ac_cv_use_pthread" = yes ; then

View File

@ -0,0 +1 @@
A tool to measure maximum TCP and UDP bandwidth

View File

@ -0,0 +1,9 @@
Iperf is a tool for measuring maximum TCP and UDP bandwidth,
reminiscent of ttcp and nettest. It has been written to overcome
the shortcomings of those aging tools. Iperf can also test UDP
bandwidth, loss, and jitter.
WWW: http://dast.nlanr.net/Projects/Iperf/
- Pete
petef@databits.net

View File

@ -0,0 +1,8 @@
bin/iperf
%%PORTDOCS%%share/doc/iperf/README
%%PORTDOCS%%share/doc/iperf/index.html
%%PORTDOCS%%share/doc/iperf/jperf.gif
%%PORTDOCS%%share/doc/iperf/lib.html
%%PORTDOCS%%share/doc/iperf/release.html
%%PORTDOCS%%share/doc/iperf/ui_license.html
%%PORTDOCS%%@dirrm share/doc/iperf

View File

@ -141,6 +141,7 @@
SUBDIR += ipcad
SUBDIR += ipcalc
SUBDIR += ipcheck
SUBDIR += iperf
SUBDIR += ipfm
SUBDIR += iplog
SUBDIR += ipw

27
net/iperf/Makefile Normal file
View File

@ -0,0 +1,27 @@
# New ports collection makefile for: iperf
# Date Created: 20 May 2001
# Whom: Pete Fritchman <petef@databits.net>
#
# $FreeBSD$
#
PORTNAME= iperf
PORTVERSION= 1.2
CATEGORIES= net
MASTER_SITES= http://dast.nlanr.net/Projects/Iperf/
MAINTAINER= petef@databits.net
NO_CDROM= "can't charge a fee for the software"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/iperf ${PREFIX}/bin
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/iperf
.for file in README doc/index.html doc/jperf.gif doc/lib.html doc/release.html \
doc/ui_license.html
${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/iperf
.endfor
.endif
.include <bsd.port.mk>

1
net/iperf/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (iperf-1.2.tar.gz) = b727074c779f8f3087dec5e455840201

View File

@ -0,0 +1,11 @@
--- cfg/Makefile.orig Sat May 19 23:54:00 2001
+++ cfg/Makefile Sat May 19 23:54:12 2001
@@ -31,7 +31,7 @@
#
all: configure
- ./configure
+ ./configure --cc=${CC} --cxx=${CXX}
clean:
-rm -f $(CLEAN_FILES)

View File

@ -0,0 +1,40 @@
--- cfg/configure.orig Sat May 19 23:45:26 2001
+++ cfg/configure Sat May 19 23:54:28 2001
@@ -90,6 +90,12 @@
| --cache-f=* | --cache-=* | --cache=* | --cach=* | --cac=* | --ca=* | --c=*)
cache_file="$ac_optarg" ;;
+ --cc=*)
+ ac_cv_prog_CC="$ac_optarg" ;;
+
+ --cxx=*)
+ ac_cv_prog_CXX="$ac_optarg" ;;
+
-datadir | --datadir | --datadi | --datad | --data | --dat | --da)
ac_prev=datadir ;;
-datadir=* | --datadir=* | --datadi=* | --datad=* | --data=* | --dat=* \
@@ -952,7 +958,7 @@
echo $ac_n "checking whether the C++ compiler ($CXX $CXXFLAGS $LDFLAGS) is a cross-compiler""... $ac_c" 1>&6
echo "configure:954: checking whether the C++ compiler ($CXX $CXXFLAGS $LDFLAGS) is a cross-compiler" >&5
echo "$ac_t""$ac_cv_prog_cxx_cross" 1>&6
-cross_compiling=$ac_cv_prog_cxx_cross
+cross_compiling="no"
echo $ac_n "checking whether we are using GNU C++""... $ac_c" 1>&6
echo "configure:959: checking whether we are using GNU C++" >&5
@@ -1065,14 +1071,7 @@
echo
-if test -z "$ac_cv_use_pthread"; then
- ac_cv_use_pthread="yes"
-fi
-echo "Make iperf multi-threaded (using pthreads)? [$ac_cv_use_pthread] "
-read tmp
-if test -n "$tmp"; then
- ac_cv_use_pthread="$tmp"
-fi
+ac_cv_use_pthread="no"
if test "$ac_cv_use_pthread" = yes ; then

1
net/iperf/pkg-comment Normal file
View File

@ -0,0 +1 @@
A tool to measure maximum TCP and UDP bandwidth

9
net/iperf/pkg-descr Normal file
View File

@ -0,0 +1,9 @@
Iperf is a tool for measuring maximum TCP and UDP bandwidth,
reminiscent of ttcp and nettest. It has been written to overcome
the shortcomings of those aging tools. Iperf can also test UDP
bandwidth, loss, and jitter.
WWW: http://dast.nlanr.net/Projects/Iperf/
- Pete
petef@databits.net

8
net/iperf/pkg-plist Normal file
View File

@ -0,0 +1,8 @@
bin/iperf
%%PORTDOCS%%share/doc/iperf/README
%%PORTDOCS%%share/doc/iperf/index.html
%%PORTDOCS%%share/doc/iperf/jperf.gif
%%PORTDOCS%%share/doc/iperf/lib.html
%%PORTDOCS%%share/doc/iperf/release.html
%%PORTDOCS%%share/doc/iperf/ui_license.html
%%PORTDOCS%%@dirrm share/doc/iperf