Upgrade to 1.1.27.
PR: ports/21945 Submitted by: trevor
This commit is contained in:
parent
a04dd59e50
commit
ea81a2cd2b
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33761
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gimp
|
||||
PORTVERSION= 1.1.26
|
||||
PORTVERSION= 1.1.27
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ftp://ftp.gimp.org/pub/gimp/unstable/v${PORTVERSION}/ \
|
||||
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/gimp/unstable/v${PORTVERSION}/ \
|
||||
@ -28,7 +28,7 @@ USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GTK= yes
|
||||
WANT_GNOME= yes
|
||||
#WANT_GNOME= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
@ -57,9 +57,9 @@ pre-fetch:
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(HAVE_GNOME)
|
||||
USE_GNOME= yes
|
||||
.endif
|
||||
#.if defined(HAVE_GNOME)
|
||||
#USE_GNOME= yes
|
||||
#.endif
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/gimp.setfont ${PREFIX}/bin
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gimp-1.1.26.tar.bz2) = 4951bb1f992cdd351c5c3861ba197bcf
|
||||
MD5 (gimp-1.1.27.tar.bz2) = a00d603344a0b6d5890a4d2209406115
|
||||
|
@ -0,0 +1,20 @@
|
||||
--- plug-ins/print/print-escp2.c.orig Fri Oct 13 01:17:44 2000
|
||||
+++ plug-ins/print/print-escp2.c Fri Oct 13 01:18:14 2000
|
||||
@@ -26,6 +26,8 @@
|
||||
* compile on generic platforms that don't support glib, gimp, gtk, etc.
|
||||
*/
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
#ifndef WEAVETEST
|
||||
#include "print.h"
|
||||
#endif
|
||||
@@ -4000,7 +4002,7 @@
|
||||
if (lineoffs[0].v[j] != 0)
|
||||
fprintf(stderr,
|
||||
"WARNING: pass %d subpass %d row %d: lineoffs %ld\n",
|
||||
- w.pass, i, row, lineoffs[0].v[j]);
|
||||
+ w.pass, i, row, (long)lineoffs[0].v[j]);
|
||||
lineoffs[0].v[j] = 0;
|
||||
lineactive[0].v[j] = 0;
|
||||
}
|
@ -195,7 +195,8 @@ libexec/gimp/1.1/plug-ins/gtm
|
||||
libexec/gimp/1.1/plug-ins/guillotine
|
||||
libexec/gimp/1.1/plug-ins/gz
|
||||
libexec/gimp/1.1/plug-ins/header
|
||||
%%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
@comment %%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/hot
|
||||
libexec/gimp/1.1/plug-ins/hrz
|
||||
libexec/gimp/1.1/plug-ins/ifscompose
|
||||
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gimp
|
||||
PORTVERSION= 1.1.26
|
||||
PORTVERSION= 1.1.27
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ftp://ftp.gimp.org/pub/gimp/unstable/v${PORTVERSION}/ \
|
||||
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/gimp/unstable/v${PORTVERSION}/ \
|
||||
@ -28,7 +28,7 @@ USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GTK= yes
|
||||
WANT_GNOME= yes
|
||||
#WANT_GNOME= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
@ -57,9 +57,9 @@ pre-fetch:
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(HAVE_GNOME)
|
||||
USE_GNOME= yes
|
||||
.endif
|
||||
#.if defined(HAVE_GNOME)
|
||||
#USE_GNOME= yes
|
||||
#.endif
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/gimp.setfont ${PREFIX}/bin
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gimp-1.1.26.tar.bz2) = 4951bb1f992cdd351c5c3861ba197bcf
|
||||
MD5 (gimp-1.1.27.tar.bz2) = a00d603344a0b6d5890a4d2209406115
|
||||
|
20
graphics/gimp-app/files/patch-plug-ins_print_print-escp2_c
Normal file
20
graphics/gimp-app/files/patch-plug-ins_print_print-escp2_c
Normal file
@ -0,0 +1,20 @@
|
||||
--- plug-ins/print/print-escp2.c.orig Fri Oct 13 01:17:44 2000
|
||||
+++ plug-ins/print/print-escp2.c Fri Oct 13 01:18:14 2000
|
||||
@@ -26,6 +26,8 @@
|
||||
* compile on generic platforms that don't support glib, gimp, gtk, etc.
|
||||
*/
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
#ifndef WEAVETEST
|
||||
#include "print.h"
|
||||
#endif
|
||||
@@ -4000,7 +4002,7 @@
|
||||
if (lineoffs[0].v[j] != 0)
|
||||
fprintf(stderr,
|
||||
"WARNING: pass %d subpass %d row %d: lineoffs %ld\n",
|
||||
- w.pass, i, row, lineoffs[0].v[j]);
|
||||
+ w.pass, i, row, (long)lineoffs[0].v[j]);
|
||||
lineoffs[0].v[j] = 0;
|
||||
lineactive[0].v[j] = 0;
|
||||
}
|
@ -195,7 +195,8 @@ libexec/gimp/1.1/plug-ins/gtm
|
||||
libexec/gimp/1.1/plug-ins/guillotine
|
||||
libexec/gimp/1.1/plug-ins/gz
|
||||
libexec/gimp/1.1/plug-ins/header
|
||||
%%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
@comment %%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/hot
|
||||
libexec/gimp/1.1/plug-ins/hrz
|
||||
libexec/gimp/1.1/plug-ins/ifscompose
|
||||
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gimp
|
||||
PORTVERSION= 1.1.26
|
||||
PORTVERSION= 1.1.27
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ftp://ftp.gimp.org/pub/gimp/unstable/v${PORTVERSION}/ \
|
||||
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/gimp/unstable/v${PORTVERSION}/ \
|
||||
@ -28,7 +28,7 @@ USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GTK= yes
|
||||
WANT_GNOME= yes
|
||||
#WANT_GNOME= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
@ -57,9 +57,9 @@ pre-fetch:
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(HAVE_GNOME)
|
||||
USE_GNOME= yes
|
||||
.endif
|
||||
#.if defined(HAVE_GNOME)
|
||||
#USE_GNOME= yes
|
||||
#.endif
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/gimp.setfont ${PREFIX}/bin
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gimp-1.1.26.tar.bz2) = 4951bb1f992cdd351c5c3861ba197bcf
|
||||
MD5 (gimp-1.1.27.tar.bz2) = a00d603344a0b6d5890a4d2209406115
|
||||
|
20
graphics/gimp-devel/files/patch-plug-ins_print_print-escp2_c
Normal file
20
graphics/gimp-devel/files/patch-plug-ins_print_print-escp2_c
Normal file
@ -0,0 +1,20 @@
|
||||
--- plug-ins/print/print-escp2.c.orig Fri Oct 13 01:17:44 2000
|
||||
+++ plug-ins/print/print-escp2.c Fri Oct 13 01:18:14 2000
|
||||
@@ -26,6 +26,8 @@
|
||||
* compile on generic platforms that don't support glib, gimp, gtk, etc.
|
||||
*/
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
#ifndef WEAVETEST
|
||||
#include "print.h"
|
||||
#endif
|
||||
@@ -4000,7 +4002,7 @@
|
||||
if (lineoffs[0].v[j] != 0)
|
||||
fprintf(stderr,
|
||||
"WARNING: pass %d subpass %d row %d: lineoffs %ld\n",
|
||||
- w.pass, i, row, lineoffs[0].v[j]);
|
||||
+ w.pass, i, row, (long)lineoffs[0].v[j]);
|
||||
lineoffs[0].v[j] = 0;
|
||||
lineactive[0].v[j] = 0;
|
||||
}
|
@ -195,7 +195,8 @@ libexec/gimp/1.1/plug-ins/gtm
|
||||
libexec/gimp/1.1/plug-ins/guillotine
|
||||
libexec/gimp/1.1/plug-ins/gz
|
||||
libexec/gimp/1.1/plug-ins/header
|
||||
%%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
@comment %%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/hot
|
||||
libexec/gimp/1.1/plug-ins/hrz
|
||||
libexec/gimp/1.1/plug-ins/ifscompose
|
||||
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gimp
|
||||
PORTVERSION= 1.1.26
|
||||
PORTVERSION= 1.1.27
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ftp://ftp.gimp.org/pub/gimp/unstable/v${PORTVERSION}/ \
|
||||
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/gimp/unstable/v${PORTVERSION}/ \
|
||||
@ -28,7 +28,7 @@ USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GTK= yes
|
||||
WANT_GNOME= yes
|
||||
#WANT_GNOME= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
@ -57,9 +57,9 @@ pre-fetch:
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(HAVE_GNOME)
|
||||
USE_GNOME= yes
|
||||
.endif
|
||||
#.if defined(HAVE_GNOME)
|
||||
#USE_GNOME= yes
|
||||
#.endif
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/gimp.setfont ${PREFIX}/bin
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gimp-1.1.26.tar.bz2) = 4951bb1f992cdd351c5c3861ba197bcf
|
||||
MD5 (gimp-1.1.27.tar.bz2) = a00d603344a0b6d5890a4d2209406115
|
||||
|
20
graphics/gimp/files/patch-plug-ins_print_print-escp2_c
Normal file
20
graphics/gimp/files/patch-plug-ins_print_print-escp2_c
Normal file
@ -0,0 +1,20 @@
|
||||
--- plug-ins/print/print-escp2.c.orig Fri Oct 13 01:17:44 2000
|
||||
+++ plug-ins/print/print-escp2.c Fri Oct 13 01:18:14 2000
|
||||
@@ -26,6 +26,8 @@
|
||||
* compile on generic platforms that don't support glib, gimp, gtk, etc.
|
||||
*/
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
#ifndef WEAVETEST
|
||||
#include "print.h"
|
||||
#endif
|
||||
@@ -4000,7 +4002,7 @@
|
||||
if (lineoffs[0].v[j] != 0)
|
||||
fprintf(stderr,
|
||||
"WARNING: pass %d subpass %d row %d: lineoffs %ld\n",
|
||||
- w.pass, i, row, lineoffs[0].v[j]);
|
||||
+ w.pass, i, row, (long)lineoffs[0].v[j]);
|
||||
lineoffs[0].v[j] = 0;
|
||||
lineactive[0].v[j] = 0;
|
||||
}
|
@ -195,7 +195,8 @@ libexec/gimp/1.1/plug-ins/gtm
|
||||
libexec/gimp/1.1/plug-ins/guillotine
|
||||
libexec/gimp/1.1/plug-ins/gz
|
||||
libexec/gimp/1.1/plug-ins/header
|
||||
%%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
@comment %%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/hot
|
||||
libexec/gimp/1.1/plug-ins/hrz
|
||||
libexec/gimp/1.1/plug-ins/ifscompose
|
||||
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gimp
|
||||
PORTVERSION= 1.1.26
|
||||
PORTVERSION= 1.1.27
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ftp://ftp.gimp.org/pub/gimp/unstable/v${PORTVERSION}/ \
|
||||
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/gimp/unstable/v${PORTVERSION}/ \
|
||||
@ -28,7 +28,7 @@ USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GTK= yes
|
||||
WANT_GNOME= yes
|
||||
#WANT_GNOME= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
@ -57,9 +57,9 @@ pre-fetch:
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(HAVE_GNOME)
|
||||
USE_GNOME= yes
|
||||
.endif
|
||||
#.if defined(HAVE_GNOME)
|
||||
#USE_GNOME= yes
|
||||
#.endif
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/gimp.setfont ${PREFIX}/bin
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gimp-1.1.26.tar.bz2) = 4951bb1f992cdd351c5c3861ba197bcf
|
||||
MD5 (gimp-1.1.27.tar.bz2) = a00d603344a0b6d5890a4d2209406115
|
||||
|
20
graphics/gimp1/files/patch-plug-ins_print_print-escp2_c
Normal file
20
graphics/gimp1/files/patch-plug-ins_print_print-escp2_c
Normal file
@ -0,0 +1,20 @@
|
||||
--- plug-ins/print/print-escp2.c.orig Fri Oct 13 01:17:44 2000
|
||||
+++ plug-ins/print/print-escp2.c Fri Oct 13 01:18:14 2000
|
||||
@@ -26,6 +26,8 @@
|
||||
* compile on generic platforms that don't support glib, gimp, gtk, etc.
|
||||
*/
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
#ifndef WEAVETEST
|
||||
#include "print.h"
|
||||
#endif
|
||||
@@ -4000,7 +4002,7 @@
|
||||
if (lineoffs[0].v[j] != 0)
|
||||
fprintf(stderr,
|
||||
"WARNING: pass %d subpass %d row %d: lineoffs %ld\n",
|
||||
- w.pass, i, row, lineoffs[0].v[j]);
|
||||
+ w.pass, i, row, (long)lineoffs[0].v[j]);
|
||||
lineoffs[0].v[j] = 0;
|
||||
lineactive[0].v[j] = 0;
|
||||
}
|
@ -195,7 +195,8 @@ libexec/gimp/1.1/plug-ins/gtm
|
||||
libexec/gimp/1.1/plug-ins/guillotine
|
||||
libexec/gimp/1.1/plug-ins/gz
|
||||
libexec/gimp/1.1/plug-ins/header
|
||||
%%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
@comment %%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/hot
|
||||
libexec/gimp/1.1/plug-ins/hrz
|
||||
libexec/gimp/1.1/plug-ins/ifscompose
|
||||
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= gimp
|
||||
PORTVERSION= 1.1.26
|
||||
PORTVERSION= 1.1.27
|
||||
CATEGORIES= graphics gnome
|
||||
MASTER_SITES= ftp://ftp.gimp.org/pub/gimp/unstable/v${PORTVERSION}/ \
|
||||
ftp://ftp.insync.net/pub/mirrors/ftp.gimp.org/gimp/unstable/v${PORTVERSION}/ \
|
||||
@ -28,7 +28,7 @@ USE_X_PREFIX= yes
|
||||
USE_XPM= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GTK= yes
|
||||
WANT_GNOME= yes
|
||||
#WANT_GNOME= yes
|
||||
USE_LIBTOOL= yes
|
||||
INSTALLS_SHLIB= yes
|
||||
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
|
||||
@ -57,9 +57,9 @@ pre-fetch:
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if defined(HAVE_GNOME)
|
||||
USE_GNOME= yes
|
||||
.endif
|
||||
#.if defined(HAVE_GNOME)
|
||||
#USE_GNOME= yes
|
||||
#.endif
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${FILESDIR}/gimp.setfont ${PREFIX}/bin
|
||||
|
@ -1 +1 @@
|
||||
MD5 (gimp-1.1.26.tar.bz2) = 4951bb1f992cdd351c5c3861ba197bcf
|
||||
MD5 (gimp-1.1.27.tar.bz2) = a00d603344a0b6d5890a4d2209406115
|
||||
|
20
graphics/gimpshop/files/patch-plug-ins_print_print-escp2_c
Normal file
20
graphics/gimpshop/files/patch-plug-ins_print_print-escp2_c
Normal file
@ -0,0 +1,20 @@
|
||||
--- plug-ins/print/print-escp2.c.orig Fri Oct 13 01:17:44 2000
|
||||
+++ plug-ins/print/print-escp2.c Fri Oct 13 01:18:14 2000
|
||||
@@ -26,6 +26,8 @@
|
||||
* compile on generic platforms that don't support glib, gimp, gtk, etc.
|
||||
*/
|
||||
|
||||
+#include <sys/types.h>
|
||||
+
|
||||
#ifndef WEAVETEST
|
||||
#include "print.h"
|
||||
#endif
|
||||
@@ -4000,7 +4002,7 @@
|
||||
if (lineoffs[0].v[j] != 0)
|
||||
fprintf(stderr,
|
||||
"WARNING: pass %d subpass %d row %d: lineoffs %ld\n",
|
||||
- w.pass, i, row, lineoffs[0].v[j]);
|
||||
+ w.pass, i, row, (long)lineoffs[0].v[j]);
|
||||
lineoffs[0].v[j] = 0;
|
||||
lineactive[0].v[j] = 0;
|
||||
}
|
@ -195,7 +195,8 @@ libexec/gimp/1.1/plug-ins/gtm
|
||||
libexec/gimp/1.1/plug-ins/guillotine
|
||||
libexec/gimp/1.1/plug-ins/gz
|
||||
libexec/gimp/1.1/plug-ins/header
|
||||
%%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
@comment %%GNOME:%%libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/helpbrowser
|
||||
libexec/gimp/1.1/plug-ins/hot
|
||||
libexec/gimp/1.1/plug-ins/hrz
|
||||
libexec/gimp/1.1/plug-ins/ifscompose
|
||||
|
Loading…
Reference in New Issue
Block a user