Unofficial port from icculus.org of

"Aliens versus predator" game, demo from Alien.

WWW: http://www.icculus.org/avp/

PR:		ports/138806
Submitted by:	Stas Timokhin [devel stasyan.com]
		(the email address in the PR is defunct)
Fixes from:	Anonymous [swell.k gmail.com], myself
This commit is contained in:
Rene Ladan 2010-09-02 16:30:20 +00:00
parent b2be6f84a4
commit ea408b3f5c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=260436
7 changed files with 136 additions and 0 deletions

View File

@ -61,6 +61,7 @@
SUBDIR += atris
SUBDIR += atris-sounds
SUBDIR += avanor
SUBDIR += avp-demo
SUBDIR += awale
SUBDIR += awele
SUBDIR += balazar

56
games/avp-demo/Makefile Normal file
View File

@ -0,0 +1,56 @@
# New ports collection makefile for: games/avp-demo
# Date created: 11 Sep 2009
# Whom: Stas Timokhin <devel@stasyan.com>
#
# $FreeBSD$
#
PORTNAME= avp-demo
PORTVERSION= 0.1
CATEGORIES= games
MASTER_SITES= http://www.stasyan.com/devel/distfiles/
DISTFILES= avp_git_20090911.tar.gz avp_data_a03.tar.gz
MAINTAINER= devel@stasyan.com
COMMENT= Aliens versus predator unofficial port from icculus.org
USE_SDL= mixer sdl
USE_GMAKE= yes
USE_GL= gl
WRKSRC= ${WRKDIR}
BUILD_WRKSRC= ${WRKDIR}/avp_git
USE_OPENAL= yes
.include <bsd.port.pre.mk>
.if !(${ARCH} == i386 || ${ARCH} == pc98)
BROKEN= does not compile
.endif
do-install:
#Install program and doc
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/avp ${PREFIX}/bin/avp
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${BUILD_WRKSRC}/LICENSE ${DOCSDIR}/LICENSE
${INSTALL_DATA} ${BUILD_WRKSRC}/README ${DOCSDIR}/README
.endif
#Install data files from Alien demo
${MKDIR} ${DATADIR}
${MKDIR} ${DATADIR}/avp_huds
${MKDIR} ${DATADIR}/avp_rifs
${MKDIR} ${DATADIR}/fastfile
. for f in alien.rif alien_hud.rif hnpc_civvie.rif hnpcmarine.rif sentry.rif
${INSTALL_DATA} ${WRKDIR}/avp/avp_huds/${f} ${DATADIR}/avp_huds/${f}
. endfor
${INSTALL_DATA} ${WRKDIR}/avp/avp_rifs/temple.rif ${DATADIR}/avp_rifs/temple.rif
. for f in common.ffl ffinfo.txt marsound.dat snd15.ffl snd30.ffl tex1.ffl tex15.ffl tex26.ffl tex27.ffl tex30.ffl tex32.ffl tex34.ffl tex38.ffl tex40.ffl tex43.ffl snd27.ffl
${INSTALL_DATA} ${WRKDIR}/avp/fastfile/${f} ${DATADIR}/fastfile/${f}
. endfor
${INSTALL_DATA} ${WRKDIR}/avp/language.txt ${DATADIR}/language.txt
post-install:
${SED} -e "/%%DATADIR%%/s//${DATADIR:S/\//\\\//g}/g" ${PKGMESSAGE};
.include <bsd.port.post.mk>

6
games/avp-demo/distinfo Normal file
View File

@ -0,0 +1,6 @@
MD5 (avp_git_20090911.tar.gz) = a368f1e1f19e66c8de8028ff32af3de6
SHA256 (avp_git_20090911.tar.gz) = c38fd6eda94edd974b4d4a5690064b2da481f81f621046d0e9d2fe2078aea80d
SIZE (avp_git_20090911.tar.gz) = 4252858
MD5 (avp_data_a03.tar.gz) = 5dc570dd3c85de7293297ca1bebf0420
SHA256 (avp_data_a03.tar.gz) = f345e621afafd4c56de26c4d37fc85edb9d3aeb4961dd4f2ad0c60106696a4f6
SIZE (avp_data_a03.tar.gz) = 23472167

View File

@ -0,0 +1,30 @@
--- avp_git/Makefile.orig
+++ avp_git/Makefile
@@ -1,15 +1,8 @@
-CC = gcc
-CXX = g++
-
-CFLAGS = -m32 -g -Wall -pipe
-#CFLAGS += -O2
-#CFLAGS += -DNDEBUG -O6 -ffast-math -fomit-frame-pointer -march=pentium3 -mtune=pentium4
-
CFLAGS += -Isrc -Isrc/include -Isrc/win95 -Isrc/avp -Isrc/avp/win95 -Isrc/avp/support -Isrc/avp/win95/frontend -Isrc/avp/win95/gadgets
-CFLAGS += $(shell sdl-config --cflags) $(shell openal-config --cflags)
+CFLAGS += $(shell sdl-config --cflags) $(shell pkg-config openal --cflags)
-CXXFLAGS = $(CFLAGS)
+CXXFLAGS += $(CFLAGS)
-LDLIBS = -m32 $(shell sdl-config --libs) $(shell openal-config --libs)
+LDLIBS = $(shell sdl-config --libs) $(shell pkg-config openal --libs)
ROOT = main.c files.c winapi.c stubs.c version.c mathline.c opengl.c fmv.c oglfunc.c openal.c cdplayer.c menus.c net.c frustum.c kshape.c map.c maths.c md5.c mem3dc.c mem3dcpp.cpp module.c morph.c object.c shpanim.c sphere.c tables.c vdb.c
AVP = ai_sight.c avpview.c bh_agun.c bh_ais.c bh_alien.c bh_binsw.c bh_cable.c bh_corpse.c bh_deathvol.c bh_debri.c bh_dummy.c bh_fan.c bh_far.c bh_fhug.c bh_gener.c bh_ldoor.c bh_lift.c bh_light.c bh_lnksw.c bh_ltfx.c bh_marin.c bh_mission.c bh_near.c bh_pargen.c bh_plachier.c bh_plift.c bh_pred.c bh_queen.c bh_rubberduck.c bh_selfdest.c bh_snds.c bh_spcl.c bh_swdor.c bh_track.c bh_types.c bh_videoscreen.c bh_waypt.c bh_weap.c bh_xeno.c bonusabilities.c cconvars.cpp cdtrackselection.cpp cheatmodes.c comp_map.c comp_shp.c consolelog.cpp davehook.cpp deaths.c decal.c detaillevels.c dynamics.c dynblock.c equipmnt.c extents.c game.c game_statistics.c gamecmds.cpp gamevars.cpp hmodel.c hud.c inventry.c language.c lighting.c load_shp.c los.c mempool.c messagehistory.c missions.cpp movement.c paintball.c particle.c pfarlocs.c pheromon.c player.c pmove.c psnd.c psndproj.c pvisible.c savegame.c scream.cpp secstats.c sfx.c stratdef.c targeting.c track.c triggers.c weapons.c
@@ -48,7 +41,7 @@ OBJ = $(ROOTOBJ) $(AVPOBJ) $(SHAPESOBJ)
all: avp
avp: $(OBJ)
- $(CXX) -o avp $(OBJ) $(LDLIBS)
+ $(CXX) -o avp $(OBJ) $(LDLIBS) $(LDFLAGS)
clean:
-rm -rf $(OBJ) avp

4
games/avp-demo/pkg-descr Normal file
View File

@ -0,0 +1,4 @@
Unofficial port from icculus.org of
"Aliens versus predator" game, demo from Alien.
WWW: http://www.icculus.org/avp/

View File

@ -0,0 +1,8 @@
*************************************************************************
Set the environment variable:
AVP_DATA=%%DATADIR%%
*************************************************************************

31
games/avp-demo/pkg-plist Normal file
View File

@ -0,0 +1,31 @@
bin/avp
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%DATADIR%%/avp_huds/alien.rif
%%DATADIR%%/avp_huds/alien_hud.rif
%%DATADIR%%/avp_huds/hnpc_civvie.rif
%%DATADIR%%/avp_huds/hnpcmarine.rif
%%DATADIR%%/avp_huds/sentry.rif
%%DATADIR%%/avp_rifs/temple.rif
%%DATADIR%%/fastfile/common.ffl
%%DATADIR%%/fastfile/ffinfo.txt
%%DATADIR%%/fastfile/marsound.dat
%%DATADIR%%/fastfile/snd15.ffl
%%DATADIR%%/fastfile/snd30.ffl
%%DATADIR%%/fastfile/tex1.ffl
%%DATADIR%%/fastfile/tex15.ffl
%%DATADIR%%/fastfile/tex26.ffl
%%DATADIR%%/fastfile/tex27.ffl
%%DATADIR%%/fastfile/tex30.ffl
%%DATADIR%%/fastfile/tex32.ffl
%%DATADIR%%/fastfile/tex34.ffl
%%DATADIR%%/fastfile/tex38.ffl
%%DATADIR%%/fastfile/tex40.ffl
%%DATADIR%%/fastfile/tex43.ffl
%%DATADIR%%/fastfile/snd27.ffl
%%DATADIR%%/language.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/avp_huds
@dirrm %%DATADIR%%/avp_rifs
@dirrm %%DATADIR%%/fastfile
@dirrm %%DATADIR%%