- Update to 0.05
- Added XML::Simple as OPTIONal dependency - Made PREFIX-clean under perl 5.005_03 PR: 63087 Submitted by: maintainer
This commit is contained in:
parent
5c4a2950e1
commit
ea35143c90
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=101572
@ -5,8 +5,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= Config-Auto
|
||||
PORTVERSION= 0.04
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.05
|
||||
CATEGORIES= devel perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
|
||||
MASTER_SITE_SUBDIR= Config
|
||||
@ -18,14 +17,21 @@ COMMENT= Magical config file parser
|
||||
BUILD_DEPENDS= ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles
|
||||
RUN_DEPENDS= ${BUILD_DEPENDS}
|
||||
|
||||
OPTIONS= XMLSIMPLE "Support for XML config files" off
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.ifdef(WITH_XMLSIMPLE)
|
||||
BUILD_DEPENDS+= ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
|
||||
RUN_DEPENDS+= ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
|
||||
.endif
|
||||
|
||||
PERL_CONFIGURE= yes
|
||||
|
||||
MAN3= Config::Auto.3
|
||||
|
||||
test:
|
||||
cd ${WRKSRC} ; make test
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
post-patch:
|
||||
@${RM} ${WRKSRC}/lib/Config/Auto.pm.orig
|
||||
|
||||
.if ${PERL_LEVEL} < 500600
|
||||
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
|
||||
@ -33,7 +39,15 @@ BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
|
||||
post-patch:
|
||||
@${PERL} -pi -e 's/^our (\$$\w+)/use vars qw($$1); $$1/;' \
|
||||
-e '$$_ = "" if (/5.006/);' \
|
||||
${WRKSRC}/Auto.pm
|
||||
-e '$$_ = "" if (/use warnings/);' \
|
||||
${WRKSRC}/lib/Config/Auto.pm
|
||||
@${RM} ${WRKSRC}/lib/Config/Auto.pm.orig
|
||||
.endif
|
||||
|
||||
.if ${PERL_LEVEL} <= 500503
|
||||
# make PREFIX-clean under perl 5.005_03
|
||||
post-configure:
|
||||
@${PERL} -pi -e 's,/usr/local/,\$${PREFIX}/,g' ${WRKSRC}/Makefile
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -1 +1,2 @@
|
||||
MD5 (Config-Auto-0.04.tar.gz) = 8070d1954ff43c6af4b3d7820e2e390d
|
||||
MD5 (Config-Auto-0.05.tar.gz) = 89d5e2ef26172c70b1eba914ca2f0372
|
||||
SIZE (Config-Auto-0.05.tar.gz) = 6266
|
||||
|
13
devel/p5-Config-Auto/files/patch-Auto.pm
Normal file
13
devel/p5-Config-Auto/files/patch-Auto.pm
Normal file
@ -0,0 +1,13 @@
|
||||
--- lib/Config/Auto.pm.orig Sat Feb 21 12:39:16 2004
|
||||
+++ lib/Config/Auto.pm Sat Feb 21 12:40:02 2004
|
||||
@@ -120,8 +120,8 @@
|
||||
|
||||
# Some general sanity checks
|
||||
if (exists $score{perl}) {
|
||||
- $score{perl} /= 2 unless ("@$data_r" =~ tr/;//) > 3 or $#$data_r < 3;
|
||||
- delete $score{perl} unless ("@$data_r" =~ tr/;//);
|
||||
+ $score{perl} /= 2 unless ("@$data_r" =~ /;/) > 3 or $#$data_r < 3;
|
||||
+ delete $score{perl} unless ("@$data_r" =~ /;/);
|
||||
delete $score{perl} unless ("@$data_r" =~ /([\$\@\%]\w+)/);
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user